This page describes using the ViewStation's serial
connection for TCP/IP services with the PPP protocol.
PPP
Protocol for Serial Communications
You can use the PPP Protocol
(otherwise called Internet standard Point to Point Protocol) to run
TCP/IP connections to the X Window protocol on a host computer. PPP is
defined by RFCs 1171 and 1172. The PPP protocol is more than a superset
of SLIP and CSLIP. The PPP protocol will not use or recognize SLIP or
CSLIP packets.
PPP provides link-level error detection, IP address
negotiation and assignment, Address/Control fields and Protocol field
compression, Link-level authentication (defined by PAP in RFC 1172 and
CHAP in RFC October 1991 Draft), Link-status monitoring by LQM (LCP
Draft August 1991), as well as support for SLIP (RFC 1055) and CSLIP
(RFC 1144). PPP corrects many of the deficiencies of SLIP and permits
many more features and adjustments in the serial communications
interface.
Using PPP on the ViewStation
PPP must
be installed on your host computer. Many computer operating systems have
PPP built-in; there are also commercial programs which offer PPP
connections for communications, or you can obtain PPP from the
Internet. It is included with all HDS ViewStation terminals at no
charge, no special software is needed.
To select the PPP Protocol, go to the Communications Options
menu and click on Serial Port Use line (for the line you want). Select
the PPP option, then click on the PPP/SLIP Options line. CAUTION:
Select PPP, or SLIP options only if that is your only connection. If
you have other connections to the host or Ethernet and use PPP only
occasionally, you should select "Unspecified" as your serial port use
and use the "Start PPP" option on the pull-down menu. The reason for
this "Unspecified" selection is that if "PPP" is your Serial Port Use
selection, the ViewStation will send repeated requests to the host to
start the PPP daemon, even if you aren't currently using a PPP session.
The PPP/SLIP Options menu contains a lot of PPP settings,
which are explained on another page PPP Settings.
More detailed explanations are provided with the PPP products.
SLIP/CSLIP Protocols
You can use the SLIP (Serial Line Internet
Protocol) or CSLIP (Compressed SLIP) protocol just as with PPP. If you
use the Compressed SLIP protocol, you must have the ability to handle
compressed packets on the remote host computer (Van Jacobsen
compression, RFC 1144).
PPP Connection Example
This example describes a starting a
simple PPP session. It assumes that the PPP is correctly configured on
the host system and that a serial connection can be opened.
Using the ViewStation's Serial Terminal client, open a serial
connection to the host computer, either directly or via modem. When the
connection is complete, use the Serial Options pull-down menu and
select "Start PPP". This will close the Serial Terminal window and
leave you with an open connection to the PPP interface (just as if you
had just connected your ViewStation to the Ethernet).
Open a
TCP/IP connection to the host with Telnet. Use the IP address of the
PPP remote host. If you have HDSware 3.2, this new IP address for the
PPP connection will be entered automatically for the Serial port you're
using. If you have an older HDSware version, you will have to enter the
new IP address for the ViewStation and restart it (the connection will
remain open). If you have PPP address negotiation enabled (the
default), the remote host will determine and set an IP address for the
ViewStation. If address negotiation is disabled, you must enter the
ViewStation's PPP IP address on the PPP/SLIP Options menu.
At
this point, you can open a Telnet session to the host over the PPP
serial line. You may notice a delay when the Serial Terminal window
closes which is caused by the PPP negotiation with the host, but there
is an interval permitted for you to open the Telnet session before the
PPP connection times out.
It may be advantageous to establish a separate logon for users
making a PPP connection to a host. If your regular Ethernet login is
"bill", you may want to have a separate logon for "billPPP". This would
allow the billPPP logon to start a shell script that aids your PPP
connection. This script might include a line to start the PPP daemon on
the host (usually just starting /etc/pppd on the host, or
whatever the PPP configuration on your system requires) and a line to
start a Telnet session.
Return to Section Heading Page
Return to the Home Page
If you need more information than is available here, you can reach
HDS via email at info@hds.com, or
call us at 1.800.HDS.1551 in the USA, or at +610.277.8300 from outside
the US. For questions or problems regarding the HDS WWW page, contact
webmaster@hds.com.
© 1996 by HDS Network Systems
Inc.