OL2000: How to Use Command-Line SwitchesID: Q193282
|
The Outlook Help file contains an entry that lists command-line switches which allow you to start Outlook in a specific mode or with a specific form.
This article lists additional command-line switches that are not included
in the Outlook Help topic, and how to use them. These command-line switches can be used for diagnostic purposes.
To determine the path to Outlook, follow these steps:
C:\Program Files\Microsoft Office\Office\Outlook.exe
NOTE: The full path needs to be in quotation marks to preserve long filenames."C:\Program Files\Microsoft Office\Office\Outlook.exe." /Cleanreminders
CAUTION: Some of the following switches are designed to reset files and settings. This means that using them may cause the loss of your customizations. Also, creating a new .pst or profile will use a default file and not an existing one. Those settings are still available on the computer, just not being used for the command-line switch.Command-Line switch Purpose ------------------- ------- /CleanFreeBusy Cleans and regenerates free/busy information. /CleanReminders Cleans and regenerates reminders. /CleanViews Restores default views. /CheckClient Prompts for default manager of e-mail, news, and contacts. /ResetFolders Restores missing folders for the default delivery location. /ResetOutlookBar Rebuilds the Outlook Bar. /NoPreview Turns off the preview pane and removes the option from the View menu. /CleanSchedPlus Deletes all Schedule+ data (free/busy, permissions, and .cal file) from the server and allows the free/busy information from the Outlook Calendar to be used and viewed by all Schedule+ 1.0 users.
NOTE: The switches /Regserver and /Unregserver are no longer valid with Outlook 2000./Cleanprofile Removes and recreates default registry keys. This has also been used to repair a situation where WinFax does not show up on the menu. /Cleanpst Starts Outlook with a clean .pst. Use this switch with Internet Mail Only. /Safe Start Outlook without extensions, preview pane, or toolbar customization. /Recycle Reuses existing windows to open up the folders specified. Used in combination with the /explorer switch or the /folder switch. /Explorer Opens new window in "explorer" mode (Navigation bar on). /Folder Opens new window in "folder" mode (Navigator bar off). /Profiles Shows MAPI Profiles dialog box regardless of Options setting on the Tools menu. /Profile <profilename> Loads specified profile. (If your profile contains a space, Outlook may treat it as an invalid profile name when using this switch. Work around this by wrappping the profile name in quotes.) /s <filename> Loads specified shortcuts file (.fav file). /p <msgfilename> Prints <msgfilename>. Same as /f except is associated with the print verb instead of open. /Embedding <msgfilename> Used to open a .msg file as an OLE embedding. Standard OLE command-line argument. /c <messageclass> Creates a new item of the specified message class (Outlook forms or any other valid MAPI form).
For more information about command-line switches, click Microsoft Outlook Help on the
Help menu, type Control what happens when you start Outlook in the Office Assistant or
the Answer Wizard, and then click Search to view the topic.
The Microsoft Office Resource Kit also contains information on these command-line switches. For more information about the Microsoft Office Resource Kit, please see the
following Microsoft World Wide Web site:
http://www.microsoft.com/office/ork/
Additional query words: OL2K
Keywords : kbdta
Version : WINDOWS:2000
Platform : WINDOWS
Issue type : kbhowto
|
Last Reviewed: January 25, 2000 © 2000 Microsoft Corporation. All rights reserved. Terms of Use. |