Knowledge Base

XL98: Error Editing Chart Linked to a Closed Workbook

Article ID: 182777

Article Last Modified on 9/11/2002


APPLIES TO


This article was previously published under Q182777

SYMPTOMS

When you attempt to edit a series on a chart that is linked to a closed workbook, you may receive the following error message:
Reference is not valid. Reference must be to an open worksheet.

CAUSE

This behavior may occur when the following conditions are true:

  • On the Chart menu, you click Source Data. -or-

  • You proceed to step 2 of the Chart Wizard. -and-

  • You click the Series tab and type a reference to a closed workbook in the Values box.

WORKAROUND

To work around this behavior, open the source workbook. To do this, follow these steps:

  1. On the Edit menu, click Links.
  2. Select the appropriate source file and click Open Source.
You can update the data series by using either the Source Data command or the Chart Wizard.

STATUS

This behavior is by design of Microsoft Excel 98 Macintosh Edition.

MORE INFORMATION

When you close the workbook and use the Chart Wizard, some functionality, such as changing the chart type, is not available. Note that you cannot use the Source Data command on the Chart menu. If you do so, you repeatedly receive the error message that is described in this article.

REFERENCES

For more information about charting, click Contents And Index on the Help menu (or on the Balloon Help menu if you are using a version of the Macintosh operating system earlier than 8.0), click the Index button in Microsoft Excel Help, type the following text

charts, creating

and then click Show Topics. Select the "Create a chart" topic, and click Go To. If you are unable to find the information you need, ask the Office Assistant.

Additional query words: XL98

Keywords: kberrmsg kbnofix kbchart kbprb KB182777