Workbook Is Recalculated Many Times When You Save as HTML
Article ID: 176074
Article Last Modified on 8/15/2003
APPLIES TO
- Microsoft Excel 97 Standard Edition
- Microsoft Excel 98 for Macintosh
This article was previously published under Q176074
SYMPTOMS
The following problems may occur when you use the Internet Assistant
Wizard (Html.xla) to save files in the Hypertext Markup Language (HTML)
format:
- The first time you click Save As HTML on the File menu, all open
workbooks are recalculated 2 times.
- When you click Finish in step 4 of the Internet Assistant Wizard, all
open workbooks are recalculated 14 times.
This may be a problem when any open workbooks take a long time to be
recalculated, when worksheets in open workbooks use circular references or
iteration, or when formulas in open workbooks use volatile functions, such
as the RAND and NOW functions.
RESOLUTION
To resolve this problem, set the calculation mode to manual calculation
before you click Save As HTML on the File menu. To do this, follow these
steps:
- On the Tools menu, click Options (or Preferences).
- Click the Calculation tab.
- Click Manual and click OK.
After you have saved the HTML file, you can select Automatic or Automatic
Except Tables under Calculation.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article.
Additional query words: XL97 XL
Keywords: kbprb KB176074