Works: Pasting Data from Database into Spreadsheet Clears Some Cells
Article ID: 152649
Article Last Modified on 11/15/2004
APPLIES TO
- Microsoft Works 4.5 Standard Edition
- Microsoft Works 4.5a
- Microsoft Works 4.0 Standard Edition
- Microsoft Works 4.0a
This article was previously published under Q152649
SYMPTOMS
When you copy data from the last (rightmost) field in List view of a
Works Database and paste the data into a Spreadsheet, cells to the
right of the destination cells are overwritten with blanks. For
example, assume your Database has 5 fields and your Spreadsheet has 10
columns. If you select 5 fields from the Database and paste them into
the first column of the Spreadsheet, columns 6 through 10 will be
overwritten.
RESOLUTION
This behavior only occurs if you have included the last field in the
database in your selection. To prevent this behavior from occurring, add
a column to the end of your database.
To add a column to your database do the following:
- Open your Database and on the View menu, click
List.
- Click the last (rightmost) field.
- On the Record menu, point to Insert Field and click
After.
- On the Insert Field dialog box, click Add and then
click Done.
- On the Format menu, click Field Width.
- Set the field width to zero and click OK.
You will not see the field you added; if you need to select it again, use
Go To on the
Edit menu to select it and set the width to a positive value.
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Additional query words: 4.00 4.00a 4.50 4.50a works2000 wks w_works db
Keywords: kbbug kbui kbpending KB152649