Changes with Macintosh System 7.5 Update 2.0, Part 3 |
ID: Q152495
The information in this article applies to:
-
Apple Macintosh System Software 7.5.3
SUMMARY
This article lists the enhancements that are included as part
of the System 7.5 Update 2.0. This list was taken from the
"New in this Update - 3" file that came with the installation
medium:
NOTE: The System 7.5 Update 2.0 includes all of the changes
that were included with the System 7.5 Update 1.0. These
changes are listed separately in the following article in the
Microsoft Knowledge Base:
Q138646 Macintosh System 7.5 Update 1.0 Changes
MORE INFORMATION
Changes for PowerPC-based Models
PowerPC-based computers with PCI slots now use the Monitors &
Sound control panel to control monitor and sound settings
instead of the Sound & Displays control panel. (System Update
2.0 removes Sound & Displays.) You can do a custom
installation to install the Sound control panel if you need it
for older applications. (The Monitors & Sound control panel
works only on PCI-based computers.)
Includes native SCSI (not on desktop 5200, 5300, 6200, and
6300 series computers).
Fixes a SCSI Manager problem that would hang any PowerPC-based
computer if a Sony or WangDAT DAT drive was used with
Retrospect.
Fixes a problem on desktop 5200, 5300, 6200, and 6300 series
computers running QuickTime 2.1 that would prevent sound from
being heard in Fusion Recorder's Record window until either a
recording was started or the TV volume in the Sound control
panel was unmuted.
Includes both native and 68K versions of common Modern Memory
Manager routines, inproving performance of emulated
applications by speeding up calls to common routines. (System
software version 7.5 and 7.5.1 included only the native
implementations, while system software version 7.5.2 included
both native and 68K versions.)
Includes a rewritten fixed-point math library to provide
better performance for QuickDraw, other parts of the system,
and all applications that use this library. Because QuickDraw
and other parts of the System use this library extensively,
installing this update will cause noticeable performance
gains.
PowerPC-based computers with PCI slots might have a different
physical Ethernet address after you install this update. The
update fixes a bug that caused an incorrect physical Ethernet
address to be used in environments where TCP/IP addresses are
obtained using BootP, DHCP, or RARP. To see the new Ethernet
address after you install the update, open the File menu in
the AppleTalk or TCP/IP control panel and choose Get Info. If
you install the update and are no longer able to use your
TCP/IP-based applications, contact your network system
administrator.
On PowerPC-based computers (including those with PowerPC
Upgrade cards) running system software version 7.5 or 7.5.1,
this update introduces the Native Resource Manager. This
version of the Native Resource Manager is slightly newer than
the version released with system software version 7.5.2. The
System 7.5.2 Update file includes the same improved version of
the Native Resource Manager.
Reduces times to open applications on PowerPC-based computers
with virtual memory turned on. System 7.5.2 (not 7.5 or 7.5.1)
would significantly slow down while opening certain
applications, such as Microsoft Excel version 5.0, if virtual
memory was turned on. With Update 2.0 installed, start times
should be about the same whether or not virtual memory is
turned on.
Fixes a bug affecting plug-ins that import from an
application. This problem existed in all PowerPC-based
computers running system software versions 7.1.2, 7.5, 7.5.1,
and 7.5.2. and was originally fixed by the CFM Updater
extension (distributed with QuickDraw 3D). Update 2.0 deletes
this extension, which is no longer needed.
Fixes a bug in starting up from removable media with virtual
memory on. (Although this bug was fixed in 7.5.2, it still
exists in 7.1.2, 7.5, and 7.5.1 PowerPC computers.)
Fixes problems with the DR Emulator. (The DR Emulator works
only on PCI-based computers and the PowerBook 2300, 5300, and
500 upgrade.)
Fixes a problem in certain IDE drives that resulted in cached
data not being written to the disk at shutdown.
Fixes anti-aliasing errors for Kanji Type 1 fonts.
Fixes a problem that resulted in off-white often being drawn
as white. (This effect, while generally subtle, was
significant enough for some applications to merit a fix.)
Fixes a crash problem (a Type 11 error) in Native QuickDraw;
this error occurred when using Quark XPress v3.1.1 with system
software versions 7.5 and 7.5.1. System 7.5.2 corrected this
problem. If you still have Type 11 errors when using Quark
XPress 3.3.1 with System 7.5.3 on a PowerPC-based computer,
try upgrading to QuarkXPress 3.3.2.
Fixes a problem in the Dialog Manager that caused some
applications to crash after a dialog box was dismissed.
Supports DayStar Turbo 601 cards in a Macintosh IIci or Iisi.
If you use Microsoft Office 4.2.1, you need the extension
"Office 4.2x Update For Power Mac", version 1.0.1, and the
Microsoft Office Manager control panel, version 4.2.1b. For
more information about how to download these files, click
the article numbers below to view the articles in the Microsoft
Knowledge Base:
Q20783 MC1265: Patch to Correct Problem with MOM in Mac System 7.5.2
Q130776 MC1164: Extension to Prevent Hanging Power Macintosh Programs
Changes for PowerBook and PowerBook Duo Models
Contains a new version of password security software. The
version that shipped with the PowerBook 5300 and the PowerBook
190 computers could lock out international users since the
software to handle international keyboards does not load until
after the password is requested during startup. If the
password contained a character that was not available on a
U.S. keyboard, it could not be entered and the computer could
not finish starting up. The new version of the password
security software fixes this problem.
Fixes a problem in the Assistant Toolbox that caused the
Assistant Toolbox to be incompatible with Open Transport.
Fixes a problem that prevented PowerBooks and PowerBook Duos
from going to sleep if SimpleText or certain other
applications were running in the background.
Fixes problems with the DR Emulator. (The DR Emulator works
only on PCI-based computers and the PowerBook 2300, 5300, and
500 upgrade.)
Changes for Other 68K-based Models
Quadra 900 and 950: Fixes a problem in the Sound control
panel. Before this update, the External Line and Internal CD
buttons in the Sound control panel were reversed, so that
clicking the Internal CD button was interpreted as though the
External Line button had been clicked (and vice-versa).
Quadra 950: Fixes a problem with the Sound control panel.
Before this update, clicking the Add button sometimes caused
the computer to crash.
Centris 660AV, Quadra 660AV, and Quadra 840AV: Includes Apple
Video Player v.1.4, which replaces the Video Monitor
application (which is no longer supported).
Changes for AppleVision Monitors
If you use AppleVision software, use version 1.0.2 or later.
Earlier versions of AppleVision are not compatible with System
7.5 Update 2.0.
If you have a 1710AV monitor and a PCI-based computer, use
AppleVision 1.0.4 and the Monitors & Sound control panel.
AppleVision 1.0.2 is not compatible with PCI-based computers
that are running System 7.5.3.
If you have a 1710AV monitor and a non-PCI-based computer, use
AppleVision 1.0.2, the Sound control panel, and the Monitors
control panel.
Changes Related to Printing
Includes version 2.1.1 of the StyleWriter 1200 driver, which
fixes a crash bug on System 7.5.2-capable computers.
Includes the LaserWriter 8F (version 8.2.3F) driver, which
supports all the fax options on the LaserWriter 16/600. The
LaserWriter 8 (version 8.3.3) driver, which is also included
in Update 2.0, does not support all these fax options.
Supports QuickTime compressed images and ColorSync 2.0 through
the LaserWriter 8 (version 8.3.3) driver.
The LaserWriter 8 (version 8.3.3) and LaserWriter 8F (version
8.2.3) drivers contain fixes for two common printing problems
found on PCI-based computers: freezing when trying to print to
a printer that's busy, and freezing when trying to print large
documents or printing to LocalTalk-based printers.
Changes Related to Networking
On computers with 68030, 68040, or PowerPC processors, Easy
Install automatically installs Open Transport networking
software, which provides improved network flexibility and
performance. Open Transport is available on all computers with
68030, 68040, or PowerPC processors except for the desktop
5200, 5300, 6200, and 6300 series computers. Open Transport
will be active only if it was active before the update was
installed (otherwise, classic AppleTalk is active). If your
computer is not PCI-based, you can use the Network Software
Selector (NSS) to switch between Open Transport and classic
AppleTalk. You'll find the NSS utility in the Apple Extras
folder after you install System 7.5 Update 2.0.
Switching from Open Transport to classic AppleTalk usually
causes the network connection to revert to LocalTalk. After
you switch networking software and restart your computer, you
can use the Network control panel (classic AppleTalk) or the
AppleTalk control panel (Open Transport) to reselect the
desired network connection.
Depending on your system and networking needs, Open Transport
may require 400K[ASCII 208]1200K more RAM than classic AppleTalk. In
many cases, you can reduce this amount by turning on Virtual
Memory.
For more information, see the Open Transport Information
folder, inside the Apple Extras folder.
Known Problems and Workarounds
Apple Video Player displays an incorrect dialog box if it is
opened on a computer that does not have video-in capability.
Apple Video Player complains that the Video Startup extension
was not installed properly instead of stating that video-in is
required for this application to run.
If, when you try to print, you see a message that your
printing preferences are missing or damaged, open the Chooser
and select a printer.
Some versions of the LaserWriter driver (version 7.2 and
earlier) and the QuickDraw GX printer drivers still have the
problems that interfere with PCI-based computers trying to
print on a busy printer or trying to print large documents. If
you experience these problems, select the LaserWriter 8.3.2
driver from the Chooser.
Two different control panels are named "Energy Saver". The
older version worked by dimming the external screens of
certain computers. The newer Energy Saver, which works
differently, works only on PowerPC computers with PCI slots.
The universal System Folder that can be created by Update 2.0
contains only the newer Energy Saver. If your universal System
Folder requires both versions of the Energy Saver, do the
following:
- Rename the newer Energy Saver.
- Use Custom Install to install the older Energy Saver.
The new minimum RAM disk size is 416K. If a smaller RAM disk
exists during the installation of this update, it will be
turned off and its contents lost when the computer is
restarted. Therefore, before installing this update on a
computer with a RAM disk smaller than 416K, move all the
contents of the RAM disk to another disk.
Digital audio recording and playback can occasionally "skip"
if virtual memory is turned on. To reduce this skipping, turn
off virtual memory.
HyperCard version 2.3.3 or earlier does not record sound
properly on computers with PCI slots. Other sound recording
application programs, including SimpleSound and the Sound
control panel, can record sounds that you can import and play
within HyperCard 2.3.
When used with SerialDMA, DOS Compatibility software will not
be able to use hardware handshaking on the PC serial port.
There is an incompatibility between AppleShare Workstation
software version 3.6.1 and Connectix Speed Copy (part of Speed
Doubler version 1.1 or earlier). Use the Extensions Manager to
turn off Speed Copy before you install this update, and
contact Connectix to get the latest version of Speed Doubler.
(You can contact Connectix at http://www.connectix.com, 415
571-5100, or 800-950-5880.).
On a PowerBook 190 with Open Transport active: If you choose
the Infrared Port from the "Connect via" pop-up menu of the
AppleTalk Control Panel, then restart the computer and
networking doesn"t work, try putting the computer to sleep and
waking it up or choose the Modem/Printer Port and then switch
back to the Infrared Port.
If you have a PCI-based Mac OS computer connected to a Novell
Netware network: This update contains the Ethernet
Compatiblity extension version 1.0.3, which fixes a problem in
the system shutdown code. To use this extension, you need to
Custom Install the Ethernet Driver Update. A side effect of
this fix is a two-minute delay in shutting down the computer.
When using Drive Setup (version 1.0.4 or earlier) on some IDE
hard drives, the "Update driver", "Customize volume", and
"Test disk" options are dimmed. To use these options, back up
all data on the IDE disk (onto another disk), and use Drive
Setup to reinitialize the IDE disk.
If you have a Macintosh Centris 660AV, Quadra 660AV, or Quadra
840AV, some system alert sounds may not play correctly with
the alert volume turned down. To avoid the problem, keep the alert volume
turned all the way up and adjust the Built-In system volume by following
these steps:
- Open the Sound control panel.
- Choose Volumes from the pop-up menu.
- Adjust the volume.
Speech version 1.4.1 can cause a Macintosh Plus (a model which
does not support speech) to hang during startup. If your
Macintosh Plus hangs during startup, do the following:
- Restart the computer while holding down the Space bar.
- When the Extensions Manager dialog box appears, turn off
Speech.
If your computer has a 68000 processor and the computer won[ASCII 213]t
start up, try pressing the Shift key (to turn off extensions)
while you restart. If there is a "Color StyleWriter 2000 CMM"
file in your Extensions folder (inside the System Folder),
take this file out of the Extensions folder and restart your
computer. (To use the Color StyleWriter 2000 series printer,
you need a 68020 or higher processor.)
Tips
Many LaserWriter LS users are unaware that this printer is
supported by the LaserWriter 300 driver. To make this clear,
future system releases will rename this driver to LaserWriter
300/LS. For now, you can either rename this driver or wait for
a future release to do it for you. If you rename it, you must
select the new name from the Chooser before you can print
using this renamed driver.
Recent-documents tracking (in Apple Menu Options) tracks all
files that are opened,even those opened by an application as
part of its start sequence (such as drop-in filters used by
desktop publishing packages). This tracking can significantly
slow down the starting of these applications. To reduce this
overhead you can:
- turn off "recent documents" tracking in the Apple Menu
Options
control panel
- turn off Apple Menu Options in the Extensions Manager
This update resets all settings in the Apple Menu Options
control panel to their default values. If you have made
changes to Apple Menu Options, you will need to select them
again after installing this update. If you have set Apple Menu
Options to track more than ten items in any category, you may
want to move some of those aliases out of their folders before
you install the update, which deletes all but the ten most
recent items in each category.
The products included here are manufactured by vendors
independent of Microsoft; we make no warranty, implied or
otherwise, regarding these products' performance or
reliability.
Additional query words:
mac m_works powermac 7.5 7.5.1 power ppc
Keywords :
Version : MACINTOSH:7.5.3
Platform : MACINTOSH
Issue type :
Technology : kbvcSearch