System Changes in Macintosh System 7.5 Update 2.0, Part 1 |
The information in this article applies to:
-
Apple Macintosh System Software 7.5.3
SUMMARY
This article discusses the components included as part of the System
7.5 Update, 2.0. This information comes directly from the "New in this
Update - 1" file included with the update:
NOTE: The System 7.5 Update 2.0 includes all of the changes that were
included with the System 7.5 Update 1.0. These changes are listed
separately in the following article in the Microsoft Knowledge Base:
Changes with the Macintosh System 7.5 Update 1.0
MORE INFORMATION
General Information About the Update
System 7.5 Update 2.0 provides the enhancements introduced in
System 7.5 Update 1.0, plus many more.
This update installs the latest versions of all components
(including any components that were disabled using the
Extensions Manager) it finds on the disk it is updating.
After running the Installer, the updated components will be
in the same folders as they were before installing the
update. For example, new versions of disabled extensions will
be in the "Extensions (Disabled)" folder, and new versions of
disabled control panels will be in the "Control Panels
(Disabled)" folder.
The file called "System 7.5 Update" replaces the enabler on
all computers capable of running system software versions 7.5
and/or 7.5.1. Computers that did not previously need an
enabler to work with system software versions 7.5 and 7.5.1
still need the System 7.5 Update file, since it contains most
of the fixes delivered in this update.
The file called "System 7.5.2 Update" replaces the enabler
file on all computers capable of running system software
version 7.5.2.
This update includes all of the fixes included with the
previously released 7.5.2 Printing Update, the PowerBook 5300
System Software Update, and the PowerBook 2300c Update. These
updates are not needed if System 7.5 Update 2.0 is installed.
If any of these have been installed, System 7.5 Update 2.0
should still be installed, since it contains additional
fixes.
After installing the update, the About This Macintosh window
says "System Software 7.5.3." The window also says "System
7.5Update 2.0," to indicate the source of the system software.
Changes to the Finder
This update includes a new version of the Finder with the
following changes:
When rebuiliding the desktop, comments typed in a file's Get
Info window are no longer deleted. (Of course, if you delete
the desktop database for example, by making it visible using
a utility and then moving it to the Trash, the comments will
be lost because the Finder will have to build a new desktop at
startup.)
The Name field (used in Finder windows set to one of the list
views) is wider, allowing more characters to be seen in the
filenames.
On PowerPC-based computers, icons are translucent when dragged
(rather than simply appearing as outlines). When dragging
several icons at once, only the icon under the mouse will be
translucent,the others will still be outlines.
Copying large numbers of small files is faster. (Previous
versions of the Finder updated the bar in the copy progress
dialog box approximately thirty times per second; the new
version updates the copy progress bar far less frequently.)
The Finder Update file (once named PowerPC Finder Update) is
now part of the Finder. This update deletes all old versions
of this file.
When the Clipboard is active, the Clean Up Window command is
dimmed. This eliminates a crashing bug in the Finder.
The Finder flushes the processor's cache more intelligently,
improving the Finder speed on all 68040- and PowerPC-based
computers.
Fixes a problem that caused an out-of-memory error when
emptying the Trash if QuickDraw GX was installed.
Fixes a problem that caused seemingly false out-of-memory
messages when trying to open or close Finder windows. This
problem sometimes occurred when the desktop had very few icons
on it, a window with the Kind column was visible, and a large
number of different kinds of documents had been displayed
since the last restart.
Fixes a problem introduced by the Finder that shipped with
System 7.5 Update 1.0. The Find window of Find File will now
be made active if Find File is already open and the Find option
is chosen from File menu (or Find File from the Apple menu).
If you are trying to connect to your computer and your server
password has expired or needs to be changed when you try to
use an alias to connect to the server, you'll see a message
that the password needs to be changed. (Prior versions told
the user that the server couldn't be found.)
File copies are now done asynchronously, which makes the CPU
more available to other applications during copying. If
another application is made active during a file copy, the
computer does not slow down as much. This effect is most
noticeable when using Apple Remote Access.
Finder window titles are now erased before they are
overwritten. (Previous versions rendered window titles
unreadable in some circumstances.)
Changes to Find File
The following are the changes in Find File 1.1.2:
- Includes a list of Shortcuts, available from the Guide menu
(with the question-mark icon) when Find File is active.
- Includes a new preference used in sorting by Kind, "Use
full descriptions for found items," which gives more
specific Kind descriptions. Using this checkbox results
in slower sorts; not using it results in faster sorts but
with less specific Kind descriptions.
- Fixes a crashing bug that occurred if the same item was
dragged to the same location before the Finder finished
the earlier move.
- Fixes a bug that allowed non-numeric data to be input into
the Size search field.
- Fixes a bug that allowed a pasted item to exceed the length
of several search fields.
- Fixes a bug that allowed too many digits to be entered in
the Size search field.
- Allows you to drag a volume icon onto the Location pop-up
menu.
- Fixes the zoom box on 68K systems.
- Changes the alert message to be more informative when a
server being searched is disconnected.
- Changes the way the Found Items list displays items that
are in the Trash after the Trash has been emptied.
- Fixes a searching bug that occurred when the Kind requested
was "font."
- Fixes a crash that sometimes occurred when clicking the
Stop button in the sorting dialog box. This dialog box now
displays a spinner during a sort.
- Fixes a memory bug that sometimes occurred after several
consecutive searches.
- Fixes a display bug with Found Items that occurred when
using large font sizes.
- Fixes the CD-ROM icon in the Drives pop-up menu.
- Enables Find File to find invisible files, some of which
you can move (such as the Desktop, Desktop DB, and the
Desktop DF files).
- The Clear menu item now deletes only the selected text.
(The Clear key no longer deletes anything.)
- Fixes a bug that occurred when dragging a file onto the
Kind search field. Fonts and applications now show up as
such, not as documents.
- Fixes a crash that sometimes occurred when dragging an item
from the Found Items window to the desktop.
- Changes the prompt message when search fields are empty.
- Cleans up Balloon Help.
- Includes a new preference to specify transliteration.
- Speeds up searches in 2-byte languages if no
transliteration is necessary to perform the search.
- Fixes a bug where the filename input for 2-byte languages
could exceed maximum length.
Changes to Standard File
Fixes an occasional crash in Standard File that occurred when
the data cache was not flushed before being disabled.
Fixes a memory leak with some of the dialog boxes used for
opening and saving documents in Standard File.
Fixes a problem in the dialog box used for opening files that
could allow the pop-up menu to be dimmed in Standard File.
Changes to Control Panels
PowerPC-based computers with PCI slots now use the Monitors &
Sound control panel, instead of the Sound & Displays control
panel, to control monitor and sound settings. (System Update
2.0 removes Sound & Displays.) You can do a custom
installation to install the Sound control panel if you need it
for older applications. (The Monitors & Sound control panel
works only on PCI-based computers.)
The Memory control panel now displays "Will be off after
restart" if Virtual Memory is turned off, as a reminder that
just turning Virtual Memory off does not fully deactivate it.
The Memory control panel now uses a larger default setting for
the Disk Cache. After you install this update, the new setting
will be used only if the Use Defaults button in the Memory
control panel is clicked. The new default is 32K for each
megabyte of physical RAM installed, up to a maximum of 4096K.
(Virtual RAM is ignored for this calculation.) Thus, a
computer with 16MB of physical RAM would use 512K for its
default disk cache size, resulting in better performance for
disk-intensive tasks than the original default of 96K.
Fixes a bug in resizing a RAM disk in the Memory control panel
while File Sharing is on.
Fixes a problem in General Controls panel that caused problems
with Retrospect Remote if either application or System Folder
protection was turned on.
Includes a new option in the General Controls panel: "Folder
that is set by the application." Clicking this option sets the
default folder to the folder containing the document being
opened. Thus, when you open a document by double-clicking its
icon, the default folder will be set to the folder containing
the document (instead of to the Documents folder or to the
folder containing the application that opened that document).
Fixes a problem in General Controls panel that could hang the
computer if Applications folder protection was turned on and
there was a document or alias named "Applications" at the root
level of the startup disk.
Fixes a problem in the General Controls panel's folder-
protection code that could cause folders to become invisible
if Stuffit Spacesaver was installed.
CloseView no longer uses key combinations that were already
used by the Finder. The new key combinations for CloseView
are:
- Command-Option-K: turns CloseView on or off
- Command-Option-+ (the plus sign): increases magnification
- Command-Option-- (the minus sign): decreases magnification
If CloseView is active, it remains active after you change
your monitor's bit depth.
CloseView no longer hangs the system if Balloon Help is on
and an audio CD is inserted.
Includes the following new international keyboard layouts:
- French Canadian
- ISO Canadian
- Spanish
Installs the updated versions of the following international
keyboard layouts if older versions are already installed:
Changes to Apple Guide
This update includes Macintosh Guide 1.3 (and several new
Guide Additions files), which provides updated onscreen help
for system software.
This update includes Apple Guide version 2.0.2, which includes
the following improvements:
- Fixes problems with displaying coach marks in modal dialog
boxes.
- Fixes a serious memory leak that occurred every time a
Guide file was opened.
- Fixes a problem that caused every twenty-first index item
to disappear when multiple additions were in use.
- Fixes a problem that occurred when Apple Guide encountered
additions files that did not apply to the current
configuration of hardware and system software (for
example, if the QuickTime Guide were installed, but
QuickTime was not installed or had been turned off with
Extensions Manager).
- Defaults to US ASCII sorting only if the current script
is Roman and the current language is English. (Apple Guide
1.2.5 defaulted to US ASCII on any Roman script system.)
- Fixes problems with coach marks on 68K machines. (Coach
marks were sometimes drawn on the wrong menus.)
- Fixes a Look For problem in Japanese systems by first
trying to use the script code from the current database.
- Fixes a bug in <Delete Index> that affected Japanese
systems.
- Fixes problems with mixed-mode handling of installed coach
and context handlers.
- Fixes a problem that sometimes caused Apple Guide to shut
down completely on PowerPC-based computers. For example,
if a PowerBook additions file was present on a PowerPC-
based desktop computer, Apple Guide 1.2.5 would completely
shut down because the additions file couldn[ASCII 213]t be used.
Now, Apple Guide ignores the PowerBook addition and
continues running.
- Fixes a problem that prevented Apple Guide 1.2.5 from
starting up if QuickTime wasn't installed on the machine.
This problem occurred only on PowerPC-based computers.
- Includes localizable error strings for use in various abort
messages.
Changes to Apple Menu Options
Includes Apple Menu Options v.1.1.2, which introduces the
following changes:
- Has been largely rewritted for better performance and
improved stability.
- Fixes a problem that could hang the computer when the Apple
Menu Options preference file was dragged to the Trash.
- Fixes a problem that could hang the computer if there was a
locked alias in the Recent Documents, Recent Applications,
or Recent Servers folders. The new version ignores locked
aliases.
- Moved a large 68K patch that caused a general slowdown on
PowerPC based computers. This patch is now active only
while the mouse button is held down on the menu bar or in
a menu.
- Increases the height of the editing field used for entering
the number of documents, applications, and servers.
- Fixes a problem that could prevent the Recent Documents,
Recent Applications, and Recent Servers folders from being
deleted when tracking of those items is turned off.
- Fixes a problem that could cause Apple Menu Options to hang
if its settings were changed and the System Folder was on
a locked volume (such as a startup CD or locked floppy
disk). The hang would occur when Apple Menu Options tried
to write the new settings into the locked preferences
file. The new version does not try to record new settings
on a locked volume.
- Fixes a problem with sorting order; Apple Menu Options no
longer uses the U.S. standard for modified Roman and
Scandinavian alphabets.
- Prevents Apple Menu Options from deleting original files[ASCII 209]
it can now only delete aliases. (This change solves a
problem that occurred when users saved documents directly
into the Recent Documents folder. Once the document was
saved, Apple Menu Options replaced the file with an alias
to that file.)
- Fixes a problem that sometimes caused the contents of the
Apple menu to show up in place of the proper contents for
submenus.
The third-party product discussed here is manufactured by a vendor
independent of Microsoft; we make no warranty, implied or
otherwise, regarding this product's performance or
reliability.
Additional query words:
mac m_works powermac 7.5 7.5.1 power ppc kbreadme
Keywords :
Version : MACINTOSH:7.5.3
Platform : MACINTOSH
Issue type :
Technology :