Flight Simulator 95: Contents of the Readme.txt File
  
PSS ID Number: Q177236
Article last modified on 11-25-1997
 
WINDOWS:1.0
 
WINDOWS
 

======================================================================
---------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Flight Simulator for Windows 95, version 1.0
---------------------------------------------------------------------
 
SUMMARY
=======
 
This article contains a copy of the information in the Readme.txt file
included with Flight Simulator for Windows 95. The Readme.txt file is
located on the Flight Simulator CD-ROM in the FS6 folder, and on your hard
disk in the Flight Simulator folder.
 
MORE INFORMATION
================
 
Microsoft Flight Simulator ReadMe
August 1996
(c) Copyright 1996 Microsoft Corporation.
 
This Document Contains Important Information Specific to
Flight Simulator for Windows 95
 
Other Sources of Information About Flight Simulator
 
You can find more information about Flight Simulator in the
printed "Pilot's Handbook" and Pilot's Help, the multimedia
help system for Flight Simulator.
 
The "Pilot's Handbook" includes background information about
the new features in Flight Simulator, the airplanes you can
fly, and navigation charts.
 
Pilot's Help includes topics about aerodynamics, cockpit
instruments, aircraft systems, weather, navigation,
regulations, and other subjects related to aviation, plus an
Airport/Facilities Directory and detailed procedures for
using Flight Simulator. To start Pilot's Help, click Pilot's
Help on the Help menu in Flight Simulator.
 
And don't forget to visit the Flight Simulator Web site to
get the latest information. The Web site includes a product
support page with up-to-date tips, answers to frequently
asked questions, and articles. Click the Flight Simulator
Web Site command on the Help menu or use the following URL:
 
http://www.microsoft.com/games/fsim/
 
CONTENTS
 
"Monster Truck Madness" Trial Version
Configuring Joysticks
More Information About Video Displays and Video Drivers
Sound and System Performance
Visibility and System Performance
Configuring and Using Scenery with the Scenery Library
DirectX 2.0 Video Drivers
Microsoft DirectX 2.0 General Questions and Answers
BAO Flight Shop V5.0 Converters
BAO Europe 1 Scenery Add-On Scenery Product
Scenery Products Shipped Before Flight Simulator
  for Windows 95
Hardware and System Troubleshooting
Changing CD-ROM Drive Letters
============================================================
"MONSTER TRUCK MADNESS" TRIAL VERSION
 
The Flight Simulator for Windows 95 CD-ROM includes a free
trial version of the racing game "Microsoft Monster Truck
Madness." Double-click the file MTM TRIAL VERSION in the
MONSTER TRUCK DEMO folder to install and run this trial
version.
 
CONFIGURING JOYSTICKS
 
You can customize the buttons and other settings of a
joystick by editing the [JOYSTICK] sections of the
FLTSIM95.CFG file. You can find this file in the Flight
Simulator folder that setup created on your hard disk.
 
By editing this file, you can switch the buttons used for
raising and lowering the flaps, use buttons to change
elevator trim, and so forth. FLTSIM95.CFG is a text (ASCII)
file, so you can edit it with WordPad, Notepad, or any word
processor that can save text (ASCII) files.
------------------------------------------------------------
Before changing FLTSIM95.CFG, make a backup copy of the file
so you can restore the original settings if you make a
mistake or don't like the changes you've made.
------------------------------------------------------------
Editing FLTSIM95.CFG: General Considerations
 
To change joystick settings, edit the section of
FLTSIM95.CFG under the label [JOYSTICK_00]. If you have
installed more than one joystick, you'll find a
[JOYSTICK_XX] section for each joystick, where "XX" is the
number of a joystick.
 
Before changing FLTSIM95.CFG, make sure the value following
the LOCKED label (immediately below the [JOYSTICK] heading)
is set to 1, not 0. If LOCKED=0, Flight Simulator overwrites
the configuration file with the default values whenever you
choose the Preferences command on the Options menu.
 
You should also make sure that you do not change the value
after the TYPE label. This value is set automatically when
you choose the Preferences command from the Options menu and
select a joystick on the Controls tab.
 
It's also best not to change the value for the AXIS_FLAGS
label. This label determines which axes Flight Simulator
uses. Flight Simulator sets this value automatically.
 
Labels in FLTSIM95.CFG
 
Each line of the [JOYSTICK] section of FLTSIM95.CFG has a
label and a value. Each label defines a joystick function
(movement forward, back, left, or right; pressing a button;
and so forth). The value assigned to each label determines
movement along an axis or action taken when you press a
button. For example, the AXIS_EVENT_00 label controls
movement of the ailerons. The number after the equal sign is
the label's value.
 
The following table explains the function of each type of
label.
 
Label                  Action
------------------------------------------------------
AXIS_EVENT_##           Left, right, forward, or back
                        movement of the joystick
AXIS_SCALE_##           Direction the controls move
                        when you move the joystick.
                        These values normally should
                        be positive; negative values
                        reverse control movements
AXIS_NULL_##            Width of the "null" zone for
                        each axis.
BUTTON_DOWN_EVENT_##    Defines what action occurs
                        when you press a button.
BUTTON_DOWN_REPEAT_##   Determines whether an action
                        repeats if you hold down a
                        button.
-------------------------------------------------------
Reversing Joystick Controls
 
To fly with reversed joystick controls, change the values
after the labels AXIS_SCALE_00, AXIS_SCALE_01,
AXIS_SCALE_02, and AXIS_SCALE_03. Make the numbers after
each AXIS_SCALE label negative. The values should be in the
range -1 to -127.
 
You can tell which axis is affected by looking at the
AXIS_EVENT label that precedes each AXIS_SCALE label. Here
are the default settings:
 
AXIS_EVENT_00=65763 represents the ailerons
AXIS_EVENT_01=65762 represents the elevator
AXIS_EVENT_03=65764 represents the rudder
AXIS_EVENT_02=65765 represents the throttle
 
For example, to reverse the ailerons, change the lines
 
AXIS_EVENT_00=65763
AXIS_SCALE_00=64
 
 - to -
 
AXIS_EVENT_00=65763
AXIS_SCALE_00=-64
 
Reconfiguring Joystick Buttons
 
To reconfigure the buttons on a joystick, change the values
for BUTTON_DOWN_EVENT labels. If you want an action to
repeat if you hold down a button, add a
BUTTON_DOWN_REPEAT_##=1 label after the BUTTON_DOWN_EVENT##
label for that button.
 
The following table lists the values you can assign to
BUTTON_DOWN_EVENT labels.
 
Action                              Value
--------------------------------------------------
Extend or retract landing gear      65570
Autopilot master on/off             65580
Apply brakes                        65588
Nose down trim                      65607
Nose up trim                        65615
Pan view left                       65671
Pan view right                      65672
Look forward                        65674
Look forward right                  65675
Look right                          65676
Look right rear                     65677
Look back                           65678
Look back left                      65679
Look left                           65680
Look left forward                   65681
Autopilot approach hold on/off      65724
Autopilot heading hold on/off       65725
Autopilot altitude hold on/off      65726
Autopilot wing leveler on/off       65727
Autopilot NAV1 hold on/off          65729
Extend flaps in increments          65758
Retract flaps in increments         65759
Slew ahead or move elevator         65762
Slew sideways or move ailerons      65763
Slew heading or move rudder         65764
Throttle                            65765
Slew hold or apply brakes           65796
Slew heading or move ailerons       65797
 
-------------------------------------------------
If you have a CH Virtual Pilot Pro yoke, these are the
default values for the left hat switch:
 
Action                              Value
-------------------------------------------------
Cycle through gauges                65800
Reverse cycle through gauges        65801
Autopilot altitude hold and
  wing leveler on/off               65802
 
The gauges are VOR2, ADF, NAV2, NAV1, COMM, VOR1, in that
order. As you cycle through the gauges, you stop on the
whole and decimal parts of the ADF, NAV1, NAV2, and COMM
displays so you can increase or decrease the frequency or
radial.
 
Using BUTTON_DOWN_EVENT_## LABELS
 
Each BUTTON_DOWN_EVENT_## label corresponds to a button on
the joystick. The buttons are numbered 0-31. Buttons 32-63
define the positions of the "hat" switch. Most joysticks
support 4 or 8 "hat" positions. If your joystick has a 4-
position "hat" switch, only the even-numbered
BUTTON_DOWN_EVENT_## labels are used.
 
The value assigned to a BUTTON_DOWN_REPEAT_## label must be
0 or 1. If the value is 1, the action assigned to button
repeats if you hold down the button. If the value is 0 (or
if a BUTTON_DOWN_EVENT_## label is not followed by a
BUTTON_DOWN_REPEAT_## label), the action does not repeat.
 
Example:
 
If you have a Microsoft Sidewinder joystick, Flight
Simulator includes the following lines in the configuration
file:
 
BUTTON_DOWN_EVENT_00=65796
BUTTON_DOWN_REPEAT_00=1
 
The first label assigns the brakes to the trigger button.
The BUTTON_DOWN_REPEAT_00=1 label means the brakes are
applied continuously if you hold down the trigger.
 
Suppose you have a Microsoft Sidewinder joystick and want to
replace the flaps retract/extend functions assigned to
buttons 2 and 3 with nose-down and nose-up elevator trim.
Edit the BUTTON_DOWN_EVENT_02 and BUTTON_DOWN_EVENT_03
labels as shown below. If you add the BUTTON_DOWN_REPEAT_##
labels, nose-down or nose-up trim is applied continuously if
you hold down the corresponding button.
 
BUTTON_DOWN_EVENT_02=65607
BUTTON_DOWN_REPEAT_02=1
BUTTON_DOWN_EVENT_03=65615
BUTTON_DOWN_REPEAT_03=1
 
Changing an Axis Null Zone
 
The four AXIS_NULL_## labels determine the width of the null
zone for each axis (some joysticks have only three axes and
therefore the configuration file includes only three
AXIS_NULL_## labels). In other words, these labels define
how "touchy" the joystick is in the pitch, roll, and yaw axes
and how responsive the throttle is to small movements.
 
The value for an AXIS_NULL_## label must be in the range 0-127.
The larger the number, the wider the null zone--that is, the
controls are less sensitive to small movements of the joystick
along that axis. To make the controls more sensitive to small
movements, assign a smaller value to the appropriate
AXIS_NULL_## label. Flight Simulator sets all
AXIS_NULL_## labels to a value of 36. However, you can set a
value for each axis.
 
The range displayed on the RPM indicator depends on the
values assigned to the AXIS_SCALE_## and AXIS_NULL_## labels
for the throttle. The throttle is defined by the
AXIS_EVENT_## label that is assigned the value 65765. To get
the full RPM range, as you increase the value assigned to
the NULL values, you must also increase the value assigned
to the SCALE value. A SCALE value above 80 and a NULL value
below 40 give a full range.
 
============================================================
MORE INFORMATION ABOUT VIDEO DISPLAYS AND VIDEO DRIVERS
 
Some video cards do not display the non-rectangular
instrument panel window efficiently. You may be able to
increase performance by turning off the Display Non-
Rectangular Control Panel option. On the Views menu, choose
the View Options command. Select the Instrument Display tab,
and then clear the Display Non-Rectangular Control Panel
option.
 
DirectX has replacement drivers available for most major
manufacturers' video cards. In many cases, you'll get better
video performance if you use the DirectX drivers. For more
information, see the discussion on DirectX later in this
document.
 
For best performance, use the 256 colors (8 bit) setting for
your video resolution. Displaying more colors affects
performance.
 
You can find more information about video cards and video
drivers in the Hardware and System Troubleshooting section
of this document.
============================================================
 
SOUND AND SYSTEM PERFORMANCE
 
You can change sound settings by adding a [SOUND] section to
the FLTSIM95.CFG file.
 
------------------------------------------------------------
Before changing FLTSIM95.CFG, make a backup copy of the file
so you can restore the original settings if you make a
mistake or don't like the changes you've made.
------------------------------------------------------------
 
For example, setting mono sound and a lower sample rate may
improve system performance.
 
Here are settings for mono sound (single channel) and a
sample rate of 11 kHz:
 
[SOUND]
Channels=1
SamplesPerSec=11025
BitsPerSample=16
 
To set stereo sound and a sample rate of 22 kHz, use these
settings:
 
[SOUND]
Channels=2
SamplesPerSec=22050
BitsPerSample=16
 
The value assigned to SamplesPerSec should be equal or
greater to the sample rate of any wave file that will be
played. High values for SamplesPerSec may reduce overall
system performance.
 
The value assigned to BitsPerSample can be 8 or 16.
 
Sound Problems
 
If you switch to Flight Simulator from another application
while sound is playing, you may not hear Flight Simulator
sounds. To restore Flight Simulator sounds, press the Q key
twice, or switch from Flight Simulator to any other Windows
application, and then switch back again. Either action
should restore sounds in Flight Simulator.
 
============================================================
VISIBILITY AND SYSTEM PERFORMANCE
 
You can change the visibility setting in Flight Simulator
and improve system performance.
 
To Change Visibility
 
1. On the World menu, click Weather.
 
2.  In the Basic Weather dialog box, select the Visibility
option, and then click Unlimited.
 
  -or-
 
  If you're using the Advanced Weather dialog box, click the
Visibility tab, and then click Unlimited.
 
3. Click OK.
 
============================================================
CONFIGURING AND USING SCENERY WITH THE SCENERY LIBRARY
 
You can use the scenery library to find, add, delete, and
organize scenery files in Flight Simulator. You can also use
the scenery library to add, delete, or modify the CD-ROM
Performance Boosters that automatically load scenery from
the CD-ROM as you fly between scenery areas.
 
------------------------------------------------------------
Setup installs the scenery you select into the proper
directories and organizes that scenery into appropriate
areas and layers. Before you use the scenery library, make
sure that you read and understand the topics in the "Working
With Scenery" section of Pilot's Help. If you accidentally
delete scenery, reorganize scenery improperly, or modify CD-
ROM Performance Boosters incorrectly, you might have to
reinstall Flight Simulator to restore the proper settings.
------------------------------------------------------------
 
You can find complete information about the scenery library
in the Using Flight Simulator section of Pilot's Help. In
the table of contents, look for the topics in the book
"Working With Scenery." If you have questions about the
options and controls that you see in the scenery-related
dialog boxes, click the "?" in the upper-right corner of the
dialog box, and then click the item that you want more
information about.
 
Finding Scenery Files with the Scenery Library
 
Before you can use scenery files with Flight Simulator, you
must use the scenery library to locate them.
 
To Find Scenery Files
 
1. On the World menu, click Scenery Library.
Flight Simulator displays a message suggesting you do not
make changes to the scenery library unless you are sure of
the consequences. Choose Cancel to return to Flight
Simulator or choose OK to proceed.
 
2. Click Files, click Search, and then click Search Drive.
 
3. When the scenery is found, enter a Scenery Area Title,
select the options you want in the dialog box, and then
click Add Files or Add All Files in Path. Do not press RETURN
to close this dialog box.
 
4. Click Close.
 
Arranging Scenery Areas
 
You can rearrange scenery areas by assigning them to
different layers.
 
To Arrange Scenery Areas
 
1. On the World menu, click Scenery Library.
Flight Simulator displays a message suggesting you do not
make changes to the scenery library unless you know what you
are doing. You can choose Cancel to return to Flight
Simulator, or choose OK to proceed.
 
2. Click Files, and then click Arrange Layers.
 
3. Select the options you want in the dialog box, and click
OK.
 
Adding Scenery Areas
 
If you purchase additional scenery or want to add scenery
that came with your Flight Simulator package, it's best to
use the setup utility that came with that add-on to install
the appropriate scenery areas.  If you purchased Microsoft
Hawaii, Caribbean, Japan, or Scenery Pack I, see the section
titled "Setting Up Microsoft Scenery Packs" later in this
document.
 
If you want to add scenery to Flight Simulator manually,
make sure you understand how scenery areas and layers work.
You must also know the exact path name and file name for
each scenery file you want to add.
 
To Add a Scenery Area
 
1. On the World menu, click Scenery Library.
Flight Simulator displays a message suggesting that you do
not make changes to the scenery library unless you know what
you are doing. You can choose Cancel to return to Flight
Simulator, or choose OK to proceed.
 
2. Click Files, and then click Add.
 
3. Type the name of the scenery area file you want to add,
select the options you want in the dialog box, and click OK.
 
Changing Scenery Areas
 
You can change the path, title, type, layer, and status of
scenery areas. Before you change the settings for a scenery
area, make sure you understand how scenery areas and layers
work.
 
To Change the Settings for a Scenery Area
 
1. On the World menu, click Scenery Library.
Flight Simulator displays a message suggesting you do not
make changes to the scenery library unless you know what you
are doing. You can choose Cancel to return to Flight
Simulator, or choose OK to proceed.
 
2. Click Files.
 
3. Click the scenery area file you want to change and then
click Edit.
 
4. Select the options you want in the dialog box, and click
OK.
 
Deleting Scenery Areas
 
You can delete scenery areas from your hard drive to save
disk space. It's best to use Setup to remove scenery areas
that you no longer want. Before you delete a scenery area
manually, make sure you understand how scenery areas and
layers work.
 
To Delete a Scenery Area
 
1. On the World menu, click Scenery Library.
Flight Simulator displays a message suggesting you do not
make changes to the scenery library unless you know what you
are doing. You can choose Cancel to return to Flight
Simulator, or choose OK to proceed.
 
2. Click the scenery area file you want to delete, and then
click Delete.
Flight Simulator displays the message "Are you sure you want
to delete the selected scenery file?"
 
3. Click OK to delete the selected scenery area file.
 
  -or-
 
  Click Cancel if you changed your mind.
 
Working with CD-ROM Performance Boosters
 
CD-ROM performance boosters monitor your aircraft's position
and automatically load scenery from the CD-ROM drive to a
cache directory on your hard drive to improve performance as
you fly into different scenery areas.
 
------------------------------------------------------------
NOTE Before you use the scenery library, make sure that you
read and understand the topics in the "Working With Scenery"
section of Pilot's Help. If you delete, modify, or add CD-
ROM Performance Boosters incorrectly, you might have to
reinstall Flight Simulator to restore the proper settings.
------------------------------------------------------------
 
To Add, Delete, Or Edit a CD-ROM Performance Booster
 
1. On the World menu, click Scenery Library.
Flight Simulator displays a message suggesting you do not
make changes to the scenery library unless you know what you
are doing. You can choose Cancel to return to Flight
Simulator, or choose OK to proceed.
 
2. Click Performance.
 
3. Select a CD-ROM performance booster file and the options
you want in the dialog box, and click OK.
 
============================================================
DIRECTX 2.0 VIDEO DRIVERS
 
DirectX is a Windows system component that improves access
to hardware. Flight Simulator for Windows 95 requires
DirectX, version 2.0 or later. Setup installs DirectX on
your computer when you install Flight Simulator.
 
DirectX Replaces Video Drivers
 
DirectX 2.0 setup automatically updates your Windows 95
drivers and DirectX 1.0 drivers. In some cases, the latest
video drivers from your video card manufacturer have
additional functionality specific to your video card. If
these drivers are marked as DirectX 1.0 drivers, DirectX
setup replaces them with a generic DirectX 2.0 driver, and
you may lose some features specific to your video card.
 
If you want to retain the additional functionality in your
original video card drivers, you can:
 
Contact your video card manufacturer to get a DirectX 2.0
compatible video driver. This is the best solution.
 
-or-
 
Reinstall your DirectX 1.0 driver. Although this is not the
best solution, in most cases DirectX 2.0 will work with your
DirectX 1.0 driver.
 
Getting Updated DirectX 2.0 Drivers from Manufacturers
 
Contact your video card manufacturer and follow the
manufacturer's instructions to get the latest driver. These
drivers are often available on the manufacturer's World Wide
Web site or from a bulletin board (BBS). The driver is
usually available as a PKZip (ZIP) file or a self-extracting
executable (EXE) file.
 
If the manufacturer of your video card includes specific
instructions for installing the driver, follow them.
Otherwise, unzip the files into a temporary subdirectory on
your hard disk or onto a floppy disk. Then follow these
instructions:
 
1. Open the Display Properties dialog box by right-clicking
on the Windows desktop and then clicking Properties on the
popup menu.
 
2. In the Display Properties dialog box, click the Settings
tab.
 
3. Click Change Display Type.
 
4. In the Advanced Display Properties dialog box, click the
Adapter tab.
 
5. Click Change.
 
6. In the Select Device dialog box, click Have Disk.
 
7. If you have the latest video driver from your video card
manufacturer on a disk or CD-ROM, select the appropriate
drive and click OK. Otherwise click Browse. Go to the
temporary subdirectory you created for the video card files
and open the DISPLAY.INF file.
 
8. In the Select Device dialog box, choose the driver that
matches your video card and then click OK.
 
9. Click OK as many times as necessary to accept the
changes.
 
10. To restart your computer, click Yes in the System
Settings Change dialog box.
 
Restoring Your DirectX 1.0 Video Driver.
 
You should have a disk with the video drivers that shipped
with your system. You can also get a DirectX 1.0 driver by
contacting your video card manufacturer.
 
If you have specific instructions from your video card
manufacturer for installing the DirectX 1.0 driver, follow
them. Otherwise, follow these instructions:
 
To Restore A DirectX 1.0 Video Driver
 
1. Open the Display Properties dialog box by right-clicking
on the Windows desktop and then clicking Properties on the
popup menu.
 
2. In the Display Properties dialog box, click the Settings
tab.
 
3. Click Change Display Type.
 
4. In the Advanced Display Properties dialog box, click the
Adapter tab.
 
5. Click Change.
 
6. In the Select Device dialog box, click Have Disk.
 
7. If you have the latest video driver from your video card
manufacturer on a disk or CD-ROM, select the appropriate
drive and click OK. Otherwise click Browse. Go to the
temporary subdirectory you created for the video card files
and open the DISPLAY.INF file.
 
8. In the Select Device dialog box, choose the driver that
matches your video card and then click OK.
 
9. Click OK as many times as necessary to accept the
changes.
 
10. To restart your computer, click Yes in the System
Settings Change dialog box.
 
MICROSOFT DIRECTX 2.0 GENERAL QUESTIONS AND ANSWERS
 
Q. What is Microsoft DirectX?
A. Microsoft DirectX is a set of drivers available with the
Microsoft Game Software Development Kit (SDK).
 
Q. What components make up Microsoft DirectX?
A. DirectX components include DirectDraw, DirectInput,
DirectPlay, and DirectSound. DirectDraw and DirectSound
components replace current Windows 95 and DirectX 1.0
display and sound drivers with DirectX 2.0 drivers.
 
Q. How do I obtain Microsoft DirectX?
A. If you develop computer games and you want to provide
DirectX functionality within your game, you need the
Microsoft Game SDK. The Game SDK is available on the
Microsoft Developer's Network (MSDN) Level 2 CD-ROM.
Independent software vendors (ISVs) who use these components
in their games can redistribute them.
 
Q. What is DirectDraw?
A. DirectDraw allows direct access of video display memory,
hardware blitters, hardware overlays, and page flipping.
DirectDraw provides this functionality while maintaining
compatibility with existing Windows 95-based programs and
device drivers. Essentially, DirectDraw is a memory manager
for video memory. Using DirectDraw, a program can easily
manipulate video memory, taking full advantage of the
blitting and color decompression capabilities of different
types of video hardware without becoming dependent on a
particular piece of hardware.
 
Q. What is DirectInput?
A. The Microsoft DirectInput application programming
interface (API) provides fast and consistent access to
analog and digital joysticks. The DirectInput API maintains
consistency with the joystick APIs of the Microsoft Win32
Software Development Kit (SDK), but has improved
responsiveness and reliability by changing the device driver
model. DirectInput device drivers also use the registry to
store settings for standard joysticks, calibration
information for previously configured joysticks, and
settings for OEM-supplied joysticks.
 
Q. What is DirectPlay?
A. The Microsoft DirectPlay application programming
interface (API) for Windows 95 is a software interface that
simplifies game access to communication services. DirectPlay
provides a way for games to communicate with each other that
is independent of the underlying transport, protocol, or
online service.
 
Q. What is DirectSound?
A. The Microsoft DirectSound application programming
interface (API) is the audio component of the Microsoft
Windows 95 Game SDK that provides low-latency mixing,
hardware acceleration, and direct access to the sound
device. DirectSound provides this functionality while
maintaining compatibility with existing Windows 95-based
programs and device drivers.
 
Q. What do I do if I have problems with the DirectX drivers
that replace my Windows 95 video and sound drivers?
A. If you experience problems with the DirectX video or
sound drivers, you can remove them by running DXSETUP.EXE.
You can find DXSETUP.EXE on the Flight Simulator CD-ROM.
 
To run DXSETUP.EXE
 
1. Insert your Flight Simulator CD-ROM in your CD-ROM drive.
 
2. Open Windows Explorer, and then select your CD-ROM drive.
 
3. Open the Setup folder on the Flight Simulator CD-ROM.
 
4. Double-click the DirectX folder, which is inside the
Setup folder.
 
5. Double-click the file DXSETUP.EXE to run DirectX
Setup.
 
NOTE: After you run DXSETUP.EXE, some DirectX files remain
in the Windows\System folder. These files do not affect the
Windows 95 video or sound drivers. To remove these files,
restart your computer in MS-DOS mode and remove the
following files from the Windows\System folder:
 
DSOUND.*
DDRAW.*
DDHELP.EXE
DPLAY.DLL
DPSERIAL.DLL
DPWSOCK.DLL
 
Q. Who supports Microsoft Game SDK and DirectX?
A. Microsoft Game SDK is supported by Microsoft Developer
Support. The DirectX drivers, such as video and sound
drivers, are supported by the Microsoft Desktop Systems
group. If your DirectX drivers are provided by an original
equipment manufacturer (OEM), the drivers are supported
by that manufacturer.
 
Q. I'm running Windows NT 4.0 and I see the message
"Direct3D is not preinstalled in this version of Windows."
What should I do?
A. This message has no effect on Flight Simulator. You don't
need to make any changes after running Flight Simulator
setup.
 
============================================================
BAO FLIGHT SHOP V5.0 CONVERTERS
 
Look for aircraft and adventure converters to be available
through on-line services.
============================================================
 
SCENERY PRODUCTS SHIPPED BEFORE FLIGHT SIMULATOR
  FOR WINDOWS 95
 
This section describes how to use add-on scenery that was
designed for previous versions of Flight Simulator with
Flight Simulator for Windows 95.
 
Before proceeding, read all the instructions carefully.
 
BAO EUROPE 1 ADD-ON SCENERY PRODUCT
 
To use the BAO Europe 1 Add-On scenery, you must copy
files from your BAO disks into a folder in the directory
where you installed Flight Simulator for Windows 95. Then
you must run two EXE files and use the scenery library in
Flight Simulator to finish installing the BAO Europe
scenery.
 
To Copy the Files
 
1.  Find the folder where you installed Microsoft Flight
Simulator. The default is C:\PROGRAM FILES\MICROSOFT
GAMES\FLIGHT SIMULATOR. In the steps below, this folder
is referred to as <FLTSIM>.
 
2.  Copy the file DISK1A.EXE from disk #1 to the <FLTSIM>
folder.
 
3.  Create a EUROPE1 folder under your <FLTSIM>\SCENERY
folder and name it <FLTSIM>\SCENERY\EUROPE1.
 
4.  Copy the file DISK1.EXE from disk #1 and DISK2.EXE from
disk #2 to the EUROPE1 folder.
 
5.  Create two new folders under the EUROPE1 folder with the
names SCENERY and TEXTURE.  These folders should be named
<FLTSIM>\SCENERY\EUROPE1\SCENERY and
<FLTSIM>\SCENERY\EUROPE1\TEXTURE.
 
6. From your Flight Simulator CD, copy the files in the
\SCENERY SETUP\EUROPE1 folder to the
<FLTSIM>\SCENERY\EUROPE1\SCENERY folder.
 
To Run the DISK1 and DISK2 EXE Files
 
You should run these EXE files from an MS-DOS command
prompt.
 
1. Change to the <FLTSIM> folder on your hard drive and run
DISK1A.EXE. Type disk1a at the command prompt.
 
2. Delete the file DISK1A.EXE from the <FLTSIM> folder. Type
del disk1a.exe at the command prompt.
 
3. Change to the <FLTSIM>\SCENERY\EUROPE1 folder and run
DISK1.EXE and DISK2.EXE. Type disk1 and disk2 at the command
prompt.
 
4. Delete the files DISK1.EXE and DISK2.EXE from the EUROPE1
folder. Type del disk1.exe and del disk2.exe at the command
prompt.
 
Completing Installation with the Scenery Library
 
To finish installing the BAO Europe scenery, use the scenery
library in Microsoft Flight Simulator.
 
1. On the World Menu, click Scenery Library.
 
2. To display the Scenery Areas window, click the Files
button.
 
3.  Click the Search button. When the Scenery Area Search
window appears, select the drive where you installed
Flight Simulator and click on the Search Drive button.
 
4. When the search is complete, click the Next Path button
until you see the add-on folder you created.
 
5. Type the scenery area title Europe 1 and select the
scenery area type Local.
 
6. Click the Scenery Area Active button, and then click the
Add All Files In Path button.
 
7. Click Close.
 
============================================================
Setting up Microsoft Scenery Packs
 
This section describes how to use Microsoft scenery add-on
products for Microsoft Flight Simulator 5.0 or 5.1 with
Microsoft Flight Simulator for Windows 95.
 
First, note that if you own Microsoft New York, Paris, or
the BAO Las Vegas or Washington DC add-on scenery packs,
you don't need to install those scenery add-ons. Those
products are now included in Flight Simulator for Windows
95, and they're installed when you run setup.
 
If you own Microsoft Caribbean, Japan, Hawaii, or Scenery
Pack I, you must use a new setup program, included on the
Flight Simulator for Windows 95 CD, to set up those
products.
 
To Start the New Scenery Setup
 
1. Insert the Microsoft Flight Simulator for Windows 95 CD
in your CD-ROM drive.
 
2. Click the Start menu on the Windows 95 taskbar and select
Run.
 
3. When the Run window appears, enter
 
d:\scnsetup\setup.exe
 
(If your CD-ROM drive uses a letter other than d:, replace
d: with the appropriate letter.)
and click OK.
 
To continue installing the scenery, follow the on-screen
instructions. Scenery Setup asks which Scenery add-on you
are installing and for your original disks. Make sure you
select ALL of the Scenery add-ons which you want to install.
 
Note that certain areas of new scenery included with Flight
Simulator for Windows 95 are disabled to make way for these
add-ons. You can reactivate these areas by using the scenery
library in Flight Simulator. If you installed Hawaii, you
should reactivate the North America scenery area.
For more information about the scenery library, see the
section "Configuring and Using Scenery with the Scenery
Library" in this document. You'll also find detailed
information about the scenery library in the topics under
"Working With Scenery" in the "Using Flight
Simulator Section" of Pilot's Help.
 
If you decide to install additional Microsoft add-on scenery
products (Caribbean, Hawaii, Japan, or Scenery Pack 1), first
re-run Scenery Setup and uninstall any existing add-ons from
that list. Then run Scenery Setup again and select ALL
of the products you want install.
 
============================================================
HARDWARE AND SYSTEM TROUBLESHOOTING
 
This section describes some issues related to specific video
drivers and other hardware.
 
Issue: Joystick problems.
 
Resolution: If Flight Simulator doesn't recognize your
joystick, or if your joystick isn't working properly,
use the following procedure: From the Options menu,
choose Preferences. Select the Controls tab and press
the Calibrate button. To save the new settings, click OK.
To close the Preferences dialog box, click OK again.
To make sure the changes take effect, exit and then
restart Flight Simulator.
 
Issue: Matrox Millenium PowerDesk PCI boots only 50 percent
of the time
 
Discussion: DirectX 2.0 setup installs Millennium DirectDraw
drivers that do not work with the later PowerDesk drivers.
If you installed DirectX 2.0 after installing the PowerDesk
drivers, re-install the PowerDesk drivers. If this action
does not fix your problem, contact Matrox for updated
drivers.
 
Issue: The UNIVBE video driver doesn't allow DirectX 2.0 to
work correctly.
 
Discussion: Disabling the line in AUTOEXEC.BAT that calls
UNIVBE will fix the problem.
 
1. Open your AUTOEXEC.BAT file with Notepad or any other
editor that can save text (ASCII) files.
 
2. Search for the line that contains a reference to UNIVBE
 
3. Add REM to the start of the line to disable the driver.
   The edited line should look like this:
 
      REM UNIVBE.DRV
 
4. Restart your system.
 
To use the UNIVBE video driver again, edit AUTOEXEC.BAT
again. Removing REM from the beginning of the line that
contains UNIVBE.DRV and restart your system.
 
Issue: An error message appears that says, "A required .DLL
file, DDRAW.DLL, was not found."
 
Discussion: You need to reinstall DirectX, a system
component that makes more efficient use of your computer's
video hardware. DirectX is installed on your computer when
you install Flight Simulator.
 
To Reinstall DirectX
 
1. Insert your Flight Simulator CD-ROM in your CD-ROM drive.
 
2. Open Windows Explorer, and then select your CD-ROM drive.
 
3. Open the Setup folder on the Flight Simulator CD-ROM.
 
4. Double-click the DirectX folder, which is inside the
Setup folder.
 
5. To run DirectX setup, double-click the file DXSETUP.EXE.
 
6. Click ReInstall DirectX.
 
Issue: I can't play videos in Windows NT 4.0
 
Discussion: You must have administrative permissions on your
system to correctly and completely install Microsoft Flight
Simulator on a computer running Windows NT 4.0. Log on as
the Administrator, or talk to your system administrator to
change your permissions. Then, run Indeo setup from the CD-
ROM. Indeo setup is located at:
 
\FS6\Setup\Indeo\Setup.exe
 
============================================================
CHANGING CD-ROM DRIVE LETTERS
 
If you add a hard drive to your system or take other actions
that cause your CD-ROM drive letter to change after you
install Flight Simulator, you will see error messages about
CD-ROM performance boosters when you start Flight Simulator.
You will also see an error message if you try to run Flight
Simulator setup from the Add/Remove Programs dialog box in
the Windows Control Panel. These errors occur because Flight
Simulator uses the letter originally assigned to the CD-ROM
drive.
 
To correct the error messages associated with the
performance boosters, use the scenery library in Flight
Simulator.
 
To Change the CD-ROM Drive Letter for Performance Boosters
 
1. On the World menu, click Scenery Library.
 
2. Click the Performance button.
 
3. In the Performance Boosters dialog box, select the first
scenery area in the list of performance Boosters and
click Edit.
 
4. In Source Path, type the new CD-ROM drive letter and
click OK.
 
5. Repeat steps 3-4 for each scenery area in the performance
boosters list.
 
6. Click Restart.
 
7. Click OK twice to exit the scenery library.
 
To correct the setup error, you must run setup again from
the Flight Simulator CD-ROM. You cannot fix this error by
running setup from the Control Panel or from your hard disk.
 
Additional query words: flightsim fltsim flt sim fs95 fs read me text
read-me 1.00
======================================================================
Keywords          : kbreadme
Version           : WINDOWS:1.0
Platform          : WINDOWS
=============================================================================
Copyright Microsoft Corporation 1997.