With all the various specialized (and sometimes cryptic) tools for creating Web pages that exist on the Internet, have you ever said to yourself, "Gee, it'd be really nice if I could just use my everyday office productivity tools, like my word
processor, to create smart-looking Web pages with a minimum of hassle"? If so, then this chapter is for you!
This chapter introduces you to five free add-on programs that plug right into the Microsoft Office and Office 95 family of productivity tools, extending those productivity tools as quick, easy-to-use, and powerful Web authoring platforms. Because this
book is about Microsoft Internet Explorer 3.0 (which runs only under Windows 95 and Windows NT 4.0), the focus in this chapter is on the Internet Assistants for the Office 95 family of productivity tools. The Office 95 family of productivity tools
includes
Word 7.0, Excel 7.0, PowerPoint 7.0, and Access 7.0. You'll learn how to create a Web site using the most powerful of the Internet Assistants, Microsoft's Word Internet Assistant, and then augment that site with specialized documents created using the
Internet Assistants for the other members of the Office 95 family.
The Microsoft Word Internet Assistant is a free add-on program for users of Microsoft Word Version 7.0 or higher that enables users to create documents in Word or convert existing Word documents for publishing on the World Wide Web. It also enables
users to browse the Web right from within Word, without having to use an external Web browser program. This is made possible by a special built-in Web browsing component that's never more than a mouse click away.
If you're already a Microsoft Word user and have had a little exposure to the Internet, chances are that you already have what you need to use Word Internet Assistant. The following are the most basic requirements to run the Microsoft Word Internet
Assistants for Office 95:
The last two items are not required if you want to use Word Internet Assistant for creating and reading hypertext documents over an existing local area network (for example, for corporate intranet Web pages). However, in order to use Word Internet
Assistant to browse and create pages for the World Wide Web, you'll need either a direct Internet connection through your institution or business or a SLIP/PPP account obtained with a private Internet access provider.
If you already have the basic hardware/software requirements to run Microsoft Word, you probably don't need to upgrade your hardware. Word Internet Assistant is not a big program, and adds very little to Word's existing hardware requirements; just 2MB
of free hard disk space is all that's required for the entire program.
There is one software component that is highly recommended if you plan on working with Word documents to create Web pages, and that is a Microsoft scanner/cleaner for the much-publicized Word prank macros (WinWord.Concept, WinWord.Nuclear, and
so
on). Prank macros, as the name implies, are rogue scripts created in WordBasic (the scripting language built into every copy of Microsoft Word) whose function is to carry out whatever mischievous deed their miscreant author intends. These prank macros
attach themselves to Word documents and can easily infect another machine when a user uses Word to open up an infected document. The prank macros can not only cause Word to behave strangely (WinWord.Concept, for example, blocks navigation through the
directory tree in the File | Save As dialog box, and makes it impossible to save the current document as anything other than a template), but can cause file and directory corruption/deletion in the case of the more malicious prank macros. The Microsoft
Word Prank Macro Scanner/Cleaner tool is free and can be obtained at the following Microsoft Internet sites:
http://www.microsoft.com./kb/softlib/mslfiles/WD1215.EXE
ftp://ftp.microsoft.com./softlib/mslfiles/WD1215.EXE
NOTE
The latest revision of the Microsoft scanner/cleaner, at the time of this writing, is Version 1215and it is on the CD-ROM included with this book. Check Microsoft's WWW home page for updates:
http://www.microsoft.com./msoffice/msword/freestuff/mvtool/mvtool2.htm
After you download this file, place it in an empty directory and execute it to unarchive it. You'll notice that three new files were unarchived: WD1215.DOC, SCANPROT.DOT, and README.DOC. Read that README.DOC file for instructions on final installation
into your copy of Microsoft Word. After you execute the installation procedure outlined in README.DOC, the installation will scan your copy of Microsoft Word for any existing prank macro infection, scan your hard disk for documents that carry any prank
macros, and install several macros to protect your copy of Microsoft Word from future infection. This process takes only a couple of minutes, but you know what they say about "an ounce of prevention." One prank macro infection, especially one of
the more malicious ones, would set you back far longer than it takes to install the scanner/cleaner.
Microsoft Word Internet Assistant is incredibly easy to install. While it is installing, it will add the appropriate menus and toolbars to Microsoft Word to enable you to begin writing HTML documents (and export existing Word documents into HTML)
immediately. A copy of Microsoft Word Internet Assistant Version 2.03z is available on the included CD-ROM. After you have located this file, just follow this procedure for installation:
If you ever have to reinstall the Microsoft Word Internet Assistant for any reason, just repeat the preceding procedure, but just after the little splash dialog box that states that it's searching for installed components, you'll see the Internet
Assistant for Microsoft Word Setup dialog box with two new buttons: Reinstall and Remove All. Click Reinstall if you want to reinstall Microsoft Word Internet Assistant, or click Remove All if you want to completely remove it.
You can obtain updates for Microsoft Word Internet Assistant from Microsoft's Web site or FTP site. Point your Web browser at the following URL:
http://www.microsoft.com./msword/internet/ia/ia95/default.htm
Now that you have installed Microsoft Word IA, you are ready for the fun part: using it to actually compose a home page from scratch. The hardest step in this process is actually deciding upon contentwhat to actually put on your home page.
Remember the old real estate joke, "What are the three most important items in real estate? Location, location, and location." An analogous joke works here: "What are the three most important items in Web authoring? Content, content, and
content." Deciding what to put on your home page is the most important step, for it is the content of your page that will attract people and keep them coming back in the future. After you've decided upon content, the next most difficult task is
figuring out how to present ithow your page will look and feel. The Web site should be laid out logically so that the visitor can easily see what your Web site is about. The first page, therefore, should be more or less a table of contents of what
your site is about, telling the user what can be found there and providing links that the user can click on to easily navigate around.
The example presented in this chapter guides you through the task of creating a Web presence for an imaginary bookstore called Book Binders, a moderate-sized bookstore with a good repertoire of books in stock that holds weekly book signings by various
authors. You'll use the various Microsoft Internet Assistants to create a home pagethe first page a visitor to the site seesfor Book Binders. This home page will include links to other pages (which the user can just click on to view),
as
well as provide links to some of Book Binders' documents and brochures that have been turned into Web pages. First, however, the next section takes a look at some of the considerations you need to make when you design the Web site.
The best way to logically set up your Web site is to create a directory structure to organize and contain all the documents and images that you plan to publish on it. The idea here is that after you've created all the pages, images, and links to
connect
them all together, "packaging up" the whole directory structure for publishing on a Web server is a simple matter. Start by creating this directory structure:
In this section you're going to see just how easy Microsoft Word Internet Assistant makes creating Web pages. Start up Microsoft Word, select New from the File menu, select HTML.DOT from the General tab, and click OK (see Figure 25.2). This template
came from the Word Internet Assistant installation program, which added it to the list of templates your copy of Word already had. This template adds a few new options (discussed as they come up in the example) to your toolbar when you select it, as well
as hides those Word toolbar options that are not applicable to HTML documents.
After you click OK on the template selection dialog box, you'll be at the beginning of a new document, ready to begin typing your Web page. If you're familiar with the toolbars in Word, you'll notice that the Formatting toolbar (the second toolbar down
from the menu bar) no longer sports the Font and Size drop-down selection lists. This is one of those toolbar options that are not applicable to Web authoring because it is the visiting person's browser program (the client Web browsing software) that
determines what font and size to use. As a Web author, you're concerned only with the structure of the documentwhich makes your job easier. You're probably wondering, "OK, but how does the client Web browsing program know to display some
text larger than the rest, and know when to bold, italicize, and so on?" This is part of the structure of the HTML document; an HTML document is divided into different parts by tags.
Figure 25.3 shows some of the tags that are available from the Styles drop-down list in the Formatting toolbar. This figure shows the six standard heading levels for HTML documents; H1 displays the largest text available, and H6 displays the smallest
text available. Again, keep in mind that size is relativethe client Web browsing program determines precisely what font and size (pitch) to use for displaying the various heading levels.
First, you need to add a title to the top of the home page, which will be the first text your viewers will see. (This is usually the name of the company or institution.) From the Style drop-down list in the Formatting toolbar, choose the largest
heading, H1, click the Center text icon (the seventh icon to the right of the Style drop-down list), and type in the title Book Binders.
While you're at it, add a subtitle to let people know what Book Binders is all about. Choose Heading 2, H2, click the Center text icon, and type in the subtitle A Bookstore For The Masses. Before you get any farther, name the document default.htm by
saving it to disk in the c:\Website directory you created. On the Save As dialog box in the File menu, make sure the Save as type: drop-down list at the bottom displays HTML Document (*.htm), and then type default.htm in the File name: field.
CAUTION
Do not be tempted to merely type in the filename with an .HTM extension, thinking that Word Internet Assistant will automatically save the document as the correct type. If you initially save the document and do not change the Save as type: to display HTML Document (*.htm), Word will save the document as a normal Word document by default. The next time you work on it, it will still look like a valid HTML document because the same toolbars, editing screen, and HTML template will display as they did before, but the document itself will not function as an HTML document.
Now that you have saved the document for the first time as the proper type, with the name of default.htm, you can use File | Save, and Word will save the document properly from here on out. It's time to add some descriptive information to the page. You
should keep this short and sweet, because the home page is more or less a table of contents for the whole Web site.
Select the Normal,P paragraph style from the Style drop-down menu in the Formatting toolbar, and type in the company description shown in Figure 25.5. This new home page is starting to take shape!
TIP
You can type paragraphs one right after the other using the default paragraph style (Normal,P). When you press Enter at the end of each paragraph, a new paragraph is started automatically.
Of course, just as you can with any good word processor, you can copy and paste text from any document into your HTML document and then edit that text's properties to fit HTML standards.
So far, the home page looks more like a normal document than a table of contents. One way to spruce it up a bit is to provide a list. There are two types of lists in HTML: numbered lists and bulleted lists. You can easily insert them into the document
using Word IA's Numbered List and Bulleted List buttons (eighth and ninth buttons, respectively, to the right of the Style drop-down menu in the Formatting toolbar). The numbered list tends to denote a certain order or sequence to the items, so a bulleted
list is more appropriate for our example. Visitors to the Book Binders home page might not be interested in the order of the items that they see on the page, and more than likely want to go straight to the information they need.
A bulleted list would work well just below the short introductory paragraph. From the Style drop-down list in the Formatting toolbar, select List Bullet,UL (or click the Bulleted List button, the ninth button to the right of the Style drop-down list).
Type in the bulleted list items you see in Figure 25.6. (Word Internet Assistant automatically provides the bullets for you in a bulleted list when you press Enter; it also automatically provides the numbers for numbered lists.)
NOTE
The UL next to List Bullet in the Style drop-down list stands for Unordered Listthe standard HTML tag for specifying a bulleted list. Likewise, the OL next to List Number means Ordered Listthe standard HTML tag for specifying a numbered list.
TIP
Besides being able to create a bulleted or numbered list by selecting one or the other from the Styles drop-down list before typing the text, you can also highlight existing paragraph text and make a bulleted or numbered list out of it by selecting the List Bullet or List Number as appropriate. Once you've highlighted the text and selected the list type from the Style drop-down menu, just position the flashing cursor in this text and press the Enter key where you want each new bullet to appear.
If you've surfed the Net before, you've probably noticed the heavy use of something called rules or horizontal bars in Web pages. The reason for their frequent use is simple: not only do they make a page look sharper, but they add a kind of delineation
or page separation in long documents. There are many variations on the theme for rules, using different colors and pictures. Some of the fancier ones include solid bars of color, bars of rainbow hues, and those yellow-and-black diagonally striped bars
that
you recognize from construction sites. This example uses a basic rule as a separator.
The first thing you should ask yourself when you are deciding where to put rules in your HTML document is, naturally, where you want the appearance of separation in your document. In the Book Binders home page, a rule between the subtitle and the body
text seems natural. To place one there, position your flashing cursor at the end of the subtitle and press Enter. Now you have two choices for creating the horizontal rule: selecting Horizontal Rule,HR from the Styles drop-down list, or clicking on the
Horizontal Rule button (fifth button from the far right side of the Formatting toolbar). You should see a nice horizontal rule appear right on the new line that occurred when you pressed Enter.
Another good place for a horizontal rule would be right after the bulleted list, because you're going to be inserting some more material right there. Try the second method of adding a horizontal rule by positioning the flashing cursor at the end of the
last item in the bulleted list. Press Enter to drop the cursor to the next line, press the Backspace key twice to get out of bulleted list mode, and then click the Horizontal Rule button on the toolbar.
You might think that so far, the home page you are creating doesn't appear special at all. However, you're about to get into the meat of what HTML is about: hyperlinks. The key to hyperlinks are things called anchors, or highlighted text
(usually
blue in color). When you click an anchor, it jumps the user to the destination to which it's linked. The Book Binders home page has three items in its bulleted list that inform the user what to click to navigate around the Web site, and you need to create
those hyperlinks. First, however, you must create those documents themselves because part of the hyperlink process is selecting the actual file to which a particular anchor jumps.
From the File menu, select Save to save the latest changes to your default.htm home page, but do not close default.htm. Now begin a new HTML document as you did before, selecting New from the File menu and selecting HTML.DOT from the General tab. For
the purposes of brevity (and quick illustration), select Heading 1,H1 from the Styles drop-down list, and type in Book Binders Information Center. Save this document as an HTML document, with the name c:\Website\pages\infocntr.htm. Switch your Word view
back to default.htm. Next, create a hyperlink between the words Book Binders Information Center in the first item of the bulleted list and the document c:\Website\pages\infocntr.htm. Follow these steps:
NOTE
Hyperlinks can contain two types of file paths: relative and absolute. A relative path is relative to the current HTML document's location on the web server. For example, say that the currently displayed HTML document is default.htm, and there exists a pages subdirectory in which default.htm is located; a hyperlink using a relative path to the infocntr.htm document in the pages subdirectory would use the path pages/infocntr.htm (notice the lack of a leading slash).
An absolute path includes a full path to the document to which it's anchored, regardless of where in the server's directory tree the currently displayed HTML document is located. These absolute paths usually have a leading slash (for example, /pages/infocntr.htm). It is highly recommended that you use relative paths in your hyperlinks wherever possible because when you copy your Web site's directory structure to the Web server, the links will remain accurate no matter where in the Web server's directory tree your home page's directory structure is located.
To see how absolute paths are created, click the Link Path button on the Hyperlink dialog box to see the Use fixed file location option. Enabling this option will cause all hyperlinks from that point out to use absolute paths. The Book Binders example used in this chapter uses relative paths for all hyperlinks, so make sure that Use fixed file location is not enabled. You should leave this option not enabled unless you have specific reasons to use absolute paths.
Figure 25.8. The resulting hyperlink.
Inside Microsoft Word, hyperlinks work just as they do on a Web site, with an exception: a single mouse click on the anchor merely highlights it (for use in editing the properties of that anchor), whereas a double mouse click navigates you to the
document to which it's linked. This is most likely the opposite of what you're used to with a standard Web browser; single-clicks in a Web browser navigate, while double-clicks highlight. The reason Microsoft Word with Internet Assistant works this way is
because you're editing a document; because the phrase Book Binders Information Center is now considered a single object in the document (an anchor in this case), it's standard fare in authoring tools to use a single mouse click to select
that
object for editing purposes.
Go ahead and give this a trysingle-clicking on Book Binders Information Center should highlight the whole phrase, giving you the opportunity to edit the link properties with the Hyperlink button on the Formatting toolbar; a double-click should
navigate you to the c:\Website\pages\infocntr.htm file you created earlier.
This is a good time to discuss Word Internet Assistant's Web Browse view, which enables you to test-drive your page thus far. Notice the very first icon over on the far left of the Formatting toolbar (the one that looks like a pair of eyeglasses).
That's the Switch to Web Browse View icon, and as its name implies, it switches from Edit mode to Browse mode. Give it a try. With the default.htm file as the active document, click on the Switch to Web Browse View icon and watch what happens. Now,
instead
of the I-beam mouse cursor you see in Edit mode, there's a normal arrow cursor like you'd see in a Web browser program. It is here in Browse view that the mouse clicks work the way you'd expect them to in a browser program: single-clicks navigate you to
the document that the anchor is linked to, and double-clicks highlight the anchor. Single-click on Book Binders Information Center in your Web page, and notice how it immediately navigates you to the linked document behind itno double-clicking
necessary.
Word Internet Assistant will even enable you to create hyperlinks to documents that do not exist yet. Try this: in the second item of your bulleted list, highlight the two words Book Catalog at the end of the sentence. Click the Hyperlink button on the
Formatting toolbar, and use the Browse button to navigate to the c:\Website\pages directory. In the File Name: field of the Select File to Link dialog box, type in bkcatlog.htm (you'll create this file later) and click OK. Click OK at the Hyperlink dialog
box to complete the link. Notice that you have created an anchor out of Book Catalog which, when double-clicked, brings up the error dialog box shown in Figure 25.9. You'll fix this later when you use Excel Internet Assistant to create the bkcatlog.htm
file. For now, just dismiss this error dialog box.
Hyperlinks are not limited to just documents resident on your local machine; you can create hyperlinks to other Web sites, or even to specific documents located several layers deep on other Web sites. Word Internet Assistant makes this easy; all you
have to know is the URL (Uniform Resource Locator) pathname to that Web site or remote document.
You can try this by adding a new item to your bulleted list that will jump the user to a remote site; say the Library Of Congress search engine. Position your cursor at the end of the third bullet item, and press Enter to create a fourth bullet. Type
the text you see in Figure 25.10, create an anchor out of the words Library Of Congress search engine, and instead of using the Browse button to look for a local document, type in the following for the File or URL field of the Hyperlink dialog box: http://lcWeb.loc.gov./harvest/. This is shown in Figure 25.10.
Click OK on the Hyperlink dialog box. If you're anxious to see what this is going to do, go ahead and start up your Internet connection (if it's via a dial-up modem connection), click on the Switch to Web Browse View icon (the little eyeglasses), and
single-click on the Library Of Congress search engine anchor. Word IA will attempt to contact the remote site as shown in Figure 25.11. After it has been contacted, Word IA will download the appropriate HTML documents to display the Library Of Congress
search engine (see Figure 25.12). You can use this search engine to search for online publications such as public domain newsletters, reports, and so on.
NOTE
Notice that you're still in Word, which opens up a new window to display this site. This window works just like any Web browser; this is not a static Word document at all. You can click on the hyperlinks presented, fill in the text entry fields, and click on any buttons presented from the remote site. If you didn't know you were in Word, you'd probably swear you were using a Web browser. You know what? You actually are! In the beginning of this chapter, I mention "a Web browsing component that is never more than a mouse click away." That Web browsing component is InternetWorks, a product developed by a company called BookLink Technologies, Inc., which is now wholly owned by America Online (the product, that is). Just before InternetWorks was sold to America Online, Microsoft licensed enough of its code to create the Web browsing component of Word Internet Assistant.
To form good Web authoring habits from the beginning (as well as to be kind to potential Web site visitors), it's a good idea to title and sign your Web page. Titling a page is not the same as putting title text at the top of the page; instead,
it's giving your page the name by which it is known on the Webinformation that Web indexing/search engines use to find your site. This information is not always visible on the page itself; if it displays anywhere, it'll more than likely show up on
the Web browser program's title bar. The title information is some of the hidden code that Word Internet Assistant inserts at the top of your HTML document.
Word Internet Assistant provides two ways to title a Web page: you can click on the Title button on the toolbar (the last icon on the far right of the Formatting toolbarit looks like a sheet of paper with a lowercase i in it), or select
HTML Document Info from the File menu. Title your home page Book Binders Bookstore; this is descriptive enough that Web search/indexing engines will be able to help a person looking for book resources to find it. Click the Title button on the Formatting
toolbar (or select HTML Document Info from the File menu), and type in Book Binders Bookstore, as shown in Figure 25.13. Click OK.
Figure 25.13. Titling the home page.
Signing a Web page means placing information on it (usually at the bottom) that enables visitors to contact the people behind the Web site and placing a date on the page. This is neatly done with the Address style from the Formatting toolbar.
The
Address style is the Web convention of displaying the address information in a special way. Browsers such as Internet Explorer, Netscape, and Mosaic might show this information in italicized text, while other browsers might show the address information
indented or right-justified. Either way, the address information will be set off in a way that makes it clearly different from the rest of the document.
From the Formatting toolbar, select Address from the Styles drop-down menu, and then enter information something like that shown in Figure 25.14. Also notice that the e-mail path is anchored so that visitors can merely click on the e-mail path to send
you e-mail. You can do this by highlighting the e-mail path, clicking on the Hyperlink button on the Formatting toolbar, and in the File or URL: field of the Hyperlink dialog box, typing in the e-mail path again, only this time prefaced with mailto:. This
is a special tag in HTML that tells the local browser software to spawn the local e-mail program with the specified e-mail path as the recipient; all the viewer has to do is type the e-mail message body. Although the Web browsing component of Word
Internet
Assistant doesn't recognize this tag, most stand-alone Web browsers do, and I've included it here because most of the Web pages you see out on the Internet are set up much the same way.
You're probably wondering all along what all this Internet Assistant "GUI stuff" has been really doing behind the scenes. With the default.htm file as the active window, select HTML Source from the View menu. Well look at all that HTML
codeand guess what? You wrote it! As in Figure 25.15, there should be a two-button toolbar kind of floating around the top of this HTML Source window; the left button returns you to Edit mode, while the right button formats and color codes
the
HTML. Click the left button to return back to Edit mode.
One of the main attractions to the Web is its capability to incorporate pictures into documents, and the abundance of Web pages with pictures and graphics certainly bears that out. Word Internet Assistant makes the process of incorporating pictures and
graphics into the HTML document mindbendingly easy; just place your I-beam cursor where you want the picture to appear, and click the Picture icon on the Formatting toolbar (the fourth button from the far right). This brings up a dialog box in which you
can specify the pathname (there's a Browse button that'll help you do this) and pretty much click OK.
One thing that Word Internet Assistant does not have in its arsenal, however, is an image editing capability. You'll need a separate graphics package to do that, and preferably one that can work with both GIF (Graphics Interchange Format) and JPEG
(Joint Photography Exchange Group) images. Sorry, the built-in Windows 95/Windows NT PaintBrush just won't do. This chapter is about all the Internet Assistants (and not just Word), so this topic is discussed later in this chapter as a feature of the
PowerPoint Internet Assistant, where you can create and edit GIF and JPEG files. The next section introduces Excel Internet Assistant and shows you how to create some HTML tables for your Web site.
Microsoft Excel Internet Assistant is an add-in wizard that enables users to create and distribute Microsoft Excel documents online for viewing with any popular browser. It helps Excel users convert their spreadsheet data to HTML format either as a
separate document or into an existing document.
The hardware and software requirements for Excel Internet Assistant is basically the same as for the Internet Assistants for the other members of the Office 95 family; in the case of the Excel application itself, you need Version 7.0 or higher.
One highly recommended software item is a minor patch to Excel to correct three known bugs. This free patch corrects the following known problems: the 15-digit number bug, the Link to same cell on different sheets bug, and the Transposing ranges bug.
To
get a copy of the patch, as well as a more in-depth description of the three known bugs, point your Web browser to
http://www.microsoft.com./kb/softlib/mslfiles/XL15LINK.EXE
This file is also provided on the CD-ROM. Once downloaded (or found on the CD-ROM), place the XL15LINK.EXE file in a separate empty directory and execute it to unarchive it. Follow the instructions in the resulting README.TXT file for further
installation.
After you've applied the patch to your copy of Excel, you're ready to install the Excel Internet Assistant. The Excel Internet Assistant can be found on the CD-ROM, but you can get updates by pointing your Web browser at the following URL:
http://www.microsoft.com./msexcel/internet/ia/
Installing Excel Internet Assistant is a little bit different than installing Word Internet Assistant; instead of running an executable to start the installation process as you would with Word Internet Assistant, you merely drop the file HTML.XLA into
the LIBRARY subdirectory of your Excel product directory. Just follow this easy procedure to install and enable the Excel Internet Assistant:
Excel Internet Assistant is incredibly easy to use, and is one of the very best tools to use if you have to create tables for Web pages. Because tables in Web pages look and function like spreadsheets, Excel Internet Assistant lends itself well as a
tool to create themrich color, font, text formatting and all. In other words, if you have a spreadsheet with a certain look and feel, you can maintain this look and feel as you export it to an HTML table. This includes a spreadsheet with various
colors, different fonts, text formatting, and so onExcel IA can create a Web page table from this spreadsheet with all these things. You can use the following basic procedure to create a Web page table from any spreadsheet:
That's it! To illustrate, the next paragraphs explain how to create a really simple Excel spreadsheet showing what could be an excerpt from an online book catalog, and import that into the Web page as a table. This could be an example of the
bookstore's
"special of the month." Start Excel and type in a small spreadsheet like the one shown in Figure 25.17. Don't be afraid to spiff up the looks of this simple spreadsheet; use bold text for the column headers, maybe some color text in certain
places, and so on.
Figure 25.17. Creating a simple spreadsheet, and preparing to export it with Excel IA
Next, highlight the whole block of rows/columns where you typed text (including any column headers). An easy way to do this is to position your mouse at the top-left cell where you typed something, press and hold your primary mouse button, and drag
diagonally until you end up at the bottom-right cell. Release the primary mouse button. From the Tools menu select Internet Assistant Wizard. The first dialog box asks what cells you want to convert to an HTML table; by default, the location range of the
cells you highlighted will already appear there. Click Next.
The second dialog box asks where you want the resulting table to appear; either as a new HTML document (which you'll get to select a filename for in a subsequent step), or into an existing HTML document. Have it create a new document; you can use this
as an opportunity to fix the link you made from the anchor Book Catalog (in the second item of the bulleted list) to a previously nonexistent document c:\Website\pages\bkcatlog.htm. Use the Browse button to navigate to it, and click Next.
The third and final dialog box asks for more specific information that would be relative to a stand-alone HTML documentthings like Title, Heading, Footer information, and so on. Fill these fields in, using Figure 25.18 as your guide, and click
Finish. Remember, the Title information is the information that appears in the title bar of the visiting person's Web browser, whereas the Header information actually appears as part of the HTML document at the very top. If you've done this
successfully, clicking on the Book Catalog anchor in default.htm (while in Web Browse viewthe little eyeglass icon) should navigate you to the nicely formatted table shown in Figure 25.19.
Figure 25.18. Filling in the information for a stand-alone HTML document.
NOTE
If you do not see a cleanly formatted table while in Word Internet Assistant, but rather one with what seems to be HTML comments between the Header and the table (which might be blue in color), then you are still in Edit mode. Click the little eyeglass icon on the far left of the Formatting toolbar to switch to the Web Browse view, and you should see the document properly.
The Microsoft PowerPoint Internet Assistant enables users of PowerPoint for Windows 95 to create professional-looking Web pages merely by creating a PowerPoint presentation and then saving it as HTML. Because most Web sites consist of multiple pages
that are linked together using hyperlinks, PowerPoint lends itself well as a Web authoring tool. A typical workflow would be to create the PowerPoint presentation first, and then convert it to HTML.
The minimum version of PowerPoint needed is Version 7.0. The hardware and other software requirements are pretty much the same as the other Internet Assistants, so this section focuses on a free patch you might need depending on your version of
PowerPoint. There is a very important patch for PowerPoint Version 7.0a that corrects a screen redraw problem as well as a memory leak. The following caution describes the bug and a temporary way to get around it until the patch is applied.
CAUTION
PowerPoint version 7.0a has a bug in it that causes it to exhibit a screen redraw problem in certain views after several minutes of use. This bug exists only in the "a" release of PowerPoint 95. It makes PowerPoint drain system resources, causing screen redraws to distort and system performance to degrade upon continued use. When the bug manifests itself, you might receive system alerts notifying you of low system resources. If you do, you should immediately save your work and exit PowerPoint. Your files will be OK, right up to, and including, the last changes you made to them. If, on the other hand, you do not save and exit PowerPoint as soon as you notice the symptoms, you are susceptible to losing any recent changes to the open PowerPoint files. After you exit PowerPoint, system resources (and the responsiveness of other running applications) will return to normal. The problem occurs only under Windows 95, although it can occur under Windows NT 3.51 with heavy PowerPoint use.
Check your version of PowerPoint 95 by selecting About Microsoft PowerPoint from the Help menu. The second line down from the top should report the version number. If you have Version 7.0a, you need the patch. If your version number is merely 7.0
(without the a), you do not need the patch.
A copy of the patch is provided on the CD-ROM, but you can also point your Web browser to the following URL to get it:
http://www.microsoft.com./kb/softlib/mslfiles/PPREDRAW.EXE
Merely place this file in an empty directory, and execute it to unarchive it. Next, follow the instructions in the resulting README.TXT file to apply the patch.
PowerPoint Internet Assistant is included on the CD-ROM, but updates can be had by pointing your Web browser at
http://www.microsoft.com./mspowerpoint/internet/ia/
Place the PPTIA.EXE file in its own empty directory, and execute it to unarchive it. This should result in four new files: IA4PPT95.EXE, IA4PPT95.HTM, IA4PPT95.DOC, and README.TXT. The IA4PPT95.EXE is the actual setup program, and README.TXT is nothing
more than a packing list file (something like a MANIFEST.TXT). The real documentation is in the IA4PPT95.DOC and IA4PPT95.HTM files. These are essentially the same document but in different formats: Word and HTML, respectively. Use whichever of the two
formats is more convenient for you. When you double-click on either file in Explorer, it should spawn the appropriate application to read it: Word, in the case of IA4PPT95.DOC; or your Web browser, in the case of IA4PPT95.HTM.
To install PowerPoint Internet Assistant, first check to see if PowerPoint is already running; if it is, close it. Next, double-click the IA4PPT95.EXE file in Explorer. From here, you can pretty much follow the instructions on the screen. User
intervention is required only twice, and in both cases a click of the OK button continues the installation. After the installation completes, when you start PowerPoint, you should notice a new item added to the File menu as shown in Figure 25.20: Export
as
HTML.
NOTE
If you use a network installation of PowerPoint (that is, you run PowerPoint from a network-mounted drive on a server), running the preceding installation procedure will not work. You'll need to contact your site system administrator to have him or her install PowerPoint Internet Assistant into that server's PowerPoint installation.
In both the IA4PPT95.DOC and IA4PPT95.HTM files, there is a basic procedure that you can use to create HTML documents from a PowerPoint presentation. It's located in the section Step by Step with the Internet Assistant for PowerPoint. Rather than
repeating those steps, this section focuses on actually using the PowerPoint Internet Assistant to create an information center for the Book Binders company Web page. Remember the short infocntr.htm file you created with Word Internet Assistant to
illustrate Word IA's ease of creating hyperlinks to other local documents (the one where you only typed in Book Binders Information Center at the top of the document)? This section shows you how to flesh out that file with a PowerPoint presentation.
Start PowerPoint and create a very short PowerPoint presentation on Book Binders. Feel free to use PowerPoint's AutoContent Wizard or one of your own templates. In Figure 25.20, I used AutoContent Wizard, answering it with the following options:
First dialog box
Second dialog box
Third dialog box
Fourth dialog box
Click Finish at the last dialog box.
You should now have an eight-slide presentation with boilerplate text that you can replace with any text you want. To save time (and because this is only an example Web site anyway), go right to exporting this eight-slide presentation as is to HTML.
From the File menu, select Export as HTML as shown in Figure 25.20. You should see the HTML Export Options dialog box, which enables you to choose the output style, output format (GIF or JPEG), JPEG image quality and file size, as well as the folder where
the resulting HTML files will go.
CAUTION
When PowerPoint Internet Assistant exports a presentation as HTML, it creates not only HTML files, but GIF/JPEG images as well. PowerPoint Internet Assistant exports both the HTML files and the GIF/JPEG images to one directory: the directory you specify in the Folder for HTML Export on the HTML Export Options dialog box. It is highly recommended that you export each and every PowerPoint presentation you plan to use in your Web site to its own subdirectory of your Web site tree; otherwise, you will end up with an incredible mess of HTML files and GIF/JPEG images in what you might have thought was an HTML-only directory.
In Figure 25.21, notice that the sample PowerPoint presentation is being exported to c:\Website\pages\infocntr. Even though this directory doesn't exist yet, PowerPoint Internet Assistant will create it. The reason we're not just exporting to the
c:\Website\pages directory is not only to avoid a mixture (a mess) of GIF/JPEG images and HTML files in this directory, but to have all the HTML/images for the presentation located in one place, their own subdirectory, in case they ever need to be
removed,
edited, or replaced.
To make a change, it's a simple matter to remove the files in the Web presentation's subdirectory, make the necessary changes to the parent PowerPoint presentation, and then re-export the parent PowerPoint presentation as HTML to that subdirectory. If
the Web presentation were exported to, say, c:\Website\pages, you'd have a mess to clean up in there, for you'd have to remove all the Web presentation-related files without disturbing the other HTML files already there. With this being the only
"gotcha" in PowerPoint Internet Assistant, however, you can quickly create whole portions of your Web site with one fell swoop. You'll see in a minute.
After you have typed in the path c:\Website\pages\infocntr for the folder to export to (or you can use the Browse button as shown in Figure 25.21), click OK, and immediately slide your mouse all the way to the bottom of the screen, out of the
PowerPoint
window. The export process will begin.
NOTE
During the export process, you will see various splash dialog boxes and windows appearing and disappearing on your screen (as in Figure 25.22). The Scroll Lock indicator on your keyboard may also flash on and off. Do not move your mouse anywhere near the PowerPoint window during this time, or you might get stray graphics/zingers in the resulting Web presentation.
After the export is completed, you'll see a Status dialog box informing you that the export completed successfully. You can move your mouse now: click OK on this dialog box, save your PowerPoint presentation to a safe place (you might want to consider
the c:\Website\pages directory itself for later edits/updates), and exit PowerPoint.
What happened here is that all the PowerPoint slides themselves were exported to graphics files of the type you chose on the HTML Export Options dialog (sldXXX.gif or sldXXX.jpg). Along with those graphics files, the following were created:
Both the images and the HTML text files went to the c:\Website\pages\infocntr directory, which itself was created by the export process. The HTML files are set up so that one links to the next, just like a PowerPoint presentation, but with a twist: an
index.htm file was also created that acts as a master menu of them all. It is this index.htm file that you want to link to the Book Binders Information Center anchor on the main page. To view the index.htm file, just double-click it in Explorer, and you
should see something like what's shown in Figure 25.23.
Notice a cool feature of the PowerPoint Internet Assistant: it names each anchor on the index.htm to the text found at the top of each slide; that is, the title text at the top of each slide is now an anchor on the index.htmjust click on it to go
to that document. Imagine the possibilities: if you had to create a bunch of small Web documents with a master menu from which the user could pick, you could simply create a PowerPoint presentation with descriptive document titles at the top of each slide
(each slide being a stand-alone document). Export that presentation as HTML, and voilá! An entire technical data center, or card catalog, or recipe list, oryou get the idea.
You might notice that the product registration information you entered when initially installing PowerPoint made its way into this file and appears at the top. If that's the case in your index.htm file, it's easily fixedjust bring that file up
inside of Word (with Word IA installed, of course), edit out the registration information, and save it back as an HTML file. Done!
Next, create a link from the anchor Book Binders Information Center to this index.htm file. Start up Word and open up the c:\Website\default.htm file. Single-click on the anchor Book Binders Information Center to highlight it, and click the Hyperlink
button on the Formatting toolbar (the icon that looks like three links of chain). Using the Browse button on the Hyperlink dialog box, navigate down to the c:\Website\pages\infocntr directory and select the index.htm file (see Figure 25.24). Click Open on
the Select File To Link dialog box, and then click OK on the Hyperlink dialog box. This procedure orphans the original file c:\Website\pages\infocntr.htm that you used as a placeholder for the Book Binders Information Center anchor, so you can now just
delete the infocntr.htm file altogether.
TIP
The first section of this chapter mentions that Word IA lacks a native graphics editor capable of dealing with GIF/JPEG files. Remember how I hinted that PowerPoint Internet Assistant can? Just use PowerPoint to create a one-slide presentation, export it as HTML to a temporary directory (say, c:\temp), and grab the sld001.gif or sld001.jpg file (as appropriate) that the export process creates.
You might be interested in the little button images that the export process creates as well; these are useful for placing at the bottom of your pages so the users can navigate back and forth. Without their .GIF/.JPG file extensions, these little button images are called p2hnext (an arrow pointing to the right; looks like the Play button on a VCR), p2hprev (an arrow pointing to the left), and p2hup (a double arrow pointing to the left; looks like the Rewind button on a VCR). You might also want to take a peek at the other p2h files to see if you can use them. The remainder of the files from the one-slide presentation export process can be deleted.
Now to create a logo for the Book Binders home page. In PowerPoint, pick a template/slide style that you like, and type the introductory company text and subtitle on it. Delete any extraneous empty slides that might also be in that presentation
setyou want only one slide. (This saves on the time required for the export and avoids creating extra files for slides you don't need.) Export that single-slide presentation to a temporary directory. Take the sld001.gif (or sld001.jpg) file, and
copy
that to your c:\Website\images directory as logo.gif (or logo.jpg). Next, open the default.htm file in Word and insert the picture where you want it to appear by using the Picture button on the Formatting toolbar (see Figure 25.25). You might want to use
this logo to replace the name and subtitle, so after inserting the picture, just delete the text for the name and subtitle (see Figure 25.26). Pretty easy, eh?
This chapter covered a lot of ground. You've learned how to use the Word, Excel, and PowerPoint Internet Assistants as integrated tools to create an example Web site. The majority of the example site was created with Word Internet Assistant for general
layout and look and feel; you then filled the site in using the other Internet Assistants. If you've used relative pathnames for all the hyperlinks in your HTML documents, copying the entire c:\Website directory structure to the Web server for publishing
is now easy. Relative paths make it easy to transfer Web site directory structures without having to worry about "breaking" the hyperlinks.
Note that from within the Word Internet Assistant, you can use the smart icons on the toolbar to insert things like spreadsheets and presentations. Another tool you have in your arsenal is to use normal Windows drag and drop functionality to insert
these objects into your HTML document, and Word IA will take care of the translation to HTML. Some of the more detailed things you didn't learn but you might want to use is Word IA's capability to create fill-in forms. This is accessible within Word IA by
navigating Insert | Form Field.
There are two other Internet Assistants you might want to look at: the Schedule+ Internet Assistant (which was in beta at the time of this writing), and the Access Internet Assistant. The Access Internet Assistant requires database knowledge of tables,
queries, form datasheets, and reports, all of which are beyond the scope of this chapter. You can obtain both of these Internet Assistants from Microsoft's Web site at the following URLs:
Schedule+ Internet Assistant:
http://www.microsoft.com./msscheduleplus/internet/ia/
Access Internet Assistant:
http://www.microsoft.com./msaccess/internet/ia/
You should now have a good idea of how to use the various Internet Assistants for the Office products to create logically laid out and aesthetically pleasing Web pages. This leads us nicely into the next chapter, which deals with Microsoft FrontPage.
FrontPage is a soup-to-nuts web site authoring and management suite, with a personal web server component built-in.