Previous Page TOC Next Page



- 5 -
Installing and Configuring Internet Explorer 3.0
by Joe Kraynak


You're connected to the Internet. Now you're ready to fire up Internet Explorer 3.0 and take it for a test drive. But before you pull this Cadillac of Web browsers out on the open road, you have to get it, install it, and set it up for optimum performance.

In this chapter, you'll learn how to download Internet Explorer 3.0 from Microsoft's FTP server (if you don't already have it), how to install it on your hard drive, and how to get it up and running. Whether you have a Mac running System 7, or a PC running Windows 3.1 or Windows 95, this chapter shows you which version of Internet Explorer to download and how to set it up.

Then, the fun starts. Later sections in this chapter show you how to take control of Internet Explorer 3.0 to make it look and act the way you want it to. You'll learn how to change the size of text that's displayed on a Web page, the background color, and the appearance of links and shortcuts.

After you've changed the face of Internet Explorer 3.0, you might want to make additional changes to improve its performance. You'll learn how to streamline Internet Explorer 3.0 to increase its overall performance and how to increase the memory and disk cache size so you can quickly reload pages you have already visited.

Getting a Copy of Internet Explorer 3.0


Microsoft Corporation's marketing department is one of the most aggressive departments of its kind. When Microsoft wants to increase market share for one of its software products, it simply drops the price—to nothing. When Microsoft went to war against Intuit's Quicken, Microsoft bundled Microsoft Money free with just about every Microsoft product on the market.

The same is true with Internet Explorer. All you have to do to get a copy of Internet Explorer is connect to Microsoft's Internet site and copy the file. It's not shareware, so you don't have to pay for it later, and registration is optional. Soon, you won't even have to download Internet Explorer—it will come as an integral part of the Windows operating system (assuming you upgrade).



TIP

Before you connect and download, make sure you know which version you need. Obviously, if you have a Macintosh, you'll want the Mac version of Explorer. Not so obvious is that Internet Explorer 3.0 is not the same for Windows 3.1 and Windows 95. Make sure you get the right version of Internet Explorer 3.0 for your version of Windows.


You can download Internet Explorer from Microsoft's FTP server using an FTP program or a Web browser that can handle FTP transfers (most Web browsers support FTP file transfers). If you don't have a Web browser, install the older version of Internet Explorer from the CD at the back of this book, and use it to connect to Microsoft's FTP server and download the latest version.

The following steps show you the basic procedure for downloading Internet Explorer. These steps assume that you are using Internet Explorer 2.0 to download Internet Explorer 3.0. If you are using an earlier version of Internet Explorer, or a different Web browser, your steps might be a little different.

  1. Establish your Internet connection, as explained in Chapter 3, "How to Get Connected," and Chapter 4, "Configuring Windows 95 for the Internet."

  2. Double-click on the icon for running your Web browser. Your Web browser runs and then loads the starting page. (This page differs depending on how you set up your Web browser.)

  3. In the URL or Address text box, type http://www.microsoft.com/ie/, and press Enter. This connects you to the Internet Explorer Home Page.

  4. Click on the Get It! link, as shown in Figure 5.1. This connects you to the Get Microsoft Internet Explorer page, which shows the available versions. (The link you click on might differ from the one shown here. Microsoft is constantly updating its Web pages.)

    Figure 5.1. You can copy Internet Explorer and use it for free.

  5. Click on the link for the Internet Explorer version you want to download. Make sure you select the Download option for the operating system and language you are using (for example, under Windows 95, you might select Download English). This displays a page that explains more about Internet Explorer. You can read more about Internet Explorer, read download and installation instructions, or download Internet Explorer right now.

  6. Click on the icon for downloading a free copy of Internet Explorer. A dialog box appears (as shown in Figure 5.2), asking if you want to save the file to disk. The dialog box you see will differ if you are using a different Web browser.

    Figure 5.2. If you are using a previous version of Internet Explorer, you can download the file or run it.

  7. If you are using a previous version of Internet Explorer to download the latest version, click Open. After Internet Explorer downloads the file (called msie30.exe), it runs the file, which automatically updates Internet Explorer.

    If you are using a different Web browser, choose the command for downloading the file, and then pick the directory or folder in which you want the Internet Explorer file stored (see Figure 5.3). (You can run this file later to install Internet Explorer.)

    Figure 5.3. Netscape Navigator 2.0 asks where you want to store msie30.exe. Pick a directory or folder.

  8. Wait until your Web browser indicates that the file has been successfully downloaded.

If you used a previous version of Internet Explorer to download the latest version, and you chose to run the file automatically after downloading it, simply follow the on-screen instructions, and you're done. Skip ahead to "Running Internet Explorer 3.0."

If you downloaded the file to run later, and you're using Windows, see the next section, "Installing Internet Explorer for Windows." If you're using a Mac, skip ahead one section to "Installing Internet Explorer for the Macintosh."

Installing Internet Explorer for Windows


Like most files you find on the Internet, msie30.exe is a compressed file that contains all the program files that make up Internet Explorer 3.0. Fortunately, msie30.exe is a self-extracting, self-installing compressed file.

In other words, your job is going to be very easy. To install Internet Explorer 3.0 in Windows 95, run My Computer or Windows Explorer, and change to the drive and folder that contains msie30.exe. Double-click on msie30.exe, and answer a couple questions to install Explorer 3.0 (see Figure 5.4).

Figure 5.4. Internet Explorer 3.0 installs itself, but you have to answer a couple questions.

If you have Windows 3.1, you can run msie30.exe from File Manager. You can also run files from Program Manager. Open Program Manager's File menu, and select Run. Use the Run dialog box to run msie30.exe, and then answer any questions. The installation utility creates a program group that contains an icon for running Internet Explorer 3.0.

Installing Internet Explorer for the Macintosh


Everything is easy on a Mac, right? Well, installing Internet Explorer 3.0 for the Mac is actually a little more difficult than installing the Windows version. The problem is that Internet Explorer 3.0 for the Mac does not come as a self-extracting file. It comes as a BinHex encoded file, and you need a special utility to decompress the file.

The CD at the back of the book contains such a utility, called StuffIt Expander (see Appendix E, "About the CD-ROM"). Copy the StuffIt file to a folder on your hard drive, double-click on the icon, and follow the on-screen instructions. This places an icon for StuffIt Expander on your desktop.

Now you can use StuffIt Expander to decompress the Internet Explorer 3.0 file you downloaded. Drag the icon for the file you downloaded over the StuffIt Expander icon and release the mouse button. StuffIt Expander decompresses the Internet Explorer 3.0 file and creates an Internet Explorer Installer icon. Double-click on the Internet Explorer Installer icon and follow the on-screen instructions to complete the installation.



TIP

You can obtain the latest version of StuffIt Expander from Aladdin Systems at

http://www.aladdinsys.com/

The only trouble is that the Stuffit Expander file is encoded, and you need to decode it before you can use it. Some Mac FTP programs, such as Fetch and Anarchie, can decode Mac Binary files during the downloading operation. However, Web browsers do not perform this important operation. If you use a Web browser to download the file, you must then use an older version of StuffIt Expander to decode the file for the newer version.



Running Internet Explorer 3.0


After you have Internet Explorer 3.0 on your computer, you can run it simply by double-clicking on its icon. If this is the first time you've run Internet Explorer, this starts the Internet Setup Wizard. Assuming you have already set up your Internet connection, click the Use Current option, and click Next. If you have not set up your Internet connection, follow the on-screen instructions to do so, now.

Whenever you click the Internet icon or try to run one of your Internet programs, Windows checks to see whether you're connected to the Internet. If you haven't connected, Internet Explorer 3.0 runs your TCP/IP program and displays a dialog box asking for login information (your name and password). Enter the requested information, and click Connect to connect to your service provider.



TIP

If you double-click on the Internet Explorer 3.0 icon and receive an error message that your operating system cannot find Winsock, try establishing your Internet connection before running Internet Explorer 3.0.


After your computer connects to the service provider, Internet Explorer 3.0 loads Microsoft's home page, as shown in Figure 5.5. If you receive a message saying that Internet Explorer 3.0 cannot find the page, there's probably something wrong with your DNS settings. Check your Network settings and Dial-Up Networking properties to make sure you've entered the proper settings.

Figure 5.5. Internet Explorer 3.0 is set up to automatically connect to Microsoft's home page.

You will no doubt want to play around and wander the Web before you start customizing Internet Explorer 3.0, and I'm not about to try to stop you. Go ahead and click on links (highlighted text and icons), and use the Back and Forward buttons to navigate.

As you play, you might want to skip ahead to Part II, "Navigating with Internet Explorer 3.0." When you're done, come back here for details on how to improve the look and performance of Internet Explorer 3.0.

Customizing Internet Explorer 3.0


Internet Explorer 3.0 is set up to look and behave the way most people want it to. The problem is that you're not most people. Maybe you don't care about all the fancy graphic images on a page—you just want the page to load fast. Maybe you want big text, red links, and a white background. And you don't want security warnings whenever you fill out a search form.

You can change all these settings and more in Internet Explorer 3.0 to make Internet Explorer 3.0 the browser you want. The following sections explain how to make cosmetic changes to Internet Explorer 3.0. Later in this chapter, you will learn how to enter settings that control Internet Explorer 3.0's performance.



TIP

You can enter most settings in Internet Explorer 3.0 without being connected to the Internet. Simply keep Internet Explorer 3.0 running, but disconnect from your service provider. However, some options (such as setting the start and search pages) do require that you be connected.



Customizing Microsoft's Home Page


Microsoft's home page used to be fairly standard. It had links to Microsoft products, support, and search tools. Recently, Microsoft opted for a less conventional, fully customizable page. When you see Microsoft's home page for the first time, click the Custom Start Page link, and complete the on-screen forms to specify what you want on the page (current sports scores, stock quotes, weather reports, daily comic strips, you name it).

Microsoft builds the page for you, giving you a unique page to start each day. You can rebuild the page to include different items at any time. Simply choose the link for customizing the page.

Taking Control of the Toolbar


Another way to customize Internet Explorer is to change the size and appearance of its toolbars. Take any of the following steps to customize the toolbar:

Feel free to play around with the toolbar to get a feel for how you can stretch it or shrink it to your liking.

You can also modify the buttons on the Links toolbar to point to your favorite pages. First, open a Web page to which you want to assign a Links button. Open the View menu, select Options, and click the Navigation tab. Open the Page drop-down list, and click the Quick Link button to which you want to assign this page (the buttons are numbered). Click on the Use Current button, and click OK.

Starting with a Different Home Page


The best way to sell anything on the Web is to create a great Web browser, and then have it automatically load your company's home page on startup. Whenever you run Internet Explorer 3.0, it loads Microsoft's home page, which you can customize, as explained in "Customizing Microsoft's Home Page," earlier in this chapter.

This isn't a bad place to start, but you can do better. Maybe you'd like to start with a search page, such as Yahoo! (at http://www.yahoo.com) or Web Crawler (at http://www.webcrawler.com). If you're into art, perhaps you'd like to start with Art on the Net (http://www.art.net). Or maybe you like to start your day with the Wall Street Journal (http://www.wsj.com).

As long as you know the address of the page you want to start with (or you know how to get there), you can have Internet Explorer 3.0 load that page at startup. Internet Explorer 3.0 is also set up to load Microsoft's Search page whenever you click on the Find button. If you know the URL of another search page you would prefer to use, you can use it instead.

To change the start or search page, connect to the Internet, run Internet Explorer 3.0, and take the following steps:

  1. Load the page that you want to use as your starting page. (For details on how load Web pages, see Chapter 6, "Browsing the Web.")

  2. Open the View menu, and select Options. The Options dialog box appears.

  3. Click on the Navigation tab (see Figure 5.6).

    Figure 5.6. Internet Explorer 3.0 lets you enter URLs for the start and search page you want to use.

  4. In the Page text box, make sure Start Page is displayed.

  5. Click on the Use Current button, and click OK. The URL for the current page replaces the URL for Microsoft's home page.

  6. To change your search page, display the page you want Internet Explorer 3.0 to display when you click the Search button.

  7. Open the View menu, and click on Options.

  8. Click on the Navigation tab.

  9. Open the Page drop-down list, and select Search Page.

  10. Click on the Use Current button, and click OK.

You can change back to the original start and search pages by repeating these steps and clicking on Use Default instead of Use Current.



TIP

Search pages also make good starting points. Yahoo! is one of the most popular starting points because it offers both search capabilities and an extensive categorical listing of Internet sites. You might also try Point Communications (http://www.pointcom.com), home of the Top 5% Web Sites.



Setting the Background and Text Color


Many Web pages have their own background color or design and use the default color for displaying text (black). Most Web pages, however, do not specify a background. In such cases, the Web browser itself determines the background color—a dingy gray in Internet Explorer 3.0.

To specify a different background or text color (for Web pages that do not specify these settings), take the following steps:

  1. Open the View menu and select Options.

  2. Make sure the General tab is selected (see Figure 5.7).

    Figure 5.7. The Internet Options dialog box is the key to configuring Internet Explorer 3.0.

  3. Under Appearance, select Use these colors instead of Windows desktop colors, to place a check in the box.

  4. To change the background color, click on the Background button. This displays the Color dialog box, shown in Figure 5.8.

    Figure 5.8. The Color dialog box.

  5. Click on the desired color in the Basic Colors list, and then click OK. (You can click on the Define Custom Colors button to create a unique blend of colors.)

  6. To change the text color, click on the Text button. The Color dialog box appears.

  7. Click on the desired color in the Basic Colors list, and then click OK.

  8. To save your changes, click OK. Internet Explorer 3.0 automatically refreshes the current page to display the text and background colors you selected. (If the page itself specifies a background color, the color will not be changed.)



TIP

When you select colors, contrast is of the utmost importance. If you display green text on a red background, you'll likely go blind trying to read it. In this book, we have selected a black text on a white background. Although unoriginal, it's easy on the eyes.



Selecting Different Fonts


HTML codes, used for formatting Web pages, typically provide a Web browser with general instructions on how to display text. For example, the <H1> </H1> codes tell the browser that the text between the codes should be displayed as a level one heading. The Web browser decides how level one headings will appear.

Internet Explorer 3.0 is set up to use specific fonts (type styles) for displaying text. For most text, it uses Times New Roman as the proportional font and Courier New as the fixed-width font. (A proportional font gives each character only the space it needs; a skinny i gets less space than a fat m. Fixed-width fonts give each character the same space; these fonts are commonly used for computer code and text you must type.)

You can change the font and text size that Internet Explorer 3.0 uses. To change the text size, open the View menu, point to Fonts, and click on the desired size: Largest, Large, Medium, Small, or Smallest.



TIP

To quickly change the text size, click on the Font button in the toolbar. As you click on the button, Internet Explorer cycles through the same text size settings available on the View | Fonts menu: Large, Largest, Smallest, Small, Medium. If a Web page specifies a font size, that setting will override any setting you enter. However, most Web pages provide only general directives about fonts and sizes.


To change the font (type style) that Internet Explorer 3.0 uses, open the View menu, select Options, and make sure the General tab is selected. Open the Proportional font or Fixed-width font drop-down list, and click on the desired font (see Figure 5.9). Click OK.

Figure 5.9. Select the desired font from one of the drop-down lists.

Changing the Appearance of Shortcuts and Addresses


In addition to changing the appearance of text, you can change the way Internet Explorer 3.0 displays links (called shortcuts in Internet Explorer 3.0), and the way it displays URLs (addresses) in the status bar.

To change the look of shortcuts and addresses, open the View menu, select Options, and click on the General tab. Shortcuts to pages are normally underlined and blue (for pages you have not yet visited), and maroon (for pages you have visited). To change the color of a shortcut, click on the Visited links or Unvisited links button, click on the desired color, and click OK. To turn off underlining, click on Underline links to remove the check mark.

Entering Internet Security Settings


Whenever information passes from one point to another on the Internet, it passes through other computers, where it can be intercepted and read. With all the traffic on the Internet, it's hard to say how frequently this happens, but it is technically possible for someone to read the information you send or receive.

To help prevent sensitive information (such as credit card numbers) from falling into the wrong hands, the Internet and Internet Explorer 3.0 follow security standards. Whenever you fill out and submit a form on the Web, Internet Explorer 3.0 displays a warning box, explaining the risks and asking if you want to continue.

In most cases, you're probably not sending sensitive information. Maybe you filled out a search form, and you don't really care if someone else finds out what you're looking for. But the warning dialog box pops up anyway, and after awhile, the warnings can become more annoying than useful.

To prevent the dialog boxes from popping up all the time, you can reduce the security levels. Or, if you lean toward paranoia, you can increase security. Open the View menu, select Options, and click on the Security tab (see Figure 5.10). You can change any of the following security settings (click OK when you're done):

Safety Level displays a dialog box that enables you to specify how tight you want security to be for transferring and playing active content. This is originally set to Expert, so Internet Explorer displays a warning message before downloading and playing any active content on a page. You might want to change the setting to Normal.

Figure 5.10. Internet Explorer 3.0 gives you complete control over security settings.



TIP

If you opt for low security, you can still tell if the current Web site is secure. When you are viewing a page at a secure site, Internet Explorer 3.0 displays a lock icon in the status bar.



Increasing the Speed of Internet Explorer 3.0


If you're trudging through the Web with a modem (even at a rate of 28.8kbps), some pages are S-L-O-W. You might connect to the page right away, but then you have to wait for all the fancy graphics, animations, and sounds to trickle over the phone lines. You might start to wonder if there's any way to speed things up.

There are a few techniques you can try. First, be sure to mark any pages you plan on visiting again as Favorites (see Chapter 7, "Favorite Places"). That way, you don't have to follow a trail of links to find the page again.

Second, you can change some settings in Internet Explorer 3.0 to make pages load more quickly and to reload pages you've already visited from your disk or memory instead of from the Web. The following sections show you how.

Making Pages Load Faster


In order to increase the speed at which Internet Explorer 3.0 loads pages, you have to make a few trade-offs. For example, large graphics take the most time to load, so you can increase the page load speed simply by telling Internet Explorer 3.0 not to load pictures.

To change the page load settings, open the View menu, select Options, and click on the General tab. Turn off any or all of the following options: Show pictures, Play sounds, and Play videos (see Figure 5.11). Click OK.

Figure 5.11. Turn off these options for faster page loading.

If you turn off pictures, sounds, or video clips whenever you load a Web page, Internet Explorer 3.0 does not automatically load any items you turned off that might be built into the page. In their place, Internet Explorer 3.0 displays icons. To view an individual picture or play a sound or video clip, right-click on its icon and select the Play option.



NOTE

Internet Explorer 3.0 is not capable of displaying all the pictures, sounds, animations, video clips, and other treats you'll find on the Web. To play some file types, Internet Explorer 3.0 needs helper applications, plug-ins, or ActiveX controls—add-on programs that can play additional file types. For details on how to find and install helper applications, see Chapter 15, "Using Helper Applications."



Loading Previously Viewed Pages


Because it takes so long for Web pages to cross the Internet, most Web browsers have a caching system that stores pages you've already visited. (A cache is a temporary storage area in your computer's memory or on its disk.) Internet Explorer 3.0 is set to use up to ten percent of your disk space for caching Web pages.

You can change the cache settings to increase the speed at which Internet Explorer 3.0 loads pages you have already visited. This will improve performance when you use the Forward or Back button to return to pages, or when you load a page you have visited in a previous session.

To change the cache settings, open the View menu, select Options, and click on the Advanced tab. Under Temporary Internet Files, click on the Settings button. The cache options appear, as shown in Figure 5.12. You can change any of the following settings (click OK when you're done):

Figure 5.12. You can increase the cache size to improve overall performance.

Setting the AutoDial Options


When you install Internet Explorer 3.0, it sets up an AutoDial feature, which displays a login dialog box if you try to run an Internet application without first connecting to your service provider. For example, if you try to run Internet Explorer 3.0 before connecting to the Internet, a dialog box appears, prompting you to enter your name and password.

You can change the AutoDial settings to turn off AutoDial or to change the default service provider (if you have more than one service, or if you change services).

To change the AutoDial settings, open the View menu, select Options, and click on the Connection tab. The AutoDial settings appear, as shown in Figure 5.13. Enter any of the following settings, and then click OK:

Figure 5.13. AutoDial reminds you to connect whenever you use an Internet application.

Using Proxies


If you have a network connection (rather than accessing the Internet via modem), you might have to use proxies. A proxy is a server that stands between your local area network and the Internet, filtering any exchanges. The proxy prevents any unauthorized access to the local area network.

Check with your network administrator to find out the address and port number of the proxy server. To enter this information in Internet Explorer 3.0, open the View menu, select Options, and click on the Connection tab (see Figure 5.14). Click on Connect through a proxy server, to turn the option on. Click on the Settings button, and then type the proxy server's address and port number (for example, mcp.com:80) in the Proxy Server text box.

If you need to access an Internet server that is part of your local area network, you can bypass the proxy. Click inside the Do not use proxy server for addresses beginning with text box, type the address and port number of the local Internet server you want to use, and press Enter. You can add more than one address to the list. You can also bypass the proxy servers for any local Internet server by selecting Do not use proxy server for local (intranet) addresses. Click OK when you're done.

Figure 5.14. If you have a network connection, you might have to use proxies to access the Internet.

Additional Configuration Settings


Internet Explorer 3.0 has a bunch of configuration options that didn't really go with any of the tabs, so Microsoft lumped them all at the bottom of the Advanced tab:


Censoring the Internet with Ratings


Now that the courts have decided (at least for now) that it is unconstitutional for the government to censor the Web, censoring is left up to individuals. Internet Explorer 3.0 is the first Web browser to have a built-in censoring tool.

To turn on Internet Explorer's censor, display the Options dialog box, click on the Advanced tab, and click on the Enable Ratings button. Type a password, and press Enter. This displays the Content Advisor dialog box, which allows you to set the ratings for Language, Sex, Nudity, and Violence. Initially, these ratings are all set to the most strict level.

This dialog box also allows you to change your password and pick a different ratings system. (Ratings systems are supplied by various companies. If you know of a company whose ratings system you would rather use, follow their instructions to set up the ratings system in Internet Explorer.)

What's Next?


Now that you've set up Internet Explorer 3.0 to suit your tastes, you're ready to sail out on the wide open Web. Part II, "Navigating with Internet Explorer 3.0," shows you how to browse the Web (when you have no destination in mind), quickly return to pages with shortcuts and Favorites, use Internet search tools, and take advantage of other resources on the Internet with Internet Explorer 3.0.

Previous Page Page Top TOC Next Page