
by Michael Desmond
Windows 98 extends and improves the video handling talents found in Windows 95. The old Media Player applet is still on-hand to play back video files, but the new video workhorse is ActiveMovie. This up-to-date facility enables you to do one-stop-shopping for popular video formats.
You can instantly find information on any video file by right-clicking its icon and selecting Properties from the shortcut menu. The Properties dialog box includes three tabs: General, Details, and Preview. The General tab features information such as file size and dates.
You'll find useful information in the Details sheet, as shown in Figure 24.1. In addition to the run-time of the video clip, you will see information on the audio and video encoding schemes used to create the file--which can be very useful information if you are trying to get optimal performance. The Video Format section includes helpful data on the pixel resolution of the captured video, as well as the frame rate and data rate.
FIG. 24.1 Detailed information about frame rates, playback data rates, and capture resolutions can help you troubleshoot video playback problems.
Click the Preview tab to view the selected video clip directly from the Properties dialog box. Then click the Play button. The slider bar control, which scrolls to the right as the video plays, lets you jump to any portion of the clip. To stop the clip, click the Stop button.
TIP: If a video file fails to play or suffers from jerky playback, use the Properties dialog box to see how it was encoded. If the file was encoded at a resolution higher than 320*240 pixels or if the file uses 16-bit or 24-bit color, your system might need an upgrade in order to handle the playback. If the file will not play at all, also check to see which codec is identified in the Properties box. You might need to install the proper video playback driver in order for your system to recognize the video format.
Windows 98 provides two different applets for playing back digital video clips. They are:
New to Windows 98 is the ActiveMovie control. This applet takes over the video handling duties from the venerable Media Player and adds greater file support and better performance. However, you can still use Media Player to view files with the .AVI extension.
The easiest way to play a video clip in Windows 98 is to launch it directly from Windows 98 Explorer by selecting the icon. The ActiveMovie player launches, and after a brief pause, the video begins to play.
To play a video using the ActiveMovie control, do the following:
TIP: If the ActiveMovie player is already open, you can play back videos by dragging and dropping the desired file's icon onto the ActiveMovie window.
To play your video clips from the Media Player, do the following:
TIP: You can launch files from the Device menu. To do so, click Device, and then select the media type from the numbered list. The Open dialog box then appears, displaying only files matching the selected type.
In addition to providing support for many video file formats beyond AVI, ActiveMovie provides useful tools for customizing video playback.
You can load a video file into ActiveMovie by dragging and dropping any recognized video file type--including AVI and MPEG--onto the application window. It takes a few seconds to load the file, during which time the application bar will display something like this: Demo.avi (Opening) Once the file is loaded, ActiveMovie displays the following file information in the interface window:
To play a file, do any of the following:
You can optimize video playback by right-clicking the ActiveMovie display interface and selecting Properties from the context menu. The ActiveMovie Control properties sheet includes four tabs:
Using the Playback Sheet
The Playback properties sheet, shown in Figure 24.2, provides useful tools for controlling the way the open audio file plays.
FIG. 24.2 From the Playback sheet, you can select a section of the file to play or make a file repeat a specific number of times.
The slider bars in the Volume area are grayed out, but you can still tweak your video clips from the Timing area of the Playback sheet by doing the following:
NOTE: The format of the Start and Stop boxes changes depending on whether you have selected a time-based or frame-based display of the video clip duration. For precise work, it is generally more convenient to work with frame values than to work with time.
Using the Movie Size Sheet
The Movie Size sheet lets you set the size of the playback window for the open file. Click the Select the Movie Size drop-down arrow and select from the following size options:
CAUTION: Playing video at expanded resolutions can reduce frame rates and result in jerky playback because the CPU and graphics card struggle to output the increased number of graphics pixels. A doubled video window, for example, contains four times the graphics information of a video played at native resolution (two times the height plus two times the width yields a 4X increase in pixels).
As does the Maximized option, the Run Full Screen check box causes the open video file to expand to the size of the display. However, this mode does not run in a standard playback window; instead, all the other elements on the display are disabled to allow the video playback to take over the screen. For systems with older graphics cards, this dedicated video playback mode can help boost the playback frame rate of full-screen video clips.
Using the Controls Sheet The Controls sheet gives you access to interface controls for playing files.
With its improved performance, wider file support, and enhanced features for developers, ActiveMovie is the video playback tool for Windows 98. Still, Microsoft has kept the Media Player applet around for those who want to use it. After a file is loaded into Media Player, you can access a number of controls from the menu bar.
The Options dialog box lets you control how video clips play back. To get to it, click Edit, Options. You can then do the following from the Options box:
The OLE Object area, shown in Figure 24.3, contains tools for customizing playback of video files within external applications, such as word processors or spreadsheets.
FIG. 24.3 You can customize the playback of video files inside of other applications by using the Media Player's Options dialog box.
Follow these guidelines for using the objects in the OLE Object area:
NOTE: The dither control should only be used with systems with very limited graphics resources, such as graphics boards that cannot support 16-bit color output. Dithering to the limited VGA palette will result in very poor color reproduction, making many video clips all but unusable.
Click Edit, Selection to go to the Selections dialog box. From here, you can demarcate a portion of the file to be played back or to be sent to another application.
NOTE: The position information in the From, To, and Size boxes will be displayed either as number of frames or in amount of time (minutes:seconds:tenths), depending on which format (either frames or time) you select from the Scale menu.
You'll also find useful tools in the Device menu.
Click Device, Properties to go to the Video Properties dialog box. Here you can set the size of the playback window for the open file, as shown in Figure 24.4. A representation of a monitor with a video window serves as a guide to let you preview the size of the video window. Open the Window drop-down list to see the size options.
FIG. 24.4 The display image in the Video Properties dialog box provides a graphic example of how large the adjusted video window will be.
CAUTION: As it does in ActiveMovie, expanding the video window can impair performance.
The Full Screen radio button sets the video file to play back at the full size of the display. However, this mode does not run in a standard playback window; instead, all the other elements on the display are disabled to allow the video playback to take over the screen. For systems with older graphics cards, this dedicated video playback mode can help boost the playback frame rate of full-screen video clips.
The Windows 98 Device Manager gives you access to all your hardware settings. Here, you can examine the graphics settings that might be affecting your video playback. To access graphics controls under the Device Manager, do the following:
The Properties box features three tabs: General, Driver, and Resources. The General sheet provides basic information, such as the manufacturer of the device driver and the hardware it is tailored for. Click the Resources tab, and you will find the standard resource interface for Windows 98 hardware. This display lets you view and adjust memory address settings for the graphics adapter.
NOTE: You are not likely to make use of this facility to fix conflicts with the display hardware because any such conflict would render the display inoperable. However, you might be able to cross-reference the address information provided with that shown in another device's Resource sheet, which could help you determine which devices are in conflict.
A welcome new feature of Windows 98 is the Driver tab of the device properties sheet. You will see two buttons at the bottom of this sheet. The Driver File Details button lets you view the actual driver files used to operate the graphics adapter. More interesting is the Upgrade Driver button, which launches Windows 98's automated hardware update scheme. To automatically upgrade your graphics adapter driver, do the following:
TIP: If you are experiencing graphics problems, you might be able to resolve them by turning off acceleration features within your graphics card. From the System Properties sheet, click the Performance tab and click the Graphics button. If the Hardware Acceleration slider bar is set all the way to the right, as shown in Figure 24.5, drag the control a step to the left and click OK. Click Yes when Windows 98 prompts you to restart. If the problems continue, you can repeat this process, further disabling acceleration features that might be causing the problem.
FIG. 24.5 The Advanced Graphics Settings dialog box lets you incrementally turn off hardware acceleration features in order to improve stability.
The Multimedia properties sheet, accessible through the Control Panel, gives you control of a variety of multimedia settings under Windows 98. To open the Multimedia properties sheet, click Start, Settings, Control Panel, and then click the Multimedia icon. The properties sheet appears.
There are five tabs arrayed across the top of the Multimedia properties sheet. Two of these directly impact video playback:
The Video sheet of the Multimedia Properties dialog box provides the same video windows size controls found in both the ActiveMovie and Media Player applets. When you select a window size option, the image in the display shows a facsimile of what the clip will look like. Open the Window drop-down list, and you will see the following options:
The Full Screen radio button sets the video file to play back at the full size of the display. However, this mode does not run in a standard playback window; instead, all the other elements on the display are disabled to allow the video playback to take over the screen. For systems with older graphics cards, this dedicated video playback mode can help boost the playback frame rate of full-screen video clips.
The Devices sheet of the Multimedia Properties dialog box gives you access to drivers and hardware configurations for video devices and other multimedia components. The sheet provides a list of multimedia components under the Multimedia Drivers heading. To view the installed devices for a given component, click the plus sign (+) next to the item.
When it comes to video controls, the most important stop is the entry called Video Compression Codecs. Here you will find a laundry list of video compression/decompression drivers, as shown in Figure 24.6, which allow the ActiveMovie and Media Player applets to recognize and play back digital video files.
FIG. 24.6 More codecs than you can shake a stick at: The Devices tab lets you see what types of video files your PC is equipped to handle.
You can view the controls and properties associated with each codec by selecting an item and clicking the Properties button. The Properties dialog box also lets you remove the selected codec if you want. Some codec property boxes also include a Settings button, which might simply provide a splash screen showing the vendor and date (as the Cinepak codecs do, for example) or might provide controls for managing compression settings.
Also under the Devices tab is a heading for Video Capture devices. Here you will find driver entries for video capture cards, parallel port cameras (such as Connectix's QuickCam), and other video input devices. Individual configuration options for these devices (which are provided by the vendor) might be available from the Devices sheet using the Settings tab. If you do not have a capture device installed, the Video Capture Device item will not contain any underlying entries.
Behind the video formats are compression/decompression schemes called codecs. Codecs squeeze digital video down to a manageable size, but they require a matching driver on the playback to allow the video to be uncompressed and played. Windows 98 comes with a variety of codec drivers, which are listed in the Multimedia Properties dialog box found in the Control Panel.
While most codecs provide only video playback, some are designed to both compress and decompress video. The VDOWave codec from VDONet, for example, lets users conduct video conferences over the Internet. The Settings button in the VDOWave property box lets you set compression levels (see Figure 24.7).
FIG. 24.7 The web-centric VDOWave video codec lets you tailor the level of compression to suit the speed of your Internet connection.
NOTE: Don't confuse video codecs with video file formats. A file format like AVI or MOV can often be compressed using a number of codecs. For example, AVI files can be compressed using Indeo, Cinepak, Video1, and TrueMotion codecs, just to name a few.
Unlike file compression schemes such as PKZip, video compression is lossy. That means the codec throws out some visual data in an effort to achieve compression ratios as high as 100:1 or more. Lossless compression schemes, such as PKZip typically achieve compression ratios of about 1.7:1 or 2:1 in the best cases. By throwing out data, codecs allow video to play at data rates as low as 28.8Kbps for web-based video and 300Kbps for CD-ROM titles. However, the quality of these clips suffers, with poor resolutions, color degradation, and low frame rates that result in jerky playback.
These are some of the most common codecs:
Underneath the interface, Microsoft speeds video performance using a technology called DirectDraw. This suite of developer tools, device drivers, and operating system components is part of the larger DirectX technology, which provides multimedia support for Windows 98.
DirectDraw is important because it allows inexpensive graphics hardware to boost video playback. The technology also provides a critical shortcut for video playback, so that graphics data can get to the screen faster. The most recent version of DirectDraw (part of DirectX 5.0), includes support for Intel's MMX-enhanced processors. Windows 98's ActiveMovie and Media Player applets both provide enhanced video playback on MMX-capable CPUs.
Graphics hardware can also help boost video performance. Virtually all of today's graphics boards use DirectDraw to provide video acceleration. These boards handle the following tasks:
Playing digital video is one of the most demanding things your PC can do. In order for digital video to play back under Windows 98, a variety of hardware and software underpinnings must be in place. These include:
To make digital video comprehensible to PCs, a number of standard file formats are used. These formats all use a frame-based approach to displaying video, much the way cellulite film consists of a string of visual frames that are played quickly to deliver the illusion of motion. Sound is laid on top of the image stream, creating video.
In order to recognize a video file format, Windows 98 must have the proper drivers installed. By default, Windows 98 includes support for the following formats:
There are a variety of other less-common video formats on the market, including streaming video formats intended for web-based video playback. In fact, ActiveMovie provides streaming video support, in which it actually begins playing a video file before the entire file has loaded. This lets your video clips start with less delay.
One of the most significant advances in PC-based multimedia is the arrival of DVD, or Digital Versatile Disc. Based on 5.25-inch discs that look identical to CD-ROMs, DVD-ROM can store up to 4.7GB on a single side. Down the road, enhanced DVD-ROM discs will be able to nearly double the amount of data on each side. The standard also allows for two-sided discs, meaning that DVD-ROM discs will eventually hold as much as 17GB of data--perfect for broadcast-quality, high-resolution video.
In fact, DVD uses the same MPEG-2 video format seen in Direct Satellite Services (DSS) such as DirecTV, USSB, and PrimeStar. The problem is that MPEG-2 video is very complex, requiring hardware-based decompression to provide smooth playback of the broadcast-quality video. While fast MMX-enhanced PCs can play MPEG-2 video, hardware is needed to make it acceptable for viewing.
Windows 98 provides support for DVD-ROM drives and hardware, including components for handling MPEG-2 video and AC-3 surround sound audio. However, you will need to make sure you have the proper drivers to operate the DVD-ROM drive and the add-in board. Check with your vendor to make sure you have the proper drivers in place.
Windows 98 provides a variety of tools to let you play, edit, and create audio files. Those familiar with Windows 95 will find that many of the tools are largely unchanged in Windows 98, while new ones such as Windows 98's ActiveMovie control await.
PC-based audio comes in two forms: wave audio and MIDI. Wave audio, or WAV files, are digital representations of analog sound. When you record speech or music to the hard disk, for example, the resulting file is a wave audio file.
MIDI files (or musical instrument device interface) use a series of commands to tell your PC's sound hardware what notes and instruments to play. This makes for smaller files, but you are limited by the library of instruments available to your hardware and software.
You can find information on any audio file by right-clicking any WAV or MIDI file icon and selecting Properties from the shortcut menu. The properties sheet for WAV and MIDI files displays key information regarding the size, length, and format of the file. The General page displays file size and type information. Click the Details tab, and you'll get useful information such as the encoding scheme used to create a WAV file, as well as the duration of WAV and MIDI files (see Figure 24.8). You can sample both WAV and MIDI files from the Preview sheet of the Properties dialog box by clicking the Play button on the sheet. The clip will play directly from the sheet.
FIG. 24.8 From the Details sheet of the File Properties dialog box, you can check useful information such as the encoding format of wave files and the overall runtime of the audio clip.
Windows 98 provides a number of tools for playing back wave audio files, including:
Both the Media Player and Sound Recorder are unchanged from Windows 95. The ActiveMovie control, however, is new and is an important resource for handling audio.
The easiest way to play a WAV or MIDI file in Windows 98 is to launch it directly from Windows 98 Explorer. For MIDI files, the ActiveMovie player launches and the file begins to play immediately. For WAV files, the Sound Recorder applet launches. In both cases, the applet closes immediately after the file finishes playing.
To play an audio file using the ActiveMovie control, do the following:
TIP: If the ActiveMovie player is already open, you can play audio files by dragging and dropping the desired file's icon onto the ActiveMovie window.
FIG. 24.9 A position bar and time display prompt you during playback of files under ActiveMovie.
You can also play wave audio file from the Windows 98 Sound Recorder. To do so, follow these steps:
To play audio files from the Windows 98 Media Player, do the following:
TIP: You can also launch files from the Device menu. Click Device, and then select the media type from the numbered list. The Open dialog box then appears, displaying only files of the selected file type.
Like Windows 95, Windows 98 lets you play audio CDs in your CD-ROM drive using the CD Player applet shown in Figure 24.10.
FIG. 24.10 The CD Player applet provides all the functions of a standard audio CD player.
To play CDs, do the following:
If you want to record or edit WAV files in Windows 98, you'll want to use the Sound Recorder applet. This section introduces you to Windows 98 audio editing and recording.
When you open a file in Sound Recorder, you see a visual representation of the audio file, including a status bar that indicates how far along in the file you are. The buttons beneath the slider bar control operations such as fast forward and rewind, similar to those on a tape recorder. The Position reading shows the current point in the audio file, and the Length reading tells you the complete duration of the file in seconds.
The File menu contains a number of familiar options, including commands for saving audio files. The Revert command lets you undo edits.
If you want to record a WAV audio file, the only way to do so within Windows 98 is with the Sound Recorder applet. To record an audio file, do the following:
Sound Recorder provides some useful editing tools that let you enhance existing WAV files. These capabilities can be accessed from the application menus. You can perform any of the following tasks:
When you save WAV files in Sound Recorder, you can set the compression and audio format to best suit your needs. While recordings of your favorite CDs might need high-fidelity digital playback, simple sound effects and speech clips can use less space-consuming formats. Click File, Save As. In the Save As dialog box, click the Change button. The Sound Selection dialog box lets you set the compression format, as well as the bit rate and depth of the wave file. From the Name drop-down list (shown in Figure 24.11), select one of the following three options: Telephone Quality: 8-bit, 11.025-kHz, mono
Radio Quality: 8-bit, 22.05-kHz, mono CD Quality: 16-bit, 44.1-kHz, stereo CD quality is best for recorded music or any clip that requires very precise playback. Radio quality is a good compromise for music or speech clips because it conserves disk space while keeping much of the audio fidelity. Telephone quality minimizes file sizes but results in limited audio quality.
FIG. 24.11 From the Sound Selection dialog box, you can choose from preconfigured audio formats, or you can create customized schemes of your own.
You can use ActiveMovie to play wave and MIDI files. In both cases, the new applet gives you a number of controls to let you customize playback.
You can load a file into ActiveMovie by dragging and dropping a Wave or MIDI file onto the application window. It will take a few seconds for the file to load, during which time the application bar will display something like this:
Canyon.mid (Opening)
After the file is loaded into ActiveMovie, you will see the following file information displayed in the black window:
To play a file, do any of the following:
You can optimize audio playback by right-clicking the ActiveMovie display interface and selecting Properties from the context menu. The ActiveMovie Control properties sheet includes four tabs:
Of these, Playback and Controls are important for audio playback.
Using Playback Properties
The Playback sheet of the Properties dialog box (see Figure 24.12) provides useful tools for controlling the way the open audio file plays.
FIG. 24.12 Volume and Timing controls let you customize playback of audio files. Slider bars located in the Volume area on the left side of the Playback sheet control volume and balance. Here's how to use them:
In the Timing area, you can do the following:
Using Controls Properties The Controls sheet of the Properties dialog box gives you access to interface controls for playing files, as shown in Figure 24.13.
FIG. 24.13 You can slim down the ActiveMovie interface by turning off many of the VCR-like control elements on the display. You can even tweak the colors.
Follow these guidelines for using the controls on this sheet:
The Media Player applet has been replaced by ActiveMovie in Windows 98, but the Media Player program is still available if you want to use it. Once a file is loaded into Media Player, you can access a number of controls from the menu bar.
The Options dialog box lets you control how audio files play back. To get to it, click Edit, Options. You can do the following in the Options box:
The OLE Object area contains tools for customizing playback of audio files within separate applications. Follow these guidelines for using the objects in the OLE Object area:
You'll also find useful tools in the Device menu. These are some of the things you can do:
FIG. 24.14 Avoid choppy audio playback by increasing the memory buffer in the MCI Waveform Driver Setup dialog box.
Click Edit, Selection to go to the Selections dialog box. From here, you can demarcate a portion of the file to be copied to the Windows 98 Clipboard. Use these methods to select the portion you want to copy:
The CD Player lets you create custom play lists by entering information about the currently loaded CD and then setting up the list of tracks you want to play. When the audio CD is loaded later, Windows 98 recognizes the unique bit pattern of the disc and calls up the information you entered. Other features for tweaking playback are outlined in the next two subsections.
To create a custom play list for a loaded audio CD, you use the controls in the Disc Settings dialog box, shown in Figure 24.15.
FIG. 24.15 The play list feature is one of the most powerful options offered by the CD Player.
Follow these steps to build a play list:
TIP: You can select multiple tracks at once by holding down the Ctrl key and clicking on the tracks. To select a range of continuous items, click the first track, hold down Shift, and then click the last track; the two you selected and all of those in between are selected.
The CD Player provides a lot of controls in its compact interface, matching the functionality of dedicated CD players. In the View menu, you will find the following commands:
The Options menu offers several other useful commands. Random Order, Continuous Play, and Intro Play let you determine how the CD Player will move through the tracks on the installed audio CD. The Preferences command gives you access to the Preferences dialog box, where you can adjust appearance display, limit the intro play length, and set other options, as shown in Figure 24.16.
FIG. 24.16 Use the Preferences dialog box to tweak the CD Player interface and behavior.
Windows 98 provides one-stop shopping for tweaking the level and balance settings for your sound card's various inputs and outputs. Not only can you adjust overall volume, you can adjust the volume and balance of individual inputs and outputs, including wave and MIDI audio output and CD audio playback.
You can access the Volume Control using any of the following methods:
NOTE: The easiest way to adjust volume is to click the taskbar speaker icon. A small slider bar control appears that lets you either adjust the volume level or mute the audio altogether. The small control disappears when you click on any other area of the screen.
The Volume Control (shown in Figure 24.17) provides controls for playback and recording operation, as well as for specific audio applications such as voice recognition. Each audio component is represented by a horizontal slider bar with which you adjust the balance and a vertical slider with which you adjust volume. A Select check box allows you to turn a given component on or off.
FIG. 24.17 The Windows 98 Volume Control is the master control for setting balance and volume settings.
The default view for the Volume Control is for playback devices. Table 24.1 outlines the Volume Control components.
| Control Name | Operation | What it does |
| Volume Control | Playback | All audio output |
| Line-In | Playback, Record | Audio originating from the sound board's line-in port |
| Microphone | Playback, Record | Audio captured by the microphone |
| CD | Playback, Record | Audio played from the CD-ROM drive's analog out port |
| MIDI | Playback | Playback of MIDI files |
| Wave | Playback | Playback of wave files |
| Record Control | Record | All audio input |
| Voice Commands | Other | Voice input from microphone |
To access the volume control settings for playback, record, or other applications, click O_ptions, Properties and then click the desired radio button in the Adjust Volume For area of the Properties dialog box.
In the Show the Following Volume Controls list, select the check boxes for the items you want to have displayed in the Volume Control. Any item that you deselect (remove the check mark from its box) will not be displayed when the Volume Control is launched.
If more than one audio device is installed in your PC, you can select which device to work with. To do so, select the desired device from the Mixer Device drop-down list.
If you want to tinker with hardware under Windows 98, you need to know your way around the Device Manager. To access audio controls under the Device Manager, do the following:
FIG. 24.18 Click the Sound, Video, and Game Controllers item, and your installed audio hardware will be displayed.
The Properties dialog box that appears features three tabs: General, Driver, and Resources.
The General sheet identifies the manufacturer and model of the selected device, as well as information on any conflicts in the Device status area. It also lets you tailor the device for use by a specific system profile.
The Driver sheet lets you view information about the device drivers used to run the selected hardware. To see which driver files are loaded for the device, click the Driver File Details button and browse the Driver files list on the page that appears.
An intriguing new feature is the automated driver update facility in Windows 98. Here's how to use it:
Finally, the Resources sheet lets you change the hardware resources for the audio device, including IRQ, DMA, and base I/O address settings. The Conflicting Device list box at the bottom of the sheet prompts you if a hardware device conflict is present. If so, you can adjust the resource settings of a device by doing the following:
The Multimedia Properties dialog box, accessible through the Control Panel, is ground zero for managing multimedia settings in Windows 98. Here you will find resources for handling audio drivers and hardware, as well as for using compression schemes when saving files. To open the Multimedia Properties dialog box, click Start, Settings, Control Panel. Select the Multimedia icon, and the Properties dialog box appears.
The Multimedia Properties dialog box contains nine tabs, five of which directly affect audio:
The Audio sheet of the Multimedia Properties dialog box is divided into two sections: Playback and Recording. Each lets you adjust overall volume level settings. What's more, Windows 98 adds intriguing controls for audio playback and recording.
Controlling Audio Playback Settings
You can select the audio playback device you want to control by picking it from the Preferred Device list. To change settings for the device, click the Advanced Properties button. The Speakers sheet, shown in Figure 24.19, lets you configure Windows 98 for your particular speaker setup. The large image depicting a PC with speakers changes to reflect your selection. Click OK to put the new settings into effect.
FIG. 24.19 The Speakers sheet of the Advanced Audio Properties dialog box lets you tweak audio playback to suit your speakers.
To tweak audio playback and your system's performance, click the Performance tab. The Hardware Acceleration slider bar tells Windows 98 to employ more available hardware features to audio playback. If you experience problems with playback, try moving the slider to the left. Deactivating acceleration features can help eliminate conflicts.
The Sample Rate Conversion Quality slider bar determines how much processing power the PC applies to creating realistic audio playback. If your system is very fast, move this slider to the right. You should enjoy better audio without an unacceptable loss of performance. To return to the original settings, click the Restore Defaults button.
Customizing Wave Audio Recording Profiles
As with playback, you can adjust settings for audio recording. Select the recording device from the Preferred Device list, and then click the Advanced Properties button to go to the Advanced Audio Properties dialog box. Here you will find only a Performance tab, which looks identical to that for audio playback described above. Moving the Hardware Acceleration and the Sample Rate Conversion Quality slider bars lets you trade audio quality for smoother performance and better stability. To return to the original settings, click the Restore Defaults button.
The MIDI sheet of the Multimedia Properties dialog box lets you configure and install MIDI devices such as keyboards and MIDI-capable sound cards. By default, the Single Instrument radio button is selected, denoting the primary MIDI device on the sound board.
Create a Custom MIDI Scheme
If you have external MIDI devices attached to your PC, you can create a custom configuration to employ these devices. To create a custom configuration, do the following:
If you select your custom MIDI scheme, the assigned device plays when the corresponding channel is called up in a MIDI score.
Add a MIDI Device
You can also use this dialog box to install a new MIDI device, such as a keyboard. To add a new device, follow these steps:
This sheet lets you set the volume of playback for audio CDs played in CD-ROM drives. Here's how to use the controls:
When you finish adjusting the settings, click OK to put your changes into effect.
The Devices sheet of the Multimedia Properties dialog box provides access to drivers and hardware configurations for audio devices and other multimedia components. This sheet provides a list of multimedia components under the Multimedia Drivers heading. To view the installed devices for a given component, click the plus sign (+) next to the item, as shown in Figure 24.20.
FIG. 24.20 The Device sheet of the Multimedia Properties dialog box provides access to a host of audio devices and controls.
You can view the controls and properties associated with each device by selecting an item and clicking the Properties button. From the Properties dialog box for any component, you can deactivate or remove the device. Some device properties sheets also include a Settings button, which takes you to the corresponding controls for the hardware.
In addition to wave and MIDI devices, the Devices sheet includes a roster of items under the Audio Compression Codecs heading. These compression drivers let Windows 98 save sound files in compact format, and they are listed in order of priority. Higher priority codecs are more likely to be used by applications than are lower priority codecs. You can change the priority by selecting a codec, clicking the Properties button, and selecting a new priority number in the Change Priority From drop-down list (see Figure 24.21).
FIG. 24.21 Tell Windows 98 how to compress audio files from the Codec Properties dialog box.
Much of what is new about audio in Windows 98 relates to the plumbing. Under the graphical interface, a technology called DirectSound works. DirectSound is a standard set of components, drivers, and development tools that provide audio handling for Windows 95 and 98. It also provides a standard interface for audio hardware and applications that work with Windows 98.
Does DirectSound make the Sound Blaster standard irrelevant? Not yet. DOS-based games continue to look for specific audio hardware, with Creative Labs' Sound Blaster boards remaining the most often supported hardware. And Windows 98 continues to provide driver support for Sound Blaster boards within the operating system because these boards make up a large percentage of the installed base.
In addition to the basic audio handling of DirectSound, Windows 98 includes a technology called DirectSound3D. This component of Windows 98's multimedia toolbox lets the latest games and multimedia titles deliver 3D sound to provide enhanced realism. DirectSound3D allows games to produce so-called positional audio, which makes sounds seem like they are coming from specific directions. Programmers can tell Windows 98 where to put sounds based on what is going on inside a game at the time--a real benefit for immersive gameplay.
In order to take advantage of the new audio handling capabilities, you need a sound board that is DirectSound compliant. What does that mean? Basically, your sound card must have DirectSound drivers, which might be found on the Windows 98 web site or at the sound board vendor's web site.
For games and title to take full advantage of DirectSound and DirectSound3D, they must also support the technology. Those lacking the new audio tools will still work fine because Windows 98 continues to provide the familiar media control interface (MCI) commands that have been used by Windows programmers for years. However, you will get the best performance and audio features from new DirectSound-enabled programs.
Digital audio comes in two forms: waveform audio (WAV files) and MIDI. WAV files are digital representations of analog sound, much as a graphics bitmap is a representation of a real-world image. In fact, Windows WAV files are similar to the digital audio stored on audio CDs.
When your system records a WAV file, the incoming signal is converted to a series of bits that represent the curve of the original analog signal. The quality of a digital audio file--and also its size--is related to its resolution and frequency. For example, CD-quality audio has a resolution of 16 bits and frequency of 44.1KHz, while the audio found in most AVI video clips is about 8 bits and 22KHz.
To understand what goes into a wave file, you need to know about its components:
The audio format determines the digital quality of the sound, but sound hardware is important, too. Interference inside the PC and the quality of audio components both affect sound output. Many sound boards have inferior frequency responses, which means they do not accurately reproduce sounds at the high and low range of human hearing. Most boards also produce poor signal-to-noise ratios (a measure of how much noise is in the output) with performance that falls far below that of CD players.
Some boards, such as Creative Labs' Sound Blaster AWE 64 Gold, provide good audio quality. However, even the best sound board won't match the quality of consumer audio components.
Hardware aside, why don't all clips use 16-bit 44.1KHz audio? Table 24.2 shows just how large a minute of uncompressed digital audio can get.
| Frequency | 8-bit | 16-bit |
| 11KHz | 1.2MB | 2.6M |
| 22KHz | 2.6MB | 5.2M |
| 44.1KHz | 5.2MB | 10.4M |
Unfortunately, the less sound you store, the less realistic the results. Losing the stereo data can render playback flat and leave it without spatial cues, such as when instruments or sounds come from one speaker or another. Dropping the bit depth can add audible hiss to sound files and can lessen the precision of reproduction. Lowering the frequency means that the audio is being sampled less often, so the card is unable to smoothly re-create the changes in sound.
Another way to conserve space is through compression. Like video files, audio compression techniques reduce file size by coding redundant information in a compact format and even by throwing out some aural information. Windows 98 includes several compression schemes:
The other half of the Windows audio scheme is MIDI. MIDI is actually a standard from the music industry, developed for synthesizers and other professional audio equipment. Unlike WAV files, which are digital representations of analog sound, MIDI files are composed of simple instructions that tell a MIDI device what to do. A MIDI file consists of instructions that tell your sound card which notes to play, with which instruments, and at what volume.
Of course, in order for these instructions to work, your sound board must be able to understand MIDI instructions. More importantly, all sound boards and MIDI audio equipment must work with the same set of instructions so that when a MIDI file calls for instrument number 98, the same instrument is played on all hardware. Instrument identifications are standardized under the General MIDI standard, which comprises 128 MIDI instruments.
TIP: Make sure your sound card supports the General MIDI standard. General MIDI consists of 128 instruments and defines their identification for all audio equipment. Some boards can have more than 128 instrument sounds, but they must comply with General MIDI in order to work reliably with MIDI files.
There are two types of MIDI: wavetable synthesis and FM synthesis. Until about two or three years ago, most sound boards provided inexpensive FM synthesis MIDI. FM synthesis is an innovative scheme in which two or more signals are mixed to emulate the sound of actual instruments. While FM MIDI synthesis can play back any MIDI file, the scheme lacks the ability to produce realistic instrument sounds, particularly when many instruments are involved.
For top-quality MIDI playback, you need a board that supports wavetable MIDI. Wavetable MIDI cards use samples of actual instrument recordings to produce realistic music. When a MIDI file calls for a trumpet to play a C note, the boards play an actual sample of that instrument. Because it would take too much room to store every note of every instrument, boards use algorithms to produce the proper sounds from the set of samples.
To get best results, your sound hardware should provide at least 16-voice polyphony. Polyphony refers to the capability to play more than one sound at once. For example, many MIDI scores play a veritable desktop orchestra, requiring 20 or even 32 MIDI voices to play at the same time.
NOTE: Creative Lab's Sound Blaster 64 AWE provides 64-voice polyphony, handling 32 voices in hardware on the card and another 32 voices through the PC's CPU.
Many boards now provide software-based wavetable MIDI, which uses system memory and the PC's CPU to process MIDI sounds. While the scheme reduces cost on the sound board, the work of juggling MIDI sounds can bog down older Pentium PCs. In addition, software MIDI won't work with software that runs DOS mode, which includes some popular flight simulators.
Some sound boards also allow you to work with custom MIDI sounds, which is useful for adding effects and other noises to games and titles. Custom MIDI sounds are loaded from the system hard disk into the sound board or system memory so that the applications can play them back.
Finally, Windows 98 is enabling a new market of audio products: PCI-based sound boards. Until recently, virtually all sound boards had to conform to Creative Labs' Sound Blaster scheme in order to ensure compatibility with the universe of software on the market. Under Windows 95 and 98, DirectSound now provides the new standard target for both software and hardware makers.
Unlike the Sound Blaster standard, which requires static IRQ, DMA, and base I/O assignments, DirectSound is tailored to work with the dynamic resource environment of Windows 98. The Plug and Play PCI bus can shift a sound board's resources to suit the current system needs, and software will still be able to find and use the hardware. With Sound Blaster cards, such a resource shift would disable the audio device until the resources were reconfigured.
What's more, PCI-based sound cards enjoy the high-speed data connection of the PCI bus, which runs at up to 132MB/s, versus 5MB/s for ISA. This allows software to send up to 20 independent channels of audio to the sound card, each of which can be managed and transformed individually. ISA cards, by contrast, can handle just one or two such channels.
Multi-channel audio is critical for true 3D sound and for home theater-like surround sound. DVD-ROM titles, for example, will use the Dolby AC-3 audio encoding scheme to push surround sound audio through five positioned speakers and a front-mounted subwoofer, while games will use multi-channel audio to independently juggle voices, music scores, and sound effects in real time.
Windows 98 is also opening up audio on the new Universal Serial Bus (USB). Using the Windows Driver Model (WDM) driver technology, which unifies Windows 95 and 98 and Windows NT drivers, future audio hardware will work over USB instead of the PCI or ISA bus. The benefit: greatly enhanced wave audio fidelity.
Some USB speakers from companies like Altec Lansing are actually digital. Normally, digital audio files are converted to analog electrical pulses on the sound board by a device called a digital-to-analog converter (DAC). Unfortunately, the electromagnetic frequencies (EMF) given off inside the PC's case distort the analog signal, producing poor audio fidelity. USB audio hardware will allow the digital audio to stay digital until it actually reaches the external speaker device, eliminating the disruptive EMF problem. Conversion will happen at the speaker itself.
Audio CD playback will also get a change. Gone will be the analog line-out connection running from the CD-ROM drive to the sound board. Instead, audio CD output will be moved digitally over the ISA or PCI bus to the sound card, where it will be converted to analog format--the same approach used to handle WAV files.
© Copyright, Macmillan Computer Publishing. All rights reserved.