Platinum Edition Using Windows 98

Previous chapterNext chapterContents


- 22 -

Customizing the Look and Feel of Windows


by Curtis Knight

Establishing Custom Settings for Each User

Windows 98 allows you to create a profile for each user of the computer. Your user profile contains your individual customizations to Windows 98. This means that when you log on to the system, the settings you established for yourself are still there. When your coworkers log on, their settings are still there also.


TIP: As you read through this chapter, remember that where you are told to click on a file or folder and then click the OK or Open buttons, it is often possible to simply double-click the file or folder to finish the task.

If more than one person uses your computer, it is recommended that you set up user profiles before you begin implementing any of the customizations in this chapter. That way, when other people log on to the computer, they will be able to make their own customizations to Windows 98 without affecting one another's settings.

To establish user profiles, follow these steps:

1. Open Control Panel and activate Users. You'll see the dialog in Figure 22.1. Click the Next button to continue.

FIG. 22.1 Activate Users from Control Panel and Click Next to begin setting up a new user profile.

2. In the Add User dialog, type a username into the User name text box, and click Next to continue.

3.
In the Enter New Password dialog, type a password into the Password text box, and press the tab key to move the insertion point to the Confirm password text box. Retype the identical password in the Confirm password text box and click Next to continue.

4.
In the Personalized Items Settings dialog, check the items you want to customize. For example, if you want a separate My Documents folder for this user, check the My Documents Folder check box. If you want this user to have their own custom Start Menu, check the Start Menu check box.

You also need to decide whether to tell Windows 98 to create a copy of each of these items or create new ones with default settings. Creating new items for each user will save disk space if the new user doesn't make very many changes to Windows 98 settings.

When you've finished making your choices, click Next to continue.

5.
When the Ready to Finish dialog displays, click Finish to continue. Windows will set up the new user profile and prompt you to reboot the computer.

To set up more profiles, run Users from Control Panel again, and you will be taken through the same setup routine for each new user.

Resizing the Taskbar

Occasionally, you might want to resize the Taskbar. For example, if your system has enough memory to allow several applications to be open simultaneously, the Taskbar can become so cluttered that the icons are too small to tell which is which. In this case, resizing the Taskbar will help you read the icon text.

Another reason you would resize the Taskbar is that with all the customization features implemented in Windows 98, the Taskbar can contain numerous toolbars and Quick Launch icons. Resizing the Taskbar makes it easier to find the elements you need to work with.


NOTE: Be careful not to add too much to your Taskbar. If you do, you might find yourself spending more time searching your Taskbar than it would take to just browse to the file, application, or shortcut the old-fashioned way.
To gain maximum benefit from toolbars and Quick Launch, only implement them for those programs you use frequently. If you access a file or program once a week or less, think twice before establishing a toolbar or Quick Launch icon. 

To resize the Taskbar, follow these steps:

1. Move the mouse pointer over the inside edge of the Taskbar until it becomes a double-headed arrow.

2.
Drag the edge of the Taskbar until it is the size you want. (It is possible to size it as large as one-half the screen area.)

3.
Now release the mouse button.

Moving the Taskbar

By default, Windows places the Taskbar at the bottom of the screen. If you prefer the Taskbar in a different position, you can move it to any of the four edges of the screen. For example, photographers often need to drag the Taskbar to one side of the screen to allow more vertical desktop real estate when working with a vertically formatted photograph.

To move the Taskbar, point to a blank area of it and use the left mouse button to drag it where you want it.

Using the New Taskbar Features

When you right-click on a blank area of the taskbar, a shortcut menu (often called a context menu) pops up. The main purpose of this menu is to give you access to Taskbar customization. There are also options included in the menu to help you rearrange the open windows on your desktop.

The first item on the taskbar's shortcut menu is toolbars. Toolbars contains a menu with three options: Desktop, Quick Launch, and New Toolbar.

Figure 22.2 shows the taskbar with two additional toolbars.

FIG. 22.2 As you can see, the taskbar can become cluttered quickly. This taskbar has two additional toolbars: Address and Desktop.

Table 22.1 describes the four buttons added to Quick Launch during the Windows install.

Table 22.1  Built-In Desktop Toolbars

Toolbar Name Description
Internet Explorer Yep, you guessed it, this is a shortcut to Internet Explorer.
Mail This is a shortcut to Microsoft's contact manager Outlook Express. Outlook Express is included with Internet Explorer 4.x.
Show Desktop This is probably the most useful of the four buttons Windows places on the Quick Launch toolbar. If your desktop becomes cluttered with open application windows, or if your current application window is maximized and you need to get to your desktop, click the show desktop icon, and all your windows are automatically minimized. Click the icon again, and all your windows are restored to the previous state and position.
View Channels When you click this button, you get a full screen browser to view your channels. If you have not set up your Internet access, the Internet connection wizard will guide you through the setup.

Creating Toolbars with Frequently Used Folders and Web Pages

Windows 98 provides you with a quick and simple way to establish your own custom toolbars for your most often used files and folders. In a nutshell, it creates a toolbar that contains shortcuts to all the files and subfolders within the folder you select.

To create a custom toolbar, follow these steps:

1. Select new toolbar from the Taskbar shortcut menu.

2.
The New Toolbar dialog pops up. This dialog provides a Windows Explorer style view of your system.

3.
Navigate to the folder you want to convert to a toolbar, and click the OK button. The folder is now represented in a toolbar.


TIP: My Briefcase is an excellent candidate for a custom toolbar.

You can also create a toolbar for your favorite web pages. If you have a permanent Internet connection (generally this is done through your local area network at the office), you can create a toolbar that displays a web page. You can create this even if you use a dial-up connection to the Internet, but it's not quite as useful.

To create a web page toolbar, follow these steps:

1. Point Internet Explorer to the web page you want to display.

2.
Right-click the taskbar, point to Toolbars, and select New Toolbar.

3.
In the New Toolbar dialog, scroll down to Internet Explorer, and click the plus sign to expand it.

4.
Select the web page you want, and click the OK button to create your new toolbar and close the New Toolbar dialog. A new toolbar will be displayed on your taskbar.


TIP: At the taskbar's default size you can only see one line of your web page at a time. To see more of your Web page toolbar, you can either use the spinner buttons at the right or resize the taskbar. See the section "Resizing the Taskbar" earlier in this chapter for details.
To remove a custom toolbar, right-click the taskbar or a toolbar, point to Toolbars, and click on the toolbar you want to remove.

Arranging Your Open Windows

Your taskbar context menu contains five options for rearranging the windows on your desktop. Can't make sense of what's open? Desktop too cluttered? Don't want to close any applications? No worries, this section will help you get a handle on the mess.

These options are accessed by right-clicking on the taskbar:

Right-clicking the taskbar and selecting Properties is the quickest way to access the Taskbar Properties dialog. Figure 22.3 shows the Taskbar Properties dialog.

FIG. 22.3 With the Taskbar Properties dialog, you select the options you want and click the OK button.

Taskbar Properties can also be accessed through Start, Settings, Taskbar.

Table 22.2 describes the four options available for customizing the taskbar.

Table 22.2  Taskbar Options Tab

Check box Description
Always on top When you check this box, your taskbar is always visible, even when you maximize a window.
Auto hide When you check this box, your taskbar changes to a very thin line. To make the taskbar visible again, simply point to the thin line.
Show small icons in Start menu If you check this box, the icons and start menu are slightly smaller and the Windows logo down the left side of the menu is removed. To see the difference, watch the preview window as you check and uncheck this box.
Show Clock Check this box to make the clock visible in the system tray, which appears to the far right of the taskbar. To remove the clock from the system tray, uncheck the box.


TIP: If you check both Always on top and Auto hide, you can maximize your application window and still have easy access to the taskbar any time by pointing to the edge of the screen where your taskbar is.

Setting the Date and Time

To change the date and time on your computer, follow these steps:

1. Double-click the clock in the taskbar. The date/time Properties dialog box is displayed as shown in Figure 22.4.

FIG. 22.4 Double-click the clock to bring up the Date/Time Properties dialog.

2. The dialog is divided into two sections: date and time. To change the month, click the down arrow to the right of the month list box. This brings a drop-down list from which you can select the month. Click the month you want.

3.
To change the year, either highlight the text in the year text box and type the year directly, or use the spinner buttons to advance one year at a time up or down.

4.
Select the day of the month by clicking in the calendar box below the month in year text boxes.

5.
The time section shows an analog clock and a digital clock in a text box. The time is changed using the digital clock text box. This text box is divided into four fields: hour, min., seconds, and a.m./p.m. To change the time, place the insertion point in the field you need to change, and use the bar to the right of the text box to increment or detriment the field. You can also type directly into the fields. For instance, if the current time reads 11:00:00pm and you need to change it to 3:00:00pm, simply use your mouse to highlight the 11 and type the number 3.

Changing the Time Zone

After adjusting the date and time, double-check the current time zone display at the bottom of the Date and Time tab. If it displays the wrong time zone, select the Time zone tab in the Date/Time Properties dialog.

This displays a world map and a drop-down list box from which you can select the proper time zone. To select the time zone click the down arrow to the right side of the time zone drop-down list box. Select the proper time zone from the list and click apply.

Also at the bottom of this tab is a check box titled Automatically adjust clock for daylight saving changes. If you check this box, Windows will automatically adjust for daylight savings time twice a year. If you live in an area where daylight savings time is not in effect, such as Indiana, make sure this box is not checked.

When you're finished, click the OK button to close the Date/Time Properties dialog. Your changes are applied when you click the OK button, or if you want that warm fuzzy, click Apply after making your changes; then close the dialog.

Managing Buttons on a Toolbar

Now that you've been experimenting with your taskbar, you might have too many toolbars, or one or more of them might be too big. Table 22.3 explains some taskbar management techniques.

Table 22.3  Taskbar Options Tab

Task Description
Resizing Toolbars When you get too many toolbars, you can't see everything. To get around this, you can resize your toolbars, shrinking those that you don't need to see and expanding the others.
To resize a toolbar, point to the small vertical bar at the left edge of the toolbar, and drag left to expand it, right to make it smaller.
When you resize a toolbar, the toolbar to the left of it expands or contracts automatically.
Removing Toolbars If you got carried away with those custom toolbars and you want to get rid of some, right-click the taskbar or the title of one of the toolbars, point to Toolbars, and click the toolbar you want to remove.
Removing Buttons from the Quick Launch bar The buttons on your Quick Launch bar are just fancy shortcuts. To remove a button from the Quick Launch bar, right-click it, and choose Delete from the context menu.
Hiding Text and Titles on the Custom and Desktop Toolbars Another way to reduce the size of your toolbars is to tell Windows not to display the text for each icon.
To hide the toolbar title, right-click the toolbar title and click Show title to remove the check mark.

Removing Toolbars

Figure 22.5 shows the right-click menu for a Quick Launch button.

FIG. 22.5 This is the Context menu for a Quick Launch button; to remove the button, click Delete.

Adding and Removing Programs in the Start Menu

There are two ways to add items to the Start menu. If you prefer to add to the Start menu using a Wizard approach, follow these steps.


NOTE: The Start menu is actually a folder on your hard disk, located in the Windows directory. Any files or shortcuts you place in \Windows\Start Menu\ will show up in your Start menu. 
1. Right-click a blank area of the taskbar, and select Properties.

2.
Select the Start Menu Programs tab.

3.
Click the Add button. This starts the Create Shortcut wizard (see Figure 22.6).

4.
The first dialog in this wizard asks for the command line of the executable file for the program. If you know the path and filename of the executable for the application, type it into the command-line text box. If you don't know the path and filename, you can click the browse button to bring up the browse dialog. Find the executable name and click the open button.

When the path and filename for the executable are displayed correctly in the command-line text box, click the next button.

FIG. 22.6 Click the Add button from the Start Menu Programs tab to start the Shortcut Wizard. Type the path to the document or program, or click Browse to search for it. Then click Next.

5. The Select program folder dialog is displayed. This is a tree-style view of your Start menu. You can select an existing folder, or you can click the new folder button to create a new folder. If you decide to create a new folder, you will see a new folder with the name program group (1), highlighted in rename mode. Type a new name for the folder and press Enter.

6.
When you've selected a folder or created a new one, click the next button.

7.
The Select a Title for the Program dialog is displayed. In the Select a name for the shortcut: text box, type an intuitive name for your new shortcut.

8.
Click the Finish button.

9.
Now check Start menu to make sure it works properly. If it does, close the Taskbar Properties dialog with the OK button.

To remove a program shortcut from the Start menu, follow these steps:

1. Right-click a blank area of the taskbar, and select Properties.

2.
Select the Start Menu Programs tab.

3.
Click the remove button. The remove shortcuts/folder's dialog is displayed.

4.
Navigate to the shortcut you want to remove, and click the close button.

5.
Now go to the Start menu to make sure the shortcut was removed properly. If it was, close the Taskbar Properties dialog with the OK button.


TIP: You can remove an entire folder from the shortcut menu by selecting the folder. When you select a folder name, all shortcuts and folders under that folder are removed from the Start menu.

If you prefer to create and remove folders and shortcuts for the Start menu using Windows Explorer, click the Advanced button. The Advanced button launches Explorer and takes you directly to the Start menu folder. From here, simply create new folders and shortcuts the same way you would any other folder on your hard drive.

Clearing the Documents List in the Start Menu

Windows 98 maintains a history of the documents you've accessed. You can access these documents by clicking Start, Documents and selecting the document you need to access. Clearing the list is useful if you have accumulated several documents in your Documents history that you no longer access frequently or that don't exist anymore.

To empty your Documents menu, follow these steps:

1. Right-click a blank area of the taskbar, and select Properties.

2.
Select the Start Menu Programs tab.

3.
Click the clear button in the Documents menu section located at the bottom of the page.

Customizing the Windows Display

Today's video cards and monitors give you a wide choice of resolutions and color schemes. This section shows you how to adjust the display to your needs.

Using Desktop Themes

One of the coolest customization features of the Microsoft Windows 95 Plus Pack now comes with Windows 98. You can use Desktop Themes to customize wallpaper, screen savers, mouse pointers (animated cursors), and many other elements of your Windows display.

Microsoft includes all the themes from the original Plus Pack as well as a few new ones, or you can create and save your own themes by either mixing existing elements or using your own sounds, wallpaper, animated cursors, and so on.

You can access Desktop Themes from Control Panel. Select a theme from the Theme drop-down list and proceed to customize as you wish.

Changing the Screen Resolution

Screen resolution is a measure of the density of the pixels displayed. More pixels means finer detail. One side effect of high resolution is that everything appears smaller. The advantages are more content on the screen, and you get more detail.

To adjust the screen resolution, follow these steps:

1. From the Display Properties dialog box shown in Figure 22.7, select the Settings tab. The top portion of this page contains one or more icons that represent your monitor(s). Multiple monitors are covered later in the chapter.

2.
If you have more than one monitor attached, single-click the monitor you want to adjust.

3.
Click the down arrow at the right of the Screen Area drop-down list box, and select the resolution you want.

4.
Click Apply.

FIG. 22.7 Right-click the desktop and select Properties to make changes to your display. To change screen resolution, select the Settings tab.

5. Click the OK button.

6.
The resolution will change, and you'll see a confirmation dialog. If you're happy with the display, click the OK button within 15 seconds. If the display is unreadable, wait 15 seconds, and Windows will restore the settings to the previous resolution.

Changing the Number of Colors Available to Your Monitor

The Color palette box in the Display Properties dialog allows you to determine the number of colors your applications and Windows send to the monitor. The number of colors available depends on several factors: the quality of the video card, the quality of the video driver, and the amount of video RAM available. The combination of these factors determines the color palette and video resolution combinations you have available.

To change the number of colors available, follow this procedure:

1. From the Display Properties dialog box, select the Settings tab. The top portion of this page contains one or more icons that represent your monitor(s). Multiple monitors are covered in the section "Configuring Multiple Monitors."

2.
If you have more than one monitor attached, single-click the monitor you want to adjust.

3.
Click the down arrow to the right of the Color drop-down list, and select the number of colors you want your applications and Windows to display.


NOTE: Remember that 3D graphics require more video RAM than 2D graphics. Therefore, depending on the selected resolution, your 3D graphics might not use the number of colors you choose here. If this happens, your 3D graphics will be a bit on the ugly side until you choose a lower resolution.

Changing your resolution is covered in the previous section, "Changing the Screen Resolution." 


4. If you choose a color palette too high for the resolution selected in the Screen Area section, Windows will decrement the resolution to the highest resolution that can be used with the color palette you select. Experiment until you find an acceptable combination.

Changing Font Sizes

By default, Windows uses a font size of 96 dots per inch. This is referred to as Small Fonts, or Normal size. Large Fonts is 125 percent of Normal size, or 120 dots per inch. You can also specify a custom font size if neither of these is satisfactory.

To change your font size, follow these steps:

1. From the Display Properties dialog box, select the Settings tab. The top portion of this page contains one or more icons that represent your monitor(s). Multiple monitors are covered in the section "Configuring Multiple Monitors."

2.
If you have more than one monitor attached, single-click the monitor you want to adjust.

3.
Click the Advanced button. This brings up a property sheet for you video adapter.

4.
On the General tab, click the down arrow to the right of the Font size drop-down list box, and select Small Fonts, Large Fonts, or Other.

5.
If you selected either small or large, click the OK button to apply the changes, and close the dialog.

6.
If you want to specify a custom font size, select Other.

7.
In the Custom font size dialog, you can select from a drop-down list in the Scale fonts to be ___% of normal size drop-down list or type the scale you want directly into the box. The minimum scale is 20 percent. If you type something smaller into the box, Windows will change it for you to 20 percent.

8.
The scale sample is displayed in the sample box and states the pixels (dots) per inch. You can also drag to the scale you want by clicking anywhere within the ruler and dragging left or right to decrease or increase the font scaling.

9.
When you find the scale you want, click the OK button.

10.
When you finish making your adjustments, click the OK button to apply the settings and close the Display Properties dialog.

Adjusting the Refresh Rate

To adjust the refresh rate for your video adapter, follow these steps:

1. From the Display Properties dialog box, select the Settings tab. The top portion of this page contains one or more icons that represent your monitor(s). Multiple monitors are covered in the section "Configuring Multiple Monitors."

2.
If you have more than one monitor attached, single-click the monitor you want to adjust.

3.
Click the Advanced button. This brings up a property sheet for your video adapter.

4.
At the bottom of the adapter tab is a drop-down list called Refresh rate. Most adapters only have two settings available: Adapter default and Optimal. Some will list specific refresh rates measured in Hz.

Generally, you want to set this to optimal, especially if you're having trouble with screen flicker.

Configuring Multiple Monitors

This section shows you how to use a dual monitor setup. This text assumes a setup of two monitors and does not give details on hardware installation.

For details on changing resolution, refresh rate, and color settings for each monitor, refer to the appropriate sections in this chapter.

Windows 98 supports up to eight monitors. Each must have its own PCI VGA video adapter. Your monitors are numbered from 1 through 8.

Setting up Windows to work with your monitors is very simple when you have the hardware installed. Follow these steps:

1. From the Display Properties dialog box, select the Settings tab. The top portion of this page contains one or more icons that represent your monitors. The icons are squares containing large digits representing the number of the monitor.

2.
Click once on monitor number 2. In the bottom-left corner of the Settings page, click the I want to use this monitor check box.

3.
By default, monitor number 2 is assumed to be on the left side. You can move the icons around to better represent the physical setup of your monitors. If your main monitor is on the right side, simply move the icons around with the mouse until they represent the actual positioning of your two monitors. You can even arrange them in a vertical or diagonal arrangement.

4.
The positioning of the icons is significant because it determines how you access each monitor.

5.
When you have the icons arranged, click the OK button.

That takes care of getting your second display ready to use. Now let's see how to use it.

The secondary display(s) becomes an extension of your desktop. Therefore, it does not have its own Taskbar. In fact, there is nothing on the secondary display until you put something there.

Getting objects to the other monitor is very easy. All you do is drag the object to the other monitor. If your secondary monitor is to the left, just drag the object off the left side of your primary monitor. If you want to work with Netscape and Internet Explorer at the same time, drag one to the other monitor. You can even drag the taskbar over there to get it out of your way.

Customizing the Windows Desktop

You can customize your desktop so it has a look and feel that reflects your personality and how you work.

This section shows you how to create your own color schemes, put a nice nature photo on your desktop, and add texture to your desktop background.

Using Existing Color Schemes

To use an existing color scheme, follow these steps:

1. In the Display Properties dialog, select the Appearance tab.

2.
The top half of the Appearance tab shows the different elements of the Desktop and your application windows that can be modified. This preview window shows the effect of the currently selected colors for each component or scheme.

3.
To select an existing scheme, click down or to the right of the scheme list box, and select a scheme from the list. The effects of the scheme are displayed in the preview window.

4.
If one of these schemes is suitable, select it and click Apply. The new color scheme will be applied immediately. If you like what you see, click the OK button to close the dialog.

Creating Custom Color and Text Schemes

If none of these schemes are appropriate and you only want to change a few elements, follow these steps to create your own color scheme:

1. Click the down arrow to the right of the Item: drop-down list box, and select the element you want to change.

2.
Click the Color: button to display the color palette. If you see the color you want, select it. If the color you want is not there, select Other to display a larger color palette and the custom colors dialog. Select an existing color or create your own, and click the OK button.

3.
When you've finished making color changes, click Apply to see what the changes will really look like. If you don't like them, switch back to the Windows standard color scheme and start over, or modify the colors you don't like. When you get the colors you want, click the OK button.

Some elements are also sizable. If this is possible for a particular element, the Size: box will no longer be grayed.


TIP: If you find a scheme that is very close to what you want, you can select that scheme, change the colors of the few items you want to change, and then use the Save As button to give the new scheme the name.
4. To change the fonts, click the down arrow to the right of the Font: drop-down list box, and select the desired font from the drop-down list.

5.
To change the font size, either select from the existing lists by clicking the Windows size text box, or highlight the contents of the size text box and type the font size directly into the box.

6.
To change the color of the font, click the down arrow in the color box to display the palette, and click on the color you want to use. Click the Other button to create a custom color or select from a larger color palette.

7.
To the right of the color palette button are the style buttons and italics. These are toggle buttons. If the button is depressed, that font style is turned on. To turn off, simply click the button again.

8.
When you have selected all the colors fonts and sizes you'll need, click the Save as button. This brings up the Save scheme dialog box. In the Save color scheme as text box, type the name you want to give to your new color scheme and click the OK button.

Wallpapering Your Desktop with a Graphic

Would you prefer to display a graphic or even a photo on your desktop instead of that blasé background? No problem; here's how:

1. From the Display Properties dialog box, select the Background tab. The top half of this property page is a graphic representation of your monitor/desktop. When you select wallpaper from the wallpaper list, a preview of the wallpaper is displayed there. Figure 22.8 shows the Background tab with a photo of Mount St. Helens selected as the wallpaper.

FIG. 22.8 Right-click the desktop and select properties. Use the background tab to change the wallpaper and pattern for your desktop.

2. Scroll through the items in the Select an Internet Document (HTML) or a picture: and click the one you want to use.

If the graphic you want to use for your wallpaper is not visible in the wallpaper list, click the browse button, and navigate to the location of your bitmap or HTML file. Select the file you want, and click the Open button.


TIP: To get your own files to show up in the Wallpaper list, simply copy them to the Windows folder. The next time you go to the Display Properties dialog, your Custom wallpaper will show up in the wallpaper list.
3. Most wallpaper bitmaps are very small and can be tiled to create a wallpaper effect. In the lower-right corner of the Background property sheet, you'll see the drop-down list called Display. Click the down arrow to the right of this list box to display the list. Select either tiled or center. If you choose center, only one copy of the bitmap is displayed directly in the center of your desktop. This is the recommended method for displaying photographs and HTML files.

Changing the Background Pattern

To change the background pattern:

1. Select (None) in the wallpaper list.

2.
Click the pattern button to display the pattern dialog.

3.
Click on the pattern you want to display. See the effect in the preview window to the right of the pattern list.

4.
To modify the pattern click the Edit pattern button. This brings up the pattern, which allows you to modify the pattern to your liking. When you're finished editing the pattern, click the Change button to view the sample. If the sample is satisfactory, click Done.

5.
Click the OK button to return to the Display Properties dialog.

6.
Click Apply to see the changes. If you like the changes, click the OK button.

Changing Desktop Icons

Want to change those system icons on the desktop? Follow these steps:

1. From the Display Properties dialog box, select the Effects tab. In the Desktop icons box you'll see the system icons that can be changed, including an option to use large icons.

2.
In the Desktop icons box, single-click the icon that you want to change, and click the Change icon button. This brings up the Change icon dialog.

3.
By default you'll see the icons inside explorer.EXE. Scroll to the right and left until you find the icon you want and click on it. Then click the OK button to close the dialog. You'll see the changes in the Desktop icons box.

4.
If none of these icons suits your fancy, you can select another file to choose icons from. To do this, click the Browse button. This brings up a standard Windows browsing dialog. In the Files of type drop-down list select the file type you want to search for. Navigate the directory of the file you want to search.

Icons are small images embedded inside files. Generally the icon for a particular application is embedded inside the executable file. Some of these have a .DLL extension and some have .ICO extensions, but virtually any file can contain an icon. In fact, most Windows applications' executable files (.EXE or .COM) contain their own icon. This is the icon Windows uses by default.

Some .DLL files and most .ICO files are nothing more than a large collection of files. Shell32.dll is such a file. You can find Shell32.dll in the Windows directory.

The two check boxes in the Visual settings area are pretty self-explanatory. To turn the feature on, click it to place a check in the check box. To disable the feature, remove the check mark.

Using the Screen Saver

Many of the Windows NT screen savers have been included in Windows 98. This gives you a much broader and more interesting selection of screen savers than previous versions of Windows.

Experiment with the individual setting for each screen saver, and make changes often to keep your computer a little more interesting.

Protecting Your Computer with a Screen Saver Password

If you don't want someone walking up to your computer and snooping around while you're getting coffee, follow these steps to set up password protection:

1. From the Display Properties dialog box, select the Screen Saver tab.

2.
Click the down arrow to the right of the screen saver list box, and select a screen saver if one isn't already selected.

3.
Click the password protected check box.

4.
Click the Change button. This brings up the Change Password dialog.

5.
In the New password: text box, type the new password you want to use, and press the tab key to move to the Confirm new password: text box. Retype your new password and click the OK button.

6.
A dialog box will be displayed in the middle of the screen telling you that your password has been successfully changed. Click the OK button. If the two passwords don't match, you'll receive a dialog box in the middle of the screen saying the passwords do not match and you must type them again.

Using Your Display's Energy-Saving Feature

The IBM XT (with the Intel 8086 processor) and its clones had a 100-watt power supply. This meant that at its peak usage it used about the same power as a 100-watt light bulb. And the monitor was a CGA that also used very little power, less than a television set.

With all the modern computing power and high-resolution video and other components now available, today's systems now use three to five times more power than they did in the 1980s.

Energy Star includes several Environmental Protection Agency (EPA) programs that set standards for energy efficiency. These standards are implemented in most modern computer hardware and office equipment.


ON THE WEB: The EPA has complete information on the Energy Star programs on their web site: http://www.epa.gov/appdstar/esoe/es_office.html

To take full advantage of the power saving features of your Energy Star-compliant monitor, follow these steps:

1. From the Display Properties dialog box select the Settings tab.

2.
You will see the property sheet for your video adapter. Select the Monitor tab. Table 22.4 describes the options on the Monitor page.

Table 22.4  Power-Saving Features

Option name Description
Monitor is Energy Star compliant If your monitor is Energy Star compliant, check this box. It is generally pretty obvious. Most ES-compliant monitors will have two power indicator lights on the front: yellow to indicate power has been reduced and green to indicate full power mode. Sometimes there is only one light that will change colors.
Automatically detect Plug and If your monitor is Plug and Play compatible,
Play monitors check this box. Windows will detect the power saver features of the monitor and use the appropriate software.
Reset display on suspend/resume Most adapters don't need to reset the display after a suspend. If your display is working properly, ignore this setting. Some monitors will flicker during a reset. If this bothers you, try unchecking this box.
Remember that you can also use your computer's CMOS settings to make your hard drive spin down when it's not in use. Refer to your BIOS manufacturer's documentation for information on adjusting these settings.

Changing the Screen Saver and Screen Saver Settings

To select a new screen saver, follow these steps:

1. Click the down arrow next to the screen saver drop-down list, and select the screen saver you want. The screen saver you select will show in the preview area.

2.
Click the Settings button to change the behavior and appearance. The types of settings vary with each screen saver. Experiment with the different settings; you can preview settings you have selected by clicking the Preview button.


TIP: The best way to use the preview is to use the Alt+v keyboard shortcut. Often after you click on the Preview button and you let go of the mouse, you inadvertently move the mouse slightly. The slightest mouse movement will turn off this screen saver preview. If you use the keyboard shortcut, you won't accidentally move the mouse before you're finished previewing.
3. To display your customized text, select scrolling marquee or 3D text from the screen saver list, and click the Settings button. Type the text you want to display on screen, and experiment with the other adjustments.

Changing the Sounds Related to Windows Events

Windows 98 associates different sounds with each event. For example, if an error occurs, the default sound is a chime. You can change this so that a different sound bite is played for any particular event. In fact, you can record your own sounds if you have a microphone for your sound card. For instance, you can record a wave file that says, "An error has occurred." This kind of customization is great for sight-impaired users.

Only sound files in the WAV format can be associated with Windows events. WAV files have the extension .WAV. For your own wave files to show up in the Name drop-down list box, you need to store them in a media folder under your Windows folder, for example, c:\windows\media\ My sound.wav.


ON THE WEB: Sound America is an excellent source for WAV files on the Internet. The Sound America Web Site has literally thousands of sound files most of which are WAV format. They are free for the downloading, and most of them are less than 100k in size.

The web site address is http://www.soundamerica.com.


To change the sound associated with a Windows event, follow these steps:

1. From the Control Panel, select the sounds icon. The sounds Properties dialog box is displayed.

2.
In the Events box, select the event you want to change the association for. If there is a Speaker icon to the left of the sound events, there is a sound already associated with that event. If there's no Speaker icon, no sound has been associated with that icon (see Figure 22.9).

3.
In the Name drop-down list box, select the sound file you want to associate with this event. If you want to associate a WAV file that is not in the media folder, click the Browse button, and navigate to that location of the file, and select from the Browse dialog.

4.
To preview the sound, click the right arrow to the right of the preview icon.


TIP: Windows also supplies several preset schemes that you can select from the Schemes drop-down list box. Click the down arrow to the right of the Schemes drop-down list to select the scheme you wish to use.

FIG. 22.9 Sounds Properties dialog.

5. When you finish making your custom sound associations, you can save this sound scheme with a unique name. Click the Save as button, type a name for the new sound scheme into the Save this sound scheme as text box, and click the OK button.


TIP: One very practical use for this feature is to find or record an intuitive or unique sound to associate with New Mail Notification. This way when new mail comes in, you get something more than just a chime.
Now, when you receive a new email message you will know right away, and you can check to see if it's the important one you've been waiting all day for.

Customizing Mouse and Keyboard Settings

You can customize the behavior of the mouse and keyboard to make them work exactly the way you want them.

From Control Panel, select mouse. You'll see the Mouse Properties dialog.

Table 22.5 describes the options in the three tabs in the Mouse Properties dialog.

Table 22.5  Mouse Properties--Buttons Tab

Option Name Description
Button configuration To configure your mouse for left-handed use, click the Left-handed radio button. This reverses the functionality of the left and right mouse buttons.
Double-click speed To adjust the double-click speed, move the slider bar in the double-click speed section of the buttons tab. Double-click the Jack-in-the-box in the Test area: to test your new speed setting.

Mouse Pointers and Animated Cursors

Depending on what task you're doing, your mouse pointer changes its appearance. The normal pointer is a white arrow pointing up and slightly left. If the computer is busy, such as when loading an application, your mouse pointer becomes an hourglass. This indicates that no other processing can occur until the current process is finished. If a process is working in the background, the mouse pointer becomes a combination of an arrow and an hourglass.

Windows provides several other mouse pointer schemes. To select a different scheme, click the down arrow to the right of the Scheme drop-down list. Select the pointer scheme you want to use.

The bottom half of this page shows what the mouse pointers look like. The square in the upper-right corner is a preview area for the highlighted pointer. This is really only useful if it is an animated cursor (mouse pointer). For example, if you select the animated hourglass scheme, click on the Busy cursor, and you can watch the animation in the Preview box.

If you want to create your own scheme of mouse pointers, select the pointer you want to change, and click the Browse button. This brings up a dialog box showing the contents of the cursors folder under Windows (c:\windows\cursors).

If you select a particular scheme but you want to use the Windows default for a few of the pointers, select the pointer you want to change and click the Use default button.

When you finish creating your disk pointer scheme, click the Save as button, type the new name in the Save this cursor scheme as: text box, and click the OK button.

Calibrating Mouse Movement

The Motion tab gives you the following options:

Table 22.6  Functions of the Intellipoint Mouse Wheel-Button

Action Effect
Single click This activates a scrolling feature. The scroll box in the vertical scrollbar changes appearance, and the pointer changes to a dot with an arrow above and below it when the pointer is directly over the scroll box. If the pointer is above or below the scroll box, one of the arrows will disappear, and the page will begin to scroll in that direction. The farther the pointer is from the center of the document window, the faster the document will scroll.
Click and hold The pointer changes to a dot with an arrow above and below. When you move the pointer up, the bottom arrow goes away and the document scrolls up. The reverse is true if you move the pointer down. A "ghost" pointer is visible at the position the pointer was in when you pressed the wheel. The farther the pointer is from the "ghost" pointer, the faster the document will scroll.
Spin without click The document scrolls up or down three lines at a time.
Hold left button and spin The text is highlighted as if you were doing a drag operation with the mouse.

Making Windows Accessible for the Hearing, Sight, and Movement Impaired

The Accessibility Options are indispensable for computer users with disabilities. Microsoft has done a fantastic job here. Many of these features are also useful for nonimpaired users as well. Even if you don't think you need any of these features, take a glance through them; you might be surprised at what you can do!

To open the Accessibility Options property sheet, double-click Accessibility Options in Control Panel. You'll see the dialog in Figure 22.10.

Keyboard Tab

The keyboard tab has three features:

FIG. 22.10 Run Accessibility Options from Control Panel.

FIG. 22.11 StickyKeys Settings dialog.

Sound Tab

The Sound tab contains two visual feedback features: SoundSentry and ShowSounds.

Sound Sentry tells Windows to give visual feedback at times when normally only audio feedback would occur. The settings button allows you to select what type of visual feedback is given.

ShowSounds tells your applications to give visual feedback when they would normally only give audio feedback.

FIG. 22.12 FilterKeys Settings dialog.

Display Tab

The Display tab feature forces your applications to use the color scheme specified in the Settings dialog (click the Settings button).

In the Settings dialog, you can check the Use shortcut box to enable the Left Alt+left Shift+Print Screen keyboard shortcut to enable the feature.

In the High contrast color scheme section, you can specify what scheme to use.

MouseKeys

MouseKeys allows you to use the arrow keys and the numeric keypad keys to control your mouse pointer. Click the Settings button to fine tune the feature's behavior.

General Tab

The general tab allows you to make a few global adjustments to the Accessibility Options.

Automatic reset tells Windows to turn off all Accessibility Options after a specified time of inactivity.

Notification provides two options for giving visual and audio feedback when features are turned on or off. This helps avoid accidentally toggling features on and off.

SerialKey devices is used when special input devices are attached to any of the serial ports. Use the Settings button to tell Windows what port the device is plugged into.

Using the Windows "Power Toys" Collection

The Windows Power Toys is a collection of small utility programs developed for Windows 95. Some of them have been built into the new operating system, and many of the others are still useful.

For instance, the AutoPlay Extender gives you AutoPlay capabilities for CD-ROMs that don't have AutoPlay support.

Cabview is a tool for viewing and extracting files from cabinet archives. An updated Cabview.dll is now included in the Windows 98 install. Installing the older version of Cabview from Power Toys is not recommended. CAB, short for cabinet, is a file archive format for distributing software and was implemented with the original release of Windows 95.

There are 13 different Power Toys and a readme.txt file is included that explains the functionality of each Power Toy.


CAUTION: Remember that Microsoft does not provide support for these utilities, and they were originally designed for Windows 95. Some of them might not work properly under Windows 98.
Carefully read all documentation available before using any of the Power Toys.


ON THE WEB: You can download the Power Toys from Microsoft's web site at

http://www.microsoft. com/windows95/info/powertoys.htm 



Previous chapterNext chapterContents


© Copyright, Macmillan Computer Publishing. All rights reserved.