Platinum Edition Using Windows 98

Previous chapterNext chapterContents


- 16 -

Maintaining and Troubleshooting Your System


by Ty Belknap and Larry Passo

Keeping Windows 98 Up-to-Date

No software is perfect, whether it's an operating system, a program, or the drivers for a piece of hardware. Companies are constantly working on their products to improve performance and reliability, and the main concern today is figuring out ways to get those improvements installed on user's systems.

Realizing this concern, Microsoft combined the use of the Internet with Windows 98 to get updates out quickly and easily, using the Windows Update Wizard.

Using the Windows Update Wizard

The Windows Update Wizard is a database maintained by Microsoft that contains drivers, system utilities, and other software. This gives you one convenient place on the Internet to check to see if there are Windows 98 updates available for your system. This is a Microsoft site, though, and Microsoft must approve all updated drivers on the site, so it might not have everything that you are looking for.

To search for updates using the Microsoft Update Wizard, follow these steps

1. Click Start and click the Windows Update icon. Internet Explorer comes up automatically and attempts to connect to Microsoft's Windows Update web site shown in Figure 16.1.

FIG. 16.1 The Update Wizard and Technical Support web sites are now combined.

2. Click on Update Wizard. A registration wizard pops up if this is the first time you've used the Update Wizard (see Figure 16.2). You must fill out the registration to continue. Part of the registration is to upload your configuration files to Microsoft. You can deselect a check box so this doesn't happen if you want to.

FIG. 16.2 The Update Wizard will not start if you click No.

3. The Update Wizard web page contains two options: Update and Restore. Click Update to scan the Internet for updated system files. A new Internet Explorer window pops up, as shown in Figure 16.3. The Update Wizard loads necessary components into your system and then scans the database for updated drivers.

FIG. 16.3 When you click Update, a list of available files appears on the left side of the main window.

4. As updates are found, the wizard refreshes the screen and the list of files available for update. Select a file in the list on the left to see its description as well as its, size, and approximate download time on the right side of the main window.

5.
Click on Install to install the file. Only one file can be installed at a time, and your computer may need to be restarted after a file is installed. Let the computer restart if necessary before downloading a second update in order to verify that it is still working properly.

The Update Wizard keeps track of where the new and old files are in case there's a problem. If your system crashes after you install a new file, or if some functions no longer work properly, you can go back and reinstall the old files. To do so, follow these steps:

1. Open the Update Wizard and click Restore. A new Internet Explorer window pops up, and the wizard scans your system and gives you a list of the files you have updated, as shown in Figure 16.4.

2.
Select a file in the list on the left to show the description of the update.

3.
To remove the update, click Uninstall. Restart your system if prompted.

FIG. 16.4 The Restore option allows you to uninstall files if they cause problems.

Reading Your Registration and Version Number

Your registration and version number might not seem important at first glance. But because Microsoft updates Windows 98 with patches and service packs, knowing where this information is will be helpful.

To view your current version of Windows 98 and Internet Explorer, as well as your product ID number, right-click on My Computer and select Properties. This opens the properties sheet shown in Figure 16.5.

FIG. 16.5 You will find the Windows and Internet Explorer version numbers in the System Properties dialog box. Your product ID number is the first number in the Registered To area.

Improving Windows Performance

The performance of Windows 98 can degrade over time as you add and remove programs and make updates to the system files. This section describes how to use the Disk Defragmenter and ScanDisk features to help keep your system working at top speed. In the following subsections, you'll find steps on how to check your performance settings, adjust virtual memory, and track system resources, as well as a detailed explanation of what the Windows 98 Tune-Up Wizard is and how to use it to automate tasks.

Checking Performance Settings

Your computer's performance settings are vital tools in the war against problems. The main Performance page can warn you about old drivers or possible viruses and gives you an easy way to check your system resources.

Follow these steps to check your computer's performance settings:

1. Right-click My Computer.

2.
Left-click Properties to access your system settings.

3.
Choose the Performance tab at the top to view your performance settings (see Figure 16.6).

FIG. 16.6 Check the main Performance page often. Problems with your computer might show up here.

Look carefully through the main page of the Performance tab. Make sure that it lists the correct amount of memory and that the File System and Virtual Memory both say 32-bit. Incorrect amounts of RAM could show that there are bad RAM chips on your computer. Or it might mean that you are loading an old DOS program (like Smart Drive) in your AUTOEXEC.BAT or CONFIG.SYS files or the load= or run= lines at the beginning of your WIN.INI file.


CAUTION: If your File System area shows some or all of your hard drives using MS-DOS Compatibility Mode Paging, you might be using an old hard disk driver or the Disable All 32 Bit Protected-Mode Disk Drivers option on the Troubleshooting tab might be checked. Use the Update Manager or contact the disk manufacturer to see if updated drivers are available.
A virus is another potential cause of Compatibility Mode Paging. Viruses and antivirus programs are covered toward the end of this chapter.

The Performance tab gives you access to three types of advanced settings: File System, Graphics, and Virtual Memory. Each of those types is outlined here.

File System  

As you can see in Figure 16.7, the File System Properties dialog box has five tabs of options: Hard Disk, Floppy Disk, CD-ROM, Removable Disk, and Troubleshooting.

FIG. 16.7 The Hard Disk tab.

The Hard Disk tab configures the settings on how the hard disk reads files and how the VCACHE file system works. In the Settings area, you can configure the following options:


NOTE: VCACHE is the Windows 98 Dynamic Swap File. This file grows and shrinks as programs are opened and closed. The Swap File, named Win386.swp, is a hidden file located on the root of your first hard drive. 

The Floppy Disk tab contains only one option, which enables you to have the computer search for new floppy drives every time the system is restarted. This is a good option for laptop users who have removable floppy drives, but desktop users can save time by disabling it. The default option for this setting is off.

The CD-ROM tab configures the read-ahead and buffering for your CD-ROM system. Figure 16.8 shows the two options to be configured.

FIG. 16.8 The CD-ROM tab.

The Removable Disk tab also contains only one option: Enable Write-Behind Caching on All Removable Disk Drives. Removable disks include such drives as Zip, Jaz, and Syquest, and this is a good option to check if you have one of them. Write-behind caching allows your applications to execute faster by saving their disk writes to a buffer area in memory, which is must faster than actually writing the data directly to the disk. The contents of the buffer area will be written to the actual removable disk when the disk is ready to accept it. Because write-behind caching is enabled by default for your hard disks, the only reason to use this option is if you have removable media. The default option for this setting is off.


CAUTION: If you choose to use write-behind caching on removable disks, make sure the computer is done writing to the disk before you remove the disk, or some information might be lost. You should also consider using an Uninterruptible Power Supply (UPS) because you risk the loss of data if your computer loses power before it empties the buffer and finishes writing information to your removable disk.

The Troubleshooting tab is useful when you're working with older MS-DOS programs, especially file utility programs like Norton Utilities that weren't made for Windows 98. Figure 16.9 shows the six items on the Troubleshooting tab.


NOTE: Windows 98 handles file systems much like Windows 95 did, and you can use most Windows 95 file utility programs in Windows 98. If you are using FAT32, make sure the utility is FAT32-compatible. 

FIG. 16.9 Click on a check box to disable or enable an item.


NOTE: Every time you check (or clear) a box in the Troubleshooting tab, you must restart your computer. 

The six options on the Troubleshooting tab are:


NOTE: To preserve long filenames with disk utilities that do not recognize them:

1. Turn off tunneling.

2. Close all other applications. (LFNBK cannot rename open files.)

3. At the command prompt, type LFNBK /b drive to back up and remove long filenames.

4. Restart the computer, and then run the disk utility. If it is an MS-DOS-based utility, run it in MS-DOS mode. If it is a Windows-based utility, run it in the usual way.

5. Turn tunneling on again, and then restart the computer.

6. At the command prompt, type LFNBK /r drive to restore long filenames.
The LFNBK utility actually renames each file with a long filename to its associated alias. The filename changes are stored in the LFNBK.DAT file in the root of the drive where you are running LFNBK. This file is used to restore long filenames (when you run LFNBK with the /r switch). 



CAUTION: The LFNBK utility is intended for use only by experienced Windows 95 users who have special needs for compatibility with older disk utilities. It is not intended for everyday use by average users.

Graphics  

The Graphics button off the main Properties tab takes you to the Advanced Graphics Settings dialog box, shown in Figure 16.10.

FIG. 16.10 Hardware acceleration can be a double-edged sword; it is not as stable as it should be.

The only option here is Hardware Acceleration. If you're upgrading from Windows 95, the upgrade should keep the same settings you had before. Hardware acceleration is usually a performance boost to computers, but using hardware acceleration can cause Fatal Exception errors. The text of a Fatal Exception error usually looks something like this:

(filename) caused a Fatal Exception error in module (filename) at: 0128:bfff... (more numbers)

The bfff series is what's important here. If the series of numbers starts with A, B, or C, the error could be a video problem. The first step toward correcting it is to look over the Internet or a Bulletin Board System to see if new drivers are available for your video card. If your video card has the latest drivers but you are still having problems, start lowering the Hardware Acceleration level one step at a time. After each restart, use your computer normally to see if the error reoccurs.


TIP: Anytime you think your computer is experiencing problems related to hardware, check the Microsoft Windows Update Wizard for updated drivers. An updated driver might solve the problem.

Lowering the Hardware Acceleration option might also solve mouse pointer problems. If your pointer disappears or if your mouse pointer seems jerky (and the mouse itself is not dirty), lower the Hardware Acceleration option one or two notches and see if that helps.

Virtual Memory  

Virtual Memory is the last option on the Performance tab (see Figure 16.11). Virtual memory allows Windows to load and run faster and more efficiently. If you restarted your computer and ran System Monitor (discussed later in this chapter), you would find that Windows has about a 6MB disk cache. This is because Windows loads virtual drivers, video drivers, the drivers to run hard disks, and more in virtual memory. In addition, every program that you load adds drivers and files to that virtual memory area.


CAUTION: Virtual memory is an integral part of Windows 98 and should never be turned off except when you're troubleshooting applicable problems.

FIG. 16.11 Virtual memory is the Windows 98 swap file.

The best option is to let Windows manage your virtual memory settings. Windows 98 has a dynamic swap file that grows and shrinks in size depending on what you need.

Specifying your own settings can improve performance on your computer, but it imposes limitations on what Windows can swap to the file from RAM. Set the minimum and maximum sizes of the swap file to the same size if you decide to specify your own settings. That will make a permanent swap file on your hard disk that does not change size, so Windows doesn't have to manage the file. The more RAM you have, the smaller a swap file you need. A manually created swap file should be around 20MB if you have 32MB RAM (more if you have less RAM). The recommended minimum amount for a swap file is 12MB RAM, which can be eaten up quickly.


CAUTION: There is an option to disable virtual memory, but using it will slow your computer considerably. Ideally, you should not disable virtual memory unless you are having file-related problems.

Defragmenting Disks for Faster Access to Data

Windows 98 writes information to the hard disk drive using whatever free space is available. As programs are removed, gaps form between the files that are left on the hard disk; those gaps are then filled by new programs that are installed. This process causes fragmentation of the hard drive, which cannot be prevented.

As the hard disk becomes fragmented, the computer has to search many different areas to execute programs or bring up data files. This causes a loss of performance because moving the read/write head of the hard disk to widely separated areas on the disk drive is a relatively slow operation. Fragmentation can also cause the computer to have problems during the normal execution of programs.

Disk Defragmenter was created to alleviate these problems. The Windows 98 Disk Defragmenter searches your hard disk for files and programs that belong together and then puts them in the right spots (like organizing a filing cabinet). The new Disk Defragmenter also watches how you use your computer and puts the programs you use the most at the front of the hard disk for faster access. This is done automatically if you check the option on the Settings submenu (detailed below), so you don't have to worry about picking and choosing which programs you might use the most.


TIP: Setting your screen saver to None before you start to defragment your hard disk allows the process to end faster.

To begin using Disk Defragmenter, follow these steps:

1. Click Start, Programs, Accessories, System Tools, Disk Defragmenter.

2.
From the screen shown in Figure 16.12, select the drive you want to defragment.

FIG. 16.12 Select the drive you want to defragment.

3. Click the Settings button to open the dialog box shown in Figure 16.13.

4.
Use the following options to specify your preferences:

Rearrange Program Files So My Programs Start Faster. This tells the utility to choose the programs you use the most and put them at the front of the hard disk drive. This will cause Disk Defragmenter to run slower, but your computer could show improved performance once it's done. Check the Drive for Errors. This tells the utility to test the sectors of the physical disk for problems. The utility might come back with a message to run ScanDisk if the error is something Disk Defragmenter can't handle. This will cause Disk Defragmenter to run slower, but it is a good option to use if you've been having system problems.

FIG. 16.13 Deselect both options if you just want a quick defrag of your hard drive.

5. If you want to save your settings, click Every Time I Defragment My Hard Drive. If you only want to use the settings for this time, click This Time Only.

6.
Click OK to start the utility.

You also have the option of running Disk Defragmenter from the hard drive icon. To do so, open My Computer, right-click on a hard drive icon, and choose Properties. Then click the Tools tab to see the screen shown in Figure 16.14. The Defragmentation Status box at the bottom tells you how long it's been since your hard drive was defragmented. Select Defragment Now to start the Disk Defragmenter utility.

FIG. 16.14 You do not have the option of changing settings when you access Disk Defragmenter in this way, but it is a quick way to defrag a specific hard drive.

Using ScanDisk to Prevent and Repair Damage

ScanDisk can search all the files on your computer, as well as the physical disk(s), for errors. When it finishes the search, ScanDisk offers you options on how to fix any errors it has found.


NOTE: ScanDisk checks and fixes problems in the following areas on hard disk drives, floppy disk drives, RAM drives, and memory cards:

ScanDisk cannot find or fix errors on CD-ROM drives, network drives, or drives created by using the MS-DOS commands Assign, Subst, Join, or Interlnk. 


To start ScanDisk, click Start, Programs, Settings, System Tools, ScanDisk. The screen shown in Figure 16.15 appears. The Windows 98 version of ScanDisk can handle both FAT16 and FAT32 formatted hard disks.

FIG. 16.15 The main ScanDisk window.


NOTE: You can also start ScanDisk by selecting My Computer, right-clicking on the drive you want to scan, and choosing Properties. Select the Tools tab and click the Check Now button. 

The main ScanDisk window contains two options and a check box. Choose one of the following options:

FIG. 16.16 It's a good idea to do a surface scan if you're having trouble installing a new program.


CAUTION: The files needed to run Windows reside in the System area. If your computer has a bad sector in the System area, you might not be able to restart Windows and might have to reinstall Windows from a DOS prompt.

Toward the bottom left corner of the main ScanDisk window is the Automatically Fix Errors check box. By default, this option is not checked, and ScanDisk simply shows you each error it finds. If you check this option, ScanDisk shows you the error and gives you the following options for choosing how to deal with the error:


NOTE: ScanDisk will automatically fix the error and create an undo file if you choose to automatically fix errors. 

At the bottom of the main ScanDisk screen, you'll see an Advanced button. Click the Advanced button to access these sets of options:


NOTE: The most frequent cause of cross-linked files is computers that are not shut down properly before they are turned off. That is why Windows 98 automatically runs ScanDisk when you turn your computer back on after it has been turned off improperly. 

Click OK to apply the Advanced option settings you've selected and return to the main ScanDisk screen.

Then click Start to run ScanDisk. ScanDisk could take a long time to run (more than half an hour if you selected the Thorough option or if the hard disk is very fragmented).

Using the All-in-One Windows Maintenance Wizard

The Windows Maintenance Wizard is a program that automates ScanDisk and Disk Defragmenter, as well as clearing your system of temporary files and unwanted networking components. With this wizard, you can have Windows run ScanDisk and Disk Defragmenter automatically on specific days and during specific times when you are not using your system.

To run the Windows Maintenance Wizard, click Start, Programs, Accessories, System Tools, Maintenance Wizard. If you have never run the Maintenance Wizard before, the first screen you see asks whether you want to do an Express or Custom tune-up (see Figure 16.17).


NOTE: If you have run the Maintenance Wizard before, performing the preceding steps takes you to a dialog box that asks whether you want to Perform Maintenance Now or Change My Maintenance Settings or Schedule. If you choose Change My Maintenance Settings or Schedule, the wizard responds with the screen shown in Figure 16.17. 

FIG. 16.17 Express setup is quick and easy.

The Express method uses the most common tune-up settings and is a quick way to get the Maintenance Wizard up and running. Choose the Express setting and click Next. The next screen that appears asks what time of day you want the wizard to run (Nights, Days, or Evenings). Choose your preference and click Next. Windows shows you which tasks will be performed. Click Finish, and you're done.

The Custom method enables you to select each tune-up setting yourself. The Custom selection allows for more flexibility but is more difficult to set up. To use the Custom setting, follow these steps:

1. Choose the Custom button and click Next. The wizard asks what time of day you want the programs to run (Nights, Days, Evenings, or Custom). Choose the setting you want and click Next.

2.
The Speed Up Programs window shown in Figure 16.18 appears. This window shows you what programs you have opening at startup. You can make Windows 98 start faster by not having any programs start automatically at startup. Click Next.

FIG. 16.18 Pick your startup files carefully. They can slow down the Windows startup process.

3. In the Speed Up Programs screen, you can specify when the Windows Disk Defragmenter should run. You can click on Reschedule or Settings to make any necessary changes to the schedule or settings. Click Next.

4.
In the Scan Hard Disk for Errors screen, choose the options you want. Then click Next.

5.
Delete Unnecessary Files is a tricky option. Every time your computer shuts off or restarts abnormally, a temporary file is created. Many newer Windows programs make a temporary file in the case of an accidental shut down as well. Most of the time, these temporary files are junk and can be deleted. However, there may be a time when you're writing an important document and your computer freezes. In that situation, a temporary file may have been created that can help you get your information back.

If you do choose to have unnecessary files deleted, you can use the Settings button to indicate what types of files you want deleted (see Figure 16.19). Click Next.

FIG. 16.19 Disk Cleanup allows you to view the files that are marked for deletion.

6. The last screen confirms your choices. Your computer must be on when the scheduled choices run. Verify the information, and then click Finish. This adds Task Scheduler to the System Tray on the right end of the taskbar.


TIP: You can perform the same functions on your system manually that the Maintenance Wizard performs automatically by using the Disk Defragmenter, ScanDisk, and Disk Cleanup utilities, all of which are located in the System Tools folder.

Keeping Track of System Resources

During a normal day at the computer, you might find yourself opening and closing a few programs, accessing the Internet for web pages or to read email, and perhaps playing a game that you end up having to hide in the background. Everything you do on your computer, whether it's moving the mouse around or loading the newest game, takes system resources, or memory. You should be able to reclaim resources by closing programs, but poorly written programs don't always give all the resources back. Unfortunately, the only way to get back all of your "missing" resources is to restart your computer.

There are several easy ways to keep track of your system's resources:


NOTE: Keep in mind that Resource Meter uses system resources like all other programs do. 

Repairing Configuration Problems

Windows 98 comes with a fantastic new utility called System Information. The System Information utility keeps track of all your computer's file versions, the resources your hardware is using, and the hardware and software components of your computer.

The Tools tab at the top of the utility also provides a means of quick access to Dr. Watson, System File Checker, Registry Checker, and more.

To access the System Information utility, click Start, Programs, Accessories, System Tools, System Information.

Gathering Details with the System Information Utility

The Microsoft System Information utility is a great tool for use in the battle against errors. It's a one-stop utility that enables you to view the resources, system components, and software environment on your computer. You can also run the following utilities from the Tools menu of the System Information utility:

The main window of the System Information utility is used to gather details about your computer (see Figure 16.20). This window is divided into three sections: Resources, Components, and Software Environment.


NOTE: This utility only allows you to view your hardware settings; you cannot change the settings from here. Chapters 19 and 27 contain details on changing settings. 

For troubleshooting purposes, Resources is the best section to keep track of. Although the Components section and the Software Environment section have good information on Registry settings and system file versions, the Resources section contains the majority of conflicts and settings needed to determine problems.

FIG. 16.20 The Microsoft System Information utility enables you to make sure Windows sees all the components in your computer.

The Resources area in the left pane shows how the different hardware components on your computer are working together. The six specific types of resources you can view here include the following:


CAUTION: No two hardware devices can use the same DMA channel.

From the File menu, you can choose to Export or Print any section of or the entire contents of the System Information utility. It's a good idea to print out the Resources area for reference. The information provided might come in handy if you're adding hardware, for example.

Repairing Damaged System Files

The System File Checker will automatically scan your computer's system files and repair any files that are damaged or corrupt. You can access System File Checker from the Microsoft System Information utility by choosing Tools, System File Checker. Figure 16.21 shows the main screen of the System File Checker.

As an added bonus, the System File Checker includes a file extraction utility. Anyone who has ever had to manually extract files out of CAB files will love this file extraction feature. Click the Settings button to change the default extraction settings.

FIG. 16.21 Now there's an easy way to extract files from a CD.

Follow these steps to use the file extraction feature:

1. Click the radio button to Extract One File from Installation Disk.

2.
In the File to Extract box, type the filename (or you can browse your hard disk to find the file). Then click Start, and the screen shown in Figure 16.22 appears.

FIG. 16.22 You can type the location of the source file, or click Browse to search your hard disk or the CD for the CAB files.

3. Verify the file's location (in the Restore From box) and the destination location (in the Save File In box). Use the appropriate Browse button if you need to change either one. Then click OK.

4.
Windows asks if you want to back up the current file. This is a good idea if you are updating an older file, because the new file might not work properly. Choose a folder to place the backup in.

If the folder you choose does not exist, Windows asks if you want to create it. Choose the option you want, and then click OK to continue and back up the file, or click Skip to continue without backing up the file.

5.
Windows should display a successful replacement message. If an error occurs, run ScanDisk to make sure there are no file problems.

Scanning the Registry for Errors

Registry Checker is a simple yet powerful utility that's part of the Microsoft System Information utility. This program scans and then backs up the following system configuration files: the Registry (SYSTEM.DAT and USER.DAT), WIN.INI, and SYSTEM.INI. The backed up files are stored in a CAB file in the hidden folder \Windows\Sysbckup. To start Registry Checker, first start the Microsoft System Information utility. Then follow these steps:

1. Click Tools, Registry Checker. Registry Checker automatically begins to scan the Registry for errors.

2.
If errors are found, Microsoft System Registry and Repair provides a list of known good *.CAB files (stored in the \Windows\Sysbckup folder) and allows you to choose which version of the Registry you want to restore.

3.
Registry Checker will then ask if you want to back up the Registry. You should do so; having a current backup of the Registry is always good in case of future problems.

Changing Startup Options to Diagnose Problems

Microsoft's System Configuration utility is the next generation of the Safe mode feature that's used to troubleshoot problems. In the System Configuration utility, you can choose which parts of the startup process to use when restarting your computer.

To run the System Configuration utility, click Start, Run, and type msconfig.exe in the Run dialog box. Or, if you're in the Microsoft System Information utility, you can click Tools, System Configuration Utility. Either way, you will see the screen shown in Figure 16.23.


TIP: The System Configuration utility works in Safe mode. Use this to easily change startup troubleshooting options.

FIG. 16.23 You can now choose startup options from within Windows.

The Startup Selection area of the General tab offers these three startup options:

Using Selective Startup  

Selective Startup actually offers two distinct options: using real-mode drivers and using protected-mode drivers. The real-mode drivers are CONFIG.SYS, AUTOEXEC.BAT, and WINSTART.BAT. The protected-mode drivers are WIN.INI, SYSTEM.INI, and the startup group items. You may notice that one or more of the files listed under Selective Startup are grayed out so you can't select them. This indicates that the file is empty or missing. Most commonly grayed out is WINSTART.BAT, which is a real-mode networking file. Because Windows handles all networking components in protected mode, this file is usually not present. It is also possible that the AUTOEXEC.BAT or CONFIG.SYS might be blank or missing (and, therefore, grayed out) considering Windows handles most of the startup options those files used to control.

If the AUTOEXEC.BAT, CONFIG.SYS, and WINSTART.BAT files are all grayed out, ignore the following instructions for troubleshooting using real-mode drivers. Instead, skip down to the section on troubleshooting using protected-mode drivers.


CAUTION: You should make a backup of all your files before you start the troubleshooting process. To do so, click the Create Backup button at the bottom of the dialog box.

To troubleshoot your computer by using Selective Startup and real-mode drivers, follow these steps:

1. Open the System Configuration utility (as described in the previous section) and click the Selective Startup radio button.

2.
Click the boxes to place check marks next to Process Config.sys File, Process Autoexec.bat File, and Process Winstart.bat File (or any of the three that are not grayed out).

3.
Click the boxes to remove check marks next to Process System.ini File, Process Win.ini File, and Load Startup Group items.

4.
Click OK to restart your computer.

Your system should go into a hybrid version of Safe mode. If your system freezes or encounters problems, you know that the problem resides in AUTOEXEC.BAT, CONFIG.SYS, or WINSTART.BAT. Go back through these steps and choose one file at a time until your system has the problem again. If necessary, you can choose view a specific file by selecting one of the tabs at the top of the System Configuration Utility dialog box. Then you can mark out individual lines in that file until you can narrow down the problem.

If you have no problems booting using real-mode drivers (or if you have no real-mode drivers to worry about), the next step is to troubleshoot the protected-mode drivers. Follow these steps:

1. Open the System Configuration utility (as described in the previous section) and click the Selective Startup radio button.

2.
Click the boxes to place check marks next to Process System.ini File, Process Win.ini File, and Load Startup Group Items. (Load Startup Group Items may be grayed out; this is not a problem.)

3.
Click the boxes to remove check marks next to Process Config.sys File, Process Autoexec.bat File, and Process Winstart.bat File.

4.
Click OK to restart your computer.

Your computer should boot into normal mode Windows. If your system freezes or has problems, you know that the problem resides in SYSTEM.INI, WIN.INI, or the startup groups. Go back through these steps and choose one file at a time until your system has the problem again. If necessary, you can view a specific file by selecting one of the tabs at the top of the System Configuration Utility dialog box. Then you can mark out individual lines in that file until you can narrow down the problem.

Tracking System Crashes with Dr. Watson

Windows 98 comes with a new version of Dr. Watson to help track system crashes. Dr. Watson is loaded with Windows 98 but has no associated icons. Dr. Watson is not automatically activated when Windows 98 restarts. To get it up and running, follow these steps:

1. Click Start, Run.

2.
Type c:\windows\drwatson.exe (assuming Windows 98 is loaded in the WINDOWS folder of your C drive). A new icon appears in the System Tray at the right end of the taskbar.

3.
Double-click the Dr. Watson icon in the System Tray. Dr. Watson opens and takes a "snapshot" of your system.

With Dr. Watson running, you can easily keep track of any errors that occur. Dr. Watson intercepts each error and takes a "snapshot" of what your system is doing at the time the error occurs. Figure 16.24 shows one of Dr. Watson's snapshots.

FIG. 16.24 The Diagnosis window of Dr. Watson shows you what program or file caused the error.

To keep track of the errors, click in the white section on the bottom of the screen and type a description of what you were doing at the time the error occurred. Click File, Save when you're done to save your report. This information will be a big help if you end up calling technical support.


TIP: You can also configure how much information you want Dr. Watson to capture and retain by right-clicking the Dr. Watson icon in the System Tray and clicking on Options.

Troubleshooting Common Problems

Windows 98 comes with 13 troubleshooters to help with common problems. By using these troubleshooters in combination with the tools described earlier in this chapter, you should have a good basis for troubleshooting Windows 98.

The 13 troubleshooters cover the following topics:
Networking (which includes the Dial-Up Networking and Direct Cable Connection troubleshooters)
Modem Display
Startup and Shutdown DirectX
Print Sound
DriveSpace The Microsoft Network
Memory Hardware Conflict
MS-DOS Programs PC Card
To access any of them, click Start, Help. On the Contents tab, select Troubleshooting and then Windows 98 Troubleshooters (see Figure 16.25).

Each troubleshooter has options to choose from and gives advice on whether you should contact technical support depending on the problem you are having. Each step is written in plain English so it's easy to understand.

FIG. 16.25 Each troubleshooter provides a series of steps to guide you through testing different components of your computer.

The following list outlines each of the troubleshooters.

Protecting Your System from Viruses with McAfee VirusScan

A computer virus is a program designed to create abnormal behavior on a computer. Because the number of malicious viruses increases daily, some sort of antivirus program should be on every computer.

It's a common belief that viruses come from the Internet--through shareware or freeware programs or email. The fact is, however, that the first viruses created came out before the government allowed public access to the Internet. At that time, viruses sometimes came bundled with software that was bought in stores. Even today, you could go to a store and pick out a program that's wrapped in plastic, and there could be a virus on the disk (though it's less common).


NOTE: CD-ROM's are far less susceptible to viruses, but there is still a chance of infection if the manufacturer isn't watching closely. 

Email viruses (or email "bombs," as they're sometimes called) are becoming a legend in today's world. It is impossible, however, for email to be infected with a virus. But this does not mean that you cannot get a virus from reading email. You might receive an email message with a file attached, and that file could contain a virus. For that reason, you should never have your email program automatically open attached files. Instead, use your email program to save the file to a special directory. Then, before you open the file, scan it using antivirus software.

Many brands of antivirus software are available these days, and they all seem to do a decent job. One of the best and most common of these is the McAfee VirusScan program.

You can download a shareware version of McAfee VirusScan from the Internet. Then click the SETUP.EXE file to start the installation process.

After it's installed, McAfee VirusScan pretty much runs itself. But be aware of the installation options you can choose from if you do a custom installation. Figure 16.26 shows all the options available with McAfee VirusScan.

FIG. 16.26 Choose Custom Install to be able to pick which components you want in McAfee VirusScan.

Each component slows your computer down a bit because McAfee searches every applicable file for possible viruses. So pick and choose which components you feel are most relevant in your situation. Here's what each component does:

Other antivirus programs also have custom controls. Regardless of which program you use, choose the controls carefully so you don't lose too much performance.

Using System Monitor to Detect Bottlenecks

System Monitor is a Windows 98 tool you can use to help determine the cause of problems on a local or remote computer by measuring the performance of hardware, software services, and applications. When you make changes to the system configuration, System Monitor shows the effect of your changes on overall system performance. You can also use System Monitor to justify hardware upgrades.

Before you make major configuration changes, use System Monitor to evaluate your current configuration; this can help you determine whether a particular system or network component is causing a performance bottleneck.

The most common bottlenecks occur in memory (RAM) and the CPU. Follow these steps to track these two components using System Monitor:

1. Click Start, Programs, Accessories, System Tools, System Monitor. The utility comes up with nothing on the screen. For each item you want to add, you'll use the Edit, Add Item command.

2.
To check the performance of your CPU, click Edit, Add Item. Then click Kernel in the left pane, select Processor Usage (%) in the right pane, and click OK.

3.
To check the performance of your RAM, click Edit, Add Item. Then choose Memory Manager from the left pane, select Disk Cache Size from the right pane, and click OK.

4.
Click Edit, Add Item again. Then choose Memory Manager from the left pane, select Other Memory from the right pane, and click OK.

5.
In the main System Monitor window, click View, Line Charts. You should see a screen something like the one shown in Figure 16.27.

Here's an overview of the CPU and RAM performance statistics that System Monitor would display as a result of the previous procedure:

FIG. 16.27 You can switch among a chart, a graph, and a numbered list in System Monitor by clicking any of the right three icons.


TIP: If your processor usage is too high, it might also be a symptom that you need more RAM. If your total RAM isn't large enough for your applications, and if your system is using large amounts of virtual memory, it will cause your processor usage to increase.
To see if you are using excessive amounts of virtual memory, check the counters for Memory Manager: Page-ins and Memory Manager: Page-outs.


Previous chapterNext chapterContents


© Copyright, Macmillan Computer Publishing. All rights reserved.