Inside Windows 98

Previous chapterNext chapterContents


- 7 -

Managing Files and Folders


Much of the work you do on your PC probably involves files in one way or another. Many people find and manage document files every day. Windows 98 provides a program called Explorer that helps you view and manage your files and other objects on your PC. You also can manage your PC's file system with the Windows File Manager, folder windows, and other methods. This chapter examines Explorer and other file-related issues, including the following topics:

You can perform most file and disk management tasks without opening Explorer. You can simply open a folder window and perform the task. If you work with a large number of objects or want to copy or delete entire folders, however, using Explorer is often more practical.

Explorer is only one method for managing files and folders. This chapter focuses on file management tasks rather than on Explorer. The following section provides an overview of Explorer to help you understand how it works and how to use it effectively. Later sections explain how to perform various tasks using a variety of methods, including Explorer, to format disks and manage files and folders. This chapter treats Explorer as one tool among many you can use to manage your files and folders, instead of focusing on it as a file management application.


NOTE: Although Windows 98's primary file management tool is Explorer, Windows 98 also includes a copy of File Manager to accommodate Windows 3.x users who are migrating to Windows 98. To start File Manager, click Start | Run and enter WINFILE in the Run dialog box.

Introducing Explorer

As you might have read in Chapter 6, "Using Windows 98," the Windows 98 Explorer is an application provided in Windows 98 that you can use to view and manage the resources on your PC. Explorer provides a view of other objects, including the desktop, Printers folder, Control Panel, Network Neighborhood, Dial-Up Networking folder, Recycle Bin, Briefcase, and any other objects on your Windows 98 desktop, doing more than just showing you a view of your PC's disks. Figure 7.1 shows the Explorer window with these objects displayed in the Tree pane.

FIGURE 7.1 Explorer provides quick access to most of your PC's resources.


TIP: To run Explorer, choose Start | Programs | Windows Explorer. To open an Explorer window of a folder, hold down the Shift key and double-click on the folder's icon. If you have a shortcut on the desktop to a folder, for example, you can open an Explorer window of that folder by holding down the Shift key and double-clicking on the shortcut icon.

Examining the Explorer Window

By default, the Explorer window includes two panes. The left pane--the Tree pane--arranges the resources on your desktop in a hierarchical tree that includes all objects on the desktop. Selecting an object from the tree displays its contents in the Contents pane on the right.

How the objects appear in the Contents pane depends on which view options you select. You can display the objects as large icons, small icons, a simple list, or a detailed list by choosing one of the four options from the View menu or by choosing a view option from the toolbar. If you select the large or small icon view, a labeled icon represents each item. If you select the Details option, the Contents pane displays a small icon for each object to indicate its type (see Figure 7.2).

FIGURE 7.2 Objects displayed as a list in Explorer.

You also can display a detailed list of the objects in the selected folder by choosing View | Details or by clicking on the Details button on the toolbar. In addition to displaying an icon and description for each object, Explorer displays the object's type (a description) and the date the object was last modified (see Figure 7.3).

FIGURE 7.3 A detailed list in Explorer.

The Explorer window looks and functions much like any folder window. You can use the View menu to turn the toolbars and status bar on and off and to control other options.


TIP: You can turn on the Explorer bar to show your search page, favorites, history, or channels, just as you can with a folder window. The Explorer bar appears between the tree and contents panes.

Opening Objects in Explorer

Objects in Explorer's tree include a small plus sign (+) beside them if they contain additional folders (refer to Figure 7.1). To expand a folder to show its subfolders, click on the plus sign. After you expand a folder to show its subfolders, the plus sign switches to a minus sign (-). To collapse a folder, click on the minus sign. Collapsing a folder makes it possible to view more objects in the tree, which is useful when you want to copy or move objects between different folders and can't otherwise see both folders in the tree. Collapsing folders also simplifies the entire tree view, reducing clutter and making it easier to locate objects.


TIP: You can expand and collapse an object by double-clicking on it in the tree. If Single Click is active with Web View, you only have to click once on an object to activate it.

To view the contents of a folder, click on the folder name or icon in the tree. The Contents pane changes to display the contents of the folder. If the selected folder contains other folders, their icons appear in the Contents pane even if the folder is not expanded in the tree (see Figure 7.4).

To open an object inside a folder, double-click on the object or select the object with the arrow keys and press Enter. If the object is an application, Explorer starts the application. If the object is a document, Explorer starts the document's parent application and loads the document into the application. If you attempt to open a document that has no application association, Explorer issues the Open With dialog box (see Figure 7.5), which prompts you to specify the application you want to use to open the document. Select the application you want to use to open the document and choose OK.

FIGURE 7.4 The Contents pane displays all subfolders and other objects in the folder.

FIGURE 7.5 Use the Open With dialog box to specify which application to use to open a document.


TIP: Enable the Always use this program to open this file check box if you want to associate the selected document type with the application. This places an entry for the document in the Registry and enables Windows 98 to use the same application in the future to open documents of the same type without any input from you.


TIP: Because Explorer windows are just like other folder windows, you have the same options for controlling the appearance of the Explorer window as you do with folder windows. To set Explorer's view options, choose View | Options. For information on setting folder options, refer to Chapter 6. See Chapter 25, "Using the Active Desktop," for more information on integrating Web content and styles on the desktop.

Jumping to a Specific Folder

You can open a folder in Explorer simply by selecting it from the Tree or Contents panes. Sometimes, however, this method for opening a folder is impractical. For example, the folder you want to open might be buried deep in the tree.

Rather than burrow your way through the tree to find a folder, you can jump directly to it. To do so, type the folder name in the Address combo box on the Address toolbar; then press Enter. You also can use the combo box's drop-down list to select most recently used objects.

Specifying a file in the Address list and pressing Enter causes Explorer to open the file.

Browsing Using Explorer

The Standard Buttons toolbar provides three buttons for navigating through your file system with Explorer. These buttons are the Back, Forward, and Up buttons. They perform the following functions:

The resources you browse using Explorer are not restricted to just files and folders. You can browse the network and other items in the tree pane in the same way.

Table 7.1 lists shortcuts for working with Explorer.

TABLE 7.1 Explorer Keyboard Shortcuts

Key Function
F4 Opens the selected object drop-down list, after which you can use the arrow keys to select an object to view in Explorer.
F5 Refreshes the view.
F6 Switches between the Tree and Contents panes.
Ctrl+G Shortcut to the Go To command; similar to choosing Tools | Go To.
Ctrl+Z Issues the Edit | Undo command.
Ctrl+A Selects all objects in the Contents pane.
Backspace Moves the view to the parent folder.
* Expands all folders under the selection in the tree.
+ Expands the tree of the current selection.
- (On the numeric keypad.) Collapses the current selection's tree.
Right arrow With tree active, expands current selection's tree if not already expanded; if already expanded, moves to the first child object in the selection.
Left arrow With tree active, collapses the current selection if expanded; if not expanded, moves to the current object's parent.
Ctrl+arrow Scrolls the tree without moving the current selection.

Using Explorer Command Switches

As with many Windows applications, Explorer supports command-line switches--optional parameters you include on the command line to start Explorer set with certain options. The easiest way to apply switches is to create a shortcut to Explorer and include the switches on the shortcut command line. The syntax for the Explorer command line follows:

explorer [/n] [/e][,/root,object][[,/select],subobject]

The command-line switches in this syntax example are as follows:

Getting Quick Access to Explorer

If you use Explorer a lot, consider creating a shortcut on the desktop to Explorer (shortcuts are explained in Chapter 6. You also might want to assign a shortcut key that enables you to load Explorer with a quick keystroke. You can't assign a shortcut keystroke directly to Explorer's executable file (EXPLORER.EXE), but you can assign a shortcut keystroke to your Explorer shortcut. After you create the shortcut on the desktop to Explorer, select the shortcut and open its Context menu (Shift+F10 or right-click). In the Shortcut page of the property sheet for the shortcut, click in the Shortcut key text box; then press the shortcut key sequence you want to assign to Explorer, such as Ctrl+Alt+X. Then, whenever you need to open Explorer, just press Ctrl+Alt+X (or whatever shortcut key sequence you assign to the shortcut).

Before a shortcut keystroke can work, however, the shortcut has to be in the \Windows\Desktop folder or, if you use multiple user profiles, in the \Windows\Profiles\user\Desktop folder.

Summarizing Explorer

Explorer is tightly integrated with the Windows 98 environment. Although it is a separate program, you can consider Explorer to encompass the entire desktop. When you open a folder on the desktop, you see information presented in the same way it is presented in Explorer. Explorer simply gives you a much broader view than a folder window of your PC's resources.

The following sections examine common file and folder management tasks and describe various methods you can use to accomplish the tasks. The tasks are explained using non-Explorer methods and using an Explorer method as well.

Understanding and Using Long Filenames


WARNING: The capability to run older MS-DOS and Windows 3.x applications on files that have long filenames without destroying the filenames doesn't apply to most backup, disk utility, and antivirus applications. In general, these types of applications destroy long filenames, although the files and their data are left unaffected.

By now most PC users are familiar with long filenames. The following two sections explain two issues relating to long filenames that are not self- evident.

Using Long Filenames at the Command Prompt

Windows 98 updates many of your command-line applications (DOS commands) to support long filenames. The COPY command, for example, enables you to copy a file that has a long filename. This long filename support is available from command-line sessions you start under Windows 98 and when you boot the PC to the command line rather than to the graphical user interface (GUI).

To use a long filename at the command prompt, simply type it as you would a short filename. If the file name contains special characters such as spaces, however, you must include the filename in quotation marks. The following is an example of using the COPY command to copy a file with a long filename that contains spaces:

copy "This is a long filename.txt" "Yet another longfile name.txt"

By default, the Windows 98 command prompt environment uses a keyboard buffer of 127 characters, which limits the length of long filenames you can use at the command prompt. If you copy a file that has a long filename to the root directory of a floppy disk, for example, the long filename is limited to 119 characters--127 minus 4 characters for "copy" and another two characters for the floppy disk ID, such as "A:". Decrease the limit by 2 more if you need to enclose the long filename in quotation marks--one character for each quotation mark.

You can, however, increase the size of the keyboard buffer by using the SHELL command. To increase the size of the keyboard buffer to its maximum of 255 characters, use the /u switch along with SHELL. Edit CONFIG.SYS and add or modify the SHELL statement using the /u switch and keyboard buffer size as in the following example:

shell=c:\windows\command.com /u:255

After you modify the keyboard buffer, save the changes to CONFIG.SYS and reboot the PC. The Windows 98 command line and MS-DOS sessions you create under Windows 98 then use the increased keyboard buffer size.


NOTE: When Windows 98 exits to single-application MS-DOS mode, the system uses only the real-mode file allocation table (FAT) file system. You can't see long filenames created in Windows 98 or from the Windows 98 command line when you're in the MS-DOS mode. You can, however, still see the 8.3 aliases of the files that have long filenames.

Disabling Long Filenames

Generally you shouldn't experience any problems using long filenames. After you use long filenames, you start to wonder how you got along without them and how you could handle the constraints of the 8.3 file naming system. If by some unlikely chance you decide that using long filenames disturbs the use of your system or applications, you can disable Windows 98's use of long filenames. To disable long filenames, follow these steps:

1. First remove the long filenames by using the Long File Name Backup (LFNBK) utility located in the \admin\apptools\lfnback folder on the Windows 98 CD.

2. Run the Registry Editor (Regedit) and locate the Registry key Hkey_Local_Machine\System\CurrentControlSet\Control\FileSystem.

3. Set the value of Win31FileSystem to 01.

4. Shut down and restart the computer.


TIP: You can direct Setup to disable long filenames when you install Windows 98. For information on using Setup and disabling long filenames during Setup, refer to Chapter 2, "Installing and Starting Windows 98."

Creating Folders and Documents

Windows 98 provides a selection of methods you can use to create new folders and documents. This section of the chapter includes a discussion of why you would want to create these types of items and provides a description of the many methods you can use to create them.

Creating Folders

As you probably know, a folder you create in Windows 98 is really nothing more than a directory. Although you can use the MKDIR or MD command at the command prompt to create a directory (folder), you'll probably find that creating folders in Windows 98 is easier.

The easiest way to create a folder is to right-click where you want the folder created; then choose New | Folder. Windows 98 creates a folder named New Folder and highlights the folder name so you can immediately enter a new name for the folder. If you right-click on the desktop, the folder is created on the desktop in the \Windows\Desktop folder or in the \Windows\Profiles\user\Desktop folder, if you configure Windows 98 to provide unique desktop environments. If you right-click in an open folder, the new folder is created in the open folder (creating a subdirectory).


TIP: To use the keyboard to create a folder on the desktop, make sure that no open folder win-dow is in the foreground; then press Shift+F10 to display the desktop's Context menu. Choose New | Folder, to create the folder on the desktop. To create a folder in a folder window, choose File | New | Folder.

You use a similar method in Explorer to create a folder. Right-click on the folder in which you want the new folder created; then choose New | Folder. Or select the parent folder (or the desktop) and choose File | New | Folder.

Creating New Documents

If you have used Windows 3.x or DOS applications, you probably are used to creating documents from within an application; for example, you create the data in the application and then choose File | Save As to save the document to the disk. In Windows 98 you can start a new document without first opening the parent application for the document.

If you right-click on the desktop or in a folder and choose New, a list of document types appears (see Figure 7.6). The menu lists all document types of OLE-aware applications properly registered in Windows 98. To create a new document, simply select it from the list of document types. Windows 98 creates a new document in the currently open folder or on the desktop, depending on where you right-click.

FIGURE 7.6 You can create a new document without opening the parent application.

As when you create a new folder, Windows 98 automatically assigns a name to the new document. If you create a new Word for Windows document, for example, Windows 98 names the new file New Microsoft Word Document. The name is automatically highlighted so you can immediately enter a document name of your choice. If a document already exists with the name Windows 98 would otherwise assign, the program adds a number to the end of the new document name, such as New Microsoft Word Document #2.

When you use the preceding method to create a new document, Windows 98 does not automatically open the parent application. To edit the document, double-click on its icon, select the icon and press Enter, or simply click once on the icon if you are using Web View.


TIP: Instead of right-clicking, you can choose File | New and select the document type to create. Or you can press Shift+F10 to open the folder's or desktop's Context menu.

Sending Objects

Windows 98 enables you to send objects to a floppy disk, Microsoft Fax, your Briefcase, an e-mail recipient, other disk locations, and printers with ease. You can right-click on a file, for example, then choose Send To and select the floppy disk to which you want to send the file (see Figure 7.7). Windows 98 then copies the file to the floppy disk. Using the Send To method is simpler than opening My Computer and dragging the file to the floppy disk icon.

FIGURE 7.7 Right-click on an object and choose Send To to send the object to floppy, fax, e-mail, Briefcase, or other destination.


TIP: An alternative method of using Send To is to select the object and choose File | Send To. Or select the object and press Shift+F10 to display its Context menu.

Windows 98 adds only a few items to the Send To menu, but you can easily add other items to the menu. To do so, create shortcuts in the \Windows\SendTo folder for each of the locations to which you want to be able to send objects. Any shortcuts that appear in the \Windows\SendTo folder automatically appear on the Send To menu.

For example, if you want to be able to print a document by selecting it and choosing Send To and selecting a printer from the menu, add shortcuts in \Windows\SendTo for all your printers. Or you might want to create shortcuts in \Windows\SendTo to a selection of remote network folders.

The following list explains how Windows 98 handles an object going to some of the possible destinations:

You can find more information about copying and moving objects in the section "Copying, Moving, and Renaming Objects" later in this chapter. For information regarding setting up, using, and managing printers, refer to Chapter 8, "Printing and Managing Printers."

Formatting and Labeling Disks

As with previous versions of MS-DOS and Windows, Windows 98 offers a few different methods for formatting and labeling disks, some of which are very similar if not identical to the methods used in MS-DOS and Windows 3.x. A significant difference, however, is that you now can format a disk in Windows 98 as you work on other tasks. You'll naturally experience some performance degradation in your other applications during formatting, but the extent of the performance hit depends on your PC's CPU type and speed.


NOTE: You cannot format a disk containing open files, including the disk that Windows 98 currently is using, such as the disk from which you run Windows 98. You also cannot format compressed drives or drives currently hosting a compressed drive. To format a drive hosting a compressed drive, back up the compressed drive (if you want to keep its files), unmount it, and format the host disk. To format a compressed drive, use DriveSpace (for DriveSpace volumes) or your compression software's management program.

To format a disk, open My Computer and right-click on the disk's icon and choose Format. Or select the disk's icon and press Shift+F10 and choose Format. If Windows 98 can format the disk, a dialog box similar to the one shown in Figure 7.8 appears. If Windows 98 can't format the disk for any reason previously explained, Windows 98 displays an error message to explain why it can't reformat the drive.

FIGURE 7.8 The Format dialog box.

You can choose one of the following options to define how to reformat the disk:

In addition to specifying the type of format to perform, you also must specify the capacity of the disk to be formatted. The Cap_acity drop-down list enables you to choose the capacity for which you want the drive formatted. For 3.5-inch disks, for example, the Cap_acity drop-down list includes 1.44 MB and 720 KB selections. Options for 5.25-inch disks include selections for 1.2 MB and 360 KB formats. If you format a hard disk, the hard disk's total formatted capacity automatically appears in the list--you can't change capacity on a hard disk, but you can use DriveSpace to double its capacity. For information on using DriveSpace, refer to Chapter 15, "Managing Disks and the File System."

In addition to formatting the disk, you can add a label to it. A disk's label appears in directory listings and in Windows 3.x-style drive selection list boxes (see Figure 7.9).

FIGURE 7.9 You can apply a disk label to all disk types, including hard disks.

Unfortunately, disk labels have not seen the same increase in length as filenames in Windows 98. Disk labels are limited to no more than 11 characters. If you format a disk that has previously been formatted and labeled, the disk's current label appears in the Label text box (of the Format dialog box). You can use the existing label, enter a new label, or clear the text box to use no label at all. You also can enable the No label check box to specify that you want the disk to have no label.

If you enable the Display summary when finished check box, Windows 98 displays a status dialog box (see Figure 7.10) after it finishes formatting. The status dialog box provides information about the amount of free space on the disk, number of bad sectors, and more.

If you want to create a bootable disk, enable the Copy system files check box. In addition to formatting the disk, Windows 98 then copies the necessary boot files to the disk to enable the disk to be used to boot the PC. This is similar to the Copy system files only option button, except you use the Copy system files only option for already formatted disks; you use the Copy system files check box to create a boot disk from an unformatted disk.

After you specify the necessary settings, choose Start to begin formatting. Here you can switch away from the Format dialog box to other applications and continue working during the format.

FIGURE 7.10 A status dialog box with information about a newly formatted disk.

You also can use the FORMAT command at the command prompt to format a disk. Generally, formatting a disk from the GUI is as easy as, or easier than, using the FORMAT command--particularly for new users. You might need to use the FORMAT command, however, to format the hard disk on which you intend to install Windows 98. For more information on preparing a disk to install Windows 98, refer to Chapter 2. You can enter FORMAT /? at the command prompt to obtain a listing of FORMAT command syntax and options, assuming FORMAT.COM is in the current directory. You can find FORMAT.COM in the \Windows\Command directory.


NOTE: For information about partitioning a disk or formatting a disk to install Windows 98, refer to Chapter 14, "Disk and File System Overview."

In addition to formatting a disk through the disk's Context menu in My Computer, you can format a disk in Explorer. Select the disk you want to format and press Shift+F10 to display the disk's Context menu or right-click on the disk's icon. From the Context menu, choose Format to format the disk.


TIP: You can right-click on a disk shortcut icon to format the disk associated with the shortcut.

Copying, Moving, and Renaming Objects

Much file and folder management you do probably includes copying and moving objects between disks and folders and renaming objects. This section explains how you can perform these types of actions in Windows 98.

Copying and Moving Files and Folders

During the course of a normal week, it's a sure bet that you often copy files from folder to folder or from one disk to another. If you want to back up a couple of document files, for example, you probably copy them from the hard disk to a floppy disk or to a network disk. Moving a file is similar to copying it, except the original is deleted after it copies to its new location.

Chapter 6 explains how to copy and move objects simply by dragging them from one folder to another. One of the easiest methods of copying or moving a selection of files is to drag their icons to their destination. More often than not, using Explorer is the easiest way to accomplish this because Explorer enables you to see both the source folder and the destination folder in one window. After you open Explorer, locate and select the files you want to copy or move. Then click on one of the files and drag it and the other files to the folder or disk to which you want to copy them. Whether the drag acts as a copy or a move depends on the relationship between the source and destination folders. The following list explains the relationship:

If you want to be able to choose whether to move or copy the files, right-drag the files to their destination. This opens a menu that gives you the option of moving or copying the files or creating shortcuts to the files.


TIP: You can select multiple files and folders in the Contents pane, enabling you to copy or move a selection of folders and files. Hold down the Shift key while clicking to select a range of files or folders, and hold down the Ctrl key while clicking to select objects one at a time.

Often, however, you can't see both the destination folder in the tree and the source folder. The destination folder might be far removed in the folder structure from the source folder, or it might be located on another disk. The solution is to first locate the destination folder, expanding its parent folder if necessary. You only have to display the folder in the tree; you don't have to actually open the destination folder. Then scroll through the tree to locate and open the source folder. Select in the Contents pane all files and folders you want to copy; then scroll through the Tree pane to locate the destination folder. Drag the files from the Contents pane and drop them on the destination folder.


NOTE: Copying a folder adds it as a folder to the structure of the destination folder. Dragging the folder \Harry to the folder \Fiddlesticks creates a folder named \Fiddlesticks\Harry. All of the files and folders in \Harry are duplicated in \Fiddlesticks\Harry.

If you need to see the contents of the source and destination folders, or you want to open multiple source or destination folders, one instance of Explorer doesn't do the trick. This isn't a problem, however, because you can open as many instances of Explorer as you need. Just choose Start | Programs | Windows Explorer as many times as you want instances of Explorer on the desktop. Next, select a different view for each instance. Then select and copy files between Explorer windows as necessary.


TIP: Dragging a folder to copy it also copies all files and other folders contained in that folder. To copy the Windows folder and all its subfolders and files, for example, you simply would drag the Windows folder to a new location. Before you copy a folder, make sure you really want to copy all its files and folders too.

Using the Clipboard to Copy Files and Folders

Dragging files and folders between folder windows and Explorer windows is just one method of copying files. If you look in Explorer's File menu, you might be surprised not to find a Copy command, even if you have selected one or more files or folders. This doesn't mean you can't use the menus or keyboard to copy files--the capability does exist, but it might not be where you expect to find it.

If you select one or more files or folders and then open the Edit menu, you find the Copy command enabled. To copy files using the menu, select the files or folders you want to copy and then choose Edit | Copy or press Ctrl+C. Explorer copies the file and folder names to the Clipboard. Then select the destination to which you want the folders copied and choose Edit | Paste or press Ctrl+V. Explorer copies the files to the destination.


NOTE: Explorer does not actually copy the files or folders themselves to the Clipboard. In fact, copying the actual files to the Clipboard would often be impractical--the contents of the Windows folder and all its subfolders, for example, would scarcely fit on the Clipboard. Explorer instead simply copies the names of the selected objects to the Clipboard in a variety of special list-based formats. When you choose Edit | Paste or press Ctrl+V, Explorer looks at the contents of the Clipboard, determines that a file list exists in the Clipboard, and then copies the files to the destination based on that list.

You also can use the Clipboard to move files. Instead of copying the file and folder list to the Clipboard, however, you cut the objects and paste them into their new location. Unlike a typical cut operation, which actually removes the original to the Clipboard, Explorer treats the operation differently. When you select folders and files and then choose Edit | Cut or press Ctrl+X, Explorer dims the selected objects to indicate that they have been cut. The files and folders are removed, however, only if you select a destination and choose Edit | Paste or press Ctrl+V. If you perform any other operation, Explorer just "undims" the files and does nothing with them.

To use the Clipboard to move files, therefore, first select the files and folders you want to move. Choose Edit | Cut or press Ctrl+X to cut the file list to the Clipboard. Then select the destination folder and choose Edit | Paste or press Ctrl+V. Explorer copies the files to the new location and deletes the original copies.


TIP: You do not have to use Explorer to copy or move files with the Clipboard. You can open a folder window, select objects, and cut, copy, and paste between folder windows.

Renaming Files, Folders, and Disks

Renaming a file or folder is a simple process in Windows 98--one you can perform equally well in a folder window, on the desktop, or in Explorer. To rename a folder or file in any of these locations, simply select the object and click on its title, which highlights it. Type a new title and press Enter to change the title. If you have trouble selecting and highlighting the name, right-click on the object and choose Rename from its Context menu, which also highlights the name; then you can enter a new name.


TIP: To use the keyboard to rename an object, select the object and press Shift+F10 to open its Context menu. Then choose Rename.

Like files and folders, disks have names; a disk's label is its name. Unlike files and folders, however, you can't click on a disk's description and change the label. To change a disk's label, first select the disk's icon in My Computer or in Explorer. Open the disk's property sheet by pressing Alt+Enter. Or open the disk's Context menu by pressing Shift+F10 or by right-clicking on the icon and choosing Properties. Windows displays the property sheet shown in Figure 7.11. In the Label text box on the General page, enter up to 11 characters for the disk's label. Then choose OK or Apply to make the name change take effect.

FIGURE 7.11 Use a disk's property sheet to change its label.

Searching for Files and Folders

Windows 98 includes an integrated search tool called Find that helps you locate files, folders, computers on the network, and topics on the Microsoft Network. This section covers using Find to locate files and folders; Chapter 26, "Peer Resource Sharing and Security," explains how to use Find to locate computers on the network.

Before you begin reading about Find, however, you need to understand wild cards. The following section explains the changes to wild-card pattern matching in Windows 98. Even if you are familiar with wild cards in previous versions of DOS or Windows, you should read the following section to understand the changes to wild cards in Windows 98.

Understanding and Using Wild Cards

Windows 98 supports using wild cards to control pattern matching in filenames. Wild cards help you locate files by name or by extension quickly and easily. The two wild-card characters Windows 98 supports are the asterisk (*) and the question mark (?). You use the asterisk to represent multiple characters and the question mark to represent single characters. Aside from a few exceptions, you can use a combination of wild-card characters whenever you specify a file or folder name during a file open or search procedure.

To list or find all files whose names start with the letter G, for example, specify G*.* as the filename. This will find filenames such as GOOFY.DOC, GLAD YOU CALLED, GADFLIES.XLS, and GOOD GOLLY, MISS MOLLY.WAV. To list or find all files that have a file extension of doc, specify a filename of *.DOC. This will find files with names such as ALPHA.DOC, BRAVO.DOC, CHARLIE.DOC, DELTA ECHO FOXTROT.DOC, and any other file that has a doc extension.

If you need to refine the search a little, you can use the question mark rather than the asterisk. To list all files whose names begin with any letter and have the characters "older" as the rest of the filename, specify ?OLDER.*. This will find files with names such as COLDER.DOC, BOLDER.TXT, and HOLDER.WAV. To find a file that has a name such as HOLDER OF THE KEYS, you could specify a file string of ?OLDER*.*.

The way in which Windows 98 differs from previous versions of DOS and Windows 3.x lies in the use of the asterisk. Previously, DOS and Windows 3.x would recognize only the first asterisk and ignore any characters that followed it, up to the period that separated the filename and extension. For example, entering *OLDER.DOC would list all files with a doc extension, regardless of their names. This was equivalent to specifying *.DOC because the system ignored the characters that formed OLDER.

Windows 98, however, does not ignore the characters that follow an asterisk, and you can use multiple asterisks and question marks in a specification to further define the pattern matching. A valid search specification would be *OLDER*.*. Files found with this specification might include BOLDER21.MID, ITS COLDER IN HERE, SOLDER IS HOT.WAV, and so on. Windows 98 would find any file that contains the string OLDER. The specification ?ROUCH*.* might locate the files GROUCH.ZIP, CROUCH.DOWN.NOW, ZROUCH33, and so on. Remember, the question mark represents only one character, so a file named WHAT A GROUCH will not be found. To find such a file, use the string *GROUCH*.*.

Now that you have some background in pattern matching and wild cards, you're ready to start finding those files and folders you've been missing.

Finding Files and Folders

You can access Find from the Start menu or from Explorer. To access Find from the Start menu, choose Start | Find and then Files or Folders. To access Find from Explorer, choose Tools | Find and then Files or Folders. Windows 98 displays the Find dialog box shown in Figure 7.12.

FIGURE 7.12 Locate files and folders with the Find dialog box.

Enter a name specification in the Named combo box, or use the drop-down list portion of the combo box to select a name pattern you have entered previously. To specify the disk or folder in which Find should search for the files or folders, choose an object from the Look in combo box or type a location such as C:\. If you want Find to search all folders in the disk or folder you specify in the Look in combo box, enable the Include subfolders check box. When you're satisfied with your search criteria, choose Find Now. Find expands the dialog box to include a search results list (see Figure 7.13). Any files or folders that match the search criteria appear in this list.


TIP: To select a path or object to search, choose Browse. Use the resulting Browse dialog box to choose the object or path you want to include in the search.

FIGURE 7.13 The Find dialog box expanded to show the results list.

If you want to clear the search results list and begin a new search, choose the New Search button.

Searching by Modification Date

By default, Find searches for all files and folders that match your search pattern. You can, however, limit the search to only those files or folders modified during a certain time period. To search based on modification date, click on the Date Modified tab. The Find dialog box changes as shown in Figure 7.14.

FIGURE 7.14 The Date Modified page of the Find dialog box.

To include all files in the search, choose the All files option button. To limit the file search, choose the Find all files created or modified option. Then use one of the following three options to control the search:

When your settings in the Name & Location page and Date Modified page suit your search needs, choose Find Now to initiate the search.

Using Advanced Options

The Advanced page of the Find dialog box enables you to refine your search even further. You can use the Advanced page to specify the types of files to be included in the search, specify that the file must contain specific text to be included in the search, and specify an upper or lower file size limit. The following list explains these items:

When you are satisfied with your search criteria, choose Find Now to initiate the search.

Using Other Search Options

The Options menu includes two options you can use to further refine your search. The Case Sensitive option causes Find to treat your search string as case sensitive; for example, the string "FindMe" would not be treated as equal to "findme" or "FINDME." The Case Sensitive option applies to text within a file if you use the Containing text option; it has no effect on filenames because Windows 98 does not treat filenames as being case sensitive.

The Save Results option in the Options menu causes Find to create an icon on the desktop that contains the results of the search. You can select the icon to open a Find dialog box with the save results displayed in the results list. Enabling the Save Results option causes Find to save the results automatically. You also can choose File | Save Search to save the contents of the results window to the desktop.

Viewing and Setting Disk and File Properties

As with nearly all other objects in Windows 98, disks have various prop-erties associated with them. In fact, if you have read the sections in this chapter on formatting and labeling disks, you already know about one disk property--the disk label. In addition to its label, a disk has other properties, some of which you can modify and others that you can only view.

Viewing a Disk's Properties

To view a disk's properties, right-click on the disk's icon in My Computer or in Explorer; then choose Properties. Or select the disk's icon and press Alt+Enter. Windows 98 displays a property sheet similar to the one shown in Figure 7.15.

FIGURE 7.15 The property sheet for a disk.

The General property page shows the amount of space used on the disk, the amount of space available, the total capacity of the disk, and the disk's label. You can change a local disk's label by entering a new label in the Label text box. You can't change remote network disks' labels, however.

The only general property you can change about a disk is its label. The capacity, space used, and space available properties simply indicate the disk's capacity; you can't affect the disk's capacity by changing any of its properties. There are, however, two other property pages for a disk.

The Tools page enables you to open a variety of disk optimization tools to increase the performance of the selected disk. The Sharing page enables you to share a local disk with other users on the network. For information on sharing disks and other resources, refer to Chapter 26.

Viewing and Setting File and Folder Properties

You can view and set file properties in much the same way you view and set disk properties. Select the file or folder; then press Alt+Enter to display its property sheets. Or right-click on the object and choose Properties. The property sheets for a typical file are shown in Figure 7.16. The General property page for a folder is essentially identical to the General property page for a file. Folders have an additional property page named Sharing, which enables you to share the folder with other users on the network (see Figure 7.17).

FIGURE 7.16 The General property page for a file.

FIGURE 7.17 The Sharing property page for a folder.

Changing File Attributes

The only properties you can change for a file are its attributes. The file attributes, which appear on the General property page, are explained in the following list:

If an attribute check box is enabled, that attribute is enabled for the file. If the check box is clear, the attribute is not set. If multiple files are selected, the check box might be solid gray. This indicates that only some of the selected files have this attribute.

To change a file or folder's attributes, simply enable and clear the attribute check boxes as necessary.

Viewing Version Information

Windows application and support files include version and copyright information embedded within the file. You can view these file properties in the Version property page for the file. To view the version information, select the file and press Alt+Enter to display its property sheets. Then click on the Version tab to display the Version page (see Figure 7.18).

To view a particular property, select an item from the Item name list. The associated version information appears in the Value list.


NOTE: You can't change version information for a file; you can only view the information.

FIGURE 7.18 The Version property page.

Version information can be extremely useful for identifying out-of-date files, replacing old files with new versions, and avoiding having to replace new files with old files. When you install a Windows application, however, Setup generally displays a message when it is about to replace a newer version of a file with an older version, giving you the option of keeping the newer file or replacing it with the older version. You should almost always keep the newer version of the file.

Managing Files from the Command Line

You probably will perform most of your file and folder management tasks from the Windows 98 GUI, using folder windows or Explorer. If you often work from a DOS VM (DOS session) or you have many years of experience using DOS, you might prefer to perform some of your file and folder maintenance from the command prompt. Because Windows 98 incorporates a DOS environment, it includes most of the DOS file and directory commands included with previous versions of DOS. The syntax for the majority of these commands is identical or very similar to their DOS counterparts. For help with the syntax of a command, enter the command at the command prompt, followed by the /? switch, as in the following example:

XCOPY /?


Previous chapterNext chapterContents

© Copyright, Macmillan Computer Publishing. All rights reserved.