Sun Microsystems, Inc.
spacerspacer
spacer www.sun.com docs.sun.com |
spacer
black dot
 
 
1.  Installing and Maintaining a Sun StorEdge A5x00 Array Maintaining Storage Arrays How to Add a Disk Drive  Previous   Contents   Next 
   
 

Where to Go From Here

For procedures about how to add and remove quorum devices, see Sun Cluster system administration documentation

ProcedureHow to Replace a Disk Drive

Use this procedure to replace a disk drive in a storage array. Perform the steps in this procedure in conjunction with the procedures in the Sun Cluster system administration documentation and your server hardware manual. Use the procedures in your server hardware manual to identify a failed disk drive.

For conceptual information on quorums, quorum devices, global devices, and device IDs, see your Sun Cluster concepts documentation.

  1. Identify the disk drive that needs replacement.

    If the disk error message reports the drive problem by device ID (DID), determine the Solaris logical device name. If the disk error message reports the drive problem by the Solaris physical device name, use your Solaris documentation to map the Solaris physical device name to the Solaris logical device name. Use this Solaris logical device name and DID throughout this procedure.

    # scdidadm -l deviceID
  2. Is the disk drive you are replacing a quorum device?

    # scstat -q
    • If no, proceed to Step 3.

    • If yes, add a new quorum device on a different storage array. Remove the old quorum device.

      For procedures about how to add and remove quorum devices, see Sun Cluster system administration documentation

  3. If possible, back up the metadevice or volume.

    For more information, see your Solstice DiskSuite/Solaris Volume Manager or VERITAS Volume Manager documentation.

  4. Identify the failed disk drive's physical DID.

    Use this physical DID in Step 11 to verify that the failed disk drive has been replaced with a new disk drive. The DID and the World Wide Name (WWN) for the disk drive are the same.

    #scdidadm -o diskid -l cNtXdY
  5. Which volume manager a you using?

    • If VERITAS Volume Manager, proceed to Step 6.

    • If Solstice DiskSuite/Solaris Volume Manager, save the disk partitioning information to partition the new disk drive.

      # prtvtoc /dev/rdsk/cNtXdYs2 > filename

    Note - You can also use the format utility to save the disk's partition information.


  6. On any node that is connected to the storage array, remove the disk drive when prompted.

    # luxadm remove_device -F /dev/rdsk/cNtXdYs2

    After running the command, warning messages might display. These messages can be ignored.

  7. On any node that is connected to the storage array, run the luxadm insert_device command. Add the new disk drive when prompted.

    # luxadm insert_device boxname,rslotnumber
    # luxadm insert_device boxname,fslotnumber

    If you are inserting a front disk drive, use the fslotnumber parameter. If you are inserting a rear disk drive, use the rslotnumber parameter.

  8. On all other nodes that are attached to the storage array, probe all devices. Write the new disk drive to the /dev/rdsk directory.

    The amount of time that the devfsadm command requires to complete depends on the number of devices that are connected to the node. Expect at least five minutes.

    # devfsadm
  9. Which volume manager are you using?

    • If VERITAS Volume Manager, go to Step 10.

    • If Solstice DiskSuite/Solaris Volume Manager, on one node that is connected to the storage array, partition the new disk drive. Use the partitioning information you saved in Step 5.

    # fmthard -s filename /dev/rdsk/cNtXdYs2

    Note - You can also use the format utility to partition the new disk drive.


  10. From all nodes that are connected to the storage array, update the DID database and driver.

    # scdidadm -R deviceID

    Note - After running scdidadm --R on the first node, each subsequent node that you run the command on might display the warning, device id for the device matches the database. This warning can be ignored.


  11. On any node, confirm that the failed disk drive has been replaced. Compare the following physical DID to the physical DID in Step 4.

    If the following physical DID is different from the physical DID in Step 4, you successfully replaced the failed disk drive with a new disk drive.

    # scdidadm -o diskid -l cNtXdY
  12. Perform volume management administration to add the disk drive back to its diskset or disk group.

    For more information, see your Solstice DiskSuite/Solaris Volume Manager or VERITAS Volume Manager documentation.

  13. If you want this new disk drive to be a quorum device, add the quorum device.

    For the procedure about how to add a quorum device, see Sun Cluster system administration documentation.

ProcedureHow to Remove a Disk Drive

Use this procedure to remove a disk drive from a storage array. Example--Removing a Disk Drive shows you how to apply this procedure. Perform the steps in this procedure in conjunction with the procedures in the Sun Cluster system administration documentation and your server hardware manual.

For conceptual information on quorum, quorum devices, global devices, and device IDs, see your Sun Cluster concepts documentation.

  1. Determine if the disk drive that you are removing is a quorum device.

    # scstat -q
    • If the disk that you are replacing is not a quorum device, go to Step 2.

    • If the disk drive is configured as a quorum device, choose and configure another device to be the new quorum device. Then remove the old quorum device.

      For procedures about how to add and remove quorum devices, see Sun Cluster system administration documentation

  2. If possible, back up the metadevice or volume.

    For more information, see your Solstice DiskSuite/Solaris Volume Manager or VERITAS Volume Manager documentation.

  3. Perform volume management administration to remove the disk drive from the configuration.

    For more information, see your Solstice DiskSuite/Solaris Volume Manager or VERITAS Volume Manager documentation.

  4. Identify the disk drive that needs to be removed.

    If the disk error message reports the drive problem by DID, determine the Solaris device name.

    # scdidadm -l deviceID
  5. On any node that is connected to the storage array, run the luxadm remove_device command.

    Remove the disk drive. Press the Return key when prompted.

    # luxadm remove_device -F /dev/rdsk/cNtXdYsZ
  6. On all connected nodes, remove references to the disk drive.

    # devfsadm -C
    # scdidadm -C
 
 
 
  Previous   Contents   Next