How to Upgrade Controller Module Firmware in a Running Cluster
Use this procedure to upgrade firmware in a controller module, in a running cluster. Use either the online or the offline method to upgrade your firmware. The method that you choose depends on your firmware.
Are you upgrading the NVSRAM firmware file?
If you are not upgrading the NVSRAM file, you can use the online method.
Upgrade the firmware by using the online method, as described in the Sun StorEdge RAID Manager User's Guide. No special steps are required for a cluster environment.
If you are upgrading the NVSRAM file, you must use an offline method. Use one of the following procedures.
-- If the data on your controller module is mirrored on another controller module, use the procedure in Step 2.
-- If the data on your controller module is not mirrored on another controller module, use the procedure in Step 3.
Use this step if you are upgrading the NVSRAM and other firmware files on a controller module. This controller module must not have mirrored data.
Halt all activity to the controller module.
For more information, see your Solstice DiskSuite/Solaris Volume Manager or VERITAS Volume Manager documentation.
Update the firmware files by using the offline method, as described in the RAID Manager User's Guide.
Restore all activity to the controller module.
For more information, see your Solstice DiskSuite/Solaris Volume Manager or VERITAS Volume Manager documentation.
This step completes the firmware upgrade.
Use this step if you are upgrading the NVSRAM and other firmware files on a controller module. This controller module must not have mirrored data.
Shut down the entire cluster.
For the procedure about how to shut down a cluster, see your Sun Cluster system administration documentation.
Boot one node that is attached to the controller module into noncluster mode.
For the procedure about how to boot a node in noncluster mode, see your Sun Cluster system administration documentation.
Update the firmware files using the offline method, as described in the RAID Manager User's Guide.
Boot both nodes into cluster mode.
For more information about how to boot nodes, see your Sun Cluster system administration documentation.
This step completes the firmware upgrade.
How to Add a Disk Drive in a Running Cluster
Use this procedure to add a disk drive to a storage array that is in a running cluster.
Caution - If the disk drive that you are adding
was previously owned by another controller module, reformat the disk drive.
Reformat the disk drive to wipe clean the old DacStore information before
adding the disk drive to this storage array.
Install the new disk drive to the storage array.
For the procedure about how to install a disk drive, see the Sun StorEdge D1000 Storage Guide.
Enable the disk drive to spin up approximately 30 seconds.
Run Health Check to ensure that the new disk drive is not defective.
For instructions about how to run Recovery Guru and Health Check, see the Sun StorEdge RAID Manager User's Guide.
Fail the new drive, then revive the drive to update DacStore on the drive.
For procedure about how to fail and revive drives, see the Sun StorEdge RAID Manager User's Guide.
Repeat Step 1 through Step 4 for each disk drive you are adding.
Where to Go From Here
To create LUNs for the new drives, see How to Create a LUN for more information.
How to Replace a Failed Disk Drive in a Running Cluster
Use this procedure to replace a failed disk drive in a running cluster.
Does replacing the disk drive affects any LUN's availability?
If no, proceed to Step 2.
If yes, remove the LUNs from volume management control. For more information, see your Solstice DiskSuite/Solaris Volume Manager or VERITAS Volume Manager documentation.
Replace the disk drive in the storage array.
For the procedure about how to replace a disk drive, see the Sun StorEdge D1000 Storage Guide.
Run Health Check to ensure that the new disk drive is not defective.
For the procedure about how to run Recovery Guru and Health Check, see the Sun StorEdge RAID Manager User's Guide.
Does the failed drive belong to a drive group?
If the drive does not belong to a device group, proceed to Step 5.
If the drive is part of a device group, reconstruction is started automatically. If reconstruction does not start automatically for any reason, then select Reconstruct from the Manual Recovery application. Do not select Revive. When reconstruction is complete, skip to Step 6.
Fail the new drive, then revive the drive to update DacStore on the drive.
For the procedure about how to fail and revive drives, see the Sun StorEdge RAID Manager User's Guide.
If you removed LUNs from volume management control in Step 1, return the LUNs to volume management control.
For more information, see your Solstice DiskSuite/Solaris Volume Manager or VERITAS Volume Manager documentation.



