How to Add a Disk Drive
Use this procedure to add a disk drive to a storage array that is in a running cluster.
Verify that the new disk drive is formatted. Verify that you are not transferring the new disk from another storage array.
For information about how to move drives between StorEdge/Netra st storage array subsystems, see the Sun StorEdge RAID Manager Release Notes.
Install the new disk drive to the storage array.
For the procedure about how to install a disk drive, see the Sun StorEdge A1000 and D1000 Installation, Operations, and Service Manual or the Netra st A1000/D1000 Installation and Maintenance Manual.
Enable the disk drive to spin up for approximately 30 seconds.
Run Health Check to ensure that the new disk drive is not defective.
For the procedure about how to run Recovery Guru and Health Check, see the Sun StorEdge RAID Manager User's Guide
Fail the new drive, then revive the drive to update DacStore on the drive.
For the procedure about how to fail and revive drives, see the Sun StorEdge RAID Manager User's Guide.
Repeat Step 2 through Step 5 for each disk drive you are adding.
Where to Go From Here
To create LUNs for the new drives, see How to Create a LUN for more information.
How to Replace a Disk Drive
Use this procedure to replace a failed disk drive in a running cluster.
Does replacing the disk drive affect any LUN's availability?
If no, proceed to Step 2.
If yes, remove the LUNs from volume management control. For more information, see your Solstice DiskSuite/Solaris Volume Manager or VERITAS Volume Manager documentation.
Replace the disk drive in the storage array.
For the procedure about how to replace a disk drive, see the Sun StorEdge D1000 Storage Guide.
Run Health Check to ensure that the new disk drive is not defective.
For the procedure about how to run Recovery Guru and Health Check, see the Sun StorEdge RAID Manager User's Guide.
Does the failed drive belong to a drive group?
Fail the new drive, then revive the drive to update DacStore on the drive.
For the procedure about how to fail and revive drives, see the Sun StorEdge RAID Manager User's Guide.
If you removed LUNs from volume management control in Step 1, return the LUNs to volume management control.
For more information, see your Solstice DiskSuite/Solaris Volume Manager or VERITAS Volume Manager documentation.
How to Remove a Disk Drive
Use this procedure to remove a disk drive from a running cluster.
Is the LUN that is associated with the disk drive a quorum device? This disk drive is the disk drive that you are removing.
# scstat -q
If no, proceed to Step 2.
If yes, relocate that quorum device to another suitable storage array.
For procedures about how to add and remove quorum devices, see your Sun Cluster system administration documentation.
Remove the LUN that is associated with the disk drive you are removing.
For the procedure about how to remove a LUN, see How to Delete a LUN.
Remove the disk drive from the storage array.
For the procedure about how to remove a disk drive, see the Sun StorEdge D1000 Storage Guide.
Caution - After you remove the disk drive, install
a dummy drive to maintain proper cooling.
How to Upgrade Disk Drive Firmware
Caution - You must be a Sun service provider to perform disk drive firmware
updates. If you need to upgrade drive firmware, contact your Sun service provider.
How to Replace a Node's Host Adapter
This section describes the procedure about how to replace a failed host adapter in a running node. This node is attached to a storage array.
In the following procedure, Node 1's host adapter on SCSI bus A needs replacement. Node 2 remains in service.
Note - Several steps in this procedure require that you halt I/O activity. To halt I/O activity, take the storage array offline by using the RAID Manager GUI's manual recovery procedure in the Sun StorEdge RAID Manager User's Guide.
Without powering off the node, shut down Node 1.
For the procedure about how to shut down and power off a node, see your Sun Cluster system administration documentation.
From Node 2, halt I/O activity to SCSI bus A.
For instructions, see the Sun StorEdge RAID Manager User's Guide.
From the storage array end of the SCSI cable, disconnect the SCSI bus A cable. This cable connects the storage array to Node 1. Replace this cable with a differential SCSI terminator.
Restart I/O activity on SCSI bus A.
For instructions, see the Sun StorEdge RAID Manager User's Guide.
Does servicing the failed host adapter affect SCSI bus B?
From Node 2, halt I/O activity to the storage array on SCSI bus B.
For instructions, see the Sun StorEdge RAID Manager User's Guide.
From the storage array end of the SCSI cable, disconnect the SCSI bus B cable. This cable connects the storage array to Node 1. Replace this cable with a differential SCSI terminator.
Restart I/O activity on SCSI bus B.
For instructions, see the Sun StorEdge RAID Manager User's Guide.
Power off Node 1.
Replace Node 1's host adapter.
For the procedure about how to replace a host adapter, see the documentation that shipped with your node hardware.
Power on Node 1. Do not enable the node to boot. If necessary, halt the storage array.
From Node 2, halt I/O activity to the storage array on SCSI bus A.
For instructions, see the Sun StorEdge RAID Manager User's Guide.
Remove the differential SCSI terminator from SCSI bus A. Reinstall the SCSI cable to connect the storage array to Node 1.
Restart I/O activity on SCSI bus A.
For instructions, see the Sun StorEdge RAID Manager User's Guide.
Did you install a differential SCSI terminator to SCSI bus B in Step 7?
Remove the differential SCSI terminator from SCSI bus B. Reinstall the SCSI cable to connect the storage array to Node 1.
Restart I/O activity on SCSI bus B.
For instructions, see the Sun StorEdge RAID Manager User's Guide.
Bring the storage array back online.
For instructions, see the Sun StorEdge RAID Manager User's Guide.
Rebalance all logical units (LUNs).
For instructions, see the Sun StorEdge RAID Manager User's Guide.
Boot Node 1 into cluster mode.



