Where to Go From Here
To create a LUN from disk drives that are unassigned, see How to Create a LUN.
To upgrade storage array firmware, see How to Upgrade Disk Drive Firmware.
How to Remove a Storage Array
Use this procedure to remove a storage array from a running cluster.
Caution - This procedure removes all data that
is on the storage array you remove.
Migrate any Oracle Parallel Server/Real Application Clusters (OPS) tables, data services, or volumes off the storage array.
Is one of the LUNs in the storage array a quorum device? This storage array is the storage array that you are removing.
# scstat -q
If no, proceed to Step 3.
If yes, relocate that quorum device to another suitable storage array.
For procedures about how to add and remove quorum devices, see your Sun Cluster system administration documentation.
Halt all activity to the storage array.
For instructions, see the Sun StorEdge RAID Manager User's Guide and your operating storage array documentation.
Remove the LUN from disksets or disk groups.
If a volume manager manages the LUN, remove the LUN from any diskset or disk group. For more information, see your Solstice DiskSuite/Solaris Volume Manager or VERITAS Volume Manager documentation.
You must completely remove LUNs that were managed by VERITAS Volume from VERITAS Volume Manager control before you can delete the LUNs.
# vxdisk offline cNtXdY # vxdisk rm cNtXdY
From one node, delete the LUN.
For the procedure about how to delete a LUN, see the Sun StorEdge RAID Manager User's Guide.
Disconnect all cables from the storage array. Remove the hardware from your cluster.
Remove the paths to the LUNs you are deleting.
# rm /dev/rdsk/cNtXdY* # rm /dev/dsk/cNtXdY* # rm /dev/osa/dev/dsk/cNtXdY* # rm /dev/osa/dev/rdsk/cNtXdY*
On all nodes, remove references to the storage array.
# scdidadm -C
If you plan to remove a host adapter that has an entry in the nvramrc script, delete the references to the host adapters in the nvramrc script.
Note - If there are no other parallel SCSI devices connected to the nodes, you can delete the contents of the nvramrc script and, at the OpenBoot PROM, set setenv use-nvramrc? false.
Remove any unused host adapters from nodes that were attached to the storage array.
Shut down and power off Node 1.
For the procedure about how to shut down and power off a node, see your Sun Cluster system administration documentation.
Remove the host adapter from the Node 1.
For the procedure about how to remove a host adapter, see the documentation that shipped with your node hardware.
Perform a reconfiguration boot to create the new Solaris device files and links.
Repeat Step a through Step c for Node 2 that was attached to the storage array.
Return resource groups to their primary nodes.
# scswitch -Z
Are you removing the last storage array from your cluster?
If no, you are finished with this procedure.
If yes, proceed to Step 13.
Remove RAID Manager patches, then remove RAID Manager software packages.
Caution - If you improperly remove RAID Manager
packages, the next reboot of the node fails. Before you remove RAID Manager
software packages, see the Sun StorEdge RAID Manager Release Notes.For the procedure about how to remove software packages, see the documentation that shipped with your storage array.
How to Replace a Failed Controller or Restore an Offline Controller
Use this procedure to replace a storage array controller, or to restore an offline controller.
For conceptual information on SCSI reservations and failure fencing, see your Sun Cluster concepts documentation.
Is one of the LUNs in the storage array a quorum device?
# scstat -q
If no, proceed to Step 2.
If yes, relocate that quorum device to another suitable storage array.
For procedures about how to add and remove quorum devices, see your Sun Cluster system administration documentation.
Restart the RAID Manager daemon.
# /etc/init.d/amdemon stop # /etc/init.d/amdemon start
Do you have a failed controller?
If your storage array is offline, but does not have a failed controller, proceed to Step 4.
If you have a failed controller, replace the failed controller with a new controller.Do not bring the controller online.
For the procedure about how to replace storage array controllers, see the Sun StorEdge A3500/A3500FC Controller Module Guide and the Sun StorEdge RAID Manager Release Notes
On one node, use the RAID Manager GUI's Recovery application to restore the controller online.
Note - You must use the RAID Manager GUI's Recovery application to bring the controller online.
For information on the Recovery application, see the Sun StorEdge RAID Manager User's Guide. If you have problems with bringing the controller online, see the Sun StorEdge RAID Manager Release Notes.
On one node that is connected to the storage array, verify that the controller has the correct SCSI reservation state.
Run the scdidadm(1M) repair option (-R) on LUN 0 of the controller you want to bring online.
# scdidadm -R /dev/dsk/cNtXdY



