643802 Resource group is online on more than one node.
Description: An internal error has occurred. Resource group should be online on only one node.
Solution: Save a copy of the /var/adm/messages files on all nodes. Contact your authorized Sun service provider for assistance in diagnosing the problem.
644140 Fault monitor is not running.
Description: Sun cluster tried to stop the fault monitor for this resource, but the fault monitor was not running. This is most likely because the fault monitor was unable to start.
Solution: Look for prior syslog messages relating to starting of fault monitor and take corrective action. No other action needed
644850 File %s is not readable: %s.
Description: Unable to open the file in read only mode.
Solution: Make sure the specified file exists and have correct permissions. For the file name and details, check the syslog messages.
644850 File %s is not readable: %s.
Description: Unable to open the file in read only mode.
Solution: Make sure the specified file exists and have correct permissions. For the file name and details, check the syslog messages.
645309 Thread already running for node %d.
Description: The cl_eventd does not need to create a thread because it found one that it could use.
Solution: This message is informational only, and does not require user action.
645501 %s initialization failure
Description: Failed to initialize the hafoip or hascip callback method.
Solution: Retry the operation. If the error persists, contact your Sun service representative.
646037 Probe timed out.
Description: The data service fault monitor probe could not complete all actions in Probe_timeout. This may be due to an overloaded system or other problems. Repeated timeouts will cause a restart or failover of the data service.
Solution: If this problem is due to an overloaded system, you may consider increasing the Probe_timeout property.
646037 Probe timed out.
Description: The simple probe on the network aware application timed out.
Solution: This problem may occur when the cluster is under heavy load. You may consider increasing the Probe_timeout property.
646664 Online check Error %s: %ld: %s
Description: Error detected when checking ONLINE status of RDBMS. Error number is indicated in message. This can be because of RDBMS server problems or configuration problems.
Solution: Check RDBMS server using vendor provided tools. If server is running properly, this can be fault monitor set-up error.
646815 PCUNSET: %s
Description: The rpc.pmfd server was not able to monitor a process, and the system error is shown. An error message is output to syslog.
Solution: Save the /var/adm/messages file. Contact your authorized Sun service provider to determine whether a workaround or patch is available.
646950 clcomm: Path %s being cleaned up
Description: A communication link is being removed with another node. The interconnect may have failed or the remote node may be down.
Solution: Any interconnect failure should be resolved, and/or the failed node rebooted.
647339 (%s) scan of dlmmap failed on "%s", idx =%d
Description: Failed to scan dlmmap.
Solution: This is an internal error. Save the contents of /var/adm/messages, /var/cluster/ucmm/ucmm_reconf.log and /var/cluster/ucmm/dlm*/*logs/* from all the nodes and contact your Sun service representative.
647673 scvxvmlg error - dcs_get_service_parameters() failed, returned %d
Description: The program responsible for maintaining the VxVM namespace has suffered an internal error. If configuration changes were recently made to VxVM diskgroups or volumes, this node may be unaware of those changes. Recently created volumes may be inaccessible from this node.
Solution: If no configuration changes have been recently made to VxVM diskgroups or volumes and all volumes continue to be accessible from this node, then no action is required. If changes have been made, the device namespace on this node can be updated to reflect those changes by executing '/usr/cluster/lib/dcs/scvxvmlg'. If the problem persists, contact your authorized Sun service provider to determine whether a workaround or patch is available.
648339 Failed to retrieve ip addresses configured on adapter %s.
Description: System was attempting to list all the ip addresses configured on the specified adapter, but it was unable to do that.
Solution: Check the messages that are logged just before this message for possible causes. For more help, contact your authorized Sun service provider with the following information. Output of /var/adm/messages file and the output of "ifconfig -a" command .
649584 Modification of resource group <%s> failed because none of the nodes on which VALIDATE would have run for resource <%s> are currently up
Description: Before it will permit the properties of a resource group to be edited, the rgmd runs the VALIDATE method on each resource in the group for which a VALIDATE method is registered. For each such resource, the rgmd must be able to run VALIDATE on at least one node. However, all of the candidate nodes are down. "Candidate nodes" are either members of the resource group's Nodelist or members of the resource type's Installed_nodes list, depending on the setting of the resource's Init_nodes property.
Solution: Boot one of the resource group's potential masters and retry the resource creation operation.
649648 svc_probe used entire timeout of %d seconds during read operation and exceeded the timeout by %d seconds. Attempting disconnect with timeout %d
Description: The probe timed out while reading from the application.
Solution: If the problem persists investigate why the application is responding slowly or if the Probe_timeout property needs to be increased.
649860 RGM isn't failing resource group <%s> off of node <%d>, because no current or potential master is healthy enough
Description: A scha_control(1HA,3HA) GIVEOVER attempt failed on all potential masters, because no candidate node was healthy enough to host the resource group.
Solution: Examine other syslog messages on all cluster members that occurred about the same time as this message, to see if the problem that caused the MONITOR_CHECK failure can be identified. Repair the condition that is preventing any potential master from hosting the resource.
650276 Failed to get port numbers from config file <%s>.
Description: An error occurred while parsing the configuration file to extract port numbers.
Solution: Check that the configuration file path exists and is accessible. Check that port keywords and values exist in the file.
650390 Validation failed. init<sid>.ora file does not exist: %s
Description: Oracle Parameter file has not been specified. Default parameter file indicated in the message does not exist. Cannot start Oracle server.
Solution: Please make sure that parameter file exists at the location indicated in message or specify 'Parameter_file' property for the resource. Clear START_FAILED flag on the resource and bring the resource online.
650825 Method <%s> on resource <%s> terminated due to receipt of signal <%d>
Description: A resource method was terminated by a signal, most likely resulting from an operator-issued kill(1). The method is considered to have failed.
Solution: No action is required. The operator may choose to issue an scswitch(1M) command to bring resource groups onto desired primaries, or re-try the administrative action that was interrupted by the method failure.
650932 malloc failed for ipaddr string
Description: Call to malloc failed. The "malloc" man page describes possible reasons.
Solution: Install more memory, increase swap space or reduce peak memory consumption.



