Sun Microsystems, Inc.
spacerspacer
spacer www.sun.com docs.sun.com |
spacer
black dot
 
 
  Previous   Contents   Next 
   
 
Chapter 2

Error Messages

This chapter contains a numeric listing of Sun Cluster 3.1 error messages and descriptions. The following sections are contained in this chapter.

Message IDs 100000-199999

 

100088 fatal: Got error <%d> trying to read CCR when making resource group <%s> managed; aborting node

Description: Rgmd failed to read updated resource from the CCR on this node.

Solution: Save a copy of the /var/adm/messages files on all nodes, and of the rgmd core file. Contact your authorized Sun service provider for assistance in diagnosing the problem.

 

100293 dl_bind: kstr_msg failed %d error

Description: Could not bind to the private interconnect.

Solution: Reboot of the node might fix the problem.

 

100396 clexecd: unable to arm failfast.

Description: clexecd problem could not enable one of the mechanisms which causes the node to be shutdown to prevent data corruption, when clexecd program dies.

Solution: Contact your authorized Sun service provider to determine whether a workaround or patch is available.

 

101010 libsecurity: program %s (%lu); clnt_authenticate failed

Description: A client of the specified server was not able to initiate an rpc connection, because it failed the authentication process. The pmfadm or scha command exits with error. An error message is output to syslog.

Solution: Save the /var/adm/messages file. Contact your authorized Sun service provider to determine whether a workaround or patch is available.

 

102218 couldn't initialize ORB, possibly because machine is booted innon-cluster mode

Description: could not initialize ORB.

Solution: Please make sure the nodes are booted in cluster mode.

 

102340 Prog <%s> step <%s>: authorization error.

Description: An attempted program execution failed, apparently due to a security violation; this error should not occur. This failure is considered a program failure.

Solution: Correct the problem identified in the error message. If necessary, examine other syslog messages occurring at about the same time to see if the problem can be diagnosed. Save a copy of the /var/adm/messages files on all nodes and contact your authorized Sun service provider for assistance in diagnosing the problem.

 

102779 %s has been removed from %s.\nMake sure that all HA IP addresses hosted on %s are moved.

Description: We do not allow removig of an adapter from an IPMP group. The correct way to DR an adapter is to use if_mpadm(1M). Therefore we notify the user of the potential error.

Solution: This message is informational; no user action is needed if the DR was done properly (using if_mpadm).

 

102967 in libsecurity for program %s (%lu); write of file %s failed: %s

Description: The specified server was not able to write to a cache file for rpcbind information. The affected component should continue to function by calling rpcbind directly.

Solution: Save the /var/adm/messages file. Contact your authorized Sun service provider to determine whether a workaround or patch is available.

 

103217 Could not obtain fencing lock because we could not contact the nameserver.

Description: The local nameserver on this was not locatable.

Solution: Communication with the nameserver is required during failover situations in order to guarantee data intgrity. The nameserver was not locatable on this node, so this node will be halted in order to gurantee data integrity. Contact your authorized Sun service provider to determine whether a workaround or patch is available.

 

103566 %s is not an absolute path.

Description: The extension property listed is not an absolute path.

Solution: Make sure the path starts with "/".

 

104035 Failed to start sap processes with command %s.

Description: Failed to start up SAP with the specified command.

Solution: SAP Central Instance failed to start on this cluster node. It would be started on some other cluster node provided there is another cluster node available. If the Central Instance failed to start on any other node, disable the SAP Central Instance resource, then try to run the same command manually, and fix any problem found. Save the /var/adm/messages from all nodes. Contact your authorized Sun service provider.

 

104914 CCR: Failed to set epoch on node %s errno = %d.

Description: The CCR was unable to set the epoch number on the indicated node. The epoch was set by CCR to record the number of times a cluster has come up. This information is part of the CCR metadata.

Solution: There may be other related messages on the indicated node, which may help diagnose the problem, for example: If the root file system is full on the node, then free up some space by removing unnecessary files. If the root disk on the afflicted node has failed, then it needs to be replaced.

 

105040 'dbmcli' failed in command %s.

Description: SAP utililty 'dbmcli -d <LC_NAME> -n <logical hostname> db_state' failed to complete as user <lc-name>adm.

Solution: Check the SAP liveCache installation and SAP liveCache log files for reasons that might cause this. Make sure the cluster nodes are booted up in 64-bit since liveCache only runs on 64-bit. If this error caused the SAP liveCache resource to be in any error state, use SAP liveCache utility to stop and dbclean the SAP liveCache database first, before trying to start it up again.

 

105222 Waiting for %s to startup

Description: Waiting for the application to startup.

Solution: This message is informational; no user action is needed.

 

105337 WARNING: thr_getspecific %d

Description: The rgmd has encountered a failed call to thr_getspecific(3T). The error message indicates the reason for the failure. This error is non-fatal.

Solution: If the error message is not self-explanatory, contact your authorized Sun service provider for assistance in diagnosing the problem.

 
 
 
  Previous   Contents   Next