978812 Validation failed. CUSTOM_ACTION_FILE: %s does not exist
Description: The file specified in property 'Custom_action_file' does not exist.
Solution: Please make sure that 'Custom_action_file' property is set to an existing action file. Reissue command to create/update.
978829 t_bind, did not bind to desired addr
Description: Call to t_bind() failed. The "t_bind" man page describes possible error codes. udlm will exit and the node will abort.
Solution: This is an internal error. Save the contents of /var/adm/messages, /var/cluster/ucmm/ucmm_reconf.log and /var/cluster/ucmm/dlm*/*logs/* from all the nodes and contact your Sun service representative.
979343 Error: duplicate prog <%s> launched step <%s>
Description: Due to an internal error, uccmd has attempted to launch the same step by duplicate programs. ucmmd will reject the second program and treat it as a step failure.
Solution: Save a copy of the /var/adm/messages files on all nodes. Contact your authorized Sun service provider for assistance in diagnosing the problem.
979803 CMM: Node being shut down.
Description: This node is being shut down.
Solution: This is an informational message, no user action is needed.
980307 reservation fatal error(%s) - Illegal command
Description: The device fencing program has suffered an internal error.
Solution: Contact your authorized Sun service provider to determine whether a workaround or patch is available. Copies of /var/adm/messages from all nodes should be provided for diagnosis. It may be possible to retry the failed operation, depending on the nature of the error. If the message specifies the 'node_join' transition, then this node may be unable to access shared devices. If the failure occurred during the 'release_shared_scsi2' transition, then a node which was joining the cluster may be unable to access shared devices. In either case, it may be possible to reacquire access to shared devices by executing '/usr/cluster/lib/sc/run_reserve -c node_join' on all cluster nodes. If the failure occurred during the 'make_primary' transition, then a device group has failed to start on this node. If another node was available to host the device group, then it should have been started on that node. If desired, it may be possible to switch the device group to this node with the scswitch command. If no other node was available, then the device group will not have been started. The scswitch command may be used to retry the attempt to start the device group. If the failure occurred during the 'primary_to_secondary' transition, then the shutdown or switchover of a device group has failed. The desired action may be retried.
980425 Aborting startup: could not determine whether failover of NFS resource groups is in progress.
Description: Startup of an NFS resource was aborted because it was not possible to determine if failover of any NFS resource groups is in progress.
Solution: Save a copy of the /var/adm/messages files on all nodes. Contact your authorized Sun service provider for assistance in diagnosing the problem.
980477 LogicalHostname online.
Description: The status of the logicalhost resource is online.
Solution: This is informational message. No user action required.
980681 clconf: CSR removal failed
Description: While executing task in clconf and modifying the state of proxy, received failure from trying to remove CSR.
Solution: This is informational message. No user action required.
980942 CMM: Cluster doesn't have operational quorum yet; waiting for quorum.
Description: Not enough nodes are operational to obtain a majority quorum; the cluster is waiting for more nodes before starting.
Solution: If nodes are booting, wait for them to finish booting and join the cluster. Boot nodes that are down.
981739 CCR: Updating invalid table %s.
Description: This joining node carries a valid copy of the indicated table with override flag set while the current cluster memebership doesn't have a valid copy of this table. This node will update its copy of the indicated table to other nodes in the cluster.
Solution: This is an informational message, no user action is needed.
981931 INTERNAL ERROR: postpone_start_r: meth type <%d>
Description: A non-fatal internal error has occurred in the rgmd state machine.
Solution: Since this problem might indicate an internal logic error in the rgmd, please save a copy of the /var/adm/messages files on all nodes, the output of an scstat -g command, and the output of a scrgadm -pvv command. Report the problem to your authorized Sun service provider.
984704 reset_rg_state: unable to change state of resource group <%s> on node <%d>; assuming that node died
Description: The rgmd was unable to reset the state of the specified resource group to offline on the specified node, presumably because the node died.
Solution: Examine syslog output on the specified node to determine the cause of node death. The syslog output might indicate further remedial actions.
985111 lkcm_reg: illegal %s value
Description: Cluster information that is being used during udlm registration with ucmm is incorrect.
Solution: This is an internal error. Save the contents of /var/adm/messages, /var/cluster/ucmm/ucmm_reconf.log and /var/cluster/ucmm/dlm*/*logs/* from all the nodes and contact your Sun service representative.
985417 %s: Invalid arguments, restarting service.
Description: The PMF action script supplied by the DSDL while launching the process tree was called with invalid arguments.
Solution: This is an internal error. Contact your authorized Sun service provider for assistance in diagnosing and correcting the problem.
986190 Entry at position %d in property %s with value %s is not a valid node identifier or node name.
Description: The value given for the named property has an invalid node specified for it. The position index, which starts at 0 for the first element in the list, indicates which element in the property list was invalid.
Solution: Specify a valid node for the property.
986197 reservation fatal error(%s) - malloc() error, errno %d
Description: The device fencing program has been unable to allocate required memory.
Solution: Memory usage should be monitored on this node and steps taken to provide more available memory if problems persist. Once memory has been made available, the following steps may need to taken: If the message specifies the 'node_join' transition, then this node may be unable to access shared devices. If the failure occurred during the 'release_shared_scsi2' transition, then a node which was joining the cluster may be unable to access shared devices. In either case, access to shared devices can be reacquired by executing '/usr/cluster/lib/sc/run_reserve -c node_join' on all cluster nodes. If the failure occurred during the 'make_primary' transition, then a device group has failed to start on this node. If another node was available to host the device group, then it should have been started on that node. The device group can be switched back to this node if desired by using the scswitch command. If no other node was available, then the device group will not have been started. The scswitch command may be used to start the device group. If the failure occurred during the 'primary_to_secondary' transition, then the shutdown or switchover of a device group has failed. The desired action may be retried.
986466 clexecd: stat of '%s' failed
Description: clexecd problem failed to stat the directory indicated in the error message.
Solution: Make sure the directory exists. If the problem persists, contact your authorized Sun service provider to determine whether a workaround or patch is available.
987455 in libsecurity weak Unix authorization failed
Description: A server (rgmd) refused an rpc connection from a client because it failed the Unix authentication. This happens if a caller program using scha public api, either in its C form or its CLI form, is not running as root. An error message is output to syslog.
Solution: Check that the calling program using the scha public api is running as root. If the program is running as root, save the /var/adm/messages file. Contact your authorized Sun service provider to determine whether a workaround or patch is available.
987601 scvxvmlg error - opendir(%s) failed
Description: The program responsible for maintaining the VxVM namespace was unable to access the global device namespace. If configuration changes were recently made to VxVM diskgroups or volumes, this node may be unaware of those changes. Recently created volumes may be inaccessible from this node.
Solution: Verify that the /global/.devices/node@N (N = this node's node number) is mounted globally and is accessible. If no configuration changes have been recently made to VxVM diskgroups or volumes and all volumes continue to be accessible from this node, then no further action is required. If changes have been made, the device namespace on this node can be updated to reflect those changes by executing '/usr/cluster/lib/dcs/scvxvmlg'. If the problem persists, contact your authorized Sun service provider to determine whether a workaround or patch is available.
988355 scha_control: rejecting RESOURCE_IS_RESTARTED call on resource <%s> because it does not have a Retry_interval property
Description: A resource monitor (or some other program) is attempting to notify the RGM that the indicated resource has been restarted, by calling scha_control(1ha),(3ha) with the RESOURCE_IS_RESTARTED option. This request is rejected because the resource type does not declare the Retry_interval property for its resources. This represents a bug in the calling program. To enable the RESOURCE_IS_RESTARTED functionality, the resource type registration (RTR) file must declare the Retry_interval property.
Solution: Contact the author of the data service (or of whatever program is attempting to call scha_control) and report the error.
988416 t_sndudata (2) in send_reply: %s
Description: Call to t_sndudata() failed. The "t_sndudata" man page describes possible error codes.
Solution: None.



