资源类型特性表
资源特性表
资源组特性表
资源特性属性表
必需的 -- 特性要求在“资源类型登记”(RTR) 文件中有显式值。 否则,将不能创建特性所属的对象。 不允许使用空字符串。
有条件的 -- 特性必须在 RTR 文件中进行声明才能存在。 否则,“资源组管理器”不会创建特性, 该特性也不适用于管理公用程序。 允许使用空字符串。 如果在 RTR 文件中声明特性但未指定值,“资源组管理器”将提供缺省值。
有条件的/显式 -- 特性必须在 RTR 文件中以显式值进行声明才能存在。 否则,“资源组管理器”不会创建特性, 该特性也不适用于管理公用程序。 不允许使用空字符串。
可选的 -- 可以在 RTR 文件中声明特性。 如果未声明特性,“资源组管理器”将创建特性并提供缺省值。 如果在 RTR 文件中声明特性但未指定值,“资源组管理器”将提供缺省值。 此缺省值与未在 RTR 文件中声明特性时所用的值相同。
您不能使用管理公用程序更新资源类型特性,
Installed_nodes 除外,它不能在 RTR 文件中声明。 管理员必须设置 Installed_nodes。
| 特性名称 | 描述 |
|---|---|
|
Allow_hosts
(字符串数组) |
控制一组客户机的设置,允许这些客户机使用 cl_apid 守护程序登记以接收群集重配置事件。 此特性的一般格式是 ipaddress/masklength,它定义允许客户机从其登记的子网。 例如,设置 129.99.77.0/24 允许子网 129.99.77 上的客户机登记事件。再举一个例子,192.9.84.231/32 仅允许客户机 192.9.84.231 登记事件。此特性为 CRNP 提供安全保护。SUNW.Event(5) 手册页描述了cl_apid 守护程序。另外,将识别下列特殊关键字。 LOCAL 指位于群集直接连接的子网中的所有客户机。 ALL 允许所有客户机登记。 请注意,如果客户机与某个项匹配,而该项在 Allow_hosts 和 Deny_hosts 特性中都存在,将阻止此客户机执行登记。
种类:可选的 缺省值: LOCAL可调:从不 |
|
API_version (整数) |
此资源类型执行所使用的资源管理 API 版本。
种类:可选的 缺省值: 2可调:从不 |
|
Boot
(字符串) |
一种可选的回叫方法: “资源组管理器”在节点上调用的程序的路径。 当此类型的一个资源已被管理时,此节点将加入或重新加入群集。 此方法的预期用途是初始化此类型的资源,这与 Init 方法类似。
种类:有条件的/显式 缺省值:无缺省值 可调:从不 |
|
Client_retry_count
(整数) |
控制 cl_apid 守护程序尝试与外部客户机进行通信的次数。 如果客户机在 Client_retry_count 指定的尝试次数内无法响应,客户机将超时。 然后,将从有资格接收群集重配置事件的已登记客户机的列表中删除此客户机。 此客户机必须重新登记才可以再次开始接收事件。 要了解有关多长时间执行这些重试操作的详细信息,请参见 Client_retry_interval 特性的描述。 SUNW.Event(5) 对cl_apid 守护程序进行了描述。
种类:可选的 缺省值: 3可调:随时 |
|
Client_retry_interval
(整数) |
定义 cl_apid 守护程序与不响应的外部客户机进行通信的时间段(以秒为单位)。在此间隔期间最多进行 Client_retry_count 次与客户机进行联系的尝试。 SUNW.Event(5) 对cl_apid 守护程序进行了描述。
种类:可选的 缺省值: 1800可调:随时 |
|
Client_timeout
(整数) |
cl_apid
守护程序与外部客户机进行通信的超时值(以秒为单位)。但是,cl_apid 守护程序继续尝试与客户机进行联系,次数可调。要了解有关可以用来调整此特性的方法的详细信息,请参见 Client_retry_count 特性和 Client_retry_interval 特性的描述。SUNW.Event(5) 对cl_apid
守护程序进行了描述。
种类:可选的 缺省值: 60可调:随时 |
|
Deny_hosts
(字符串数组) |
控制一组客户机的设置,阻止这些客户机登记以接收群集重配置事件。 要确定访问,此特性的设置的优先级要高于 Allow_hosts 列表中的设置。 此特性的格式与在 Allow_hosts 特性中定义的格式相同。 此特性为 CRNP 提供安全保护。
种类:可选的 缺省值: NULL可调:随时 |
|
Failover (布尔值) |
True 表示此类型的资源不能在一次可在多个节点上联机的组中进行配置。
种类:可选的 缺省值: False可调:从不 |
|
Fini
(字符串) |
一种可选的回叫方法: 当从“资源组管理器”的控制中删除此类型的资源时,“资源组管理器”调用的程序的路径。
种类:有条件的/显式 缺省值:无缺省值 可调:从不 |
|
Init (字符串) |
一种可选的回叫方法: 当此类型的资源由“资源组管理器”控制时,“资源组管理器”调用的程序的路径。
种类:有条件的/显式 缺省值:无缺省值 可调:从不 |
|
Init_nodes (枚举) |
表示“资源组管理器”将在其上调用 Init、Fini、Boot 和 Validate 方法的节点。 The values can be RG_primaries (just the nodes that can master the resource) or RT_installed_nodes (all nodes on which the resource type is installed).
种类:可选的 缺省值: RG_primaries可调:从不 |
|
Installed_nodes (字符串数组) |
允许资源类型在其上运行的群集节点名称的列表。 “资源组管理器”自动创建此特性。 群集管理员可以设置此值。 您不能在 RTR 文件中声明此特性。
种类:群集管理员可以配置。 缺省值:所有群集节点 可调:随时 |
|
Max_clients (整数) |
控制可以使用 cl_apid 守护程序登记以接收群集事件通知的客户机的最大数目。 其它客户机登记事件的尝试被您的应用程序拒绝。 由于每个客户机登记都使用群集上的资源,因此调整此特性使用户可以控制外部客户机对群集上的资源使用。 SUNW.Event(5) 对cl_apid 守护程序进行了描述。
种类:可选的 缺省值: 1000可调:随时 |
|
Monitor_check (字符串) |
一种可选的回叫方法: 在对此类型的资源进行监视器所请求的故障转移之前,“资源组管理器”调用的程序的路径。
种类:有条件的/显式 缺省值:无缺省值 可调:从不 |
|
Monitor_start (字符串) |
一种可选的回叫方法: “资源组管理器”为启动此类型的资源的故障监视器而调用的程序的路径。
种类:有条件的/显式 缺省值:无缺省值 可调:从不 |
|
Monitor_stop (字符串) |
一种必需的回叫方法(如果设置了 Monitor_start),或者“资源组管理器”为停止此类型的资源的故障监视器而调用的程序的路径。
种类:有条件的/显式 缺省值:无缺省值 可调:从不 |
|
每个群集节点上的 Num_resource_restarts (整数) |
RGM 将此特性设置为在过去的 [n] 秒内,在此节点上为此资源进行的 scha_control RESTART 呼叫的数目,其中 [n] 是资源的 Retry_interval 特性的值。 如果资源类型未声明 Retry_interval 特性,则此类型的资源不能使用 Num_resource_restarts 特性。
种类:仅限于查询 缺省值:无缺省值 可调:从不 |
|
Pkglist (字符串数组) |
包含在资源类型安装中的软件包的可选列表。
种类:有条件的/显式 缺省值:无缺省值 可调:从不 |
|
Postnet_stop (字符串) |
一种可选的回叫方法: 在调用此类型的资源所依赖的任何网络地址资源 (Network_resources_used) 的 Stop 方法之后,“资源组管理器”调用的程序的路径。 此方法的预期用途是执行 Stop 操作,而此操作必须在网络接口被配置为停止后完成。
种类:有条件的/显式 缺省值:无缺省值 可调:从不 |
|
Prenet_start (字符串) |
一种可选的回叫方法,或在调用此类型的资源所依赖的任何网络地址资源 ( Network_resources_used) 的 Start 方法之前,“资源组管理器”调用的程序的路径。 此方法的预期用途是执行 Start 操作,而此操作必须在网络接口被配置为启动之前完成。
种类:有条件的/显式 缺省值:无缺省值 可调:从不 |
|
Resource_type (字符串) |
资源类型的名称。 要查看目前已登记的资源类型的名称,请使用此命令: scrgadm -p 从 Sun Cluster 3.1 开始,资源类型名称的语法为: [vendor_id].[resource_type]:[version] 资源类型名称的三个组成部分是在 RTR 文件中指定为 Vendor_id、 Resource_type 以及 RT_version 的特性。 scrgadm 命令插入句点 (.) 和冒号 (:) 分界符。 资源类型名称的 RT_version 后缀是与 RT_version 特性同一值。为确保 Vendor_id 唯一,应使用创建资源类型的公司的证券市场代号。注意: 您在 Sun Cluster 3.1 发布之前创建的资源类型名称继续使用以下语法: [vendor_id].[resource_type]
种类:必需的 缺省值:空字符串 可调:从不 |
|
RT_basedir
(字符串) |
用于完成回叫方法的相对路径的目录路径。 将此路径设置为资源类型软件包所在的目录。 此路径必须为完整路径,以正斜杠 ( /) 开始。
种类:必需的,除非所有方法路径名称均为绝对 缺省值:无缺省值 可调:从不 |
|
RT_description (字符串) |
资源类型的简单描述。
种类:有条件的 缺省值:空字符串 可调:从不 |
|
RT_system (布尔值) |
表示在资源类型上将此值设置为 True 时,此资源类型上所允许的 scrgadm(1M) 操作将被限制。 RT_System 值被设置为 True 的资源类型被称为系统资源类型。 编辑 RT_System 特性本身永远不被限制,无论 RT_System 的当前值是什么。
种类:可选的 缺省值: False可调:随时 |
|
RT_version (字符串) |
从 Sun Cluster 3.1 开始,这是此资源类型执行必需的版本字符串。 RT_version 是完整资源类型名称的后缀部分。
种类:有条件的/显式 缺省值:无缺省值 可调:从不 |
|
Single_instance
(布尔值) |
如果值为 True,表示群集中只能存在一个此类型的资源。因此,“资源组管理器”一次只允许一个此类型的资源在群集范围运行。
种类:可选的 缺省值: False可调:从不 |
|
Start (字符串) |
一种回叫方法: “资源组管理器”为启动此类型的资源而调用的程序的路径。
种类:必需的(除非 RTR 文件声明了 Prenet_start 方法)缺省值:无缺省值 可调:从不 |
|
Stop (字符串) |
一种回叫方法: “资源组管理器”为停止此类型的资源而调用的程序的路径。
种类:必需的(除非 RTR 文件声明了 Postnet_stop 方法)缺省值:无缺省值 可调:从不 |
|
Update
(字符串) |
一种可选的回叫方法: 在更改正在运行的此类型资源的特性时,“资源组管理器”调用的程序的路径。
种类:有条件的/显式 缺省值:无缺省值 可调:从不 |
|
Validate (字符串) |
一种可选的回叫方法: 为检查此类型的资源的特性值而调用的程序的路径。
种类:有条件的/显式 缺省值:无缺省值 可调:从不 |
|
Vendor_ID (字符串) |
参见 Resource_type 特性。
种类:有条件的 缺省值:无缺省值 可调:从不 |
有关某项特定数据服务的详细信息,请参见该数据服务的手册页。 资源特性值分为以下几类:
必需的 -- 管理员必须在使用管理公用程序创建资源时指定一个值。
可选的 -- 如果管理员在创建资源组时未指定值,系统将提供一个缺省值。
有条件的 --“资源组管理器”仅当在 RTR 文件中声明了特性时才创建此特性。 否则,此特性将不存在,而且 此特性对系统管理员也不可用。 在 RTR 文件中声明的有条件的特性可以是可选的或必需的。 有条件的特性是可选的还是必需的取决于在 RTR 文件中是否指定了缺省值。 每个有条件的特性的描述都包含了详细描述。
仅限于查询 -- 不能直接由管理工具进行设置。 “仅限于查询”的值包括
None 或 False
从不
True 或 Anytime
随时
At_creation
在将资源增加到群集时
When_disabled
在资源被禁止时
| 特性名称 | 描述 |
|---|---|
|
Affinity_timeout
(整数) |
控制在客户机关闭其与粘性可缩放服务的所有连接后,IP 亲缘性所持续的秒数。在此超时期间期满之前,客户机的任何新连接都被转送到同一个群集节点。 0 值表示只要客户机和可缩放服务之间有连接,亲缘性就将持续。-1 值表示亲缘性将一直持续到客户机所连接的群集节点崩溃或重新启动。 因此,没有超时期限。此特性只适用于 Load_balancing_policy=Lb_sticky 或 Lb_sticky_wild 的资源。
种类:可选的 缺省值: 0可调:随时 |
|
Cheap_probe_interval (整数) |
在两次资源故障快速探查的调用之间的秒数。 只能由“资源组管理器”创建此特性。 如果在 RTR 文件中声明了此特性,则此特性对管理员可用。 如果在 RTR 文件中指定了缺省值,则此特性是可选的。 如果在资源类型文件中未指定 Tunable 属性,则此特性的 Tunable 值为 When_disabled。
如果在 RTR 文件中的特性声明中未指定 Default 属性,则此特性为必需的。
种类:有条件的 缺省值:请参见前面的描述 可调:禁止时 |
|
扩展特性 |
在资源类型的 RTR 文件中声明的扩展特性。资源类型执行定义这些特性。有关可以为扩展特性设置的单个属性的信息,请参见资源特性属性。
种类:有条件的 缺省值:无缺省值 可调:取决于特定的特性 |
|
Failover_mode (枚举) |
可能的设置包括 None、Soft 和 Hard。 控制 RGM 是否重定位资源组或者异常终止节点,以响应资源上 Start、Stop 或 Monitor_stop 方法调用的失败。None 表示 RGM 将只在方法失败时设置资源状态并等待操作员介入。 Soft 表示 Start 方法的失败将导致 RGM 将资源组重定位到不同的节点,而 Stop 或 Monitor_stop 方法的失败将导致 RGM 将资源设置为 STOP_FAILED 状态,并将资源组设置为 ERROR_STOP_FAILED 状态,并且等待操作员介入。 对于 Stop 或 Monitor_stop 失败,None 和 Soft 设置等效。 Hard 表示 Start 方法的失败将导致组的重定位,Stop 或 Monitor_stop 方法的失败将导致通过终止群集节点来强制停止资源。
种类:可选的 缺省值: 无可调:随时 |
|
Load_balancing_policy
(字符串) |
定义所使用的负载平衡策略的字符串。此特性只用于可缩放服务。如果在 RTR 文件中声明了 Scalable 特性,“资源组管理器”将自动创建此特性。
Load_balancing_policy 可以取以下值: Lb_weighted(缺省值)。根据在 Load_balancing_weights 特性中设置的权重,负载在不同的节点间分配。 Lb_sticky。 可缩放服务的指定客户机(由客户机的 IP 地址标识)总是发送到群集的同一节点。 Lb_sticky_wild。 连接到通配符粘性服务的 IP 地址的指定客户机(由客户机的 IP 地址标识)总是被发送到同一群集节点,而不管将其定向到哪个端口号。
种类:有条件的/可选的 缺省值: Lb_weighted可调:创建时 |
|
Load_balancing_weights
(字符串数组) |
只用于可缩放资源。 如果在 RTR 文件中声明了 Scalable 特性,“资源组管理器”将自动创建此特性。 格式为 [权重]@[节点], [权重]@[节点],其中 [权重] 代表一个整数,它反映了分配到指定 [节点] 的负载的相对份量。 分配到某个节点的负载部份是此节点的权重除以所有权重的和。 例如,1@1,3@2 表示节点 1 收到 1/4 的负载,而节点 2 收到 3/4 的负载。 空字符串 ("") 为缺省值,它设置均匀的分配。 未指定显式权重的节点将收到缺省权重 1。
如果在资源类型文件中未指定 Tunable 属性,则此特性的 Tunable 值为 Anytime(随时)。 更改此特性将只修改新连接的分配。
种类:有条件的/可选的 缺省值:空字符串 可调:随时 |
|
类型中每种回叫方法的 [method] _timeout(整数) |
以秒为单位的时延,在此时间之后“资源组管理器”将断定方法的调用已经失败。
种类:有条件的/可选的 缺省值:3,600 秒,即一小时(如果在 RTR 文件中声明了方法) 可调:随时 |
|
Monitored_switch (枚举) |
如果群集管理员利用管理公用程序启用或禁止监视器,则由“资源组管理器”设置为 Enabled(启用)或 Disabled(禁止)。 如果设置为 Disabled,则在再次启用监视器之前,监视器的 Start 方法不会被调用。如果资源没有监视器回叫方法,则此特性不存在。
种类:仅限于查询 缺省值: Enabled可调:从不 |
|
Network_resources_used
(字符串数组) |
资源所使用的逻辑主机名列表或共享地址网络资源。对于可缩放服务,此特性必须是指存在于单独资源组的共享地址资源。 对于故障转移服务,此特性是指存在于同一资源组的逻辑主机名或共享地址资源。 如果在 RTR 文件中声明了 Scalable 特性,RGM 将自动创建此特性。如果在 RTR 文件中未声明 Scalable,Network_resources_used 将不可用,除非在 RTR 文件中明确声明。如果在资源类型文件中未指定 Tunable 属性,则此特性的 Tunable 值为 At_creation。
种类:有条件的/必需的 缺省值:无缺省值 可调:创建时 |
|
On_off_switch
(枚举) |
如果群集管理员利用管理公用程序启用或禁止资源,则由“资源组管理器”设置为 Enabled 或 Disabled。如果被禁止,则在再次启用资源之前,资源的回叫不会被调用。
种类:仅限于查询 缺省值: 禁止可调:从不 |
|
Port_list
(字符串数组) |
服务器正在侦听的端口号的列表(以逗号分隔)。每个端口号后接此端口使用的协议,例如, Port_list=80/tcp。 如果在 RTR 文件中声明了 Scalable 特性,“资源组管理器”将自动创建 Port_list。 否则,此特性将不可用,除非在 RTR 文件中明确声明。有关为 Apache 设置此特性的细节,请参见 Sun Cluster 3.1 Data Services Installation and Configuration Guide 中的 Apache 一章。
种类:有条件的/必需的 缺省值:无缺省值 可调:创建时 |
|
R_description (字符串) |
资源的简单描述。
种类:可选的 缺省值:空字符串 可调:随时 |
|
Resource_dependencies (字符串数组) |
此资源与其存在强相关性的同一或不同组中资源的列表。如果列表中的任何资源启动失败,则不能启动此资源。如果此资源与资源列表中的一个资源同时启动,RGM 将等待列表中的资源启动之后,再启动此资源。如果此资源的 Resource_dependencies 列表中的资源不启动(例如,如果列表中资源所在的资源组保持脱机状态,或者列表中的资源处于 Start_failed 状态),则此资源也保持脱机状态。如果因为依赖于无法启动的不同资源组中的资源,导致此资源保持脱机状态,此资源组将进入 Pending_online_blocked 状态。如果此资源与列表中的资源同时脱机,则此资源先停止,然后列表中的资源才停止。但是,如果此资源保持联机状态或者无法停止,列表中不同资源组中的资源仍可以停止。列表中的资源不会被禁止,除非禁止此资源。 缺省情况下,在资源组中,应用程序资源与网络地址资源存在隐含的强相关性。 资源组特性中的 Implicit_network_dependencies 包含详细信息。在资源组内部,先以相关性顺序运行 Prenet_start 方法,再运行 Start 方法。 运行 Stop 方法之后,再以相关性顺序运行 Postnet_stop 方法。在不同的资源组中,等待被依赖资源运行完 Prenet_start 和 Start 之后,依赖资源才运行 Prenet_start。等待依赖资源运行完 Stop 和 Postnet_stop 之后,被依赖资源才运行 Stop。
种类:可选的 缺省值:空列表 可调:随时 |
|
Resource_dependencies_restart (字符串数组) |
此资源与其存在重启相关性的同一或不同组中资源的列表。如果资源列表中的任何资源启动失败,则不能启动此资源。如果此资源与资源列表中的一个资源同时启动,RGM 将等待列表中的资源启动之后,再启动此资源。 如果此资源的 Resource_dependencies_restart 列表中的资源不启动(例如,如果列表中资源所在的资源组保持脱机状态,或者列表中的资源处于 Start_failed 状态),则此资源也保持脱机状态。 如果因为与无法启动的不同资源组中的资源存在相关性,从导致此资源保持脱机状态,此资源组将进入 Pending_online_blocked 状态。如果此资源与列表中的资源同时处于脱机状态,则此资源先停止,然后列表中的那些资源才停止。但是,如果此资源保持联机状态或者无法停止,列表中不同资源组中的资源仍可以停止。列表中的资源不会被禁止,除非禁止此资源。 此特性的工作方式与 Resource_dependencies 相同,唯一的不同之处在于,如果重启相关性列表中的任何资源重新启动,则此资源也重新启动。此资源的重启操作在列表中的资源返回联机状态之后进行。在资源组内部,先以相关性顺序运行 Prenet_start 方法,再运行 Start 方法。 运行 Stop 方法之后,再以相关性顺序运行 Postnet_stop 方法。 在不同的资源组中,等待被依赖的资源运行完 Prenet_start 和 Start 之后,依赖资源才运行 Prenet_start。 等待依赖资源运行完 Stop 和 Postnet_stop 之后,被依赖资源才运行 Stop。
种类:可选的 缺省值:空列表 可调:随时 |
|
Resource_dependencies_weak
(字符串数组) |
此资源与其存在弱相关性的同一或不同组中资源的列表。弱相关性确定在组内部调用方法的顺序。RGM 先调用此列表中资源的 Start 方法,再调用此资源的 Start 方法。RGM 调用此资源的 Start 方法之后,再调用此列表中的资源的 Start 方法。如果列表中的资源无法启动或保持脱机状态时,此资源却仍可以启动。如果此资源及其 Resource_dependencies_weak 列表中的某个资源同时启动,RGM 将等待列表中的资源启动后,再启动此资源。如果列表中的资源不启动(例如,如果列表中资源所在的资源组保持脱机状态,或者列表中的资源处于 Start_failed 状态),此资源仍可以启动。 当此资源的 Resource_dependencies_weak 列表中的资源启动时,此资源所在的资源组可能临时进入 Pending_online_blocked 状态。 当列表中的所有资源都已启动或无法启动时,此资源将启动,所在的资源组 将重新进入 Pending_online 状态。如果此资源与列表中的资源都处于脱机状态,则此资源先停止,然后列表中的资源才停止。但是,如果此资源保持联机状态或者无法停止,列表中不同资源组中的资源仍可以停止。列表中的资源不会被禁止,除非先禁止此资源。 在资源组内部,先以相关性顺序运行 Prenet_start 方法,再运行 Start 方法。 运行 Stop 方法之后,再以相关性顺序运行 Postnet_stop 方法。在不同的资源组中,等待被依赖的资源运行完 Prenet_start 和 Start 之后,依赖资源才运行 Prenet_start。等待依赖资源运行完 Stop 和 Postnet_stop 之后,被依赖资源才运行 Stop。
种类:可选的 缺省值:空列表 可调:随时 |
|
Resource_name (字符串) |
资源实例的名称。 此名称在群集配置内部必须唯一,并且在创建资源后不能被更改。
种类:必需的 缺省值:无缺省值 可调:从不 |
|
Resource_project_name (字符串) |
与资源关联的 Solaris 项目名称。 使用此特性可将 Solaris 资源管理功能(例如 CPU 共享和资源池)应用至群集数据服务。 在“资源组管理器”将资源联机时,“资源组管理器”启动此项目名称下的相关进程。 如果未指定此特性,则从包含此资源( rg_properties(5) 包含详细信息)的资源组的 RG_project_name 特性中取得项目名称。 如果未指定任何特性,“资源组管理器”使用预定义的项目名称缺省值。 指定的项目名称必须存在于项目数据库中,并且用户的根必须配置为命名项目的成员。 从 Solaris 9 发行版开始支持此特性。注意: 对此特性的更改将在资源重新启动后生效。
种类:可选的 缺省值:空 可调:随时 |
|
每个群集节点上的 Resource_state (枚举) |
由每个群集节点上的资源的“资源组管理器”确定的状态。 可能的状态包括 Online、Offline、Stop_failed、Start_failed、Monitor_failed 以及 Online_not_monitored。您不能配置此特性。 种类:仅限于查询 缺省值:无缺省值 可调:从不 |
|
Retry_count
(整数) |
如果资源失败,监视器尝试重新启动资源的次数。 只能由“资源组管理器”创建此特性。 如果在 RTR 文件中作了声明,则此特性对管理员可用。 如果在 RTR 文件中指定了缺省值,则此特性是可选的。 如果在资源类型文件中未指定 Tunable 属性,则此特性的 Tunable 值为 When_disabled。
如果在 RTR 文件中的特性声明中未指定 Default 属性,则此特性为必需的。
种类:有条件的 缺省值:参见描述 可调:禁止时 |
|
Retry_interval (整数) |
尝试重新启动失败的资源前计算的秒数。资源监视器将此特性与 Retry_count 一起使用。 只能由“资源组管理器”创建此特性。 如果在 RTR 文件中作了声明,则此特性对管理员可用。 如果在 RTR 文件中指定了缺省值,则此特性是可选的。如果在资源类型文件中未指定 Tunable 属性,则此特性的 Tunable 值为 When_disabled。如果在 RTR 文件中的特性声明中未指定 Default 属性,则此特性为必需的。
种类:有条件的 缺省值:请参见前面的描述 可调:禁止时 |
|
Scalable (布尔值) |
表示资源是否可缩放。如果在 RTR 文件中声明了此特性,则“资源组管理器”将为此类型的资源自动创建以下可缩放服务特性: Network_resources_used、Port_list、Load_balancing_policy 以及 Load_balancing_weights。 这些特性有缺省值,除非在 RTR 文件中对它们进行了明确声明。Scalable 的缺省值(在 RTR 文件中声明时)为 True。在 RTR 文件中声明了此特性时, Tunable 属性必须设置为 At_creation,否则资源创建将失败。如果此特性未在 RTR 文件中声明:
种类:可选的 缺省值:请参见前面的描述 可调:创建时 |
|
每个群集节点上的 Status (枚举) |
由资源监视器设置。 可能的值包括 OK(良好)、degraded(降低)、faulted(有故障)、unknown(未知)以及 offline(脱机)。 在将资源联机时,“资源组管理器”将值设置为 unknown,并在将资源脱机时将值设置为 Offline。
种类:仅限于查询 缺省值:无缺省值 可调:从不 |
|
每个群集节点上的 Status_msg (字符串) |
由资源监视器在设置 Status 特性的同时进行设置。 此特性对每个资源和每个节点都可调。 在将资源脱机时,“资源组管理器”将此特性设置为空字符串。
种类:仅限于查询 缺省值:无缺省值 可调:从不 |
|
Thorough_probe_interval (整数) |
在两次资源高开销故障探查的调用之间的秒数。 只能由“资源组管理器”创建此特性。 如果在 RTR 文件中作了声明,则此特性对管理员可用。 如果在 RTR 文件中指定了缺省值,则此特性是可选的。 如果在资源类型文件中未指定 Tunable 属性,则此特性的 Tunable 值为 When_disabled。如果在 RTR 文件中的特性声明中未指定 Default 属性,则此特性为必需的。
种类:有条件的 缺省值:无缺省值 可调:禁止时 |
|
Type (字符串) |
实例的资源类型。
种类:必需的 缺省值:无缺省值 可调:从不 |
|
Type_version (字符串) |
指定目前与此资源关联的资源类型的版本。 RGM 自动创建此特性,它不能在 RTR 文件中声明。此特性的值与资源类型的 RT_version 特性一样。创建资源时,未明确指定 Type_version 特性,尽管此特性可能显示为资源类型名称的后缀。编辑资源时,可能将 Type_version 更改为一个新值。它的可调能力源自:
种类:参见描述 缺省值:无缺省值 可调:参见描述 |
|
UDP_affinity
(布尔值) |
如果值为 True,则会按照与转送 TCP 连接同一方式将指定客户机的 UDP 包转送到同一群集服务器节点。如果客户机的 TCP 连接与某服务器节点“粘附”,则其 UDP 包也将发送到此节点。如果值为 False,则不会维持上述处理方式,且指定客户机的 UDP 包可能在与此客户机的 TCP 连接不同的节点上结束。此特性只适用于 Load_balancing_policy=Lb_sticky 或 Lb_sticky_wild 的资源。
种类:可选的 缺省值: False可调:禁止时 |
|
Weak_affinity
(布尔值) |
如果值为 True,则会启用客户机亲缘性的弱形式。这允许将与给定客户机的连接发送到同一服务器节点,以下情况除外:
使用弱亲缘性替换缺省形式,可以减少在内存消耗和处理器循环两方面的开销。 仅在 Load_balancing_policy 是 Lb_sticky 或 Lb_sticky_wild 时,才与此特性相关。此特性只用于可缩放服务。
种类:可选的 缺省值:无缺省值 可调:禁止时 |
| 您不能将 NULL 或空字符串 ("") 指定为布尔值、枚举或整数类型的缺省值。 | |
| 特性名称 | 描述 |
|---|---|
| Property |
资源特性的名称。 |
|
Extension |
如果使用,则表示 RTR 文件项声明一个由资源类型执行定义的扩展特性。 否则,此项为系统定义的特性。 |
|
Description |
一个字符串注释,用于对特性作简单描述。 对于系统定义的特性,不能在 RTR 文件中设置描述属性。 |
|
Type of the property |
允许的类型包括 字符串、布尔值、整数、枚举以及字符串数组。 对于系统定义的特性,您不能在 RTR 文件项中设置类型属性。类型决定了可接受的特性值和在 RTR 文件项中允许的特定于类型的属性。 枚举类型是一组字符串值。 |
|
Default |
表示特性的缺省值。 |
| Tunable |
表示群集管理员何时可以设置某个资源中的此特性的值。可以设置为 None 或 False 以防止管理员设置此特性。允许管理员调节的值包括 True 或 Anytime(随时)、At_creation(只在创建资源时)或 When_disabled(在资源脱机时)。缺省值为 True (Anytime)。 |
|
Enumlist |
对于 枚举类型,为此特性所允许的一组字符串值。 |
|
Min |
对于 整数类型,为此特性所允许的最小值。 |
|
Max |
对于 整数类型,为此特性所允许的最大值。 |
|
Minlength |
对于 字符串和字符串数组类型,为所允许的最小字符串长度。 |
|
Maxlength |
对于 字符串和字符串数组类型,为所允许的最大字符串长度。 |
|
Array_minsize |
对于 字符串数组类型,为所允许的数组元素的最小数量。 |
|
Array_maxsize |
对于 字符串数组类型,为所允许的数组元素的最大数量。 |