概述
开始之前
安装 Sun Cluster HA for Oracle
定制 Sun Cluster HA for Oracle
SunPlex Manager 设置了“典型”Oracle 安装。 Oracle 文档资料包含了更多的详细信息。
| Oracle 是一种复杂的产品,通过 SunPlex Manager 只能进行有限的配置。 您必须对 Oracle 有充分的了解才能对其进行安装和配置。 有关详细信息,请参见 Oracle 文档资料。 | |
您必须将 Sun Cluster HA for Oracle 配置为故障转移服务。
有关更高级的配置,可在 SunPlex Manager 安装完成后手动定制。 Oracle 文档资料包含了详细信息。
要完全定制 Sun Cluster HA for Oracle 安装,请按照 Oracle 文档或《Sun Cluster 3.1 Data Services Installation and Configuration Guide》中的描述进行操作。
Oracle 对于与
shmsys 和 semsys 相关的内核变量需要特殊的设置。这些变量在 /etc/system 文件中设置,更改将在系统重新引导后被激活。 如果自从上次修改这些设置以来未重新引导,请在开始 Sun Cluster HA for Oracle 安装之前重新引导群集节点。 有关详细信息,请参见 Oracle 安装文档。
| 注意: 如果 /etc/system 中的 shmsys 和 semsys 不包含项,这些变量的缺省值将自动插入到 /etc/system 中。 然后,必须重新引导系统。 检查 Oracle 安装文档,检验这些值是否适用于您的数据库。 |
| 安装 Sun Cluster HA for Oracle 大约需要三个小时。 | |
| 如果您退出 SunPlex Manager 或单击 Web 浏览器中的“后退”,数据服务将中断安装。
这种中断可能会由于信息不足或错误信息未解决而导致安装不完整。
要清除不完整的安装,您必须删除应用程序文件以及创建的资源和资源组。 |
|
要安装 Sun Cluster HA for Oracle, 请完成以下步骤:
% xhost [node names]
系统将启用所有群集节点。 然后,您可以在使用的工作站上显示 Oracle 安装程序窗口。
将显示群集概述窗口。
SunPlex Manager 可以确保:
如果 SunPlex Manager 发现这些条件已满足,则进行下一步。
如果 SunPlex Manager 未找到
SUNW.oracle.server 或 SUNW.oracle.listener,SunPlex Manager 将指导您完成安装和注册。 您需要提供包含 Sun Cluster 3.1 数据服务的 CD 位置。然后,SunPlex Manager 将显示一个页面,提示您提供安装信息。
| 字段 | 说明 | 要使用的 X 显示 | 用于显示 Oracle 安装程序窗口的显示名称。 群集节点必须对此显示具有 xhost 访问权限。 此显示必须是要用于查看 Web 浏览器的显示。 |
|---|---|
| 放置 Oracle CD-ROM 映像的目录 | 包含 runInstaller 命令的目录。 |
| ORACLE_BASE 目录 | 位于 Oracle 软件和管理文件结构顶端的目录。 |
| ORACLE_HOME 目录 | 包含特定发行版的 Oracle 软件的起始目录。 |
| 数据库名称 | 完整的数据库名称,它可以使该数据库与网络域中的其它数据库唯一区分。 |
| 数据库目录 | 数据库文件装载点的路径。 此路径必须是非 ORACLE_BASE 磁盘上的全局文件系统。 |
您在配置页中指定的参数将用于安装 Sun Cluster HA for Oracle。
SunPlex Manager 将检验配置页上的信息。 如果 SunPlex Manager 未发现错误,它将装入 Oracle Universal Installer。 然后,Oracle Universal Installer 开始安装 Oracle 软件。 如果 SunPlex Manager 发现错误,它将显示一条错误消息。
| Oracle Universal Installer 正在安装 Oracle 时,请勿单击“SunPlex Manager”窗口中的“继续”。 您必须等到安装程序结束并单击“Oracle Universal Installer”窗口中的“确定”后,才可以在“SunPlex Manager”窗口中继续进行操作。 | |
|
注意: 如果在本地文件系统上安装 Oracle,将为每个节点显示一个“Oracle Universal Installer”窗口。
为每个节点显示一个窗口是因为每个节点都需要单独安装。
如果在全局文件系统上安装 Oracle 软件,将显示一个安装程序窗口。
安装期间各个“Oracle Universal Installer”窗口中的进度条可能会达到百分之百若干次。 请等到安装程序显示一个对话框表明已完成数据库创建时,再继续下一步操作。 |
Oracle Universal Installer 将显示一个对话框,告知您已完成数据库创建并显示已创建的数据库信息。
Oracle Universal Installer 将关闭。 您可以继续 Sun Cluster HA for Oracle 的安装。 安装程序将显示一条确认消息。
将运行
root.sh 脚本。如果出现一个对话框,声明传送已中断,请忽略此消息。 安装程序将显示一条确认消息。
安装程序将设置配置文件。
将显示一个配置页。
| 字段 | 说明 | 网络资源 | 用于访问数据库的逻辑主机名。 |
|---|---|
| Oracle 资源前缀 | 监听进程资源将“-listener”附加到此前缀,服务器资源将“-server”附加到此前缀。 |
| ORACLE_HOME 目录 | 要包含 Oracle 产品的目录。 |
| 数据库名称 | 完整的数据库名称,它可以使该数据库与网络域中的其它数据库唯一区分。 |
| 连接 ID/口令 | 故障监视器连接到数据库时所要使用的连接 ID 和口令。 |
| 报警日志文件位置 | 报警文件的位置。 |
| 监听进程名称 | Oracle 监听进程的名称。 |
安装程序将设置并运行资源。
设置资源后,安装程序将显示一条确认消息。 现在,已完成 Sun Cluster HA for Oracle 的安装。
| 推荐步骤。要测试数据服务,请按照描述在客户机上设置 tnsnames.ora 文件并连接到数据库。 |
Oracle 文档资料和《Sun Cluster 3.1 Data Services Installation and Configuration Guide》为定制 Sun Cluster HA for Oracle 安装提供了指导。