자원

보기(View)
일반 자원 등록 정보
자세한 자원 등록 정보

작업(Actions)
자원 활성화
자원 비활성화
자원 모니터 활성화
자원 모니터 비활성화
자원 등록 정보 수정
로드 밸런싱 수정
STOP_FAILED 플래그 삭제
자원 만들기
자원 삭제


일반 자원 등록 정보 보기

자원의 등록 정보를 일반적인 보기 및 자세한 보기로 표시할 수 있습니다.

일반적인 자원 등록 정보 보기를 표시하려면 다음 단계를 수행하십시오.

  1. SunPlexTM Manager의 이동 프레임에서 자원 그룹(Resource Groups)>[자원 그룹 이름]>[자원 이름]을 선택하십시오.

  2. 보기(View) 메뉴에서 일반 등록 정보 표(General Properties Table)를 선택하십시오.
각 등록 정보에 대한 자세한 설명은
자원 등록 정보(Resource Properties) 표를 참조하십시오.

맨 위로 이동


자세한 자원 등록 정보 보기

추가 시스템 및 확장 등록 정보를 표시하는 자세한 자원 등록 정보 보기를 표시하려면 다음 단계를 수행하십시오.
  1. SunPlex Manager의 이동 프레임에서 자원 그룹(Resource Groups)>[자원 그룹 이름]>[자원 이름]을 선택하십시오.

  2. 보기(View) 메뉴에서 자세한 등록 정보 표(Detailed Properties Table)를 선택하십시오.
각 등록 정보에 대한 자세한 설명은
자원 등록 정보(Resource Properties) 표를 참조하십시오.

맨 위로 이동


자원 활성화

클러스터에서 자원을 인식하도록 하려면 자원을 활성화해야 합니다.
  1. SunPlex Manager의 이동 프레임에 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 자원 활성화(Enable Resource)를 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. 활성화할 자원을 선택하십시오.

  4. 자원 활성화(Enable Resource)를 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 나중에 스크립트 및 다른 자동화된 작업에 사용할 수 있도록 이 명령을 기록하거나 복사해 두십시오.

맨 위로 이동


자원 비활성화

자원을 비활성화하면 자원이 오프라인 상태로 전환되기 때문에 자원 그룹 페일오버가 발생할 경우에 자원이 다시 온라인 상태로 전환되지 않습니다.

자원이 사용하는 노드나 디스크에서 유지 보수 작업을 수행할 경우에는 자원을 비활성화해야 합니다.

  1. SunPlex Manager의 이동 프레임에 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 자원 비활성화(Disable Resource)를 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. 비활성화할 자원을 선택하십시오.

    다른 자원이 비활성화하려는 자원에 의존할 경우에는 해당 자원을 비활성화할 수 없습니다.

  4. 자원 비활성화(Disable Resource)를 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 나중에 스크립트 및 다른 자동화된 작업에 사용할 수 있도록 이 명령을 기록하거나 복사해 두십시오.

맨 위로 이동


자원 모니터 활성화

자원이 활성화되면 자동으로 자원 모니터 기능이 활성화됩니다. 따라서 자원을 비활성화한 경우에만 자원 모니터를 활성화하면 됩니다. 다음 단계를 수행하십시오.
  1. SunPlex Manager의 이동 프레임에 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 자원 모니터 활성화(Enable Resource Monitor)를 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. 모니터를 활성화할 대상 자원을 선택하십시오.

  4. 자원 모니터 활성화(Enable Resource Monitor)를 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 나중에 스크립트 및 다른 자동화된 작업에 사용할 수 있도록 이 명령을 기록하거나 복사해 두십시오.

맨 위로 이동


자원 모니터 비활성화

자원이 비활성화되면 자원 모니터 기능이 자동으로 중지됩니다. 자원의 구성을 변경하거나 문제를 해결할 때 자원 모니터를 비활성화해야 할 수도 있습니다.

경고 자원 모니터를 비활성화하면 더 이상 자원의 가용성이 높이 않습니다. 따라서 장애가 발생할 경우에 자원이 페일오버되지 않습니다.

자원 모니터를 비활성화하려면 다음 단계를 수행하십시오.

  1. SunPlex Manager의 이동 프레임에 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 자원 모니터 비활성화(Disable Resource Monitor)를 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. 모니터를 비활성화할 대상 자원을 선택하십시오.

  4. 자원 비활성화(Disable Resource)를 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 나중에 스크립트 및 다른 자동화된 작업에 사용할 수 있도록 이 명령을 기록하거나 복사해 두십시오.

맨 위로 이동


자원 등록 정보 수정

클러스터의 구성을 변경하기 위하여 자원 등록 정보를 수정해야 할 수도 있습니다. 자원 등록 정보를 수정할 수 있는지 확인하려면
자원 등록 정보(Resource Properties) 표를 참조하십시오. 이 표에서 조정 가능(Tunable) 값은 등록 정보를 수정할 수 있는 경우를 나타냅니다.

자원의 등록 정보를 수정하려면 다음 단계를 수행하십시오.

  1. SunPlex Manager의 이동 프레임에 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 자원 등록 정보 수정(Modify Resource Properties)을 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. 수정할 자원을 선택하십시오.

  4. 다음(Next)을 클릭하십시오.

    SunPlex Manager가 자원 등록 정보를 묻는 창을 추가로 표시합니다. 이러한 등록 정보에 대한 자세한 설명은 자원 등록 정보(Resource Properties) 표를 참조하십시오.

  5. 표시되는 필드에 새 정보를 입력하여 원하는 등록 정보 값을 변경하십시오.

  6. 자원 수정(Modify Resource)을 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 나중에 스크립트 및 다른 자동화된 작업에 사용할 수 있도록 이 명령을 기록하거나 복사해 두십시오.

맨 위로 이동


로드 밸런싱 수정

확장 가능 서비스에 대한 로드 밸런싱을 구성하려면 자원의 처리량을 변경해야 합니다.
  1. SunPlex Manager의 이동 프레임에서 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 로드 밸런싱 수정(Modify Load Balancing)을 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. 수정할 자원을 선택하십시오.

  4. 로드 밸런싱 수정(Modify Load Balancing)을 클릭하십시오.

    창이 하나 열립니다. 이 창에는 현재 처리량이 포함되어 있습니다.

  5. 로드 밸런싱을 조정하십시오.

    로드 밸런싱을 조정하려면 처리량(Weight) 필드에 새 값을 입력하십시오. 노드의 처리량을 변경하면 로드 분산(Load Distribution) 필드가 새로운 로드 분산 값을 사용하여 자동으로 업데이트됩니다. 이 분산 값은 백분율로 표시됩니다.

    참고: 로드 분산(Load Distribution) 필드는 브라우저에서 JavaScriptTM 기술을 활성화할 경우에만 표시됩니다. JavaScript 기술이 비활성화되면 필드가 비어 있습니다.

    다음 표의 예를 참고하십시오.

    자원을 실행하는 노드 노드에 의한 처리량 로드 분산
    노드 1 1 25%
    노드 2 1 25%
    노드 3 2 50%

    로드 분산을 결정하는 방법
    로드 분산을 결정하려면 노드의 처리량을 모든 노드의 전체 처리량으로 나누십시오. 모든 노드의 총 처리량은 모든 노드의 처리량을 합하여 계산됩니다.

    이 예에서 노드 1의 처리량은 1이고 총 처리량은 4입니다. 따라서 노드 1의 로드는 전체 로드의 1/4 또는 25퍼센트입니다.

  6. 로드 밸런싱 수정(Modify Load Balancing)을 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 나중에 스크립트 및 다른 자동화된 작업에 사용할 수 있도록 이 명령을 기록하거나 복사해 두십시오.

맨 위로 이동


STOP_FAILED 플래그 삭제

그룹 오프라인 전환(Take Group Offline) 작업에 실패할 경우에는 STOP_FAILED 플래그를 삭제해야 합니다.

STOP_FAILED 자원 상태가 발생하면 자원이 제어하는 몇 가지 응용프로그램 인스턴스가 시작되지 않고 사용자가 이것을 알 수 없습니다. STOP_FAILED 플래그를 삭제하기 전에 자원이 오프라인 상태인지 확인하십시오.

자원이 STOP_FAILED 상태에 있으면 다음과 같은 작업을 수행할 수 없습니다.

STOP_FAILED 플래그를 삭제하려면 다음 단계를 수행하십시오.

권장 단계 권장 단계. telnet 창을 열고 장애가 발생한 자원이 있는 노드에 연결하십시오. 그런 다음 직접 자원 응용프로그램이나 응용프로그램을 중지시키십시오.

이 단계를 수행하기 위해 프로세스를 중지시키거나 자원 유형 관련 명령을 실행하거나 다른 명령을 사용해야 할 수도 있습니다.

  1. SunPlex Manager의 이동 프레임에 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 STOP_FAILED 플래그 삭제(Clear STOP_FAILED Flag)를 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. STOP_FAILED 플래그를 삭제할 대상 자원을 선택하십시오.

  4. 플래그 삭제(Clear Flag)를 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 이제 자원과 자원 그룹이 오프라인 상태입니다.

참고: STOP_FAILED 플래그는 삭제하고 자원 응용프로그램을 직접 중지시키지 않으면 자원이 제대로 중지되지 않을 수 있습니다.

맨 위로 이동


자원 만들기

다음과 같은 다섯 가지 종류의 자원을 만들 수 있습니다.

논리 호스트 이름 자원을 만드는 단계

경고 논리 호스트 이름 자원을 만들려면 새 논리 호스트 이름과 동일한 서브넷에 대하여 어댑터나 IPMP 그룹이 구성되어야 합니다. 이러한 구성이 없으면 다음과 같은 오류 메시지가 표시됩니다.

specified hostname(s) cannot be hosted by any adapter on ...

새 서브넷에 어댑터와 IPMP 그룹을 구성하려면 IPMP 그룹을 만드십시오.

  1. SunPlex Manager의 이동 프레임에서 노드(Nodes)>[노드 이름]>IPMP 그룹(IPMP Groups)을 선택하십시오.

  2. 작업(Action) 메뉴에서 그룹 만들기(Create Group)를 선택하십시오.
  1. SunPlex Manager의 이동 프레임에 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 새 자원 만들기(Create New Resource)를 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. 논리 호스트 이름 자원 유형(Logical Host Name Resource Type) 자원 유형을 선택하십시오.

  4. 연결된 네트워크 자원에 대하여 없음(none)을 선택하십시오.

  5. 계속(Continue)을 클릭하십시오.

    SunPlex Manager가 자원 등록 정보를 묻는 창을 추가로 표시합니다.

  6. 구성에 대한 자원 등록 정보를 입력하십시오.

    이러한 등록 정보에 대한 자세한 설명은 자원 등록 정보(Resource Properties) 표를 참조하십시오.

    특정 자원 그룹 확장 등록 정보에 대한 설명은 Sun Cluster 3.1 Data Service Installation and Configuration Guide를 참조하십시오.

  7. 자원 만들기(Create Resource)를 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 나중에 스크립트 및 다른 자동화된 작업에 사용할 수 있도록 이 명령을 기록하거나 복사해 두십시오.

맨 위로 이동


공유 주소 자원을 만드는 단계

경고 공유 주소 자원을 만들려면 새 공유 주소와 동일한 서브넷에 대하여 어댑터나 IPMP 그룹이 구성되어야 합니다. 이러한 구성이 없으면 다음과 같은 오류 메시지가 표시됩니다.

specified hostname(s) cannot be hosted by any adapter on ...

새 서브넷에 어댑터와 IPMP 그룹을 구성하려면 IPMP 그룹을 만드십시오.

  1. SunPlex Manager의 이동 프레임에서 노드(Nodes)>[노드 이름]>IPMP 그룹(IPMP Groups)을 선택하십시오.

  2. 작업(Action) 메뉴에서 그룹 만들기(Create Group)를 선택하십시오.
  1. SunPlex Manager의 이동 프레임에 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 새 자원 만들기(Create New Resource)를 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. HA 공유 주소 자원 유형(HA Shared Address Resource Type) 자원 유형을 선택하십시오.

  4. 연결된 네트워크 자원에 대하여 없음(none)을 선택하십시오.

  5. 계속(Continue)을 클릭하십시오.

    SunPlex Manager가 자원 등록 정보를 묻는 창을 추가로 표시합니다.

  6. 구성에 대한 자원 등록 정보를 입력하십시오.

    이러한 등록 정보에 대한 자세한 설명은 자원 등록 정보(Resource Properties) 표를 참조하십시오.

    특정 자원 그룹 확장 등록 정보에 대한 설명은 Sun Cluster 3.1 Data Service Installation and Configuration Guide를 참조하십시오.

  7. 자원 만들기(Create Resource)를 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 나중에 스크립트 및 다른 자동화된 작업에 사용할 수 있도록 이 명령을 기록하거나 복사해 두십시오.

맨 위로 이동


페일오버 데이터 서비스를 만드는 단계

  1. SunPlex Manager의 이동 프레임에 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 새 자원 만들기(Create New Resource)를 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. 서비스의 자원 유형 이름을 선택하십시오.

  4. 연결된 네트워크 자원에 대한 논리 호스트 이름을 선택하십시오.

    논리 호스트 이름은 (lh)로 표시됩니다.

  5. 계속(Continue)을 클릭하십시오.

    SunPlex Manager가 자원 등록 정보를 묻는 창을 추가로 표시합니다.

    참고: 자원 유형이 등록되지 않았으면 SunPlex Manager가 자원 유형을 등록하라는 메시지를 표시합니다. 등록(Register)을 클릭하십시오.

  6. 구성에 대한 자원 등록 정보를 입력하십시오.

    이러한 등록 정보에 대한 자세한 설명은 자원 등록 정보(Resource Properties) 표를 참조하십시오.

    특정 자원 그룹 확장 등록 정보에 대한 설명은 Sun Cluster 3.1 Data Service Installation and Configuration Guide를 참조하십시오.

  7. 자원 만들기(Create Resource)를 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 나중에 스크립트 및 다른 자동화된 작업에 사용할 수 있도록 이 명령을 기록하거나 복사해 두십시오.

맨 위로 이동


확장 가능 데이터 서비스를 만드는 단계

  1. SunPlex Manager의 이동 프레임에 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 새 자원 만들기(Create New Resource)를 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. 서비스의 자원 유형 이름을 선택하십시오.

  4. 연결된 네트워크 자원에 대한 공유 주소를 선택하십시오.

    공유 주소는 (sa)로 표시됩니다.

  5. 계속(Continue)을 클릭하십시오.

    SunPlex Manager가 자원 등록 정보를 묻는 창을 추가로 표시합니다.

  6. 구성에 대한 자원 등록 정보를 입력하십시오.

    이러한 등록 정보에 대한 자세한 설명은 자원 등록 정보(Resource Properties) 표를 참조하십시오.

    특정 자원 그룹 확장 등록 정보에 대한 설명은 Sun Cluster 3.1 Data Service Installation and Configuration Guide를 참조하십시오.

  7. 자원 만들기(Create Resource)를 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 나중에 스크립트 및 다른 자동화된 작업에 사용할 수 있도록 이 명령을 기록하거나 복사해 두십시오.

맨 위로 이동


네트워크에서 인식하지 못하는 자원을 만드는 단계

  1. SunPlex Manager의 이동 프레임에 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 새 자원 만들기(Create New Resource)를 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. 자원의 자원 유형 이름을 선택하십시오.

  4. 연결된 네트워크 자원에 대하여 없음(none)을 선택하십시오.

  5. 계속(Continue)을 클릭하십시오.

    SunPlex Manager가 자원 등록 정보를 묻는 창을 추가로 표시합니다.

  6. 구성에 대한 자원 등록 정보를 입력하십시오.

    이러한 등록 정보에 대한 자세한 설명은 자원 등록 정보(Resource Properties) 표를 참조하십시오.

    특정 자원 그룹 확장 등록 정보에 대한 설명은 Sun Cluster 3.1 Data Service Installation and Configuration Guide를 참조하십시오.

  7. 자원 만들기(Create Resource)를 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 나중에 스크립트 및 다른 자동화된 작업에 사용할 수 있도록 이 명령을 기록하거나 복사해 두십시오.

맨 위로 이동


자원 삭제

클러스터의 구성이나 기능을 변경할 때 자원을 삭제해야 할 수도 있습니다.

자원을 삭제하기 전에 SunPlex Manager가 자동으로 자원을 비활성화합니다.

자원을 삭제하려면 다음 단계를 수행하십시오.

  1. SunPlex Manager의 이동 프레임에 있는 자원 그룹(Resource Group) 단락에서 자원 그룹(Resource Groups) 또는 [자원 그룹 이름]을 선택하십시오.

    자원 그룹(Resource Groups) 창이 열립니다.

  2. 작업(Action) 메뉴에서 자원 삭제(Delete Resource)를 선택하십시오.

    작업 창이 열립니다. 이 창에는 추가 정보를 묻는 메시지가 나옵니다.

  3. 삭제할 자원을 선택하십시오.

  4. 자원 삭제(Delete Resource)를 클릭하십시오.

    SunPlex Manager가 확인하는 메시지와 함께 작업을 완료하는 데 사용하는 명령을 표시합니다. 나중에 스크립트 및 다른 자동화된 작업에 사용할 수 있도록 이 명령을 기록하거나 복사해 두십시오.

맨 위로 이동