자원 유형 등록 정보 표
자원 등록 정보 표
자원 그룹 등록 정보 표
자원 등록 정보 속성 표
필수적 -- 이 등록 정보는 자원 유형 등록(RTR) 파일에 명시적인 값이 있어야 합니다. 그렇지 않으면 해당 등록 정보가 속한 객체를 생성할 수 없습니다. 공백이나 빈 문자열은 허용되지 않습니다.
조건적 -- 해당 등록 정보가 존재하려면 RTR 파일에 선언해야 합니다. 그렇지 않으면 Resource Group Manager (RGM)는 해당 등록 정보를 생성하지 않습니다. 또한 관리 유틸리티에서 해당 등록 정보를 사용할 수 없습니다. 공백이나 빈 문자열이 허용됩니다. 등록 정보가 RTR 파일에 선언되었지만 값이 지정되지 않았다면 Resource Group Manager에서 기본값을 제공합니다.
조건적/명시적 -- 해당 등록 정보가 존재하려면 RTR 파일에 명시적인 값으로 선언되어야 합니다. 그렇지 않으면 Resource Group Manager는 해당 등록 정보를 생성하지 않습니다. 또한 관리 유틸리티에서 해당 등록 정보를 사용할 수 없습니다. 공백이나 빈 문자열은 허용되지 않습니다.
선택적 -- 등록 정보를 RTR 파일에 선언할 수 있습니다. 해당 등록 정보가 선언되지 않은 경우에는 Resource Group Manager에서 등록 정보를 생성하고 기본값을 제공합니다. 등록 정보가 RTR 파일에는 선언되었지만 값이 지정되지 않았다면 Resource Group Manager에서 기본값을 제공합니다. 이 기본값은 해당 등록 정보가 RTR 파일에 선언되지 않았을 때 사용되는 값과 같습니다.
RTR 파일에 선언될 수 없는
Installed_nodes를 제외한 자원 유형 등록 정보는 관리 유틸리티를 사용하여 업데이트할 수 없습니다. 관리자는 반드시 Installed_nodes를 설정해야 합니다.
| 등록 정보 이름 | 설명 |
|---|---|
|
Allow_hosts
(문자열 배열) |
클러스터 재구성 이벤트를 수신하기 위해 cl_apid 데몬에 등록할 수 있는 클라이언트 집합을 제어합니다. 이 등록 정보의 일반적인 형식은 ipaddress/masklength이며, 클라이언트가 등록할 수 있는 서브넷을 정의합니다. 예를 들어 129.99.77.0/24라고 설정하면 서브넷 129.99.77의 클라이언트가 이벤트에 등록할 수 있습니다. 또 다른 예로 192.9.84.231/32라고 설정하면 클라이언트 192.9.84.231만 이벤트에 등록할 수 있습니다. 이 등록 정보는 CRNP에 보안을 제공합니다. cl_apid 데몬에 대한 자세한 내용은 SUNW.Event(5) 설명서 페이지를 참조하십시오.또한 다음 특수 키워드를 인식합니다. LOCAL은 클러스터에 직접 연결된 서브넷에 위치한 모든 클라이언트를 가리킵니다. ALL은 모든 클라이언트를 등록할 수 있게 합니다. 어떤 클라이언트가 Allow_hosts 및 Deny_hosts 등록 정보의 항목과 일치하는 경우 해당 클라이언트는 이 구현 방식을 통해 등록할 수 없습니다.
범주: 선택적 기본값: LOCAL조정: 불가 |
|
API_version
(정수) |
이 자원 유형 구현에서 사용하는 자원 관리 API 버전.
범주: 선택적 기본값: 2조정: 불가 |
|
Boot
(문자열) |
선택적 콜백 메소드: Resource Group Manager가 노드에서 호출하는 프로그램에 대한 경로. 이 노드는 이 유형의 자원이 이미 관리된 경우에 클러스터에 연결되거나 다시 연결됩니다. 이 메소드는 Init 메소드와 유사하게 이 유형의 자원을 초기화합니다.
범주: 조건적/명시적 기본값: 없음 조정: 불가 |
|
Client_retry_count
(정수) |
외부 클라이언트와 통신하는 동안 cl_apid 데몬의 시도 횟수를 제어합니다. Client_retry_count번의 시도 안에 응답하지 않은 클라이언트는 시간 초과됩니다. 그 결과 해당 클라이언트는 클러스터 재구성 이벤트를 수신하도록 등록된 클라이언트 목록에서 삭제됩니다. 이 클라이언트가 다시 이벤트 수신을 시작하려면 재등록해야 합니다. 이 구현 방식의 재시도 횟수에 대한 자세한 내용은 Client_retry_interval 등록 정보의 설명을 참조하십시오. cl_apid 데몬에 대한 자세한 내용은 SUNW.Event(5)를 참조하십시오.
범주: 선택적 기본값: 3조정: 항시 가능 |
|
Client_retry_interval
(정수) |
응답하지 않는 외부 클라이언트와 통신하는 동안 cl_apid 데몬이 사용하는 기간(초)을 정의합니다. 이 기간 동안 최대 Client_retry_count번의 클라이언트 연결 시도가 수행됩니다. cl_apid 데몬에 대한 자세한 내용은 SUNW.Event(5)를 참조하십시오.
범주: 선택적 기본값: 1800조정: 항시 가능 |
|
Client_timeout
(정수) |
외부 클라이언트와 통신하는 동안 cl_apid 데몬이 사용하는 시간 초과 값(초). 그러나 cl_apid 데몬은 조정 가능한 횟수 동안 계속 클라이언트 연결을 시도합니다. 이 등록 정보를 조정하는 방법에 대한 자세한 내용은 Client_retry_count 및 Client_retry_interval 등록 정보 설명을 참조하십시오. cl_apid 데몬에 대한 자세한 내용은 SUNW.Event(5)를 참조하십시오.
범주: 선택적 기본값: 60조정: 항시 가능 |
|
Deny_hosts
(문자열 배열) |
클러스터 재구성 이벤트를 수신하도록 등록할 수 없는 클라이언트 집합을 제어합니다. 액세스 결정 시 이 등록 정보의 설정이 Allow_hosts 목록의 설정보다 우선합니다. 이 등록 정보의 형식은 Allow_hosts 등록 정보에서 정의한 형식과 동일합니다. 이 등록 정보는 CRNP에 보안을 제공합니다.
범주: 선택적 기본값: NULL조정: 항시 가능 |
|
Failover
(부울값) |
True는 여러 노드에서 동시에 온라인화할 수 있는 그룹에서는 이 자원 유형을 구성할 수 없음을 의미합니다.
범주: 선택적 기본값: False조정: 불가 |
|
Fini
(문자열) |
선택적 콜백 메소드: 이 유형의 자원이 Resource Group Manager의 제어에서 제거되는 경우 Resource Group Manager에서 호출하는 프로그램의 경로.
범주: 조건적/명시적 기본값: 없음 조정: 불가 |
|
Init (문자열) |
선택적 콜백 메소드: 이 유형의 자원을 Resource Group Manager에서 관리하게 되는 경우 Resource Group Manager에서 호출하는 프로그램의 경로.
범주: 조건적/명시적 기본값: 없음 조정: 불가 |
|
Init_nodes (열거) |
Resource Group Manager에서 Init, Fini, Boot 및 Validate 메소드를 호출하는 노드를 가리킵니다. RG_primaries (자원을 다루는 해당 노드) 또는 RT_installed_nodes (해당 자원 유형이 설치된 모든 노드)가 값이 될 수 있습니다.
범주: 선택적 기본값: RG_primaries조정: 불가 |
|
Installed_nodes (문자열 배열) |
실행하도록 허가된 자원 유형이 있는 클러스터 노드 이름의 목록. Resource Group Manager에서 이 등록 정보를 자동으로 생성합니다. 해당 클러스터 관리자는 값을 설정할 수 있습니다. RTR 파일에서 이 등록 정보를 선언할 수 없습니다.
범주: 클러스터 관리자가 구성할 수 있습니다. 기본값: 모든 클러스터 노드 조정: 항시 가능 |
|
Max_clients (정수) |
클러스터 이벤트 알림을 수신하기 위해 cl_apid 데몬에 등록할 수 있는 클라이언트 최대 수를 제어합니다. 해당 응용 프로그램이 추가 클라이언트의 이벤트 등록 시도를 거부합니다. 각 클라이언트 등록 시 클러스터의 자원을 사용하므로 사용자는 이 등록 정보를 조정하여 외부 클라이언트의 클러스터 자원 사용을 제어할 수 있습니다. cl_apid 데몬에 대한 자세한 내용은 SUNW.Event(5)를 참조하십시오.
범주: 선택적 기본값: 1000조정: 항시 가능 |
|
Monitor_check (문자열) |
선택적 콜백 메소드: 이 유형의 자원에 대하여 모니터에 의해 요청되는 페일오버를 수행하기 전에 Resource Group Manager에서 호출하는 프로그램의 경로.
범주: 조건적/명시적 기본값: 없음 조정: 불가 |
|
Monitor_start (문자열) |
선택적 콜백 메소드: 이 유형의 자원에 대한 오류 모니터를 시작하기 위하여 Resource Group Manager에서 호출하는 프로그램의 경로.
범주: 조건적/명시적 기본값: 없음 조정: 불가 |
|
Monitor_stop (문자열) |
Monitor_start가 설정된 경우에 필요한 콜백 메소드 또는 이 유형의 자원에 대한 오류 모니터를 중지하기 위하여 Resource Group Manager에서 호출하는 프로그램의 경로.
범주: 조건적/명시적 기본값: 없음 조정: 불가 |
|
각 클러스터 노드의 Num_resource_restarts (정수) |
RGM이 설정하는 이 등록 정보는 지난 [n]초 동안 이 노드의 이 자원에 대해 수행된 scha_control RESTART 호출 횟수를 나타내며, 여기에서 [n]은 해당 자원의 Retry_interval 등록 정보 값을 의미합니다. 자원 유형에서 Retry_interval 등록 정보를 선언하지 않으면 해당 자원 유형에 대해서는 Num_resource_restarts 등록 정보를 사용할 수 없습니다.
범주: 쿼리 전용 기본값: 없음 조정: 불가 |
|
Pkglist (문자열 배열) |
자원 유형 설치에 포함된 패키지들의 선택 목록.
범주: 조건적/명시적 기본값: 없음 조정: 불가 |
|
Postnet_stop (문자열) |
선택적 콜백 메소드: 이 자원 유형이 종속되는 네트워크 주소 자원( Network_resources_used)의 Stop 메소드 호출 후 Resource Group Manager에서 호출하는 프로그램 경로. 이 메소드는 네트워크 인터페이스가 정지하도록 구성된 후 완료되어야 하는 Stop 작업을 수행합니다.
범주: 조건적/명시적 기본값: 없음 조정: 불가 |
|
Prenet_start (문자열) |
선택적 콜백 메소드 또는 이 자원 유형이 종속되는 네트워크-주소 자원 ( Network_resources_used)의 Start 메소드가 호출되기 전에 Resource Group Manager에서 호출하는 프로그램의 경로. 이 메소드는 네트워크 인터페이스가 시작하도록 구성되기 전에 완료해야 하는 Start 작업을 수행합니다.
범주: 조건적/명시적 기본값: 없음 조정: 불가 |
|
Resource_type (문자열) |
자원 유형의 이름. 현재 등록된 자원 유형들의 이름을 보려면 다음 명령을 사용하십시오. scrgadm -p 자원 유형 이름의 구문은 Sun Cluster 3.1에서 사용되기 시작하였으며 다음과 같습니다. [vendor_id].[resource_type]:[version] 자원 유형 이름의 세 구성 요소는 RTR 파일에서 Vendor_id, Resource_type 및 RT_version으로 지정된 등록 정보입니다. scrgadm 명령은 점(.)과 콜론(:) 구분 기호를 삽입합니다. 이 자원 유형 이름의 RT_version 접미어는 등록 정보의 RT_version 값과 같습니다.Vendor_id가 고유하도록 하려면 해당 자원 유형을 만드는 업체의 주식 시장 기호를 사용하십시오. 주: Sun Cluster 3.1의 릴리스 이전에 생성한 자원 유형 이름의 구문은 다음과 같습니다. [vendor_id].[resource_type]
범주: 필수적 기본값: 빈 문자열 조정: 불가 |
|
RT_basedir
(문자열) |
콜백 메소드에 대한 상대 경로를 완성하는 데 사용되는 디렉토리 경로. 이 경로는 해당 자원 유형 패키지가 위치한 디렉토리로 설정하십시오. 이 경로는 반드시 슬래시 ( /)로 시작하는 완전한 경로이어야 합니다.
범주: 필수적, 모든 메소드 경로 이름이 절대적이지 않은 경우 기본값: 없음 조정: 불가 |
|
RT_description (문자열) |
자원 유형에 대한 간단한 설명.
범주: 조건적 기본값: 빈 문자열 조정: 불가 |
|
RT_system (부울값) |
어떤 자원 유형에 대해 True로 설정하면 해당 자원 유형에 대해 허용된 scrgadm(1M) 작업이 제한됨을 의미합니다. RT_System 값이 True로 설정된 자원 유형을 시스템 자원 유형이라 합니다. RT_System 등록 정보의 편집은 RT_System의 현재 값과 상관 없이 항상 무제한으로 가능합니다.
범주: 선택적 기본값: False조정: 항시 가능 |
|
RT_version (문자열) |
Sun Cluster 3.1에서 사용되기 시작한 이 자원 유형 구현의 필수 버전 문자열. RT_version은 자원 유형의 전체 이름에 붙는 접미어 구성 요소입니다.
범주: 조건적/명시적 기본값: 없음 조정: 불가 |
|
Single_instance
(부울값) |
True인 경우 해당 클러스터에는 이 유형의 자원이 하나만 존재함을 의미합니다. 그러므로
Resource Group Manager는 이 유형의 자원이 전체 클러스터에서 한 번에 하나만 실행되도록 허가합니다.
범주: 선택적 기본값: False조정: 불가 |
|
Start (문자열) |
콜백 메소드: Resource Group Manager에서 이 유형의 자원을 시작할 때 호출하는 프로그램의 경로.
범주: 필수적(RTR 파일이 Prenet_start 메소드를 선언하지 않는 경우)기본값: 없음 조정: 불가 |
|
Stop (문자열) |
콜백 메소드: Resource Group Manager에서 이 유형의 자원을 정지할 때 호출하는 프로그램의 경로.
범주: 필수적(RTR 파일이 Postnet_stop 메소드를 선언하지 않는 경우)기본값: 없음 조정: 불가 |
|
Update
(문자열) |
선택적 콜백 메소드: 실행 중인 이 자원 유형의 등록 정보가 변경되었을 때 Resource Group Manager에서 호출하는 프로그램의 경로.
범주: 조건적/명시적 기본값: 없음 조정: 불가 |
|
Validate (문자열) |
선택적 콜백 메소드: 이 자원 유형의 등록 정보 값을 확인할 경우에 호출하는 프로그램의 경로.
범주: 조건적/명시적 기본값: 없음 조정: 불가 |
|
Vendor_ID (문자열) |
Resource_type 등록 정보를 참조하십시오.
범주: 조건적 기본값: 없음 조정: 불가 |
특정 데이터 서비스에 관한 자세한 내용은 데이터 서비스 설명서 페이지를 참조하십시오. 자원 등록 정보 값의 범주는 다음과 같습니다.
필수적 -- 관리자가 관리 유틸리티로 자원을 만들 때 값을 지정해야 합니다.
선택적 -- 관리자가 자원 그룹을 만들 때 값을 지정하지 않은 경우에는 시스템에서 기본값을 지정합니다.
조건적 -- 등록 정보가 RTR 파일에 선언된 경우에만 Resource Group Manager에서 해당 등록 정보를 만듭니다. 그렇지 않으면 해당 등록 정보가 존재하지 않습니다. 또한 시스템 관리자도 해당 등록 정보를 사용할 수 없습니다. RTR 파일에 선언된 조건적 등록 정보는 선택적이거나 필수적입니다. 조건적 등록 정보가 선택적인지 필수적인지는 기본값이 RTR 파일에 지정되어 있는지 여부에 달려 있습니다. 각 조건적 등록 정보의 설명에는 자세한 설명이 포함되어 있습니다.
쿼리 전용 -- 관리 도구에서 직접 설정할 수 없습니다. 쿼리 전용 값은 다음을 포함합니다.
None 또는 False
불가
True 또는 Anytime
항시 가능
At_creation
해당 자원이 클러스터에 추가될 때
When_disabled
해당 자원이 비활성화될 때
| 등록 정보 이름 | 설명 |
|---|---|
|
Affinity_timeout
(정수) |
클라이언트가 고정된 확장 가능 서비스에 대한 모든 연결을 끊은 후에 IP 연결 관계를 지속하는 시간(초)을 제어합니다. 이 시간 제한이 만료되기 전에 해당 클라이언트로부터의 새로운 연결은 모두 같은 클러스터 노드로 전달됩니다. 0 값은 클라이언트와 확장 가능 서비스간에 연결이 지속되는 한 연결 관계가 지속됨을 의미합니다 . -1 값은 클라이언트가 연결되어 있는 클러스터 노드가 정지하거나 재부트할 때까지 연결 관계가 지속됨을 의미합니다. 따라서 시간 제한이 적용되지 않습니다.이 등록 정보는 Load_balancing_policy=Lb_sticky 또는 Lb_sticky_wild가 있는 자원에만 적용됩니다.
범주: 선택적 기본값: 0조정: 항시 가능 |
|
Cheap_probe_interval (정수) |
자원에 대한 빠른 오류 검사 호출 사이의 시간(초). 이 등록 정보는 Resource Group Manager만이 생성할 수 있습니다. 이 등록 정보가 RTR 파일에 선언되었을 경우에 관리자가 사용할 수 있습니다. 기본값이 RTR 파일에 지정되지 않았다면 이 등록 정보는 선택적입니다. 자원 유형 파일에 Tunable 속성이 지정되지 않은 경우에는 해당 등록 정보에 대한 Tunable 값은 When_disabled입니다.
Default 속성이 RTR 파일의 등록 정보 선언에 지정되지 않았다면 이 등록 정보는 필수적입니다.
범주: 조건적 기본값: 앞의 설명을 참조하십시오. 조정: 비활성화된 경우 |
|
Extension properties |
해당 자원 유형의 RTR 파일에 선언된 확장명 등록 정보. 이 자원 유형의 구현 방식에 따라 이 등록 정보가 정의됩니다. 확장명 등록 정보에서 설정 가능한 각 속성에 대한 자세한 내용은 자원 등록 정보 속성을 참조하십시오.
범주: 조건적 기본값: 없음 조정: 특정 등록 정보에 따라 다름 |
|
Failover_mode (열거) |
사용 가능한 설정은 None, Soft, Hard입니다. 이 자원에 대한 Start, Stop, Monitor_stop 메소드 호출이 실패하면 RGM이 자원 그룹을 재배치하거나 노드를 중지할지 여부를 제어합니다.None으로 설정하면 RGM은 메소드 실패에 대한 자원 상태를 설정하고 운영자의 조치를 기다립니다. Soft로 설정한 경우, Start 메소드가 실패했다면 RGM은 자원 그룹을 다른 노드로 재배치합니다. 한편 Stop이나 Monitor_stop 메소드가 실패하면 RGM은 자원을 STOP_FAILED 상태로, 자원 그룹을 ERROR_STOP_FAILED 상태로 설정한 다음 운영자의 조치를 기다립니다. Stop이나 Monitor_stop이 실패한 경우 None 및 Soft 설정은 동일합니다. Hard로 설정한 상태에서 Start 메소드가 실패하면 그룹이 재배치됩니다. Stop이나 Monitor_stop 메소드가 실패하면 클러스터 노드를 중단시켜 자원을 강제로 중지합니다.
범주: 선택적 기본값: None조정: 항시 가능 |
|
Load_balancing_policy
(문자열) |
사용 중인 로드 균형 조정 정책을 정의하는 문자열. 이 등록 정보는 확장 가능 서비스에 대해서만 사용 가능합니다. Scalable 등록 정보가 RTR 파일에 선언되어 있는 경우에는 Resource Group Manager에서 자동으로 이 등록 정보를 만듭니다.
Load_balancing_policy에 설정될 수 있는 값은 다음과 같습니다. Lb_weighted (기본값). Load_balancing_weights 등록 정보에 설정된 로드량에 따라 여러 노드로 로드를 분산합니다. Lb_sticky. 확장 가능 서비스의 해당 클라이언트(클라이언트 IP 주소로 식별)는 항상 같은 클러스터 노드로 전송됩니다. Lb_sticky_wild. 고정된 와일드카드 서비스의 IP 주소로 연결되는 해당 클라이언트(클라이언트 주소로 식별)는 지정된 포트 번호에 관계없이 항상 같은 클러스터 노드로 전송됩니다.
범주: 조건적/선택적 기본값: Lb_weighted조정: 생성 시 |
|
Load_balancing_weights
(문자열 배열) |
확장 가능한 자원에만 해당. Scalable 등록 정보가 RTR 파일에 선언되어 있는 경우에는 Resource Group Manager에서 자동으로 이 등록 정보를 생성합니다. 형식은 [weight]@[node], [weight]@[node]이고 [weight]는 지정된 [node]에 분산되는 부하의 상대적인 양을 반영하는 정수를 표현합니다. 노드에 분산되는 부하의 분수는 이 노드에 대한 부하량을 모든 부하량의 합으로 나눈 것입니다. 예를 들면, 1@1,3@2는 노드 1은 1/4의 부하를 받고, 노드 2는 3/4의 부하를 받도록 지정합니다. 빈 문자열("")은 기본값으로 균일하게 분산되도록 설정합니다. 명시적으로 하중이 할당되지 않은 노드는 기본 부하량인 1을 받습니다.Tunable 속성이 자원 유형 파일에 지정되지 않았다면 등록 정보에 대한 Tunable 값은 Anytime입니다. 이 등록 정보를 변경하면 새 연결에 대한 분산에만 적용됩니다.
범주: 조건적/선택적 기본값: 빈 문자열 조정: 항시 가능 |
|
유형의 각 콜백 메소드에 대해 [method] _timeout(정수) |
Resource Group Manager에서 메소드의 호출에 실패하였다고 결정할 때까지의 경과 시간(초).
범주: 조건적/선택적 기본값: 3,600초 또는 1시간(해당 메소드가 RTR 파일에 선언된 경우) 조정: 항시 가능 |
|
Monitored_switch (열거) |
클러스터 관리자가 관리 유틸리티로 모니터를 활성화하거나 비활성화하는 경우 Resource Group Manager는 Enabled 또는 Disabled로 설정합니다. Disabled로 설정하면 모니터가 다시 활성화될 때까지 해당 Start 메소드가 호출되지 않습니다. 해당 자원이 모니터 콜백 메소드가 없는 경우에는 이 등록 정보가 존재하지 않습니다.
범주: 쿼리 전용 기본값: Enable조정: 불가 |
|
Network_resources_used
(문자열 배열) |
자원이 사용하는 논리 호스트 이름이나 공유 주소 네트워크 자원의 목록. 확장 가능 서비스의 경우 이 등록 정보는 반드시 별도 자원 그룹에 존재하는 공유 주소 자원을 참조해야 합니다. 페일오버 서비스의 경우, 이 등록 정보는 같은 자원 그룹에 존재하는 논리 호스트 이름이나 공유 주소 자원을 참조합니다. RTR 파일에 Scalable 등록 정보가 선언된 경우 RGM은 이 등록 정보를 자동으로 만듭니다. RTR 파일에 Scalable이 선언되지 않았다면 RPR 파일에 명시적으로 선언될 때까지 Network_resources_used는 사용할 수 없습니다.자원 유형 파일에 Tunable 속성이 지정되지 않으면 이 등록 정보의 Tunable 값은 At_creation입니다.
범주: 조건적/필수적 기본값: 없음 조정: 생성 시 |
|
On_off_switch
(열거) |
클러스터 관리자가 관리 유틸리티로 해당 자원을 활성화하거나 비활성화하는 경우에는 Resource Group Manager에서 Enabled 또는 Disabled로 설정합니다. 비활성화인 경우에는 다시 활성화될 때까지 어떠한 콜백도 호출되지 않습니다.
범주: 쿼리 전용 기본값: Disabled조정: 불가 |
|
Port_list
(문자열 배열) |
서버가 수신하는 포트 번호의 쉼표로 분리된 목록. 각 포트에 추가되는 숫자는, 예를 들어 Port_list=80/tcp처럼 해당 포트에서 사용하는 프로토콜입니다. Scalable 등록 정보가 RTR 파일에 선언되었다면 Resource Group Manager는 Port_list를 자동으로 생성합니다. 그렇지 않으면 이 등록 정보는 RTR 파일에 명시적으로 선언될 때까지는 사용할 수 없습니다.Apache용으로 이 등록 정보를 설정하는 것에 대한 자세한 내용은 Sun Cluster 3.1 Data Services Installation and Configuration Guide의 Apache 장을 참조하십시오.
범주: 조건적/필수적 기본값: 없음 조정: 생성 시 |
|
R_description (문자열) |
자원에 대한 간단한 설명.
범주: 선택적 기본값: 빈 문자열 조정: 항시 가능 |
|
Resource_dependencies (문자열 배열) |
동일한 그룹 또는 다른 그룹 중 이 자원이 강하게 종속되는 자원의 목록. 이 목록에 있는 어떤 자원이 시작에 실패하면 이 자원을 시작할 수 있습니다. 해당 자원과 목록의 자원 중 하나가 동시에 시작하면 RGM은 목록의 자원이 시작할 때까지 기다린 다음 해당 자원을 시작합니다. 이 자원의 Resource_dependencies 목록에 있는 자원이 시작하지 않으면(예: 목록에 있는 자원의 자원 그룹이 오프라인에 있거나 Start_failed 상태인 경우) 이 자원 역시 오프라인 상태를 유지합니다. 시작하지 못한 다른 자원 그룹의 자원에 종속되었기 때문에 이 자원이 오프라인 상태를 유지할 경우, 이 자원 그룹은 Pending_online_blocked 상태가 됩니다.이 자원이 목록의 자원과 동시에 오프라인화되면 이 자원이 목록의 자원보다 먼저 중지합니다. 그러나 이 자원이 온라인 상태를 유지하거나 중지하는 데 실패하면 목록 중 다른 자원 그룹에 속하는 자원은 중지합니다. 이 자원이 먼저 비활성화되지 않으면 목록의 자원은 비활성화될 수 없습니다. 기본적으로 자원 그룹에서 응용 프로그램 자원은 네트워크 주소 자원에 대해 강한 암시적 자원 종속성을 갖습니다. 자세한 내용은 자원 그룹 등록 정보의 Implicit_network_dependencies를 참조하십시오.자원 그룹 내에서 Prenet_start 메소드는 Start 메소드 전에 종속성 순서대로 실행됩니다. Postnet_stop 메소드는 Stop 메소드 다음에 종속성 순서대로 실행됩니다. 각기 자원 그룹이 다를 경우, 종속 자원은 피종속 자원이 Prenet_start 및 Start를 종료할 때까지 기다린 다음 Prenet_start를 실행합니다. 피종속 자원은 종속 자원이 Stop 및 Postnet_stop을 종료할 때까지 기다린 다음 Stop을 실행합니다.
범주: 선택적 기본값: 빈 목록 조정: 항시 가능 |
|
Resource_dependencies_restart (문자열 배열) |
동일한 또는 다른 그룹 중 이 자원이 재시작 종속성을 갖는 자원의 목록. 이 목록에 있는 모든 자원이 시작에 성공했을 때만 이 자원이 시작될 수 있습니다. 이 자원과 목록의 자원 중 하나가 동시에 시작하면 RGM은 목록의 자원이 시작할 때까지 기다린 다음 이 자원을 시작합니다. 이 자원의 Resource_dependencies_restart 목록에 있는 자원이 시작하지 않으면, 예를 들어 목록에 있는 자원의 자원 그룹이 오프라인 상태를 유지하거나 목록의 자원이 Start_failed 상태에 있다면 이 자원은 오프라인 상태를 유지합니다. 이 자원이 종속된 다른 자원 그룹의 자원이 시작하지 않아 이 자원이 오프라인 상태를 유지한다면 이 자원 그룹은 Pending_online_blocked 상태에 들어갑니다.이 자원이 목록의 자원과 동시에 오프라인화되면 이 자원이 목록의 자원보다 먼저 중지합니다. 그러나 이 자원이 온라인 상태를 유지하거나 중지하는 데 실패하더라도 목록 중 다른 자원 그룹에 속하는 자원은 중지합니다. 이 자원이 먼저 비활성화되지 않으면 목록의 자원은 비활성화될 수 없습니다. 이 등록 정보는 Resource_dependencies와 동일하게 작동합니다. 단, 재시작 종속성 목록의 자원이 재시작하면 이 자원이 재시작합니다. 이 자원은 목록의 자원이 온라인 상태로 돌아온 후에 재시작합니다.자원 그룹 내에서 Prenet_start 메소드는 Start 메소드가 실행되기 전에 종속성 순서대로 실행됩니다. Postnet_stop 메소드는 Stop 메소드 다음에 종속성 순서대로 실행됩니다. 자원 그룹이 다를 경우 종속 자원은 피종속 자원이 Prenet_start 및 Start를 종료할 때까지 기다린 다음 Prenet_start를 시작합니다. 피종속 자원은 종속 자원이 Stop 및 Postnet_stop 을 종료할 때까지 기다린 다음 Stop을 실행합니다.
범주: 선택적 기본값: 빈 목록 조정: 항시 가능 |
|
Resource_dependencies_weak
(문자열 배열) |
같은 그룹 또는 다른 그룹의 자원 중 이 자원이 약한 종속성을 갖는 자원의 목록. 약한 종속성은 그룹 내부의 메소드 호출 순서를 결정합니다. RGM은 목록에 있는 자원들의 Start 메소드를 호출한 다음 이 자원의 Start 메소드를 호출합니다. RGM은 이 자원의 Stop 메소드를 호출한 후에 목록 자원의 Stop 메소드를 호출합니다. 목록의 자원이 시작하지 못하거나 오프라인 상태를 유지하더라도 이 자원은 시작할 수 있습니다.이 자원 및 Resource_dependencies_weak 목록의 자원이 동시에 시작할 경우, RGM은 목록의 자원이 시작할 때까지 기다린 다음 이 자원을 시작합니다. 목록의 자원이 시작하지 않으면(예를 들어 목록의 자원이 속한 자원 그룹이 오프라인 상태를 유지하거나 목록의 자원이 Start_failed 상태인 경우) 이 자원이 시작합니다. 이 자원의 Resource_dependencies_weak 목록에 있는 자원이 시작하면 이 자원의 자원 그룹은 일시적으로 Pending_online_blocked 상태에 들어갈 수 있습니다. 목록의 모든 자원이 시작했거나 시작하는 데 실패할 경우 이 자원은 시작하고 해당 그룹은 Pending_online 상태에 다시 들어갑니다.이 자원이 목록의 자원과 동시에 오프라인 상태가 되면 이 자원이 목록의 자원보다 먼저 중지합니다. 그러나 이 자원이 온라인 상태를 유지하거나 중지하는 데 실패하더라도 목록 중 다른 자원 그룹에 속하는 자원은 중지합니다. 이 자원이 먼저 비활성화되지 않으면 목록의 자원은 비활성화될 수 없습니다. 자원 그룹 내에서 Prenet_start 메소드는 Start 메소드가 실행하기 전에 종속성 순서대로 실행됩니다. Postnet_stop 메소드는 Stop 메소드가 실행한 후에 종속성 순서대로 실행됩니다. 자원 그룹이 다를 경우, 종속 자원은 피종속 자원이 Prenet_start 및 Start를 종료할 때까지 기다린 다음 Prenet_start를 실행합니다. 피종속 자원은 종속 자원이 Stop 및 Postnet_stop을 종료할 때까지 기다린 다음 Stop을 실행합니다.
범주: 선택적 기본값: 빈 목록 조정: 항시 가능 |
|
Resource_name (문자열) |
자원 인스턴스의 이름. 이 이름은 클러스터 구성 내부에서 고유해야 하며 자원이 만들어진 후에는 변경할 수 없습니다.
범주: 필수적 기본값: 없음 조정: 불가 |
|
Resource_project_name (문자열) |
해당 자원과 관련된 Solaris 프로젝트 이름. CPU 공유와 자원 풀 같은 Solaris 자원 관리 기능을 클러스터 데이터 서비스에 적용하려면 이 등록 정보를 사용합니다. Resource Group Manager에서 자원을 온라인화할 때 Resource Group Manager는 이 프로젝트 이름 하의 관련 프로세스를 시작합니다. 이 등록 정보가 지정되지 않은 경우에는 자원을 포함하고 있는 해당 자원 그룹의 RG_project_name 등록 정보에서 프로젝트 이름을 가져옵니다(자세한 내용은 rg_properties(5) 참조). 두 등록 정보가 모두 지정되지 않았으면 Resource Group Manager는 미리 정의된 프로젝트 이름 기본값을 사용합니다. 지정된 프로젝트 이름이 프로젝트 데이터 베이스에 존재해야 하고 사용자 root가 명명된 프로젝트의 구성원으로 구성되어야 합니다. 이 등록 정보는 Solaris 9 릴리스부터 지원되었습니다.주: 이 등록 정보의 변경 사항은 자원이 재시작된 후에 적용됩니다.
범주: 선택적 기본값: Null 조정: 항시 가능 |
|
Resource_state on each cluster node (열거) |
Resource Group Manager에 의해 결정되는 각 클러스터 노드에 있는 자원의 상태. 가능한 상태는 Online, Offline, Stop_failed, Start_failed, Monitor_failed, 그리고 Online_not_monitored입니다.이 등록 정보를 구성할 수 없습니다. 범주: 쿼리 전용 기본값: 없음 조정: 불가 |
|
Retry_count
(정수) |
자원에 장애가 발생했을 때 모니터가 해당 자원을 재시작하기 위해 시도하는 횟수. Resource Group Manager만이 이 등록 정보를 생성합니다. 이 등록 정보가 RTR 파일에 선언되었다면 관리자가 사용할 수 있습니다. 기본값이 RTR 파일에서 지정되었다면 이 등록 정보는 선택적입니다. 자원 유형 파일에 Tunable 속성이 지정되지 않았다면 해당 등록 정보에 대한 Tunable 값은 When_disabled입니다.
Default 속성이 RTR 파일의 등록 정보 선언에 지정되지 않았다면 이 등록 정보는 필수적입니다.
범주: 조건적 기본값: 설명을 참조하십시오. 조정: 비활성화된 경우 |
|
Retry_interval (정수) |
장애가 발생한 자원을 재시작하기 위한 시도를 세는 시간(초). 자원 모니터는 이 등록 정보를 Retry_count와 함께 사용합니다. Resource Group Manager만이 이 등록 정보를 생성합니다. 이 등록 정보가 RTR 파일에 선언되었다면 관리자가 사용할 수 있습니다. 기본값이 RTR 파일에서 지정되었다면 이 등록 정보는 선택적입니다.자원 유형 파일에 Tunable 속성이 지정되지 않은 경우에는 해당 등록 정보에 대한 Tunable 값은 When_disabled입니다.Default 속성이 RTR 파일의 등록 정보 선언에 지정되지 않았다면 이 등록 정보는 필수적입니다.
범주: 조건적 기본값: 앞의 설명을 참조하십시오. 조정: 비활성화된 경우 |
|
Scalable (부울값) |
해당 자원이 확장 가능한지를 가리킵니다. 이 등록 정보가 RTR 파일에 선언되었다면 Resource Group Manager는 해당 자원 유형에 대하여 다음과 같은 확장 가능 서비스 등록 정보를 자동으로 생성합니다. Network_resources_used, Port_list, Load_balancing_policy 및 Load_balancing_weights. 이러한 등록 정보는 RTR 파일에 명시적으로 선언되지 않았다면 기본값을 사용합니다. Scalable의 기본값은(RTR 파일에 선언되었을 때) True입니다.이 등록 정보가 RTR 파일에 선언되었을 때 Tunable 속성이 At_creation으로 설정되어야 합니다. 그렇지 않으면 자원 생성은 실패합니다.이 등록 정보가 RTR 파일에 선언되지 않았다면,
범주: 선택적 기본값: 앞의 설명을 참조하십시오. 조정: 생성 시 |
|
Status on each cluster node
(열거) |
자원 모니터에 의해 설정됩니다. 가능한 값은 OK, degraded, faulted, unknown 및 offline입니다. 자원이 온라인화될 때에는 Resource Group Manager에서 값을 unknown으로 설정하고, 오프라인화 될 때에는 Offline으로 설정합니다.
범주: 쿼리 전용 기본값: 없음 조정: 불가 |
|
Status_msg on each cluster node
(문자열) |
자원 모니터에 의해 Status 등록 정보와 동시에 설정됩니다. 이 등록 정보는 자원마다 그리고 노드마다 조정 가능합니다. Resource Group Manager는 자원이 오프라인 상태가 될 때에는 이 등록 정보를 빈 문자열로 설정합니다.
범주: 쿼리 전용 기본값: 없음 조정: 불가 |
|
Thorough_probe_interval (정수) |
자원에 대한 높은 오버헤드 오류 검사 호출 사이의 시간(초). Resource Group Manager만이 이 등록 정보를 생성합니다. 이 등록 정보가 RTR 파일에 선언되었다면 관리자가 사용할 수 있습니다. 기본값이 RTR 파일에서 지정되었다면 이 등록 정보는 선택적입니다. 자원 유형 파일에 Tunable 속성이 지정되지 않은 경우에는 해당 등록 정보에 대한 Tunable 값은 When_disabled입니다.Default 속성이 RTR 파일의 등록 정보 선언에 지정되지 않았다면 이 등록 정보는 필수적입니다.
범주: 조건적 기본값: 없음 조정: 비활성화된 경우 |
|
Type (문자열) |
인스턴스의 자원 유형.
범주: 필수적 기본값: 없음 조정: 불가 |
|
Type_version (문자열) |
현재 이 자원과 관련된 자원 유형의 버전을 지정합니다. RGM은 RTR 파일에서 선언할 수 없는 이 등록 정보를 자동으로 만듭니다. 이 등록 정보의 값은 자원 유형의 RT_version 등록 정보와 같습니다. 자원이 만들어질 때 Type_version 등록 정보는 명시적으로 지정되지 않지만, 자원 유형 이름의 접미어로 표시될 수 있습니다. 자원 편집 시 Type_version은 새 값으로 변경될 수 있습니다.조정 가능 여부는 다음에 의해 결정됩니다.
범주: 설명을 참조하십시오. 기본값: 없음 조정: 설명을 참조하십시오. |
|
UDP_affinity
(부울값) |
True인 경우에는 해당 클라이언트의 UDP 패킷이 TCP 연결이 전달되는 것과 같은 방법으로 동일한 클러스터 서버 노드에 전달됩니다. 클라이언트의 TCP 연결이 서버 노드에 "고정"되어 있으면 UDP 패킷도 해당 노드로 전송됩니다. FALSE인 경우에는 이 동작이 지속되지 않으며 해당 클라이언트의 UDP 패킷이 TCP 연결과 다른 노드에서 끝날 수도 있습니다. 이 등록 정보는 Load_balancing_policy=Lb_sticky나 Lb_sticky_wild가 있는 자원에만 적용됩니다.
범주: 선택적 기본값: False조정: 비활성화된 경우 |
|
Weak_affinity
(부울값) |
True인 경우 약한 형태의 클라이언트 유사성을 활성화합니다. 그 결과 특정 클라이언트의 연결이 동일한 서버 노드로 전송되는데, 다음 경우는 제외됩니다.
약한 유사성은 메모리 사용 및 프로세서 사이클 측면에서 기본 형태에 대한 낮은 오버헤드 대안을 제공합니다. 이 등록 정보는 Load_balancing_policy가 Lb_sticky 또는 Lb_sticky_wild인 경우에만 적용됩니다.이 등록 정보는 확장 가능 서비스에서만 사용합니다.
범주: 선택적 기본값: 없음 조정: 비활성화된 경우 |
| boolean이나 enum, 또는 int 유형에 대한 기본값으로 NULL이나 빈 문자열을 지정할 수 없습니다. | |
| 등록 정보 이름 | 설명 |
|---|---|
| Property |
자원 등록 정보 이름. |
|
Extension |
사용된 경우, RTR 파일 항목이 자원 유형 구현에 의해 정의된 확장명 등록 정보를 선언하였음을 가리킵니다. 그렇지 않으면 이 항목은 시스템에서 정의한 등록 정보입니다. |
|
Description |
등록 정보의 간단한 설명을 위한 문자열 주석. 시스템에서 정의한 등록 정보에 대해 RTR 파일에 설명 속성을 설정할 수 없습니다. |
|
Type of the property |
허용된 유형은 string, boolean, int, enum 및 stringarray입니다. 시스템에서 정의한 등록 정보에 대해 RTR 파일 항목에서 유형 속성을 설정할 수 없습니다. 유형은 조건에 맞는 등록 정보 값과 RTR 파일 항목에서 허용된 유형별 속성을 결정합니다. enum 유형은 일련의 문자열 값입니다. |
|
Default |
등록 정보에 대한 기본값을 나타냅니다. |
| Tunable |
클러스터 관리자가 자원에서 이 등록 정보의 값을 설정할 수 있는 시기를 나타냅니다. 관리자가 등록 정보를 설정하지 못하도록 None 또는 False로 설정할 수 있습니다. 관리자가 조정할 수 있는 값은 True나 Anytime (항시 가능), At_creation (자원이 생성될 때) 또는 When_disabled (자원이 오프라인 상태일 때)입니다.기본값은 True (Anytime)입니다. |
|
Enumlist |
enum 유형으로서 등록 정보에 대해 허용되는 일련의 문자열 값. |
|
Min |
int 유형으로서 등록 정보에 대해 허용되는 최소값. |
|
Max |
int 유형으로서 등록 정보에 대해 허용되는 최대값. |
|
Minlength |
string과 stringarray 유형으로서 허용되는 최소 문자열 길이. |
|
Maxlength |
string과 stringarray 유형으로서 허용되는 최대 문자열 길이. |
|
Array_minsize |
stringarray 유형으로서 허용되는 배열 요소의 최소 개수. |
|
Array_maxsize |
stringarray 유형으로서 허용되는 배열 요소의 최대 개수. |