リソース

表示
一般的なリソースプロパティ
詳細なリソースプロパティ

アクション
リソースの有効化
リソースの無効化
リソースモニターの有効化
リソースモニターの無効化
リソースプロパティの変更
負荷均衡の変更
STOP_FAILED フラグのクリア
リソースの作成
リソースの削除


一般的なリソースプロパティの表示

リソースのプロパティは、一般ビューと詳細ビューで表示できます。

リソースプロパティの一般ビューを表示するには、次の手順を実行します。

  1. SunPlexTM Manager のナビゲーションフレームで、 「リソースグループ」、「[リソースグループ名]」、「[リソース名]」の順に選択します。

  2. 「 表示 」メニューから、「一般プロパティ表」を選択します。
各プロパティの完全な説明については、「
リソースプロパティ表」を参照してください。

先頭へ戻る


詳細なリソースプロパティの表示

追加のシステムプロパティおよび拡張プロパティを表示するリソースプロパティの詳細ビューを表示するには、次の手順を実行します。
  1. SunPlex Manager のナビゲーションフレームで、 「リソースグループ」、「[リソースグループ名]」、「[リソース名]」の順に選択します。

  2. 「 表示 」メニューから、「詳細属性表」を選択します。
各プロパティの完全な説明については、「
リソースプロパティ表」を参照してください。

先頭へ戻る


リソースの有効化

クラスタがリソースを認識するようにするには、そのリソースを有効にする必要があります。
  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ 」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「リソースを有効」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. 有効にするリソースを選択します。

  4. 「リソースを有効」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 将来的なスクリプトおよび別の自動タスクでの使用のために、このコマンドを書き留めておくかコピーします。

先頭へ戻る


リソースの無効化

リソースの無効化とは、リソースをオフラインにし、リソースグループのフェイルオーバー時にそのリソースが再びオンラインになる可能性を排除することです。

リソースが使用するノードまたディスクで保守作業を行う場合、リソースを無効にする必要があります。

  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ 」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「リソースを無効」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. 無効にするリソースを選択します。

    このリソースに依存するリソースが存在する場合は、無効にできません。

  4. 「リソースを無効」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 将来的なスクリプトおよび別の自動タスクでの使用のために、このコマンドを書き留めておくかコピーします。

先頭へ戻る


リソースモニターの有効化

リソースモニターは、リソースを有効にすると自動的に有効になります。 したがって、リソースモニターはそれを無効にした場合にのみ有効にする必要があります。 次の手順を実行します。
  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ 」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「リソースモニターを有効」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. モニターを有効にするリソースを選択します。

  4. 「リソースモニターを有効」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 将来的なスクリプトおよび別の自動タスクでの使用のために、このコマンドを書き留めておくかコピーします。

先頭へ戻る


リソースモニターの無効化

リソースモニターは、リソースを無効にすると自動的に停止します。 リソースモニターは、リソースの構成を変更またはトラブルシュートする場合に無効にする必要があります。

警告 リソースモニターを無効にすると、そのリソースは高可用性ではなくなります。 そのリソースは、障害発生時にフェイルオーバーしません。

リソースのモニターを無効にするには、次の手順を実行します。

  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ 」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「リソースモニターを無効」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. モニターを無効にするリソースを選択します。

  4. 「リソースを無効」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 将来的なスクリプトおよび別の自動タスクでの使用のために、このコマンドを書き留めておくかコピーします。

先頭へ戻る


リソースプロパティの変更

クラスタの構成を変更するには、リソースプロパティを変更する必要があります。リソースプロパティを変更できるかどうかを確認するには、「
リソースプロパティ表」を参照してください。 この表の値が Tunable であれば、プロパティを変更できることを示します。

リソースのプロパティを変更するには、次の手順を実行します。

  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「リリースプロパティを変更」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. 変更するリソースを選択します。

  4. 「次へ」をクリックします。

    SunPlex Manager は、リソースプロパティの入力を求める別のウィンドウを表示します。 これらのプロパティの詳細については、「 リソースプロパティ表」を参照してください。

  5. 指定のフィールドに新しい情報を入力して、該当するプロパティ値を変更します。

  6. 「リソースの変更」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 将来的なスクリプトおよび別の自動タスクでの使用のために、このコマンドを書き留めておくかコピーします。

先頭へ戻る


負荷均衡の変更

スケーラブルサービスで負荷分散を構成するには、リソースのウエイトを変更する必要があります。
  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「負荷均衡を変更」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. 変更するリソースを選択します。

  4. 「負荷均衡を変更」をクリックします。

    ウィンドウが表示されます。 このウィンドウには、現行のウエイトが表示されます。

  5. 負荷均衡を調整します。

    負荷均衡を調整するには、「ウェイト」フィールドに新しい番号を入力します。 ノードのウエイトを変更すると、「負荷分散」フィールドは新しい負荷の分散で自動的に更新されます。 この分散は、パーセンテージで表示されます。

    注: 「Load Distribution」フィールドの値は、Web ブラウザで JavaScriptTM 技術が有効な場合にのみ表示されます。 JavaScript 技術が無効な場合は、このフィールドは空のままです。

    次の表に例を示します。

    リソースを実行するノード ノードあたりのウェイト 負荷分散
    ノード 1 1 25%
    ノード 2 1 25%
    ノード 3 2 50%

    負荷分散の算出方法
    負荷分散を算出するには、すべてのノードのウェイトの合計でノードのウェイトを割ります。 すべてのノードのウェイトの合計は、すべてのノードのウェイトを足すことで算出します。

    この例では、ノード 1 のウェイトは 1 で、ウェイトの合計は 4 です。 したがって、ノード 1 の負荷は、合計負荷の 1/4 つまり 25% になります。

  6. 「負荷均衡を変更」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 将来的なスクリプトおよび別の自動タスクでの使用のために、このコマンドを書き留めておくかコピーします。

先頭へ戻る


STOP_FAILED フラグのクリア

グループをオフライン化 作業に失敗した場合、STOP_FAILED フラグを消去する必要があります。

STOP_FAILED リソース状態になると、そのリソースが制御するアプリケーションのインスタンスは起動できなくなります。 STOP_FAILED フラグを消去する前に、リソースがオフラインであることを確認してください。

リソースが STOP_FAILED 状態のときは、次の作業を実行できません。

STOP_FAILED フラグを消去するには、次の手順を実行します。

推奨する手順 推奨する手順。 telent ウィンドウを開き、問題のリソースがあるノードに接続します。 手動でリソースアプリケーションを停止します。

この手順では、プロセスの強制終了、リソース固有のコマンドの実行、別のコマンドの使用などの操作が必要になる場合があります。

  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ 」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「STOP_FAILED フラグをクリア」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. STOP_FAILED フラグを消去する必要のあるリソースを選択します。

  4. 「フラグをクリア」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 リソースおよびリソースグループの状態がオフラインになりました。

注: STOP_FAILED フラグを消去し、リソースアプリケーションを手動で停止しなかった場合は、そのリソースが正しく停止されていない可能性があります。

先頭へ戻る


リソースの作成

5 種類のリソースを作成できます。

論理ホスト名リソースを作成するには、次の手順を実行します。

警告 論理ホスト名リソースを作成するには、アダプタまたは IPMP グループのどちらかが、新しく作成される論理ホスト名と同じサブネット用に構成されている必要があります。 いずれかが構成されていない場合、次のエラーメッセージを受け取ります。

specified hostname(s) cannot be hosted by any adapter on ...

新しいサブネット上でアダプタおよび IPMP グループを構成するには、 IPMP グループを作成します。

  1. SunPlex Manager のナビゲーションフレームから、「ノード」、「ノード名」、「IPMP グループ」の順に選択します。

  2. 「アクション」メニューから、「グループを作成」を選択します。
  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ 」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「新しいリソースを作成」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. リソースタイプの「論理ホスト名リソースタイプ」を選択します。

  4. 関連するネットワークリソースについては、「なし」を選択します。

  5. 「継続」をクリックします。

    SunPlex Manager は、リソースプロパティの入力を求める別のウィンドウを表示します。

  6. 構成のリソースプロパティ情報を入力します。

    これらのプロパティの詳細については、「 リソースプロパティ表」を参照してください。

    特定のリソースグループの拡張プロパティについては、『Sun Cluster 3.1 データサービスのインストールと構成 』を参照してください。

  7. 「リソースを作成」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 将来的なスクリプトおよび別の自動タスクでの使用のために、このコマンドを書き留めておくかコピーします。

先頭へ戻る


共有アドレスリソースを作成するには、次の手順を実行します。

警告 共有アドレスリソースを作成するには、アダプタまたは IPMP グループのどちらかが、新しく作成される共有アドレスと同じサブネット用に構成されている必要があります。 いずれかが構成されていない場合、次のエラーメッセージを受け取ります。

specified hostname(s) cannot be hosted by any adapter on ...

新しいサブネット上でアダプタおよび IPMP グループを構成するには、 IPMP グループを作成します。

  1. SunPlex Manager のナビゲーションフレームから、「ノード」、「[ノード名]」、「IPMP グループ」の順に選択します。

  2. 「アクション」メニューから、「グループを作成」を選択します。
  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ 」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「新しいリソースを作成」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. リソースタイプの「HA 共有アドレスリソースタイプ」を選択します。

  4. 関連するネットワークリソースについては、「なし」を選択します。

  5. 「継続」をクリックします。

    SunPlex Manager は、リソースプロパティの入力を求める別のウィンドウを表示します。

  6. 構成のリソースプロパティ情報を入力します。

    これらのプロパティの詳細については、「 リソースプロパティ表」を参照してください。

    特定のリソースグループの拡張プロパティについては、『Sun Cluster 3.1 データサービスのインストールと構成 』を参照してください。

  7. 「リソースを作成」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 将来的なスクリプトおよび別の自動タスクでの使用のために、このコマンドを書き留めておくかコピーします。

先頭へ戻る


フェイルオーバーデータサービスを作成するには、次の手順を実行します。

  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ 」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「新しいリソースを作成」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. サービスのリソースタイプ名を選択します。

  4. 関連するネットワークリソースの論理ホスト名を選択します。

    論理ホスト名は、(lh) で示されます。

  5. 「継続」をクリックします。

    SunPlex Manager は、リソースプロパティの入力を求める別のウィンドウを表示します。

    注: リソースタイプが登録されていない場合、 SunPlex Manager はリソースタイプの登録を促します。 「登録」をクリックします。

  6. 構成のリソースプロパティ情報を入力します。

    これらのプロパティの詳細については、「 リソースプロパティ表」を参照してください。

    特定のリソースグループの拡張プロパティについては、『Sun Cluster 3.1 データサービスのインストールと構成 』を参照してください。

  7. 「リソースを作成」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 将来的なスクリプトおよび別の自動タスクでの使用のために、このコマンドを書き留めておくかコピーします。

先頭へ戻る


スケーラブルデータサービスを作成するには、次の手順を実行します。

  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ 」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「新しいリソースを作成」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. サービスのリソースタイプ名を選択します。

  4. 関連するネットワークリソースの共有アドレスを選択します。

    共有アドレスは、(sa) で示されます。

  5. 「継続」をクリックします。

    SunPlex Manager は、リソースプロパティの入力を求める別のウィンドウを表示します。

  6. 構成のリソースプロパティ情報を入力します。

    これらのプロパティの詳細については、「 リソースプロパティ表」を参照してください。

    特定のリソースグループの拡張プロパティについては、『Sun Cluster 3.1 データサービスのインストールと構成 』を参照してください。

  7. 「リソースを作成」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 将来的なスクリプトおよび別の自動タスクでの使用のために、このコマンドを書き留めておくかコピーします。

先頭へ戻る


ネットワークから見えないリソースを作成するには、次の手順を実行します。

  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ 」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「新しいリソースを作成」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. リソースのリソースタイプ名を選択します。

  4. 関連するネットワークリソースについては、「なし」を選択します。

  5. 「継続」をクリックします。

    SunPlex Manager は、リソースプロパティの入力を求める別のウィンドウを表示します。

  6. 構成のリソースプロパティ情報を入力します。

    これらのプロパティの詳細については、「 リソースプロパティ表」を参照してください。

    特定のリソースグループの拡張プロパティについては、『Sun Cluster 3.1 データサービスのインストールと構成 』を参照してください。

  7. 「リソースを作成」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 将来的なスクリプトおよび別の自動タスクでの使用のために、このコマンドを書き留めておくかコピーします。

先頭へ戻る


リソースの削除

構成またはクラスタの機能を変更した場合は、リソースを削除する必要があります。

SunPlex Manager は、リソースを削除する前にそのリソースを自動的に無効にします。

リソースを削除するには、次の手順を実行します。

  1. SunPlex Manager のナビゲーションフレームで、「リソースグループ」セクションから「リソースグループ 」 または「[リソースグループ名]」を選択します。

    「リソースグループ」ウィンドウが表示されます。

  2. 「アクション」メニューから、「リソースを削除」を選択します。

    タスクウィンドウが表示されます。 このウィンドウでは、追加情報の入力が求められます。

  3. 削除するリソースを選択します。

  4. 「リソースを削除」をクリックします。

    SunPlex Manager は、確認メッセージとこのタスクを完了するために使用されたコマンドを表示します。 将来的なスクリプトおよび別の自動タスクでの使用のために、このコマンドを書き留めておくかコピーします。

先頭へ戻る