プロパティ表

リソースタイプのプロパティ表
リソースのプロパティ表
リソースグループのプロパティ表
リソースプロパティの属性表

リソースタイプのプロパティ

リソースのプロパティ値は、以下のカテゴリに分類されます。

必須 -- プロパティはリソースタイプ登録 (RTR) ファイルに明示的な値を必要とします。 そうでない場合、プロパティが属するオブジェクトは作成できません。 ブランクまたは空の文字列を値として指定することはできません。

条件付き -- このプロパティが存在するためには、RTR ファイル内で宣言する必要があります。 そうでない場合、リソースグループマネージャはプロパティを作成しません。 また、管理ユーティリティもプロパティを利用できません。 ブランクまたは空の文字列を値として指定できます。 プロパティが RTR ファイル内で宣言されており、値が指定されていない場合には、リソースグループマネージャはデフォルト値を使用します。

条件付き/明示 -- このプロパティが存在するためには、RTR ファイル内で明示的に値を指定して宣言する必要があります。 そうでない場合、リソースグループマネージャはプロパティを作成しません。 また、管理ユーティリティもプロパティを利用できません。 ブランクまたは空の文字列を値として指定することはできません。

任意 -- プロパティは RTR ファイル内で宣言してもしなくてもかまいません。 宣言がない場合は、リソースグループマネージャはこのプロパティを作成し、デフォルト値を使用します。 プロパティが RTR ファイル内で宣言されており、値が指定されていない場合には、リソースグループマネージャはデフォルト値を使用します。 このデフォルト値は、プロパティが RTR ファイル内で宣言されていないときに使用される値と同じです。

管理ユーティリティではリソースタイプのプロパティを更新できませんが、RTR ファイル内で宣言できない Installed_nodes だけは例外です。 Installed_nodes は管理者が設定する必要があります。

リソースタイプのプロパティ

プロパティ名 説明

Allow_hosts

(文字配列 )

クラスタ構成イベントを受け取るために cl_apid デーモンに登録できるクライアントを制御します。 このプロパティは一般に ipaddress/masklength という書式をとり、クライアント登録が行えるサブネットを定義します。 たとえば、 129.99.77.0/24 と設定すると、サブネット 129.99.77 上のクライアントがイベント登録を行えます。また、 192.9.84.231/32 と設定すると、イベント登録を行えるのはクライアント 192.9.84.231 だけになります。このプロパティは、CRNP にセキュリティーを提供します。 cl_apid デーモンについては、SUNW.Event (5) のマニュアルページで説明しています。

また、次に示す特殊なキーワードも認識されます。 LOCAL は、直結されたクラスタサブネット内のクライアントを意味します。 ALL と指定すると、すべてのクライアントが登録されます。 Allow_hosts プロパティと Deny_hosts プロパティ双方のエントリとしてクライアントを指定すると、そのクライアントは実装に登録されません。

カテゴリ: 任意

初期値: LOCAL

調整: 不可

API_version

(整数)

このリソースタイプの実装によって使用される リソース管理 API のバージョン。

カテゴリ: 任意

初期値: 2

調整: 不可

Boot

(文字列)

任意のコールバックメソッド。リソースグループマネージャがノード上で呼び出すプログラムへのパス。 このノードは、このタイプのリソースがすでに管理されているときにクラスタに参加または再参加します。 このメソッドは、 Init メソッドと同様に、このタイプのリソースの初期化を行う必要があります。

カテゴリ: 条件付き/明示

初期値: デフォルトは存在しない

調整: 不可

Client_retry_count

(整数)

外部クライアントとの通信中に cl_apid デーモンによって行われる試行の回数を制御します。 Client_retry_count で指定された回数だけ試行する間にクライアントが応答に失敗すると、そのクライアントはタイムアウトし、 クラスタ再構成イベントを受け取ることができるクライアントが登録されたリストから削除されます。 元のようにイベントを受け取ることができるようにするには、そのクライアントを登録し直す必要があります。 実装によるこれらの試行の頻度の詳細は、 Client_retry_interval プロパティの説明を参照してください。 cl_apid デーモンについては、 SUNW.Event (5) で説明しています。

カテゴリ: 任意

初期値: 3

調整: 任意の時点

Client_retry_interval

(整数)

応答のない外部クライアントと通信を行う際に cl_apid デーモンが使用する時間 (秒数) を定義します。クライアントとコンタクトをとるために、 Client_retry_count に指定された回数の試行がこの時間内になされます。 cl_apid デーモンについては、 SUNW.Event (5) で説明しています。

カテゴリ: 任意

初期値: 1800

調整: 任意の時点

Client_timeout

(整数)

外部クライアントと通信を行う際に cl_apid デーモンが使用するタイムアウト値 (秒数) です。しかし、 cl_apid デーモンは設定されている試行回数 (調整可能) だけクライアントとの通信を試し続けます。このプロパティの調整に利用できる方法の詳細は、 Client_retry_count プロパティと Client_retry_interval プロパティの説明を参照してください。 cl_apid デーモンについては、 SUNW.Event (5) で説明しています。

カテゴリ: 任意

初期値: 60

調整: 任意の時点

Deny_hosts

(文字配列 )

クラスタ再構成イベントを受け取ることができないように、クライアントを制御します。 アクセスを決定する上で、このプロパティの設定は Allow_hosts リスト内の設定よりも優先されます。 このプロパティの書式は、 Allow_hosts プロパティで使用される書式と同じです。 このプロパティは、CRNP にセキュリティーを提供します。

カテゴリ: 任意

初期値: NULL

調整: 任意の時点

Failover

(ブール値)

True は、複数のノード上で同時にオンラインにできる任意のグループ内に、このタイプのリソースを構成できないことを示します。

カテゴリ: 任意

初期値: False

調整: 不可

Fini

(文字列)

任意のコールバックメソッド。 このタイプのリソースがリソースグループマネージャ の管理下から外れたときに、リソースグループマネージャが呼び出すプログラムへのパス。

カテゴリ: 条件付き/明示

初期値: デフォルトは存在しない

調整: 不可

Init

(文字列)

任意のコールバックメソッド。 このタイプのリソースがリソースグループマネージャ の管理下に入ったときに、リソースグループマネージャが呼び出すプログラムへのパス。

カテゴリ: 条件付き/明示

初期値: デフォルトは存在しない

調整: 不可

Init_nodes

(列挙)

リソースグループマネージャが Init, Fini, Boot, Validate メソッドを呼び出すノードを示します。 値には、 RG_primaries (リソースをマスターできるノードだけ)、または RT_installed_nodes (リソースタイプがインストールされるすべてのノード) を指定できます。

カテゴリ: 任意

初期値: RG_primaries

調整: 不可

Installed_nodes

(文字配列 )

リソースタイプの実行が許可されるクラスタノード名のリスト。 このプロパティはリソースグループマネージャが自動的に作成します。 クラスタ管理者は値を設定できます。 RTR ファイル内には宣言できません。

カテゴリ: クラスタ管理者自身で設定できる

初期値: すべてのクラスタノード

調整: 任意の時点

Max_clients

(整数)

クラスタイベントの通知を受け取るように cl_apid デーモンに登録できるクライアントの最大数を制御します。 イベント通知を受け取ろうとしてこの数を超えるクライアントが登録を試みても、アプリケーションによって拒否されます。 登録された各クライアントはクラスタ上のリソースを使用するため、このプロパティを調整することで外部クライアントによるクラスタリソース利用を制御できます。 cl_apid デーモンについては、 SUNW.Event (5) で説明しています。

カテゴリ: 任意

初期値: 1000

調整: 任意の時点

Monitor_check

(文字列)

任意のコールバックメソッド。 このタイプのリソースの障害モニターが要求するフェイルオーバーを行う前に、リソースグループマネージャが呼び出すプログラムへのパス。

カテゴリ: 条件付き/明示

初期値: デフォルトは存在しない

調整: 不可

Monitor_start

(文字列)

任意のコールバックメソッド。 このタイプのリソースの障害モニターを起動するために、リソースグループマネージャが呼び出すプログラムへのパス。

カテゴリ: 条件付き/明示

初期値: デフォルトは存在しない

調整: 不可

Monitor_stop

(文字列)

Monitor_start が設定されている場合に要求されるコールバックメソッド、あるいは、このタイプのリソースの障害モニターを停止するためにリソースグループマネージャが呼び出すプログラムへのパス。

カテゴリ: 条件付き/明示

初期値: デフォルトは存在しない

調整: 不可

クライアントノードごとの Num_resource_restarts

(整数)

このプロパティは、RGM によって、このノード上でこのリソースのために最後の [n] 秒間に行われた scha_control RESTART 呼び出しの数に設定されます。[n] は、リソースの Retry_interval プロパティの値です。 リソースタイプが Retry_interval プロパティを宣言していない場合、このタイプのリソースに Num_resource_restarts プロパティを使用することはできません。

カテゴリ: 照会のみ

初期値: デフォルトは存在しない

調整: 不可

Pkglist

(文字配列 )

リソースタイプのインストールに含まれている任意のパッケージリスト。

カテゴリ: 条件付き/明示

初期値: デフォルトは存在しない

調整: 不可

Postnet_stop

(文字列)

任意のコールバックメソッド。 このタイプのリソースが依存しているネットワークアドレスリソース ( Network_resources_used ) の Stop メソッドを呼び出したあとでリソースグループマネージャが起動するプログラムのパスです。 このメソッドはネットワークインタフェースが停止に構成されたあとに実行される Stop アクションを伴います。

カテゴリ: 条件付き/明示

初期値: デフォルトは存在しない

調整: 不可

Prenet_start

(文字列)

任意のコールバックメソッド。あるいは、このタイプのリソースが依存する任意のネットワークアドレスリソース ( Network_resources_used ) の Start メソッドが呼び出される前にリソースグループマネージャが呼び出すプログラムへのパス。 このメソッドはネットワークインタフェースが動作に構成される前に実行される Start アクションを伴います。

カテゴリ: 条件付き/明示

初期値: デフォルトは存在しない

調整: 不可

Resource_type

(文字列)

リソースタイプの名前。

現在登録されているリソースタイプの名前を表示するには、次のコマンドを使用します。

scrgadm -p

Sun Cluster 3.1 以降では、リソースタイプ名の構文は次のとおりです。

[vendor_id].[resource_type]:[version]

リソースタイプ名の 3 つの部分は、RTR ファイルに指定された Vendor_id 、 Resource_type 、および RT_version プロパティです。 scrgadm コマンドは、ピリオド (.) とコロン (:) の区切り文字を挿入します。 リソースタイプ名の RT_version 接尾辞は、 RT_version プロパティの値と同じです。

Vendor_id が一意であることを保証するためには、リソースタイプを作成した会社の株式市場での略号を使用します。

注: Sun Cluster 3.1 リリースより前に作成されたリソースタイプ名の構文は次のとおりです。

[vendor_id].[resource_type]

カテゴリ: 必須

初期値: 空の文字列

調整: 不可

RT_basedir

(文字列)

コールバックメソッドの相対パスを補うために使用するディレクトリパス。 このパスには、リソースタイプのパッケージが存在するディレクトリを設定します。 このパスは、スラッシュ ( / ) から始まる絶対パスである必要があります。

カテゴリ: 必須 (すべてのメソッドパスが絶対パスである場合を除く)

初期値: デフォルトは存在しない

調整: 不可

RT_description

(文字列)

リソースタイプの簡単な説明。

カテゴリ: 条件付き

初期値: 空の文字列

調整: 不可

RT_system

(ブール値)

リソースタイプが True に設定される場合、そのリソースタイプに対して許可されている scrgadm (1M) オペレーションが制限されることを示します。 RT_System 値が True に設定されるリソースタイプは、システムリソースタイプと呼ばれます。 RT_System の現在の値にかかわらず、 RT_System プロパティの編集自体は制限されません。

カテゴリ: 任意

初期値: False

調整: 任意の時点

RT_version

(文字列)

Sun Cluster 3.1 以降では、このリソースタイプの実装の必須バージョン文字列。 RT_version は、完全なリソースタイプ名の接尾辞部分です。

カテゴリ: 条件付き/明示

初期値: デフォルトは存在しない

調整: 不可

Single_instance

(ブール値)

True の場合、このタイプのリソースタイプがクラスタ内に 1 つしか存在できないことを示します。したがって、リソースグループマネージャはこのタイプのリソースをクラスタ全体で 1度に 1 つだけ実行させることができます。

カテゴリ: 任意

初期値: False

調整: 不可

Start

(文字列)

コールバックメソッド。 このタイプのリソースを起動するために、リソースグループマネージャが呼び出すプログラムへのパス。

カテゴリ: 必須 (RTR ファイルが Prenet_start メソッドを宣言している場合を除く)

初期値: デフォルトは存在しない

調整: 不可

Stop

(文字列)

コールバックメソッド。 このタイプのリソースを停止するために、リソースグループマネージャが呼び出すプログラムへのパス。

カテゴリ: 必須 (RTR ファイルが Postnet_stop メソッドを宣言している場合を除く)

初期値: デフォルトは存在しない

調整: 不可

Update

(文字列)

任意のコールバックメソッド。 このタイプの動作中のリソースのプロパティを変更されたときに、リソースグループマネージャが呼び出すプログラムへのパス。

カテゴリ: 条件付き/明示

初期値: デフォルトは存在しない

調整: 不可

Validate

(文字列)

任意のコールバックメソッド。 このタイプのリソースのプロパティ値を検査するために、リソースグループマネージャが呼び出すプログラムへのパス。

カテゴリ: 条件付き/明示

初期値: デフォルトは存在しない

調整: 不可

Vendor_ID

(文字列)

Resource_type プロパティを参照してください。

カテゴリ: 条件付き

初期値: デフォルトは存在しない

調整: 不可

先頭へ戻る


リソースのプロパティ

この説明は、データサービスの開発者を対象としたものです。

特定のデータサービスの詳細は、そのデータサービスのマニュアルページを参照してください。 リソースプロパティ値は、以下のように分類されます。

必須 -- 管理者は、管理ユーティリィティでリソースを作成するときに、必ず値を指定する必要があります。

任意 -- 管理者がリソースグループの作成時に値を指定しない場合、システムがデフォルト値を提供します。

条件付き -- リソースグループマネージャがプロパティを作成するのは、プロパティが RTR ファイル内で宣言されている場合だけです。 そうでない場合、プロパティは存在しません。 また、システム管理者もプロパティを利用できません。 RTR ファイル内で宣言された条件付きプロパティは任意または必須のどちらかです。 条件付きプロパティが任意または必須のどちらであるかを決定するのは、デフォルト値が RTR ファイルに指定されているかどうかです。 詳細については、各条件付きプロパティの説明を参照してください。

照会のみ -- 管理ツールからは直接設定できません。 「照会のみ」には、次の値が含まれます。

None または False

不可

True または Anytime

任意の時点

At_creation

リソースをクラスタに追加するとき

When_disabled

リソースを無効にするとき

リソースのプロパティ

プロパティ名 説明

Affinity_timeout

(整数)

クライアントが、スティッキスケーラブルサービスへの接続をすべて閉じた後、IP アフィニティ (IP 対応) が持続する秒数を制御します。このタイムアウトが終了するまでは、当該クライアントからの新しい接続はすべて同じクラスタノードに転送されます。 値が 0 の場合、クライアントとスケーラブルサービスとの間に接続が存在する限り、アフィニティは継続します。値が -1 の場合、クライアントがバインドされているクラスタノードに障害が起きるか、または再起動されるまで、アフィニティは持続します。 したがって、タイムアウト期間は適用されません。

このプロパティは、 Load_balancing_policy = Lb_sticky または Lb_sticky_wild を持つリソースだけに適用されます。

カテゴリ: 任意

初期値: 0

調整: 任意の時点

Cheap_probe_interval

(整数)

リソースの即時障害検証の呼び出しの間隔 (秒数)。 このプロパティを作成するのはリソースグループマネージャだけです。 このプロパティが RTR ファイル内で宣言されている場合、管理者はこのプロパティを利用できます。

RTR ファイル内でデフォルト値が指定されている場合、このプロパティは任意です。 リソースタイプファイル内で Tunable 属性が指定されていない場合、プロパティの Tunable 値は When_disabled になります。

Default 属性が RTR ファイルのプロパティ宣言で指定されていない場合、このプロパティは必須です。

カテゴリ: 条件付き

初期値: 上記を参照

調整: 無効にしたとき

拡張プロパティ

そのリソースのタイプの RTR ファイルで宣言される拡張プロパティ。リソースタイプの実装によって、これらのプロパティを定義します。拡張プロパティに設定できる個々の属性の詳細は、リソースプロパティの属性 を参照してください。

カテゴリ: 条件付き

初期値: デフォルトは存在しない

調整: 特定のプロパティに依存

Failover_mode

(列挙)

None, Soft, Hard のいずれかの設定が可能です。 リソースに対するメソッド呼び出し Start, Stop, または Monitor_stop が失敗した場合、RGM にリソースグループを再配置させるか、またはノードを停止させるかを制御します。

None に設定すると、RGM はメソッドの失敗時にリソース状態を設定し、オペレータの介入を待ちます。

Soft に設定すると、RGM は Start メソッドの失敗時にリソースのグループを別のノードに再配置します。 Stop または Monitor_stop メソッドの失敗時には、リソースの状態を STOP_FAILED 、リソースグループの状態を ERROR_STOP_FAILED に設定し、オペレータの介入を待ちます。 None と Soft のどちらに設定しても、 Stop または Monitor_stop の失敗の場合、結果は同じです。 Hard に設定すると、 Start メソッドの失敗時にグループが再配置されます。 Stop メソッドまたは Monitor_stop メソッドの失敗時には、クラスタノードの異常終了によりリソースが強制終了します。

カテゴリ: 任意

初期値: なし

調整: 任意の時点

Load_balancing_policy

(文字列)

使用する負荷均衡ポリシーを定義する文字列。このプロパティは、スケーラブルサービス専用です。 Scalable プロパティが RTR ファイル内で宣言されている場合、リソースグループマネージャは自動的にこのプロパティを作成します。

Load_balancing_policy は、次の値をとることができます。

Lb_weighted (デフォルト) : 負荷は、 Load_balancing_weights プロパティで設定されているウエイトに従って、さまざまなノードに分散されます。

Lb_sticky : スケーラブルサービスの指定のクライアント (クライアントの IP アドレスで識別される) は、常に同じクラスタノードに送信されます。

Lb_sticky_wild : ワイルドカードスティッキサービスの IP アドレスに接続する指定のクライアント (クライアントの IP アドレスで識別される) は、送信時に使用するポート番号とは無関係に、常に同じクラスタノードに送信します。

カテゴリ: 条件付き/任意

初期値: Lb_weighted

調整: 作成時

Load_balancing_weights

(文字配列 )

このプロパティは、スケーラブルリソースに対してのみ使用します。 Scalable プロパティが RTR ファイル内で宣言されている場合、リソースグループマネージャは自動的にこのプロパティを作成します。 形式は [weight]@[node], [weight]@[node] であり、 [weight] は指定する [node] に分散される負荷の相対的な値を示す整数を表します。 ノードに分散される負荷の割合は、すべてのウエイトの合計でこのノードのウエイトを割った値になります。 たとえば、 1@1,3@2 は、ノード 1 に負荷の 1/4 が割り当てられ、ノード 2 に負荷の 3/4 が割り当てられることを意味します。 この属性のデフォルトである空の文字列 ("") は、一定の分散を指定します。 明示的にウエイトを割り当てられていないノードのウエイトは、デフォルトで 1 になります。

リソースタイプファイル内で Tunable 属性が指定されていない場合、プロパティの Tunable 値は Anytime になります。 このプロパティを変更すると、新しい接続時にのみ分散が変更されます。

カテゴリ: 条件付き/任意

初期値: 空の文字列

調整: 任意の時点

Type における各コールバックメソッドの [method] _timeout

(整数)

メソッドの呼び出しが失敗したとリソースグループマネージャが結論づけるまでの時間 (秒)。

カテゴリ: 条件付き/任意

初期値: メソッドが RTR ファイル内で宣言されている場合、3,600 秒 (1 時間)

調整: 任意の時点

Monitored_switch

(列挙)

クラスタ管理者が管理ユーティリティでモニターを有効または無効のどちらにしているかによって、リソースグループマネージャが Enabled または Disabled に設定します。 Disabled に設定された場合、再び有効に設定されるまで、モニターの Start メソッドは呼び出されません。リソースがモニターのコールバックメソッドを持っていない場合、このプロパティは存在しません。

カテゴリ: 照会のみ

初期値: 有効

調整: 不可

Network_resources_used

(文字配列)

リソースが使用する論理ホスト名または共有アドレスネットワークリソースのリスト。スケーラブルサービスの場合、このプロパティは別のリソースグループに存在する共有アドレスリソースを参照する必要があります。 フェイルオーバーサービスの場合、このプロパティは同じリソースグループに存在する論理ホスト名または共有アドレスを参照します。 RTR ファイルに Scalable プロパティが宣言されている場合、RGM は自動的にこのプロパティを作成します。 Scalable が RTR ファイル内で宣言されていない場合、 Network_resources_used は RTR ファイル内で明示的に宣言されていないかぎり使用できません。

リソースタイプファイル内で Tunable 属性が指定されていない場合、プロパティの Tunable 値は At_creation になります。

カテゴリ: 条件付き/必須

初期値: デフォルトは存在しない

調整: 作成時

On_off_switch

(列挙)

クラスタ管理者が管理ユーティリティでリソースを有効または無効のどちらにしているかによって、リソースグループマネージャが Enabled または Disabled に設定します。無効に設定された場合、再び有効に設定されるまで、リソースはコールバックを呼び出しません。

カテゴリ: 照会のみ

初期値: Disabled

調整: 不可

Port_list

(文字配列 )

サーバーが待機するポート番号をコンマで区切ったリスト。各ポート番号に、そのポートが使用しているプロトコルが追加されます (例: Port_list=80/tcp )。 Scalable プロパティが RTR ファイル内で宣言されている場合、リソースグループマネージャは自動的に Port_list を作成します。 そうでない場合、このプロパティは RTR ファイル内で明示的に宣言されていない限り使用できません。

このプロパティを Apache 用に設定する方法については、『Sun Cluster 3.1 データサービスのインストールと構成』の Apache の章を参照してください。

カテゴリ: 条件付き/必須

初期値: デフォルトは存在しない

調整: 作成時

R_description

(文字列)

リソースの簡単な説明。

カテゴリ: 任意

初期値: 空の文字列

調整: 任意の時点

Resource_dependencies

(文字配列 )

同じグループまたは異なるグループにおいてこのリソースが強く依存するリソースの一覧。リスト内の任意のリソースの起動に失敗した場合、このリソースは起動されません。このリソースとそのリスト内のリソースの 1 つが同時に起動する場合、RGM はリスト内のリソースが起動するのを待ち、その後このリソースを起動します。このリソースの Resource_dependencies リスト内のリソースが起動しない場合 (リスト内のリソースのグループがオフラインの状態を継続したり、リスト内のリソースの状態が Start_failed の場合など) は、このリソースもオフライン状態に留まります。異なるリソースグループ内のリソースに依存しているためにこのリソースがオフライン状態を継続する場合は、このリソースのグループは Pending_online_blocked 状態になります。

このリソースをリスト内のリソースと同時にオフラインにすると、このリソースはリスト内のリソースよりも先に停止します。しかし、このリソースがオンライン状態を継続するかあるいは停止に失敗する場合は、リスト内の、異なるリソースグループに属するリソースが停止します。リスト内のリソースは、このリソースを始めに無効にしないかぎり無効にできません。

リソースグループにおけるデフォルトでは、アプリケーションリソースは暗黙にネットワークアドレスリソースに強く依存します。 この詳細は、「リソースグループのプロパティ」の Implicit_network_dependencies を 参照してください。

リソースグループ内では、 Prenet_start メソッドは、 Start メソッドの前に依存性の順に実行されます。 Postnet_stop メソッドは、 Stop メソッドのあとに依存性の順に実行されます。リソースグループが異なる場合、依存側は依存先リソースが Prenet_start と Start を終了するのを待ってから Prenet_start を実行します。依存先リソースは、依存側が Stop と Postnet_stop を終了するのを待ってから Stop を実行します。

カテゴリ: 任意

初期値: 空のリスト

調整: 任意の時点

Resource_dependencies_restart

(文字配列 )

同じグループまたは異なるグループ内の、このリソースが再起動のために依存するリソースの一覧。リスト内の任意のリソースの起動に失敗した場合、このリソースは起動されません。このリソースとリスト内のリソースの 1 つが同時に起動する場合、RGM はこのリスト内のリソースが起動するのを待ち、その後このリソースを起動します。

このリソースの Resource_dependencies_restart リスト内のリソースが起動しない場合 (リスト内のリソースのグループがオフライン状態を継続したり、リスト内のリソースの状態が Start_failed の場合など) は、このリソースはオフライン状態に留まります。 異なるリソースグループ内の起動に失敗するリソースに依存しているためにこのリソースがオフライン状態を継続する場合は、このリソースのグループは Pending_online_blocked 状態になります。

このリソースをリスト内のリソースと同時にオフラインにすると、このリソースはリスト内のリソースよりも先に停止します。しかし、このリソースがオンライン状態を継続するかあるいは停止に失敗する場合は、リスト内の、異なるリソースグループに属するリソースが停止します。リスト内のリソースは、このリソースを始めに無効にしないかぎり無効にできません。

このプロパティは、 再起動の依存性リストに含まれるリソースがどれか再起動するとこのリソースが再起動するという点を除いて、 Resource_dependencies とまったく同じように機能します。 このリソースの再起動は、リスト内のリソースがオンラインに戻ったあとで発生します。

リソースグループ内では、 Prenet_start メソッドは、 Start メソッドの前に依存性の順に実行されます。 Postnet_stop メソッドは、 Stop メソッドのあとに依存性の順に実行されます。 リソースグループが異なる場合、依存側は依存先リソースが Prenet_start と Start を終了するのを待ってから Prenet_start を実行します。 依存先リソースは、依存側が Stop と Postnet_stop を終了するのを待ってから Stop を実行します。

カテゴリ: 任意

初期値: 空のリスト

調整: 任意の時点

Resource_dependencies_weak

(文字配列 )

同じグループまたは異なるグループにおいてこのリソースがわずかに依存するリソースの一覧。弱い依存性は、グループ内におけるメソッドの順を決定します。RGM は、このリソースの Start メソッドの前にこのリスト内のリソースの Start メソッドを呼び出します。RGM は、リスト内のリソースの Stop メソッドの前にこのリソースの Stop メソッドを呼び出します。リスト内のリソースが起動に失敗したりオフライン状態を継続する場合でも、リソースの起動は可能です。

このリソースとその Resource_dependencies_weak リスト内のリソースが同時に起動する場合、RGM はリスト内のリソースが起動するのを待ってからこのリソースを起動します。リスト内のリソースが起動しない場合 (リスト内のリソースのグループがオフラインの状態を継続したり、リスト内のリソースの状態が Start_failed の場合など) 、このリソースが起動します。 このリソースのグループの状態は、このリソースの Resource_dependencies_weak リスト内のリソースが起動する際に一時的に Pending_online_blocked になることがあります。リスト内のすべてのリソースが起動したかあるいは起動に失敗した時点でこのリソースが起動し、そのグループの状態が Pending_online となります。

このリソースをリスト内のリソースと同時にオフラインにすると、このリソースはリスト内のリソースよりも先に停止します。しかし、このリソースがオンライン状態を継続するかあるいは停止に失敗する場合は、リスト内の、異なるリソースグループに属するリソースが停止します。リスト内のリソースは、このリソースを始めに無効にしないかぎり無効にできません。

リソースグループ内では、 Prenet_start メソッドは、 Start メソッドの前に依存性の順に実行されます。 Postnet_stop メソッドは、 Stop メソッドのあとに依存性の順に実行されます。リソースグループが異なる場合、依存側は依存先リソースが Prenet_start と Start を終了するのを待ってから Prenet_start を実行します。依存先リソースは、依存側が Stop と Postnet_stop を終了するのを待ってから Stop を実行します。

カテゴリ: 任意

初期値: 空のリスト

調整: 任意の時点

Resource_name

(文字列)

リソースインスタンスの名前。 この名前はクラスタ構成内で一意にする必要があります。リソースが作成されたあとで変更はできません。

カテゴリ: 必須

初期値: デフォルトは存在しない

調整: 不可

Resource_project_name

(文字列)

リソースに関連する Solaris プロジェクト名。 このプロパティは、Solaris リソース管理機能 (CPU 共有やリソースプールなど) をクラスタデータサービスに適用する場合に使用します。 リソースグループマネージャはリソースをオンラインにするときに、このプロジェクト名の下で関連するプロセスを起動します。 このプロパティが指定されていない場合、プロジェクト名はこのリソースを含むリソースグループの RG_project_name プロパティから取得されます (詳細については、 rg_properties (5) を参照)。 どちらのプロパティも指定されていない場合、リソースグループマネージャは事前定義されたプロジェクト名のデフォルトを使用します。 指定されたプロジェクト名はプロジェクトデータベースに存在する必要があり、さらに、指定されたプロジェクトのメンバーにユーザー root が構成されている必要があります。 このプロパティのサポートは Solaris 9 リリースからです。

注: このプロパティへの変更は、リソースが再起動された後に有効になります。

カテゴリ: 任意

初期値: Null

調整: 任意の時点

各クラスタノード上の Resource_state

(列挙)

リソースグループマネージャが決定した各クラスタノード上のリソースの状態。 状態は、 Online, Offline, Stop_failed, Start_failed, Monitor_failed および Online_not_monitored のいずれかです。

ユーザーはこのプロパティを構成できません。

カテゴリ: 照会のみ

初期値: デフォルトは存在しない

調整: 不可

Retry_count

(整数)

リソースの起動に失敗した場合に、モニターが再起動を試みる回数。 このプロパティを作成するのはリソースグループマネージャだけです。 このプロパティが RTR ファイル内で宣言されている場合、管理者はこのプロパティを利用できます。 デフォルト値が RTR ファイル内で指定されている場合、このプロパティは任意です。

リソースタイプファイル内で Tunable 属性が指定されていない場合、プロパティの Tunable 値は When_disabled になります。

Default 属性が RTR ファイルのプロパティ宣言で指定されていない場合、このプロパティは必須です。

カテゴリ: 条件付き

初期値: 説明を参照

調整: 無効にしたとき

Retry_interval

(整数)

失敗したリソースを再起動するまでの間隔 (秒)。リソースモニターは、 Retry_count とともにこのプロパティを使用します。 このプロパティを作成するのはリソースグループマネージャだけです。 このプロパティが RTR ファイル内で宣言されている場合、管理者はこのプロパティを利用できます。 デフォルト値が RTR ファイルで指定されている場合、このプロパティは任意です。

リソースタイプファイル内で Tunable 属性が指定されていない場合、プロパティの Tunable 値は When_disabled になります。

Default 属性が RTR ファイルのプロパティ宣言で指定されていない場合、このプロパティは必須です。

カテゴリ: 条件付き

初期値: 上記を参照

調整: 無効にしたとき

Scalable

(ブール値)

リソースがスケーラブルかどうかを示します。このプロパティが RTR ファイル内で宣言されている場合、リソースグループマネージャは、そのタイプのリソースに対して、次のスケーラブルサービスを自動的に作成します。 Network_resources_used, Port_list, Load_balancing_policy および Load_balancing_weights 。 これらのプロパティは、RTR ファイル内で明示的に宣言されない限り、デフォルト値を持ちます。RTR ファイル内で宣言されている場合、 Scalable のデフォルトは True です。

このプロパティが RTR ファイル内で宣言されている場合、 Tunable 属性は At_creation (作成時) に設定する必要があります。設定しなければ、リソースの生成に失敗します。

このプロパティが RTR ファイル内で宣言されていない場合、次のようになります。

  • リソースはスケーラブルではありません。
  • クラスタ管理者はこのプロパティを調整できません。
  • リソースグループマネージャはスケーラブルサービスのプロパティを設定しません。
ただし、 Network_resources_used および Port_list プロパティは、スケーラブルサービスだけでなく、非スケーラブルサービスでも有用であるため、必要に応じて明示的にこれらのプロパティを RTR ファイル内で宣言できます。

カテゴリ: 任意

初期値: 上記を参照

調整: 作成時

各クラスタノードの Status

(列挙)

リソースモニターによって設定されます。 指定可能な値は、 OK, degraded, faulted, unknown, および offline のいずれかです。 リソースグループマネージャは、リソースがオンラインになったときには、値を unknown に設定し、 リソースがオフラインになったときには、値を Offline に設定します。

カテゴリ: 照会のみ

初期値: デフォルトは存在しない

調整: 不可

各クラスタノード上の Status_msg

(文字列)

リソースモニターによって、 Status プロパティと同時に設定されます。 このプロパティは、各ノードのリソースごとに調整できます。 リソースがオフラインになったとき、リソースグループマネージャはこのプロパティを空の文字列に設定します。

カテゴリ: 照会のみ

初期値: デフォルトは存在しない

調整: 不可

Thorough_probe_interval

(整数)

リソースの高オーバーヘッド障害検証の呼び出し間隔 (秒)。 このプロパティを作成するのはリソースグループマネージャだけです。 このプロパティが RTR ファイル内で宣言されている場合、管理者はこのプロパティを利用できます。 デフォルト値が RTR ファイル内で指定されている場合、このプロパティは任意です。

リソースタイプファイル内で Tunable 属性が指定されていない場合、プロパティの Tunable 値は When_disabled になります。

Default 属性が RTR ファイルのプロパティ宣言で指定されていない場合、このプロパティは必須です。

カテゴリ: 条件付き

初期値: デフォルトは存在しない

調整: 無効にしたとき

Type

(文字列)

インスタンスのリソースタイプ。

カテゴリ: 必須

初期値: デフォルトは存在しない

調整: 不可

Type_version

(文字列)

このリソースに関連する現在のリソースタイプのバージョンを指定します。このプロパティは RTR ファイル内に宣言できません。したがって、RGM によって自動的に作成されます。 このプロパティの値は、リソースタイプの RT_version プロパティの値と同じです。リソースの作成時、 Type_version プロパティはリソースタイプ名の接尾辞として表示されるだけで、明示的には指定されません。リソースを編集する際に、 Type_version を新しい値に変更できます。

次の項目から派生:

  • 現在のリソースタイプのバージョン
  • RTR ファイル内の #$upgrade_from 指令

カテゴリ: 説明を参照

初期値: デフォルトは存在しない

調整: 説明を参照

UDP_affinity

(ブール値)

True の場合、あるクライアントからの UDP パケットは、TCP 接続と同様の方法で、同じクラスタサーバーノードに転送されます。クライアントの TCP 接続がサーバーノードに「スティック」されている場合、その UDP パケットもそのノードに送信されます。 False の場合、この動作は保持されません。あるクライアントからの UDP パケットは、そのクライアントからの TCP 接続とは異なるクラスタサーバーノードに転送されます。

このプロパティは、 Load_balancing_policy = Lb_sticky または Lb_sticky_wild を持つリソースだけに適用されます。

カテゴリ: 任意

初期値: False

調整: 無効にしたとき

Weak_affinity

(ブール値)

true の場合、弱い形式のクライアントアフィニティが有効になります。 これにより、指定のクライアントからの接続を同じサーバーノードに送信できます。ただし、次の場合は例外です。

  • 障害モニターの再起動、リソースのフェイルオーバーまたはスイッチオーバー、障害発生後のノードのクラスタへの再接続などによるサーバーリスナーの起動時
  • 管理アクションのために、スケーラブルリソースの Load_balancing_weights が変更されたとき。

弱いアフィニティはメモリーの消費とプロセッササイクルの点で、デフォルトの形式よりもオーバーヘッドを低く抑えられます。

このプロパティは、 Load_balancing_policy が Lb_sticky または Lb_sticky_wild である場合にしか適用されません。

このプロパティは、スケーラブルサービス専用です。

カテゴリ: 任意

初期値: デフォルトは存在しない

調整: 無効にしたとき

先頭へ戻る


リソースグループのプロパティ

リソースグループのプロパティ値は、以下のように分類されます。

リソースグループのプロパティ

プロパティ名 説明

Auto_start_on_new_cluster

(ブール値)

このプロパティを使用すると、新しいクラスタを形成するとき、リソースグループの自動起動を無効にできます。 True に設定した場合、リソースグループマネージャはクラスタが再起動したときに Desired_primaries を取得して、リソースグループを自動的に起動することを試みます。 False に設定した場合、リソースグループマネージャはクラスタが再起動してもリソースグループを自動的に起動しません。

カテゴリ: 任意

初期値: True

調整: 任意の時点

Desired_primaries

(整数)

リソースグループを同時に実行できるノードの数。

デフォルトは 1 です。 RG_mode プロパティが Failover の場合、このプロパティの値は 1 より大きく設定してはいけません。 RG_mode プロパティが Scalable の場合、このプロパティの値は 1 より大きく設定してもかまいません。

カテゴリ: 任意

初期値: 1 (上記を参照)

調整: 任意の時点

Failback

(ブール値)

クラスタメンバーシップが変更されたとき、リソースグループがオンラインになるノードセットを再計算するかどうかを指定するブール値。 再計算によって、リソースグループマネージャは優先度の低いノードでリソースグループをオフラインにし、優先度の高いノードでリソースグループをオンラインにします。

カテゴリ: 任意

初期値: False

調整: 任意の時点

Global_resources_used

(文字配列 )

このリソースグループ内の任意のリソースがクラスタファイルシステムを使用するかどうかを示します。管理者は、すべての広域リソースを示すアスタリスク記号 (*) と、広域リソースなしを示す空の文字列 ( "" ) も指定できます。

カテゴリ: 任意

初期値: すべての広域リソース

調整: 任意の時点

Implicit_network_dependencies

(ブール値)

True のときこのブール値は、リソースグループ内のネットワークアドレスリソースに対して、非ネットワークアドレスリソースの暗黙の強い依存関係を、リソースグループマネージャが強制することを指定します。 結果として、リソースグループマネージャは、リソースグループ内のすべてのネットワークアドレスリソースを起動してから、ほかのすべてのリソースを起動し、ほかのすべてのリソースを停止したあとにネットワークアドレスリソースを停止します。 ネットワークアドレスリソースには、論理ホスト名と共有アドレスリソース型があります。

スケーラブルリソースグループの場合、ネットワークアドレスリソースを含んでいないため、このプロパティは効果がありません。

カテゴリ: 任意

初期値: True

調整: 無効にしたとき

Maximum_primaries

(整数)

リソースグループが同時にオンラインになることのできるノードの最大数。

デフォルトは 1 です。 RG_mode プロパティが Failover の場合、このプロパティの値は 1 より大きく設定してはいけません。 RG_mode プロパティが Scalable の場合、このプロパティの値は 1 より大きく設定してもかまいません。

カテゴリ: 任意

初期値: 1 (上記を参照)

調整: 任意の時点

Nodelist

(文字配列 )

優先順位に従ってリソースグループをオンラインにできるクラスタノードをコンマで区切ったリスト。 これらのノードは、潜在的主ノードまたはリソースグループのマスターです。

カテゴリ: 任意

初期値: すべてのクラスタノードの順不同のリスト

調整: 任意の時点

Pathprefix

(文字列)

リソースグループ内のリソースが重要な管理ファイルを書き込むことができるクラスタファイルシステム内のディレクトリ。 一部のリソースの必須プロパティです。 各リソースグループの Pathprefix は、一意にする必要があります。

カテゴリ: 任意

初期値: 空の文字列

調整: 任意の時点

Pingpong_interval

(整数)

これは、再構成が発生した場合や scha_control -O GIVEOVER コマンドまたは SCHA_GIVEOVER 引数が指定された scha_control 関数が実行された場合に RGM がリソースグループをオンラインにする場所を決定するために使用する負でない整数値 (秒数) です。

再構成において、特定のノード上で Pingpong_interval で指定した秒数内に、(リソースの Start または Prenet_start メソッドがゼロ以外の値で終了、またはタイムアウトによって終了したことが原因で) リソースグループをオンラインにする動作が 2 回以上失敗した場合、RGM はそのノードはリソースグループのホストとして不適切だと判断し、別のマスターを探します。

リソースの scha_control コマンドまたは scha_control 関数の呼び出しによって、 Pingpong_interval で指定した秒数内に特定のノード上でリソースグループがオフラインになった場合、別のノードから scha_control が呼び出されると、そのノードはリソースグループのホストとして不適切だと判断されます。

カテゴリ: 任意

初期値: 3600 (1 時間)

調整: 任意の時点

Resource_list

(文字配列 )

リソースグループに含まれるリソースのリスト。管理者はこのプロパティを直接設定しません。このプロパティは、管理者がリソースをリソースグループに追加したとき、または、リソースグループからリソースを削除したときに、リソースグループマネージャによって更新されます。

カテゴリ: 照会のみ

初期値: 空のリスト

調整: 不可

RG_Affinities

(文字列)

RGM は、指定されたほかのリソースグループの現在のマスターであるノード (ポジティブアフィニティ) でこのリソースグループを見つけようとするか、あるいは指定されたリソースグループの現在のマスターではないノード (ネガティブアフィニティ) でこのリソースグループを見つけようとします。

次に設定の種類を示します。

  • ++ (強いポジティブ)
  • + (弱いポジティブ)
  • - (弱いネガティブ)
  • - - (強いネガティブ)

強いアフィニティは、徹底した強制力を持ちます。このリソースグループは、リスト内のリソースグループがオンライン (強いポジティブアフィニティ) でもオフライン (強いネガティブアフィニティ) でもないノード上でオンライン状態に切り替えられることはけっしてなく、オンライン状態を維持することも許されません。つまり、このリソースグループは強いポジティブアフィニティの関係にあるグループに自動的に「追随」し、強いネガティブアフィニティの関係にあるグループから自動的に「退避」します。

(ほかのリソースグループの現在の状態にもとづいて) このグループの強いアフィニティを満たせるだけのノードが存在しない場合、このグループはオフラインの状態に留まります。このグループの強いアフィニティを再び満たすことができるようにほかのリソースグループの状態が変化する場合は、このグループは自動的にオンラインに戻ります。すべての強い RG_affinities (ポジティブとネガティブ) を RG_dependencies とひとまとめにした書式に循環を含めることはできません。

弱いアフィニティは「最前努力 (ベストエフォート)」ベースで満たされ、徹底的に強制されることはありません。 (フェイルオーバーの後などに) このリソースグループがオンラインに切り替えられる場合、RGM はその弱いアフィニティをもっとも多く満たすことができるノードを選択しようとします。弱いアフィニティは、 Nodelist で指定される順序よりも優先されます。弱いアフィニティが原因となってこのグループがほかのグループの動きに反応してノードを変更することはありません。循環は、弱い RG_affinities の書式内で許可されます。

注: 一定のリソースグループの RG_affinities 内に強いアフィニティを複数指定する場合は注意してください。 宣言されたアフィニティの一部が満たされない場合、そのグループはオフラインの状態に留まります。

カテゴリ: 任意

初期値: 空の文字列

調整: 任意の時点

RG_dependencies

(文字配列 )

同じノード上の別のグループをオンライン / オフラインにするときの優先順位を示すリソースグループのリスト (任意)。すべての強い RG_affinities (ポジティブとネガティブ) を RG_dependencies とひとまとめにした書式に循環を含めることはできません。

たとえば、リソースグループ RG1 の RG_dependencies リストにリソースグループ RG2 が示されている場合を考えてみます。この場合、RG1 は RG2 に対してリソースグループ依存の関係にあります。次に、リソースグループ依存の効果の概略を示します。

  • ノードがクラスタに加わる場合、RG2 内のリソースに対してそのノードの BOOT メソッドがすべて完了するまで、RG1 内のリソースに対してこの BOOT メソッドが実行されることはありません。
  • RG1 と RG2 の両方が同じノード上で同時に Pending_online の状態にある場合、起動メソッド ( Prenet_start または Start ) は RG2 内のすべてのリソースがそれらの起動メソッドを完了するまで RG1 のどのリソースに対しても実行されません。
  • RG1 と RG2 の両方が同じノード上で同時に Pending_offline の状態にある場合、停止メソッド ( STOP または Postnet_stop ) は RG1 内のすべてのリソースがそれらの停止メソッドを完了するまで RG2 のどのリソースに対しても実行されません。
  • RG1 または RG2 の主ノードの切り替えは、その切り替えによって RG1 がノードの 1 つでオンライン状態となり、かつ RG2 がすべてのノードでオフライン状態となる場合は失敗します。 この詳細は、 scswitch (1M) と scsetup (1M) のマニュアルページで説明されています。
  • RG2 の Desired_primaries プロパティがゼロに設定されている場合、RG1 の Desired_primaries プロパティをゼロよりも大きな値に設定することはできません。
  • RG2 の Auto_start_on_new_cluster プロパティが False に設定されている場合、RG1 の Auto_start_on_new_cluster プロパティを True に設定することはできません。

カテゴリ: 任意

初期値: 空のリスト

調整: 任意の時点

RG_description

(文字列)

リソースグループの簡単な説明。

カテゴリ: 任意

初期値: 空の文字列

調整: 任意の時点

RG_mode

(列挙)

リソースグループがフェイルオーバーグループなのか、スケーラブルグループなのかを指定します。このプロパティの値が Failover である場合、リソースグループマネージャはリソースグループの Maximum_primaries プロパティを 1 に設定して、リソースグループを管理できるノードを 1 つだけに制限します。

このプロパティの値が Scalable である場合、リソースグループマネージャはリソースグループの Maximum_primaries プロパティに 1 より大きな値を設定することを許可します。 この値は、同時に複数のノードがリソースグループを管理できることを示します。

注: リソースグループマネージャは、 Failover プロパティが True であるリソースを、 RG_mode が Scalable であるリソースグループに追加することを許可しません。

カテゴリ: 任意

初期値: Failover ( Maximum_primaries が 1 の場合)、 Scalable ( Maximum_primaries が 1 を超える場合)

調整: 不可

RG_name

(文字列)

リソースグループの名前。 このプロパティは必須です。 また、このプロパティはクラスタ内で一意である必要があります。

カテゴリ: 必須

初期値: デフォルトは存在しない

調整: 不可

RG_project_name

(文字列)

リソースグループに関連する Solaris プロジェクト名。 このプロパティは、CPU の共有、リソースプールといった Solaris のリソース管理機能をクラスタデータサービスに適用するのに使用します。 リソースグループをオンラインにする場合、 Resource_project_name プロパティが設定されていないリソースについては RGM はこのプロジェクト名で関連プロセスを起動します。 指定されたプロジェクト名はプロジェクトデータベースに存在する必要があり、そして、指定されたプロジェクトのメンバーにユーザー root が構成されている必要があります。

このプロパティは Solaris 9 以降でサポートされます。

注: このプロパティへの変更は、リソースが再起動された後に有効になります。

カテゴリ: 必須

初期値: デフォルトは存在しない

調整: 任意の時点

各クラスタノード上の RG_state

(列挙)

各クラスタノード上のグループの状態を表現するために、RGM によって Online 、 Offline, Pending_online, Pending_offline, Pending_online_blocked, Error_stop_failed または Online_faulted に設定されます。

ユーザーは、このプロパティの設定を許可されていません。 しかし、 scswitch (1M) を呼び出すことによって (あるいは同等の scsetup (1M) または SunPlex Manager コマンドを使用して) このプロパティを間接的に設定することは可能です。

カテゴリ: 照会のみ

初期値: Offline

調整: 不可

RG_system

(ブール値)

リソースグループのこのブール値を True に設定すると、そのリソースグループに許可されている scrgadm (1M) および scswitch (1M) オペレーション が制限されます。また、そのリソースグループ内のリソースの RG_System 値を True に設定しても一部のオペレーションが制限されます。

RG_System 値が True に設定されるリソースグループは、システムリソースグループと呼ばれます。 RG_System の現在の値にかかわらず、 RG_System プロパティの編集自体は制限されません。 これらの制限の詳細は、 rg_properties (5) のマニュアルページで説明されています。

カテゴリ: 任意

初期値: False

調整: 任意の時点

先頭へ戻る


リソースプロパティの属性

リソースプロパティの属性とは、システム定義プロパティを変更したり、拡張プロパティを作成するときに使用できる属性のことです。

警告記号 boolean, enum, または int タイプのデフォルト値には、 NULL または空の文字列 ("") は指定できません

リソースプロパティの属性

プロパティ名 説明
Property

リソースプロパティの名前。

Extension

このプロパティが使用されている場合、RTR ファイルのエントリがリソースタイプの実装によって定義された拡張プロパティを宣言していることを示します。 そうでない場合、そのエントリはシステム定義プロパティです。

Description

プロパティを簡潔に記述した注記 (文字列)。Description 属性は、RTR ファイル内のシステム定義プロパティには設定できません。

プロパティのタイプ

プロパティのタイプは、 string, boolean, int, enum, および stringarray のいずれかです。 Type 属性は、RTR ファイル内のシステム定義プロパティには設定できません。Type 属性は、RTR ファイルのエントリに登録できる、指定可能なプロパティ値とタイプ固有の属性を決定します。 enum タイプは、文字列値のセットです。

Default

プロパティのデフォルト値を示します。

Tunable

クラスタ管理者が、リソースのプロパティ値をいつ設定できるかを示します。 None または False に設定すると、管理者がプロパティを設定することを防ぐことができます。Tunable の値は、 True または Anytime (任意の時点)、 At_creation (リソースを作成したときだけ)、 または When_disabled (リソースがオフラインのとき) のいずれかです。

デフォルトは、 True ( Anytime ) です。

Enumlist

enum タイプの場合、プロパティに設定できる文字列値のセット。

Min

int タイプの場合、プロパティに設定できる最小値。

Max

int タイプの場合、プロパティに設定できる最大値。

Minlength

string および stringarray タイプの場合、設定できる文字列の最小長。

Maxlength

string および stringarray タイプの場合、設定できる文字列の最大長。

Array_minsize

stringarray タイプの場合、設定できる配列要素の最小数。

Array_maxsize

stringarray タイプの場合、設定できる配列要素の最大数。

先頭へ戻る