概要
インストールの前に
Sun Cluster HA for Sun ONE Web Server のインストール
Sun Cluster HA for Sun ONE Web Server のカスタマイズ
| 注: Sun Cluster HA for Sun ONE のインストールを行うと、Sun ONE LICENSE.txt ファイルに示された条件に同意したものとみなされます。 |
注: 次の条件が満たされるかぎり、クラスタ上で Sun Cluster HA for Sun ONE Web Server のインスタンスを複数実行できます。
|
| 注: Sun Cluster 構成で複数のデータサービスを実行している場合は、任意の順序でデータサービスを設定できます (次の例外を除く)。 Sun Cluster HA for Sun ONE Web Server が Sun Cluster HA for DNS に依存する場合は、初めに DNS を設定する必要があります。 『DNS Server の概要』を参照してください。 DNS ソフトウェアは、Solaris オペレーティング環境に含まれています。 クラスタが別のサーバーから DNS サービスを取得する場合は、最初に、クラスタが DNS クライアントになるように構成してください。 |
より高度な構成作業には、SunPlex Manager によるインストールが完了したところで Administrative Console を使用して構成内容を手動でカスタマイズしてください。 SunPlex Manager よりもきめ細かなインストールを行いたい場合は、『Sun Cluster 3.1 データサービスのインストールと構成』に示されている手順で手動でインストールを行なってください。
インスタンスごとに一意のネットワークアドレスとポート番号を決定してください。
| Sun ONE Web Server データサービスのインストールは、約 10 分かかります。 | |
| インストールの開始後に SunPlex Manager を終了するか Web ブラウザ上で「戻る」をクリックすると、 データサービスによってインストール作業が切断されます。
このように途中で切断された場合は、情報が十分にインストールされなかったりエラーメッセージが不確定な状態になったりするために、インストールが未完了のままになる可能性があります。
未完了のインストールをクリーンアップするには、作成されたアプリケーションファイル、リソース、およびリソースグループを削除する必要があります。 |
|
Sun ONE Web Server をインストールするには、次の作業を行なってください。
「クラスタ」ウィンドウが表示されます。
SunPlex Manager によって次のことが確認されます。
Sun ONE Web Server データサービスパッケージのインストールと登録が完了している場合は、次の手順に進みます。
Sun ONE Web Server データサービスパッケージのインストールと登録がまだ行われていない場合は、インストールと登録の作業を行うようにメッセージが表示されます。 この場合、Sun Cluster 3.1 Agents が入った CD の場所を指定する必要があります。
構成情報が入ったウィンドウが表示されます。
| フィールド | 説明 |
|---|---|
| 管理サーバーのポート | Sun ONE Administrative Server に使用するポート。 このポートのデフォルトは 8888です。 |
| 管理サーバーのパスワード | 管理サーバーポートにアクセスするためのパスワード |
| Web サーバーのポート | Web サーバーが要求を受け付けるポート。
通常は 80 か 8080 です。
Sun Cluster HA for Sun ONE Web Server サービスとほかの HTTP サーバーを稼動させている場合で、それらが同じネットワークリソースを使用しているときは、異なるポートで待機するように構成してください。 異なるポートで待機するように構成しないと、2 つのサーバーの間でポートの衝突が発生します。 |
| Sun ONE インストール用のソースディレクトリ | Sun ONE ディストリビューションを配置するディレクトリ。 設定用の実行ファイルはこのディレクトリに置く必要があります。 |
| インストールディレクトリ | Sun ONE Web Server アプリケーションのバイナリがインストールされるディレクトリ
警告: Sun ONE Web Server アプリケーションの 1 つ以上のバイナリをこのディレクトリに配置すると、インストールは失敗します。 |
| Web ページ用のルートディレクトリ | Sun ONE Web Server の Web ページを保存するディレクトリ |
| ネットワークリソース | ネットワーク上で Sun ONE Web Server のアクセスに使用する論理ホスト名または共有アドレスを指定してください。 論理ホスト名を使用すると、Sun ONE Web Server インスタンスの 1 つがフェイルオーバーサービスとして機能します。 共有アドレスを使用すると、複数の Sun ONE Web Server インスタンスがスケーラブルサービスとして機能します。 |
| リソース名 | 作成する Sun ONE Web Server リソースの名前を指定してください。 この名前は、クラスタ内で一意のものでなければなりません。 |
| リソースグループ名 (スケーラブルなりソースに使用される) |
共有アドレスを使用した場合は、作成されるリソースの名前を指定してください。 このリソースグループには、スケーラブルな Sun ONE Web Server リソースが配置されます。 論理ホスト名を使用した場合は、フェイルオーバー Sun ONE Web Server リソースは論理ホスト名と同じリソースグループに配置されます。 |
| ネームサービス | このオプションは Sun ONE Web Server Address パラメータを制御するもので、通常、クラスタ上で使用されているネームサービスの種類と一致します。 DNS を選択する場合、アドレスには論理ホスト名または共有アドレスを指定します。 NIS を選択する場合、アドレスには論理ホスト名または共有アドレスに関連付けられた、数字による IP 値を指定します。 |
| Dots デモ | 「Dots デモ」を選択すると、クラスタ全体にわたる負荷均衡を紹介する補足的な Web ページがクラスタにインストールされます。 |
SunPlex Manager によって構成ページの情報が検証されます。 エラーがまったく見つからないと、Sun ONE Web Server アプリケーション用のバイナリがインストールされます。 エラーが見つかると、エラーメッセージと構成ページが表示されます。
SunPlex Manager によってリソースの構成と起動が行われ、 これらの作業に使用されるコマンドが表示されます。
|
推奨手順:
Web サーバーをテストするには、Web サーバー URL をクリックします。
SunPlex Manager により Sun Cluster HA for Sun ONE のテストが行われ、確認ウィンドウが表示されます。 |
|
注: Dots デモを表示するには (このデモをインストールしてある場合)、Dots デモの URL をクリックしてください。
Sun Cluster 上のノードを示すイメージ図が表示されます。 Dots デモは、クラスタ全体に渡る負荷均衡を紹介するものです。 |