View
General Resource Properties
Detailed Resource Properties
Actions
Enabling a Resource
Disabling a Resource
Enabling the Resource Monitor
Disabling the Resource Monitor
Modifying Resource Properties
Modifying Load Balancing
Clearing a STOP_FAILED Flag
Creating a Resource
Deleting a Resource
To display the general resource property view, complete the following steps:
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. Write down or copy this command for future use in scripts and other automated tasks.
You need to disable a resource when you perform maintenance on a node or disk that the resource uses.
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
If other resources depend on the resource, you cannot disable that resource.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. Write down or copy this command for future use in scripts and other automated tasks.
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. Write down or copy this command for future use in scripts and other automated tasks.
|
|
|
|
|
If you disable the resource monitor, the resource is no longer be highly available. The resource does not failover if a failure occurs. |
|
|
|
To disable a resource's monitor, complete the following steps:
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. Write down or copy this command for future use in scripts and other automated tasks.
To modify a resource's properties, complete the following steps:
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
SunPlex Manager displays an additional window that prompts you to provide resource properties. For a complete description of these properties, see the Resource Properties Table.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. Write down or copy this command for future use in scripts and other automated tasks.
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
A window appears. This window contains the current weights.
To adjust load balancing, enter a new number in the Weight field. When you change a node's weight, the Load Distribution field automatically updates with the new load distribution. This distribution is displayed as a percentage.
| Note: The Load Distribution fields only display values if you enable the JavaScriptTM technology in your web browser. If the JavaScript technology is disabled, the fields remain empty. |
An example is presented in the following table.
| Nodes That Run the Resource | Weight by Node | Load Distribution |
|---|---|---|
| Node One | 1 | 25% |
| Node Two | 1 | 25% |
| Node Three | 2 | 50% |
How to Determine Load Distribution
To determine load distribution, divide the
node's
weight by the total weight for all nodes.
The total weight for all nodes is determined by adding the weight of all nodes.
In this example, Node One's weight is 1, and the total weight is 4. Therefore, Node One's load is 1/4 or 25 percent of the total load.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. Write down or copy this command for future use in scripts and other automated tasks.
The
STOP_FAILED resource state prevents you from unknowingly starting several instances of an application that the resource controls. Before you clear the STOP_FAILED flag, ensure that the resource is offline.When a resource is in the
STOP_FAILED state, you cannot perform the following tasks:To clear a
STOP_FAILED flag, complete the following steps:
|
Recommended step.
Open a telnet window
and connect to the node on which the resource failed.
Then manually stop the resource application or applications.
This step might require you to kill processes, run resource type-specific commands, or use other commands. |
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. The resource and resource group status are now offline.
| Note: If you clear the STOP_FAILED flag, but do not manually stop the resource applications, the resource might not be properly stopped. |
|
|
|
|
|
To create a logical host name resource,
either an adapter or an IPMP group must be configured for the same subnet as the new logical host name.
If this configuration does not exist,
you receive the following error message:
specified hostname(s) cannot be hosted by any adapter on ... To configure the adapter and IPMP group on the new subnet, create an IPMP group.
|
|
|
|
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
SunPlex Manager displays an additional window that prompts you to provide resource properties.
See the Resource Properties table for a complete description of these properties.
See the Sun Cluster 3.1 Data Service Installation and Configuration Guide for the specific resource group extension properties.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. Write down or copy this command for future use in scripts and other automated tasks.
|
To create a shared address resource,
either an adapter or an IPMP group must be configured for the same subnet as the new shared address.
If this configuration does not exist,
you receive the following error message:
specified hostname(s) cannot be hosted by any adapter on ... To configure the adapter and IPMP group on the new subnet, create an IPMP group.
|
|
|
|
|
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
SunPlex Manager displays an additional window that prompts you to provide resource properties.
See the Resource Properties table for a complete description of these properties.
See the Sun Cluster 3.1 Data Service Installation and Configuration Guide for the specific resource group extension properties.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. Write down or copy this command for future use in scripts and other automated tasks.
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
Logical host names are indicated by
(lh).
SunPlex Manager displays an additional window that prompts you to provide resource properties.
| Note: If the resource type is not registered, SunPlex Manager prompts you to register the resource type. Click Register. |
See the Resource Properties table for a complete description of these properties.
See the Sun Cluster 3.1 Data Service Installation and Configuration Guide for the specific resource group extension properties.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. Write down or copy this command for future use in scripts and other automated tasks.
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
Shared addresses are indicated by (sa).
SunPlex Manager displays an additional window that prompts you to provide resource properties.
See the Resource Properties table for a complete description of these properties.
See the Sun Cluster 3.1 Data Service Installation and Configuration Guide for the specific resource group extension properties.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. Write down or copy this command for future use in scripts and other automated tasks.
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
SunPlex Manager displays an additional window that prompts you to provide resource properties.
See the Resource Properties table for a complete description of these properties.
See the Sun Cluster 3.1 Data Service Installation and Configuration Guide for the specific resource group extension properties.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. Write down or copy this command for future use in scripts and other automated tasks.
SunPlex Manager disables the resource automatically before deleting that resource.
To delete a resource, complete the following steps:
The Resource Groups window appears.
A task window appears. This window prompts you to provide additional information.
SunPlex Manager displays a confirmation message, including the command that is used to complete the task. Write down or copy this command for future use in scripts and other automated tasks.