 |
Network Registrar
CLI Reference Guide |
Status Returns
Network
Registrar Error Codes
Import
and Export File Formats
Status Returns
The
nrcmd program returns status information on the first line of information
written to the standard output stream. If there is more data, nrcmd
displays this information on additional lines.
The first line consists of a numeric status that
is followed by a human-readable error status.
The status codes are all three-digit integer
decimal numbers. The range 100 through 599 is grouped as in Table 4-1.
Table 4-1. Status Codes
Table 4-1Status
Information
|
|
|
|
100-199
|
Normal return
|
|
200-299
|
Informational (warning)
|
|
300-499
|
Error
|
|
500-599
|
Fatal Error
|
For anything other than an error, Network
Registrar assumes that the requested operation was completed; however, some
warning messages signal a condition that must be corrected. Unless a fatal
error occurs, the command line interface will keep running in interactive mode.
Fatal errors imply that something serious happened and that you must restart
the Network Registrar command line processor.
Network Registrar Error Codes
Table 4-2 lists and describes the
Network Registrar error codes.
Table 4-2.
Error Codes
|
|
|
|
100
|
OK
|
|
101
|
OK, with warnings
|
|
102
|
Lease already reserved to this client
|
|
103
|
Lease not reserved
|
|
104
|
Lease deleted along with reservation
|
|
105
|
Lease created along with reservation
|
|
106
|
Assertion failed
|
|
107
|
VPNID currently in use by at least one scope
|
|
204
|
Assigned host is not contained in pool zone
|
|
300
|
Unexpected error
|
|
301
|
No server found
|
|
302
|
Not found
|
|
303
|
Read only property
|
|
304
|
No policy found
|
|
305
|
Too many
|
|
306
|
Unknown command
|
|
307
|
Unknown keyword
|
|
308
|
Unknown parameter
|
|
309
|
Too many arguments
|
|
310
|
Too few arguments
|
|
311
|
No response to lease request
|
|
312
|
Unexpected response from server
|
|
313
|
No match
|
|
314
|
Duplicate object
|
|
315
|
Import failure
|
|
316
|
Invalid
|
|
317
|
Open failed
|
|
318
|
No MAC address found
|
|
319
|
No lease found
|
|
320
|
Generic error
|
|
321
|
Invalid name
|
|
322
|
Feature not supported
|
|
323
|
Read error
|
|
324
|
Invalid IP address list
|
|
325
|
Invalid type
|
|
326
|
ODBC database access error
|
|
327
|
IP address not contained within pool subnet
|
|
328
|
Identical MX resource record already exists
|
|
329
|
Identical TXT resource record already exists
|
|
330
|
Address is not contained in pool
|
|
331
|
Host is already assigned to an address
|
|
332
|
Address is already assigned to a host
|
|
333
|
No unassigned IP address found in pool
|
|
334
|
Address has not been assigned to a host
|
|
335
|
Static address pools are not enabled, create a
pool to enable
|
|
336
|
Range overlaps another pool
|
|
337
|
Host has multiple IP address assignments
|
|
338
|
Address has multiple host assignments, must
supply <name> argument
|
|
339
|
Expected unsigned 16-bit preference value
|
|
340
|
ODBC 3.x or higher required
|
|
350
|
Generic DHCP error
|
|
351
|
Cannot resolve partner name to an IP address
|
|
352
|
No failover object for specified partner
|
|
353
|
Still communicating with partner
|
|
354
|
Server is already in partner-down state
|
|
355
|
Can't set partner-down while in recover
|
|
356
|
Not allowed in read-only mode
|
|
357
|
Not a secondary
|
|
358
|
Not a primary
|
|
359
|
No zone matched
|
|
360
|
Forcexfer for this zone is already
scheduled
|
|
361
|
Lease is not reserved
|
|
362
|
Scope unknown in server
|
|
363
|
Invalid IP address in server
|
|
364
|
Invalid MAC address in server
|
|
365
|
Failure creating MAC address in server
|
|
366
|
Unknown object in server
|
|
367
|
Command not supported by server
|
|
368
|
Bad length in server
|
|
369
|
Inconsistent scope in server
|
|
370
|
updateSMS not configured in
server
|
|
371
|
Server out of memory
|
|
372
|
SMS interface .dll
did not load correctly
|
|
373
|
updateSMS already processing in
server
|
|
374
|
Invalid word array
|
|
375
|
updateSMS invalid argument
|
|
376
|
Lease is reserved to a different client
|
|
377
|
Client already reserved a different lease
|
|
378
|
Field name or number not found
|
|
379
|
Suboption name or number
already exists
|
|
380
|
Suboption name or number not
found
|
|
381
|
Invalid character `-' in vendor-option name
|
|
382
|
Data not found for vendor-option
|
|
383
|
Field name or number already exists
|
|
384
|
counted-array can only be used with array
types
|
|
385
|
Read-only attribute cannot be modified
|
|
386
|
Required attribute cannot be unset
|
|
387
|
Invalid vpn-id
|
|
388
|
Invalid IP address syntax
|
|
389
|
Invalid vpn name
|
|
390
|
Invalid IP address value
|
|
391
|
Invalid vpn
specification
|
|
392
|
Cannot remove session's current vpn
|
|
393
|
Duplicate property
|
|
394
|
Invalid vpn-id
specification
|
|
395
|
Lease has no scope pointer -- internal error
|
|
396
|
Invalid vpn-id
specification
|
|
397
|
Expression too long
|
|
398
|
Insufficient memory
|
|
401
|
Login failure
|
|
402
|
Permission denied
|
|
403
|
Couldn't lock database
|
|
404
|
Login required
|
|
405
|
Invalid license key
|
|
406
|
A lock is required for this operation
|
|
407
|
Unable to release lock
|
|
408
|
Unable to obtain lock
|
|
409
|
Couldn't lock static address pool
|
|
501
|
Connection failure
|
|
502
|
Server failure
|
|
503
|
Cluster version failure
|
|
504
|
Wrong license key type, local cluster key type
needed
|
|
504
|
Wrong license key type, regional key type
needed
|
|
505
|
Connected to wrong cluster type
|
|
506
|
Duplicate option id
|
|
507
|
Duplicate option name
|
|
508
|
Duplicate vendor-option-enterprise-id
|
|
509
|
Duplicate vendor-option-string
|
|
510
|
Version mismatch
|
|
511
|
No version found
|
|
512
|
Incomplete object
|
|
513
|
Incomplete attribute
|
|
514
|
Incomplete NLIST
|
|
515
|
Invalid repeat count
|
Import and Export File Formats
This section describes the import leases and
export leases file format.
The syntax is:
field1|field2|field3|...
The fields are listed next. If, in the import
file, you chose not to supply the information for an optional field, you need
to use delimiters ( | ) so that the number of fields is still 12. For
example, type xyz|abc||123:
MAC address in xx:xx:xx:...:xx
format (required)
MAC address type (required)
MAC address length (required)
IP address in dotted decimal format, a.b.c.d (required)
Start of lease time (GMT) (optional)
Lease expiration time (GMT) (optional)
Allowable extension time (GMT) (optional)
Last transaction time (GMT) (optional)
IP address of the DHCP server (optional)
Host name (without domain) (optional)
width=19 border=0>Domain name (optional)
Client ID (optional)
VPN (optional)
Note: For all the time
fields, you can use either the number of seconds since 1970, or day, month, date,
time, year format (Mon Apr 13 16:35:48 1998).
All contents are Copyright © 1992--2007 Cisco Systems, Inc. All rights
reserved.