ネットワークノードマネージャ 6.01 Runtime 既知の問題と対策

For Windows NT® 4.0


一般情報

ネットワークノードマネージャ 6.0 (NNM) の使用中に発見された問題(Known Problems)と対策(Workarounds)を以下にリストします。

このリリースノートの最新版は、http://ovweb.external.hp.com/nnm/NNM6.0/relNoteUpd/relNoteUpdate.htm をご覧ください。

以下には、トラブルシューティングのセクションもあります。


Known Problems

Below are the known problems and workarounds for the following modules:

Installation

Licensing

How to get a JDK 1.1 Compliant Web Browser

Known Problems with Web Browsers

The following table lists the known problems with various browsers, and which platform is recommended for each browser.  For the latest update on this table, please visit http://ovweb.external.hp.com/nnm/NNM6.0/relNoteUpd/relNoteUpdate.htm
Operating System Browser Browser Information
Solaris 2.5.1   Use Netscape browser for best results
  Netscape 4.06 Netscape may crash when first brought up.  See Netscape README file for required operating system patches.
  Internet Explorer 4.01 UNIX Microsoft Internet Explorer displays error when launching NNM Java applets.

Microsoft Internet Explorer on Solaris --Menus not displaying properly.  A possible workaround is to run /usr/openwin/bin/xlsfonts -o utopia-regular >/dev/null

Solaris 2.6   Use Netscape browser for best results
  Internet Explorer 4.01 MS Explorer on Solaris--Menus not displaying properly. A possible workaround is to run /usr/openwin/bin/xlsfonts -o utopia-regular >/dev/null
  Netscape 4.06 Solaris 2.6 Netscape has corrupt local display with release notes loaded due to not rendering text fonts correctly.  See the Netscape README for the two xset commands to work around this.
Windows NT 4.0   Use Internet Explorer browser for best results
  Internet Explorer 4.01 SP1
or Netscape 4.06
Java applications returning HTTP/1.0 500 Server Error and not loading. The workaround is to reinstall Windows NT Service Pack 3.
Windows 95/Windows 98   No browser has yet been fully qualified for these platforms
HP-UX 10.20   Use Netscape browser for any results
  Netscape 4.06 <NONE>
    There are many incompatibility issues between NNM and Microsoft Internet Explorer for HP-UX.
HP-UX 11.0   Use Netscape browser for any results
  Netscape 4.06 for HP-UX 10.20 HP-UX 11.0 is not officially supported by Netscape but seems to work on 32 bit hardware.
I Internet Explorer 4.01 (pre-release) There are many incompatibility issues between NNM and Microsoft Internet Explorer for HP-UX.

 

Java-based Web Interface - HP OpenView Launcher

Do Not Close Launcher Window

Java-based Web Interface - Network Presenter

Java-based Web Interface - SNMP Data Presenter

Java-based Web Interface - Alarm Browser

Web Event Correlation Configuration (ECS) Management GUI

Web Server

You may replace the NNM Web Server with your own web server by following the instructions on the CD in doc/WhitePapers/changeWebServer.txt

Network Discovery (netmon/ipmap/ovtopmd)

ERROR: "Cannot look up field id for name field IP Address" appears in the Alarm Browser (NSMfc11943)

If ovtopmd is started after clearing the databases in $OV_DB/openview, this error message will appear in the alarm browser:  This is a harmless error message which can be avoided in the future by performing the following steps after clearing out the NNM databases:
    ovstart ovwdb
    ovw -fields

ERROR: ipmap reports number of licensed connectors as -1 (NSMfc10339)

If you select the Internet symbol and look at the Object Properties ->IPmap there is an entry for the number of licensed connectors. When the unlimited license is installed this field will contain the value "-1". When any other license is installed, the number of licensed connectors will appear: i.e. 250 for the instant on license.  You can safely ignore this message.

ERROR: You remove a symbol from the map, yet it remains on the map. (NSMfc12765)

Timing conditions while manually adding 250th node to a system licensed to have only 250 managed nodes while discovery is active may cause a  'removed symbol' to remain on the map. This results from both the user and netmon attempting to add the last managed node, but in this case netmon wins. To prevent the problem from happening, turn off discovery using "Options->Network Polling Configuration" menu item, delete or unmanage nodes to bring the managed node count below 250, manually add the desired nodes, and re-enable discovery. To clean up the map, run ovtopofix (see the ovtopofix man/reference page for details)

Native Alarm Browser (xnmevents)

New Non-Web Alarm Browser (xnmevents) Behavior
All operator actions, Acknowledge, UnAcknowledge, Delete, Assign Severity, Assign Category, are global (affecting all browsers).

Alarm Browser (xnmevents) no longer maintains per user state files. There is only one common state file. Old per user state files are not compatible with NNM 6.01 and will be ignored.

Some correlated events, from the PairWise correlation, will cause the Alarm Browser to redraw twice on Windows NT. In the rare situations where this occurs, this could take up to 16 seconds of time.  (NSMfc12850)

Data Warehouse

    When using databases other than the embedded database, the user needs to manually instantiate the data warehouse schemas using ovdwsetup.ovpl before using the data warehouse.

    Using Oracle:

    All export tools are enabled for ODBC.  To use Oracle, sql*net must be installed and configured.  A default datasource has been configured in the /etc/opt/OV/share/conf/analysis/system_odbc.ini file, OVoracle.  To switch over, change the "ServerName" parameter in that file to your server as defined in tnsnames.ora.
    Then run:

    Interrupting Data Warehouse Commands

    During our testing, we have experienced situations where killing or interrupting the database client program can have an adverse effect on some database servers.While this is still being investigated it appears that some versions of Microsoft SQL Server will fail when the client is canceled via "Control-C".

    If you are using the NNM embedded database technology, you may also experience a behavior where for a short time after interruption, the database server may think the client is still active. This could result in "primary key contraint violations" or some type of concurrency problem, if the same command is immediately restarted. However this should clear up within 30 seconds and future access to the database will not be effected.

    Clicking on the Stop button in the "Tools/Data Warehouse/Export Trend Data" dialog window will not interrupt the trend export process. It will finish to completion.

    Reinstall Service Packs

    You must reinstall your Windows NT service pack after adding any Microsoft Components such as Microsoft Peer Web Services, or you will see the following error (or an SNMP error).

    ODBC Version Mismatch dialog:

    You may get an "ODBC Driver Manager" popup window for a version mismatch for various ODBC utilities such as:
            The ODBC resource DLL (C:\WINNT40\System32\odbcint.dll) is a different
         version than the ODBC driver manager (C:\WINNNT40\System32\ODBC32.dll).

    You need to reinstall the ODBC components to ensure proper operation. This happens if you install *any* application which supplies ODBC components, not necessarily just NNM.  The only way to prevent  this popup is to reinstall your last Service Pack. NNM does NOT include any Windows NT ODBC components. This mismatched DLL problem is a known issue with Windows NT.  Further information can be retrieved from Microsoft Article PSS ID Number: Q170769.

    Using ovbackup and the NNM Data Warehouse

    If you are using ovbackup.ovpl and are using the NNM Data Warehouse, when the ovbackup.ovpl command is executed, it will also instruct the Embedded Database server to initiate the online backup. In order to allow a roll-forward recovery the default backup schedule must be deactivated. The process for doing this is:

    1. copy the $OV_DB/analysis/default/solid.ini file to $OV_DB/analysis/default/solid.ini.old file.
    2. Edit the $OV_DB/analysis/default/solid.ini file.
    3. Comment out the "At=<time> backup" entry, by inserting a ";" at the beginning of the line. An example would be:
      ;At=01:00 backup
    4. Save the $OV_DB/analysis/default/solid.ini file.

    The embedded database will now be backed up only when the ovbackup.ovpl command is run. If use of ovbackup.ovpl is stopped at a future this, the default backup should be reinstated by copying the $OV_DB/analysis/default/solid.ini.old back to $OV_DB/analysis/default/solid.ini.

リモート・コンソール

HP-UX または Solaris NNM管理ステーションに接続する日本語NT上のNNMリモート・コンソールの場合、NNMとは別購入された NFS cliennt 製品が registration, symbols, conf の各サブディレクトリ下のシンボリックリンク Japanese_Japan.932 をたどる(resolve)よう設定する必要があります。 日本語NT上のNNMリモート・コンソールを動作させたとき、OVW ウィンド中のメニューが英語で表示される場合、シンボリックリンク Japanese_Japan.932 がたどられていないことが考えられます。 NFS client 製品のひとつである Disk Access の場合は、「コントロールパネル」中の「DiskAccess」アプレットを起動してシンボリックリンクをたどる(resolve)よう設定してください (DiskAccess の「Administrator Utility」からではなく)。   Disk Access のデフォルト設定ではシンボリックリンクをたどりません。

Allowing Enough Color Resources

No known problems on Windows NT.

Online Manuals

No known problems on Windows NT.

Event Configuration

(NSMfc13038)
The following procedure will cause the Event Configuration window to hang:

  1. start the Event Configuration Window from NNM's user interface, select:
    Options->Event Configuration
  2. pause NNM for back up (ovpause portion of the backup script)
  3. Edit an the event source using "Add From Map":
    Edit->Add->Event->Add From Map

The workaround is to not perform "Add From Map" during the paused portion of NNM's backup procedure. Or, if it's already paused and you cannot wait until backup has finished, from the command prompt:

SNMP Agent Issues

日本語版特有の問題(国際化の問題)


トラブルシューティング

ヒント: 次のディレクトリで、エラー・ログ・ファイルを探して、出力を調べてください。キーワード "ERROR" を探してください。

インストールのトラブルシューティング

ノード検出のトラブルシューティング

データ・ウェアハウスのトラブルシューティング

"ovstatus ovdbcheck"を実行してデータベースが実行されていることを確認します。

次のように ovdwquery コマンドを使ってデータ・ウェアハウスにデータが存在することを確認できます。

詳細は、『Reporting and Data Analysis with NNM』を参照してください。