Previous Menu Next
Starting the Open Engine

The open engine is started with the ecsd command. On UNIX you need to have superuser privileges to run ecsd.

It is possible to run many open engines on the same machine. Each engine is distinguished by an instance number.

An engine is started with the command:

ecsd -i instance

where instance is the instance number assigned to the engine.

The instance number is used with the ecsmgr command to identify the engine the command is directed to.

If the instance number is not specified it defaults to 1 (one).

pmd-linked ECS engines are always numbered instance 1 (you cannot use any other instance number).

If you attempt to start a second instance of the ECS engine with the same instance number as an already-running engine then an error is displayed and the second instance will fail to start. The already-running engine will not be affected.